1175: Lyrics syncing with iPod 30GB

Beta Testing for Windows Products and plugins

Moderator: Gurus

_dodger_
Posts: 32
Joined: Wed Dec 20, 2006 9:42 pm

Re: 1175: Lyrics syncing with iPod 30GB

Post by _dodger_ » Fri Jan 08, 2010 10:06 pm

Well, yes all those issues have been closed/resolved. Our problem however still persists as detailed on the three pages of this thread (and in the Mantis issue you linked).

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 1175: Lyrics syncing with iPod 30GB

Post by nohitter151 » Fri Jan 08, 2010 10:43 pm

_dodger_ wrote:Well, yes all those issues have been closed/resolved. Our problem however still persists as detailed on the three pages of this thread (and in the Mantis issue you linked).
Sorry, but NOT in the Mantis issue I first linked. There, it says unresolved as of build 1274: http://www.ventismedia.com/mantis/view.php?id=5995
However, the next issue where this problem is really addressed (As you pointed out), says resolved as of 1277, which is of course a later (and more recent) build: http://www.ventismedia.com/mantis/view.php?id=6072
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

_dodger_
Posts: 32
Joined: Wed Dec 20, 2006 9:42 pm

Re: 1175: Lyrics syncing with iPod 30GB

Post by _dodger_ » Fri Jan 08, 2010 11:00 pm

Okay, once again: As timepass18, 67Healey and me have stated multiple times now this still happens as of 3.2.1294 which was clearly released after the supposed fix in 1277.

The first issue you linked to had nothing to do with this one and the second issue seems to address our problem and it has been marked as resolved yet all three of us still have this problem which wouldn't be the first or second time this was supposedly fixed but the third. So it shouldn't be too hard to believe that the problem is indeed still there and the ticket was closed prematurely.

Might I ask what your interest in this problem is?

For the record: None of my posts should be seen as complaints about the bug fixing politics from MediaMonkey or be a demand for any action. I was simply stating that this problem still exists. I've learnt to live with it and I don't use the lyrics very often so it's not too bad a problem for me. But sometimes it is an annoyance so I visit this thread from time to time to check for any progress.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 1175: Lyrics syncing with iPod 30GB

Post by nohitter151 » Fri Jan 08, 2010 11:43 pm

_dodger_ wrote:Okay, once again: As timepass18, 67Healey and me have stated multiple times now this still happens as of 3.2.1294 which was clearly released after the supposed fix in 1277.

The first issue you linked to had nothing to do with this one and the second issue seems to address our problem and it has been marked as resolved yet all three of us still have this problem which wouldn't be the first or second time this was supposedly fixed but the third. So it shouldn't be too hard to believe that the problem is indeed still there and the ticket was closed prematurely.

Might I ask what your interest in this problem is?

For the record: None of my posts should be seen as complaints about the bug fixing politics from MediaMonkey or be a demand for any action. I was simply stating that this problem still exists. I've learnt to live with it and I don't use the lyrics very often so it's not too bad a problem for me. But sometimes it is an annoyance so I visit this thread from time to time to check for any progress.
My first reply was in response to "67healey" in response to the fact that there was no Mantis entry for this issue, which by now I have proven is untrue. Sure, I posted the wrong link the first time. Sorry.

My interest in this problem is that I reported the first bug and verified the second one. The Mantis entry was entered after a user reported this very problem via our eSupport system, the developers fixed it, and the user reported that it works fine now. I also have an iPod and an iPhone and the lyrics are working fine.

I also am able to re-open this Mantis entry if I see that there really is a problem. But you haven't given me much of a reason to re-open it. What have you tried? Does it fail reliably? What kind of tracks? Anything special in your configuration? Auto-conversion? Does iTunes touch the iPod at all? Is the firmware up to date? What kind of iPod? How can I reproduce this problem on my end, since it's working fine for me now?
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

MMGoldUser
Posts: 2
Joined: Mon Sep 21, 2009 9:48 pm

Re: 1175: Lyrics syncing with iPod 30GB

Post by MMGoldUser » Sat Jan 09, 2010 10:02 pm

Hi, I'm having the same problem. I'm using 3.2.0.1294 with an ipod classic 160gb with latest firmware. Try to be as detailed as I can. When I initially synced, all lyrics displayed on the ipod just fine. Any subsequent syncs somehow remove all the lyrics. It seems like if a track with lyrics already exists on the ipod, another sync somehow removes them. For example, if I delete all the tracks from the ipod then perform a sync, the lyrics will show up. But syncing again after that removes the lyrics. I only use itunes to transfer vids to the ipod. But I can reproduce the problem without opening itunes at all (delete tracks from ipod, then sync--lyrics show up, sync again--lyrics disappear).

This is my configuration for the ipod:
-sync playlists
-delete tracks not in the auto-sync list
-auto-sync tracks from device to pc
-auto-convert incompatible files to mp3 (all my files are mp3 anyway)
-use only first genre when multiples exist
-use only first value when multiple artsits exist
-force itunes-style folders
-update database based on all track changes

67Healey
Posts: 11
Joined: Thu Jan 07, 2010 8:48 pm

Re: 1175: Lyrics syncing with iPod 30GB

Post by 67Healey » Sun Jan 10, 2010 7:18 pm

nohitter151 wrote:My first reply was in response to "67healey" in response to the fact that there was no Mantis entry for this issue, which by now I have proven is untrue. Sure, I posted the wrong link the first time. Sorry.

My interest in this problem is that I reported the first bug and verified the second one. The Mantis entry was entered after a user reported this very problem via our eSupport system, the developers fixed it, and the user reported that it works fine now. I also have an iPod and an iPhone and the lyrics are working fine.

I also am able to re-open this Mantis entry if I see that there really is a problem. But you haven't given me much of a reason to re-open it. What have you tried? Does it fail reliably? What kind of tracks? Anything special in your configuration? Auto-conversion? Does iTunes touch the iPod at all? Is the firmware up to date? What kind of iPod? How can I reproduce this problem on my end, since it's working fine for me now?
Hi guys - esp nohitter151

It seems now that this thread has been revived, more & more people are chiming in that it is still a problem. I might not be a Developer, but I can read the second Mantis entry which basically states it hasn't been fixed, unless of course I can't read either :o

(0019308)
jiri (administrator)
2009-10-23 03:03

This is a problem MM can't fix, since it happens when iPod doesn't understand that particular ID3v2 tag. It often helps to remove album art from the tag.

(0019309)
jiri (administrator)
2009-10-23 04:22
edited on: 2009-10-23 04:23

Further discussion over IM showed that although the playback problem was solved, editing properties really still causes this problem. I decided to leave it this way, since the problem only affects old iPod models (Nano 4G, but not 5G) and doesn't affect iPhone/Touch at all, since all these models have Lyrics stored in the internal DB. There isn't an easy fix without side effects for the older models and so it seems to make sense to leave it this way."

So, unless I'm mistaken (again), this would lead me to beleive it HASN'T been fixed.

In regards to how to reproduce, I think everyone on this growing thread is willing to help. Which, when I read MMGoldUser's steps to reproduce, maybe it's not what the Developers were actually looking at? As it is the same scenario for me - NO Itunes; Either Send to or Synch the first time = Lyrics on IPod. Auto-synch after this - all lyrics are removed from all songs on the iPod. 80 gig iPod, newest firmware, just basic mp3. I've tried rebuilding device database, with no resolve. And jiri's comments about it only affecting "older units" - well this is actually the majority of regular iPods until Apple introduced the new 120g iPod & Nanos, so this represents a huge slice of the existing market...
Let me know if there are some logs or something that I can submit to please help this issue along..(I live for the lyrics!)

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 1175: Lyrics syncing with iPod 30GB

Post by nohitter151 » Sun Jan 10, 2010 7:56 pm

67Healey wrote: It seems now that this thread has been revived, more & more people are chiming in that it is still a problem. I might not be a Developer, but I can read the second Mantis entry which basically states it hasn't been fixed, unless of course I can't read either :o
No offense, but aren't we reading the same thing? In fact, you've quoted this from the Mantis entry:
Jiri wrote:(0019308)
jiri (administrator)
2009-10-23 03:03

This is a problem MM can't fix, since it happens when iPod doesn't understand that particular ID3v2 tag. It often helps to remove album art from the tag.
Clearly is says here "MM can't fix". Further down:
Jiri wrote: (0019309)
jiri (administrator)
2009-10-23 04:22
edited on: 2009-10-23 04:23

Further discussion over IM showed that although the playback problem was solved, editing properties really still causes this problem. I decided to leave it this way, since the problem only affects old iPod models (Nano 4G, but not 5G) and doesn't affect iPhone/Touch at all, since all these models have Lyrics stored in the internal DB. There isn't an easy fix without side effects for the older models and so it seems to make sense to leave it this way."
In case you don't understand what this says, (or haven't taken the time to read it thoroughly) it basically is just saying that if you right-click a track in the iPod node, then go to the "Lyrics" tab and hit OK, the lyrics field is cleared. Even though the track really does have lyrics, MM tries to read the lyrics from the iPod database rather than the actual track tag. This is what he is saying can't be fixed.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

67Healey
Posts: 11
Joined: Thu Jan 07, 2010 8:48 pm

Re: 1175: Lyrics syncing with iPod 30GB

Post by 67Healey » Mon Jan 11, 2010 12:55 pm

nohitter151 wrote: In case you don't understand what this says, (or haven't taken the time to read it thoroughly) it basically is just saying that if you right-click a track in the iPod node, then go to the "Lyrics" tab and hit OK, the lyrics field is cleared. Even though the track really does have lyrics, MM tries to read the lyrics from the iPod database rather than the actual track tag. This is what he is saying can't be fixed.
So <with the utmost respect>, if this bug is about not being able to display lyrics from the iPod in MediaMonkey, after you have viewed the lyrics from the device & clicked "ok" are we really talking about the same thing?
For people on this thread, as MMGoldUser has described very well, the lyrics are wiped (or not accessible) & not visible from the iPod after a subsequent sync.

I can tell you that personally, I have never tried to read the lyrics from the iPod in MediaMonkey which would duplicate the steps to reproduce from this bug, and would seem to indicate this is on a track-by-track basis, as opposed to all tracks on the iPod that have lyrics.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 1175: Lyrics syncing with iPod 30GB

Post by nohitter151 » Mon Jan 11, 2010 6:19 pm

Ok. I've reopened the ticket.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

timepass18
Posts: 4
Joined: Mon Jan 04, 2010 5:40 am

Re: 1175: Lyrics syncing with iPod 30GB

Post by timepass18 » Thu Jan 14, 2010 7:15 am

This problem is not just with old devices. I am using a thirg generation iPod touch 64GB with 3.1.2 firmware and the problem still persists for me. (No lyrics after the first sync)

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 1175: Lyrics syncing with iPod 30GB

Post by nohitter151 » Thu Jan 14, 2010 6:26 pm

timepass18 wrote:This problem is not just with old devices. I am using a thirg generation iPod touch 64GB with 3.1.2 firmware and the problem still persists for me. (No lyrics after the first sync)
Anything special at all about how you repro this? I can't reproduce it at all on my iPhone.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

timepass18
Posts: 4
Joined: Mon Jan 04, 2010 5:40 am

Re: 1175: Lyrics syncing with iPod 30GB

Post by timepass18 » Mon Feb 01, 2010 7:12 am

nohitter151 wrote:
timepass18 wrote:This problem is not just with old devices. I am using a thirg generation iPod touch 64GB with 3.1.2 firmware and the problem still persists for me. (No lyrics after the first sync)
Anything special at all about how you repro this? I can't reproduce it at all on my iPhone.
1.) Add lyrics to songs
2.)Sync songs with iPod.
3.) Disconnect iPod
4.)Connect again
5.) Sync some more songs
6.)Disconnect iPod again
7.)Lyrics of all the songs which were added earlier get wiped off.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 1175: Lyrics syncing with iPod 30GB

Post by nohitter151 » Mon Feb 01, 2010 6:00 pm

timepass18 wrote: 1.) Add lyrics to songs
2.)Sync songs with iPod.
3.) Disconnect iPod
4.)Connect again
5.) Sync some more songs
6.)Disconnect iPod again
7.)Lyrics of all the songs which were added earlier get wiped off.
Auto-sync or sync selected? Auto works fine for me, I never use manual sync...
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

timepass18
Posts: 4
Joined: Mon Jan 04, 2010 5:40 am

Re: 1175: Lyrics syncing with iPod 30GB

Post by timepass18 » Tue Feb 02, 2010 11:17 am

nohitter151 wrote:
timepass18 wrote: 1.) Add lyrics to songs
2.)Sync songs with iPod.
3.) Disconnect iPod
4.)Connect again
5.) Sync some more songs
6.)Disconnect iPod again
7.)Lyrics of all the songs which were added earlier get wiped off.
Auto-sync or sync selected? Auto works fine for me, I never use manual sync...

Manual sync..I have added all my media files to MM library...however i choose which files to sync with the iPod

owlcat
Posts: 1
Joined: Tue Jun 01, 2010 6:31 pm

Re: 1175: Lyrics syncing with iPod 30GB

Post by owlcat » Mon Jun 28, 2010 1:11 pm

Same problem - so . am i to assume that i have to have all / any tracks wiht lyrics set up in itunes so they will not get wiped every time? This is very annoying for people like me who use the lyrics field for DJ tracklists for 1-hour+ sets... :(

iphone 3g, 3.1.3 fw - itunes installed, hopefully the latest "rc" version fixes this one too as well as let's me upgrade to 4.0 ios ... i'm kinda not feeling anything though.. lol.. :(

Post Reply