[1378] Error: VirtualTrees.pas while tagging

Beta Testing for Windows Products and plugins

Moderator: Gurus

timelezz
Posts: 151
Joined: Sun Nov 27, 2005 6:08 am

[1378] Error: VirtualTrees.pas while tagging

Post by timelezz » Mon Apr 18, 2011 8:02 am

[This first post is a report about MM4 beta v1365, but the error still exists in version 1378]

While tagging I frequently get the following message

Code: Select all

Pending and direct clearance are mutual exclusive! (M:\Sources\MediaMonkey\Common\VirtTree\VirtualTrees.pas, line 25272).
I could not really find out when it happens, or how to replicate. but it happens many times while I'm tagging. (I playback while tagging)

DebugView

Code: Select all

  8.1 : 2782.438s - PID:2760 - INWMP3:_Close() 2
        2782.438s - PID:2760 - INWMP3:_Close() 3
        2782.438s - PID:2760 - INWMP3:_Close() finished
        2782.438s - PID:2760 - INWMP3:_StopOutput() started
        2782.438s - PID:2760 - INWMP3:_StopOutput() finished
        2782.438s - PID:2760 - INWMP3:_Stop() finished
        2782.438s - PID:2760 - GetFileInfo:_\\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp32782.453s - PID:2760 - Thread has started 3668
        2782.453s - PID:2760 - Thread registered, going to initialize 3668
        2782.453s - PID:2760 - Thread initialized 3668
        2782.453s - PID:2760 - Going to make final callback 3668
        2782.453s - PID:2760 - Thread has finished 3668
        2782.469s - PID:2760 - MP3.ReadHeader \\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.469s - PID:2760 - MP3.ReadHeader - File size 4380800
        2782.484s - PID:2760 - MP3.ReadHeader - Found ID3v2, length:_21207
        2782.484s - PID:2760 - MP3.ReadHeader framestarts:_21217, 21217
        2782.484s - PID:2760 - MP3.ReadHeader finished
        2782.484s - PID:2760 - MP3:_Going to read tag from \\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.484s - PID:2760 - MP3:_Tag read from \\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.484s - PID:2760 - INWMP3:_Open()
        2782.484s - PID:2760 - INWMP3:_StripID3Stream:_Openning TStreamAccess
        2782.484s - PID:2760 - Locking file:_\\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.500s - PID:2760 - Locked file:_\\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.500s - PID:2760 - Unlocking file:_\\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.500s - PID:2760 - Unlocked file:_\\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.500s - PID:2760 - INWMP3:_StripID3Stream:_SetID3Offset().
        2782.500s - PID:2760 - INWMP3:_StreamSeek 2 - 0
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 0
        2782.500s - PID:2760 - INWMP3:_StripID3Stream:_ID3 found and skipped.
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 0
        2782.500s - PID:2760 - INWMP3:_StripID3Stream:_Looking for data.
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 0
        2782.500s - PID:2760 - INWMP3:_StripID3Stream:_Open finished.
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 0
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 0
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 4359455
        2782.500s - PID:2760 - INWMP3:_OnStatus 1.
        2782.500s - PID:2760 - INWMP3:_Open() - Stream openned.
        2782.500s - PID:2760 - INWMP3:_Open() - Stream starting.
        2782.500s - PID:2760 - INWMP3:_Seek() started
        2782.500s - PID:2760 - INWMP3:_StopStream() started
        2782.500s - PID:2760 - INWMP3:_StopStream() finished
        2782.500s - PID:2760 - INWMP3:_StartStream() started
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 0
        2782.500s - PID:2760 - INWMP3:_OnStatus 11.
        2782.500s - PID:2760 - INWMP3:_Seek() finished
        2782.500s - PID:2760 - TWAInputPlugin.Play finishing
        2782.500s - PID:2760 - Winamp sim - WM_USER message 603
        2782.500s - PID:2760 - TWAInputPlugin.setPositionMS starting
        2782.500s - PID:2760 - INWMP3:_StopStream() started
        2782.500s - PID:2760 - INWMP3:_OnStatus 12.
        2782.500s - PID:2760 - INWMP3:_StopStream() finished
        2782.500s - PID:2760 - INWMP3:_Seek() started
        2782.500s - PID:2760 - INWMP3:_StopStream() started
        2782.500s - PID:2760 - INWMP3:_StopStream() finished
        2782.500s - PID:2760 - INWMP3:_StartStream() started
        2782.500s - PID:2760 - INWMP3:_StreamSeek 0 - 3302463
        2782.500s - PID:2760 - INWMP3:_OnStatus 11.
        2782.500s - PID:2760 - INWMP3:_Seek() finished
        2782.500s - PID:2760 - TWAInputPlugin.setPositionMS finishing
        2782.516s - PID:2760 - SynchronizingAfterTagging starting
        2782.516s - PID:2760 - Tagging:_Track was tagged:_\\ALGEMEEN\D\mp3\Sub Focus & Brooks Brothers - Late Run.mp3
        2782.516s - PID:2760 - Tagging:_Thread finished
        2782.516s - PID:2760 - Going to make final callback 3924
        2782.516s - PID:2760 - Thread has finished 3924
        2782.703s - PID:2760 - SynchronizingAfterTagging - buffer match found
        2782.719s - PID:2760 - SynchronizingAfterTagging finished
        2783.734s - PID:2760 - MMDS:_Written 101376 bytes
        2783.750s - PID:2760 - MMDS:_Written 101376 bytes
        2784.109s - PID:2760 - MMDS:_Written 101376 bytes
Last edited by timelezz on Tue May 24, 2011 5:05 pm, edited 1 time in total.

PhYrE
Posts: 86
Joined: Sat Jan 08, 2011 10:43 am

Re: [1365] Error: VirtualTrees.pas while tagging

Post by PhYrE » Thu Apr 28, 2011 7:11 am

The error is reproducible as follows in the latest build:

- change the rating of one item by clicking in the 'rating' column in the main window
- immediately after, right click on another file (thus changing the selection, such as the file just below it), while it's still updating the existing file.

In sorting through my media collection, I was getting it every few minutes when I get a little too fast. it produces an AV which I sent a whole bunch of as crash reports via the automatic method.

timelezz
Posts: 151
Joined: Sun Nov 27, 2005 6:08 am

Re: [1365] Error: VirtualTrees.pas while tagging

Post by timelezz » Tue May 24, 2011 9:57 am

BUMP! I thought it was solved, but it reoccurs in build 1378.
Here a screenshot http://dl.dropbox.com/u/11655033/IMAG1965.jpg

Post Reply