1381 - Thread Creation Error [#8099]

Beta Testing for Windows Products and plugins

Moderator: Gurus

Stigg
Posts: 269
Joined: Wed May 18, 2011 7:56 pm

Re: 1381 - Thread Creation Error [#8099]

Post by Stigg » Sun Jul 31, 2011 3:15 am

I must say that MM v4.0.0.1414 is the buggiest I have seen for awhile.

The infamous Thread Creation Error is back, plus the player sometimes stops half way through an album and removes the tracks from the Playlist.
And when you try to close MM, you need to use Task Manager to shut it down.

Ludek
Posts: 3074
Joined: Fri Mar 09, 2007 9:00 am

Re: 1381 - Thread Creation Error [#8099]

Post by Ludek » Mon Aug 01, 2011 9:50 am

Hi, we have received a log: http://www.ventismedia.com/mantis/file_ ... 8&type=bug
Is this your log ??
I re-opened http://www.ventismedia.com/mantis/view.php?id=8099

1. In the log you wrote: "Switched to a playlist from web view.", I have some suspicions, but I need more info. Which web view it was? Which web page?
2. Do you use AA+Details view? Does this problem appear in the details view too?

Ludek
Posts: 3074
Joined: Fri Mar 09, 2007 9:00 am

Re: 1381 - Thread Creation Error [#8099]

Post by Ludek » Tue Aug 02, 2011 5:48 am

Also standard debug log (generated using DbgView) would be helpful.

BTW. Do you use the Web Search script? One user indicated here: http://www.ventismedia.com/mantis/view. ... 099#c27046 that it is reproducable with the WebSearch script

kiwichick
Posts: 320
Joined: Tue Jul 21, 2009 6:35 am

Re: 1381 - Thread Creation Error [#8099]

Post by kiwichick » Mon Aug 08, 2011 4:59 pm

I have this problem also and I can't reproduce it. Yes, it mostly happens when using the WebSearch script (I use it in MM Form mode) but is has also happened when a song changes while editing lyrics in the Properties windows. I can successfully tag 20 or 30 songs with WebSearch and then it just starts happening. Sometimes there are an infinite number of the error windows opening up. The more of them I close, the more of them that open. It doesn't seem to be any particular type of behaviour that causes it. Sometimes they can all be closed and allow MM to be closed successfully. Sometimes they just don't stopping popping up and the only way to stop them is to close MM via Task Manager.

kiwichick
Posts: 320
Joined: Tue Jul 21, 2009 6:35 am

Re: 1381 - Thread Creation Error [#8099]

Post by kiwichick » Sat Aug 13, 2011 5:49 am

Hi there, this was supposedly fixed in v1416. I have v1418 installed and the problem still exists for me. Anyone else?

Ludek
Posts: 3074
Joined: Fri Mar 09, 2007 9:00 am

Re: 1381 - Thread Creation Error [#8099]

Post by Ludek » Sat Aug 13, 2011 7:12 am

Could you generate debug log using the DbgView app as described here: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341 ?

Stigg
Posts: 269
Joined: Wed May 18, 2011 7:56 pm

Re: 1381 - Thread Creation Error [#8099]

Post by Stigg » Sun Aug 14, 2011 2:38 am

This Thread Creation Error has gotten worse for me with v4.0.0.1418.
So much so, that MM4 is not usable for me in this state.

Apart from the numerous error message, tracks stop playing or stop at the end of the track and doesn't proceed to the next track in the playlist.

Once I start seeing the Thread Creation Error, MM4 usually won't shut down properly, and I will have to end the task using the Task Manager.

And very occasionally MM4 will shut itself down without any user input.

Lowlander
Posts: 46257
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 1381 - Thread Creation Error [#8099]

Post by Lowlander » Sun Aug 14, 2011 12:41 pm

Stigg wrote:This Thread Creation Error has gotten worse for me with v4.0.0.1418.
Stigg wrote:Could you generate debug log using the DbgView app as described here: viewtopic.php?f=6&t=341 ?
Lowlander (MediaMonkey user since 2003)

kiwichick
Posts: 320
Joined: Tue Jul 21, 2009 6:35 am

Re: 1381 - Thread Creation Error [#8099]

Post by kiwichick » Sat Aug 20, 2011 4:50 am

Stigg wrote:Could you generate debug log using the DbgView app as described here: viewtopic.php?f=6&t=341 ?
Hi there, I've just installed v1421 and the same problem exists. This time it was specifically when I was saving AlbumArt using the RightClickForWeb form.

So I installed the debug version, ran the debug version and DebugView. I've uploaded the log - I hope this is the correct link: http://www.mediamonkey.com/support/inde ... etid=12802.

There were also two error reports sent from MM itself. So they will be wherever MM sends them :D

Hope this helps. Cheers.

kiwichick
Posts: 320
Joined: Tue Jul 21, 2009 6:35 am

Re: 1381 - Thread Creation Error [#8099]

Post by kiwichick » Sat Aug 20, 2011 5:53 am

OK update: I've been trying other ways to save AlbumArt (not using RCFW) but I am still unable to. I've tried pasting into the AlbumArt pane, pasting into the Properties/Artwork tab and using the 'Add' button in the Properties/Artwork tab but the MM error report window pops up every time. I think I've sent one for each scenario. This is in my portable debug install. My standard install (not debug version) throws up an Access Violation whenever I try the same non-RCFW options. Don't know if it's related but just letting you know in case it might be.

Ludek
Posts: 3074
Joined: Fri Mar 09, 2007 9:00 am

Re: 1381 - Thread Creation Error [#8099]

Post by Ludek » Mon Aug 22, 2011 5:10 am


richardap
Posts: 11
Joined: Fri Oct 22, 2010 7:24 am

Re: 1381 - Thread Creation Error [#8099]

Post by richardap » Thu Sep 01, 2011 8:12 am

I have been getting the Thread creation error. It seems to appear during a sync to my Cowon MP3 player. At first i didn't read it properly and just assumed i had tried to add too data to my device. After reading it i have had a look around it noticed a few threads on it.
Like i said i get it while syncing my device, i am also playing music, but not doing any editing like other people seem to be. The title of the box also doesn't match a song that is either in the sync list, currently play or playlist. It has happened a couple of times today.

Windows 7
4gb RAM (about 50% used)
200gb Free space DB drive
MediaMonkey 4.0.0.1424

Ludek
Posts: 3074
Joined: Fri Mar 09, 2007 9:00 am

Re: 1381 - Thread Creation Error [#8099]

Post by Ludek » Thu Sep 01, 2011 8:39 am

Could you please generate debug log using the DbgView app as described here: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341?

Post Reply