Errors on installing

Beta Testing for Windows Products and plugins

Moderator: Gurus

ui
Posts: 91
Joined: Fri Mar 12, 2004 9:44 am
Location: The Netherlands, NH
Contact:

Errors on installing

Post by ui » Thu Jul 28, 2011 3:33 pm

See this topic first: http://www.mediamonkey.com/forum/viewto ... sh#p300984

One question was answered. However, the other question, about the error messages on starting MM, was not.

What happened to me:
- I decided to install MM completely fresh.
- Uninstalled the last build I had installed and deleted all MM folders on the system.
- Installed latest build
- Started it and the following messages appear:
1. The directory C:\Program Files\MediaMonkey\Trash cannot be created.
Cancel - Retry - Ignore -> Ignore...
2. Cannot create file C:\Program Files\MediaMonkey\locae\NL\context.mo
Cancel - Retry -> Cancel...
Language file can't be installed.
OK -> OK...
- MM starts with English UI, but the welcome-page is in Dutch.

When I start MM as Administrator: [right-click -> Run as administrator]:
- No errors are displayed, but MM starts in English.
- Select Dutch -> MM start in English.

The language files are present in C:\...\locale\NL . Context.mo is there as well.
If I delete the context.mo file myself and then start MM, the error about the trash-folder does not appear, but the others still do.
Creating a Trash-file stops that error.
But why is MM insisting on creating a context.mo, while it's already there?
Why is there no dutch UI anymore?
It used to work okay...
Best regards,
Hans

Ludek
Posts: 2998
Joined: Fri Mar 09, 2007 9:00 am

Re: Errors on installing

Post by Ludek » Sat Jul 30, 2011 11:17 am

It seems that the install wasn't fresh, because it tries to move something from C:\Program Files\MediaMonkey\Scripts to C:\Program Files\MediaMonkey\Trash, but you doesn't seem to have enough rights for this.

Could you attach a debug log (generated using DbgView), it should tell us more what is going on.

Ludek
Posts: 2998
Joined: Fri Mar 09, 2007 9:00 am

Re: Errors on installing

Post by Ludek » Mon Aug 01, 2011 6:55 am

Solved via PMs, the problem was in corrupted Netherlands language pack, fixed as http://www.ventismedia.com/mantis/view.php?id=8199

Alikalix
Posts: 16
Joined: Sun May 23, 2010 9:57 am

Re: Errors on installing

Post by Alikalix » Tue Aug 09, 2011 5:06 am

I'm getting the same errors while trying to install Polish and Czech lang. pack.

ui
Posts: 91
Joined: Fri Mar 12, 2004 9:44 am
Location: The Netherlands, NH
Contact:

Re: Errors on installing

Post by ui » Tue Aug 09, 2011 6:09 am

Are you using build 1415?
And, maybe a weird question, do you have an Apple device that you use regularly with MM?
Best regards,
Hans

rusty
Posts: 7202
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Errors on installing

Post by rusty » Fri Aug 19, 2011 4:01 pm


Post Reply