[1440] New scripts not showing up

Beta Testing for Windows Products and plugins

Moderator: Gurus

martialartsguy
Posts: 266
Joined: Mon Apr 03, 2006 9:11 am
Location: Denver, CO

[1440] New scripts not showing up

Post by martialartsguy » Thu Oct 06, 2011 10:30 am

I've just loaded 1440 over 1439 and removed all my scripts. I then added two (DB Audit & DB Cleaner).

Only the last one added shows in the Tools > Scripts menu. I added another, and it showed up, but not the previous two.

When I add a script in that is accessible in Tools > Options, it's there, just not in the above menu.
MM 4.1.10.1778

rusty
Posts: 7203
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: [1440] New scripts not showing up

Post by rusty » Thu Oct 06, 2011 1:14 pm

I just tested DB Audit and it appears for me (don't know if it actually works...)

In any case, if the problem is reproducible for you, can you generate a debug log?

Thanks.

-Rusty

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: [1440] New scripts not showing up

Post by nynaevelan » Thu Oct 06, 2011 3:56 pm

DB Audit will not work in mm4 without changing the name of one of the tables in the script.
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

Teknojnky
Posts: 5533
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Re: [1440] New scripts not showing up

Post by Teknojnky » Sat Sep 08, 2012 9:13 pm

today I created a portable version of mm 4 - 1501, and both db audit and db clean fail to show up after restarting MM.

They do appear in the tools > scripts menu after initial installation, but not after restarting.

And it appears that installing one will remove the other from the scripts menu (before restarting).

http://sites.google.com/site/owynsmedia ... Audit.mmip
http://sites.google.com/site/owynsmedia ... Clean.mmip


here is the install.vbs, which probably is the culprit

Code: Select all

scriptName = "DB_Audit"
'Add scripts.ini entries
Dim inip : inip = SDB.ApplicationPath&"Scripts\Scripts.ini"
Dim inif : Set inif = SDB.Tools.IniFileByPath(inip)
If Not (inif Is Nothing) Then
	inif.StringValue(scriptName,"Filename") = "DB_Audit.vbs"
	inif.StringValue(scriptName,"Procname") = "OnStartup"
	inif.StringValue(scriptName,"Order") = "300"
	inif.StringValue(scriptName,"DisplayName") = "MM3 Database Audit Report"
	inif.StringValue(scriptName,"Description") = "MM3 Database Audit Report"
	inif.StringValue(scriptName,"Language") = "VBScript"
	inif.StringValue(scriptName,"ScriptType") = "0"
	SDB.RefreshScriptItems
End If
 
' Add entries for Mediamonkey.ini	
' Here you set the variables you need
' all 3 types are shown here

to actually get it running, need to comment out/remove the lines with DeviceFilters within the script

Teknojnky
Posts: 5533
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Re: [1440] New scripts not showing up

Post by Teknojnky » Sat Sep 08, 2012 11:44 pm

sql viewer also affected, installer fails to add scripts.ini settings

http://www.mediamonkey.com/forum/viewto ... 19&t=54408

Post Reply