[4.0.3.1465/6] Sorting/grouping bug(s)

MediaMonkey 4.1.3 has been released. The beta forum is currently closed.

Moderator: Gurus

[4.0.3.1465/6] Sorting/grouping bug(s)

Postby MeeMeeMee » Thu Jan 19, 2012 7:59 am

I just intalled 4.0.3.1465, eager to try the fix for this isssue.
The Sorting situation got a lot worst imho.
1. For one, sorting by Summary no longer (compared to 4.0.2.1462) lists the tracks in order (according to Disk#/Track#).
Edit: The tracks within a group are sorted by title, which I find an odd design decision choice (bug?)
Edit2: The sort-by-title seems to be the default behavior. But after editing an album's title the grouping goes out of whack. When you hit F5 (refresh) the sort order now looks random.
Edit3: I should've added that when queuing for playback those out-of-order tracks, their play order is the same as their display order in the library, which is pretty bad.
2. Clicking on the Summary causes grouping to go completely out of whack. Tracks that "should" be grouped together end up randomly(?) split across multiple one, two or four-track groups. Only after you click F5 (refresh) the view is restored to normal.

My settings are as following (in Playback Rules):
Line One: $if(<Album>,<Album Artist>,<Artist>)
Line Two: $if(<Album>,$if(<Year>,[<Year>],[????]) <Album> $if(<Comment>,{<Comment>}),$if($viewmode=3,$if($groupcount=1,<Title>)))

I'm using the "Show Art with Details" view.
Last edited by MeeMeeMee on Fri Jan 27, 2012 12:48 pm, edited 6 times in total.
MM 4.0.7.1511 on Win XP SP3
Media on D-Link DNS-323 NAS box, shared using SAMBA/CIFS
MeeMeeMee
 
Posts: 75
Joined: Fri Jul 02, 2010 7:13 am

Re: [4.0.3.1465] Sorting/grouping bug(s)

Postby Otello » Thu Jan 19, 2012 8:47 am

Yes, I confirm, same problem here.

P.S.: my settings for Classical Music:

$if(<Composer>, <Composer>) - <Album>
$if(<Conductor>, <Conductor>)$If(<Artist>, - <Artist>,)$If(<Publisher>, - <Publisher>,)$If(<Year>, - <Year>)
Otello
 
Posts: 93
Joined: Tue Nov 24, 2009 11:06 am
Location: Roma - Italy

Re: [4.0.3.1465] Sorting/grouping bug(s)

Postby BKKKPewsey » Thu Jan 19, 2012 1:20 pm

Same here :(

This is the views I get:

Image

Change sort to summary and track no :-?
Image

Image

Then MM decided it had enough too and stopped responding :x
A complete mess!!!
1465 portable (debug) in Vista as administrator
Everyone has the right to be stupid Image but some abuse the privilege
BKKKPewsey
 
Posts: 361
Joined: Sun Jun 05, 2011 10:45 am
Location: United Kingdom

Re: [4.0.3.1465] Sorting/grouping bug(s)

Postby Lowlander » Thu Jan 19, 2012 1:30 pm

Don't worry, I haven't been able to get 1465 to run normally in the first place.
Lowlander
 
Posts: 36512
Joined: Sat Sep 06, 2003 5:53 pm

Re: [4.0.3.1465] Sorting/grouping bug(s)

Postby PetrCBR » Mon Jan 23, 2012 12:22 pm

Will be fixed in next build.
PetrCBR
 
Posts: 1182
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech

Re: [4.0.3.1466] Sorting/grouping bug(s)

Postby gpzbc » Fri Jan 27, 2012 1:23 am

This bug was not fixed in 1466. I just installed it and the same problem exists.
--
The gpzbc
gpzbc
 
Posts: 1167
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: [4.0.3.1466] Sorting/grouping bug(s)

Postby PetrCBR » Fri Jan 27, 2012 2:57 am

Can you send me your DB and INI file, please ? I've tried on my own and cannot reproduce.
PetrCBR
 
Posts: 1182
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech

Re: [4.0.3.1465] Sorting/grouping bug(s)

Postby Otello » Fri Jan 27, 2012 10:06 am

Petr,

there is some progress for the sorting/grouping issue.

i.e.: if I configure the summary to show the Date, too, (sorting by summary) now I have albums with the same name and the same artist but different date not grouped, as requested (thanks).

But the tracks inside albums are sorted alphabetically and not by track #, even if I Cntrl+click on Track # column header. :(
Actually, it seems that Cntrl+click has no effect at all.
Otello
 
Posts: 93
Joined: Tue Nov 24, 2009 11:06 am
Location: Roma - Italy

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby gpzbc » Fri Jan 27, 2012 12:52 pm

I am sending a PM with video, DB, and ini.
Thanks
--
The gpzbc
gpzbc
 
Posts: 1167
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby MeeMeeMee » Fri Jan 27, 2012 12:56 pm

Yup, I'm experiencing the same thing Otello is reporting:
1. Grouping works OK in the 1466 build
2. Sorting by Summary causes each group of tracks to be sorted by title. The ascending/descending sort order of the track titles is decided by locked to the Summary ascending/descending sort order.

Besides the aesthetic aspect of it, the problem is that when adding a group of tracks to the playlist, the order of playback is the same as the order they're displayed, which is not good.

When you fix this, please please please sort by Track# AND Disk#.
Additionally, please don't do that ascending/descending sort order lock thing. In my case, for example, I set up the Summary in such a way (see first post) to sort by year. That way I can sort track groups (=albums) by year, seeing an artist's latest albums at the top of the list.
If you keep this sort order lock after fixing this, I'll end up with tracks listed in reverse order. That's, probably, not very useful. Can't think of a use-case where this comes handy (but I'm open to hearing of one).
It "should" work like the sorting by Disk# works: it also sorts by Track# (ascending). Sorting by Disk# (descending) still keeps the tracks sorted by Track# (ascending).
MM 4.0.7.1511 on Win XP SP3
Media on D-Link DNS-323 NAS box, shared using SAMBA/CIFS
MeeMeeMee
 
Posts: 75
Joined: Fri Jul 02, 2010 7:13 am

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby Otello » Fri Jan 27, 2012 1:21 pm

MeeMeeMee wrote:Additionally, please don't do that ascending/descending sort order lock thing. In my case, for example, I set up the Summary in such a way (see first post) to sort by year. That way I can sort track groups (=albums) by year, seeing an artist's latest albums at the top of the list.
If you keep this sort order lock after fixing this, I'll end up with tracks listed in reverse order. That's, probably, not very useful. Can't think of a use-case where this comes handy (but I'm open to hearing of one).
It "should" work like the sorting by Disk# works: it also sorts by Track# (ascending). Sorting by Disk# (descending) still keeps the tracks sorted by Track# (ascending).


Yes: +1 ;)

I think that - given that sorting tracks alphabeticallly is obviously a bug - the core of the issue is we need different rules for album sorting and tracks sorting inside albums.
Albums sorting by Summary shouldn't interfere with tracks (inside album) sorting.
Otello
 
Posts: 93
Joined: Tue Nov 24, 2009 11:06 am
Location: Roma - Italy

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby BKKKPewsey » Fri Jan 27, 2012 1:56 pm

Yep it is great improvement on 1465 with the exceptions as noted above which I concur with.
I do notice that if I sort on album artist the track list is sorted by track no and not on alphabetical title order so not all bad news :)
Everyone has the right to be stupid Image but some abuse the privilege
BKKKPewsey
 
Posts: 361
Joined: Sun Jun 05, 2011 10:45 am
Location: United Kingdom

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby see-beyond-me » Fri Jan 27, 2012 1:58 pm

another +1
not usable when looking at 'album interpret' with track sorting alphabetically instead of following track number ordering...reverted to build-1464, the last 'good' build where it was working fine...please correct before release

/MD
see-beyond-me
 
Posts: 31
Joined: Mon May 04, 2009 12:57 pm

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby Otello » Fri Jan 27, 2012 2:03 pm

BKKKPewsey wrote:I do notice that if I sort on album artist the track list is sorted by track no and not on alphabetical title order so not all bad news :)


You're right; I didn't notice before, as I don't use the artist album column at all.
The problem is that, the way I tag Classical Music, sorting by Album Artist my library get completely screwed. ;)
Otello
 
Posts: 93
Joined: Tue Nov 24, 2009 11:06 am
Location: Roma - Italy

Re: [4.0.3.1465/6] Sorting/grouping bug(s)

Postby theta_wave » Mon Jan 30, 2012 9:47 pm

Quick question here, I'm seeing a similar problem with grouping of albums sorted via criteria set by the user autoplaylists, particularly using the advanced sorting criteria in the paid version of MM. I detailed my issue in the thread below. Are you guys simply seeing this problem under the music/entire library node when sorting using summary? I was directed here, but I'm not so sure if it is the same problem.

viewtopic.php?f=6&t=63969
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin
theta_wave
 
Posts: 258
Joined: Fri Apr 13, 2007 12:54 am

Next

Return to MediaMonkey for Windows Beta Testing

Who is online

Users browsing this forum: stan9980 and 9 guests