[1470] WASAPI outputting Noise

Beta Testing for Windows Products and plugins

Moderator: Gurus

NRGman
Posts: 37
Joined: Wed Jan 12, 2011 9:12 am
Location: Perth, Australia

[1470] WASAPI outputting Noise

Post by NRGman » Mon Feb 06, 2012 11:04 pm

HI, I have been battling to find a solution to this problem but nothijng seems to work, i what to set MM to output in WASAPI Exclusive mode to a usb dac, no mater what buffer settings, sampling or fresh instals i do i get the same noise when playing tracks.

For instance, the track i am playing is Metal By Gary Numan (http://www.youtube.com/watch?v=lpBUmS5em0w) it should sound like that, but this is what it sounds like http://www.mediafire.com/?ks7i2julxxvky41

This is the log that shows what happens when i open MM, play that track and then close it: http://www.mediafire.com/?o524kre4mqcxy1x

Any ideas?

thanks for your time
My Setup:
"HFPC" Dell Optiplex 320 (2GB RAM, 3.0 Dual Core 1.5TB HDD) Win7 Ultimate SP1 x86
Musiland Monitor 02 US USB DAC
Nad C356BEE Integrated Amplifier
Custom 2-way loudspeakers

NRGman
Posts: 37
Joined: Wed Jan 12, 2011 9:12 am
Location: Perth, Australia

Re: [1470] WASAPI outputting Noise

Post by NRGman » Wed Feb 08, 2012 5:26 am

It seems i *may* have solved it by disabling "Event Driven Exclusive Mode" but doesn't that mean I'm not getting Bit Perfect stream to my dac?
My Setup:
"HFPC" Dell Optiplex 320 (2GB RAM, 3.0 Dual Core 1.5TB HDD) Win7 Ultimate SP1 x86
Musiland Monitor 02 US USB DAC
Nad C356BEE Integrated Amplifier
Custom 2-way loudspeakers

Otello
Posts: 93
Joined: Tue Nov 24, 2009 11:06 am
Location: Roma - Italy
Contact:

Re: [1470] WASAPI outputting Noise

Post by Otello » Wed Feb 08, 2012 9:05 am

Yes, you MAY have a bit-perfect output with Wasapi exclusive mode using "Push mode", too.
Actually Event mode is theoretically better (it has a shorter path in Windows audio), but some DACs do not work well with Event mode.

But take in mind that Wasapi exclusive mode is not enough to have a bit-perfect output; for instance, if you use a DSP like DsFX, or you enabled "Level Payback Volume to:", you cannot have bit-perfect.

pavlf

Re: [1470] WASAPI outputting Noise

Post by pavlf » Mon Dec 30, 2013 7:22 am

Ahhh, here is someone else with exactly the same problem as me. That is what my audio sounds like when using wasapi in exclusive mode. I want bitperfect output, but also want gapless and at the moment the two options seem to be mutually exclusive. I can have gapless with wasapit but not bitperfect, or can have bitperfect with asio but not gapless. I would be so happy to find a solution. I know that this isn't down to individual systems as it happens on all my computers.

Post Reply