DLNA-server unavailable after wake from hibernation

Beta Testing for Windows Products and plugins

Moderator: Gurus

Teunis
Posts: 28
Joined: Sat Dec 10, 2005 6:50 am
Location: Amsterdam, NL

DLNA-server unavailable after wake from hibernation

Post by Teunis » Sat Mar 08, 2014 2:40 pm

With 4.1-stable and the new beta builds, MM's DLNA-server is unavailable after the PC has woken from hibernation. It makes no difference whether I install the server as a service or not. In the Media sharing options screen, MM indeed says the server is "Stopped". The only solution is to exit and restart MM, or go to the options, uncheck and check the DLNA-server.
The DLNA-server worked just fine after hibernation with the 4.0.7 release.
I am running Win7 and am using hybrid sleep (so basically standby with RAM kept active initially).
Could it be that the introduction of DLNA-as-service introduced a bug which manifests itself after hibernation?
Thanks! -Teunis

Lowlander
Posts: 44980
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: DLNA-server unavailable after wake from hibernation

Post by Lowlander » Sat Mar 08, 2014 4:53 pm

Lowlander (MediaMonkey user since 2003)

Ludek
Posts: 2516
Joined: Fri Mar 09, 2007 9:00 am

Re: DLNA-server unavailable after wake from hibernation

Post by Ludek » Tue Mar 11, 2014 6:32 pm

Hi, probably somehow caused by fixing http://www.ventismedia.com/mantis/view.php?id=11531, but I can't replicate the issue.

By hybrid sleep you mean 'sleep' or 'hibernate'? I don't see another option on Win7.
Does it always happen or is it random?

mcow
Posts: 816
Joined: Sun Sep 21, 2008 9:35 pm
Location: Cupertino, California

Re: DLNA-server unavailable after wake from hibernation

Post by mcow » Sat Mar 15, 2014 1:40 pm

I saw this thread and it sounded similar to the problem I've been seeing, described at
http://www.mediamonkey.com/forum/viewto ... 21&t=75634

I put my Win7 system to sleep frequently; it's usually awake only in the evenings and on weekends. When I saw this thread, I decided to try a full reboot (PC and tablet) and after that, I was immediately able to sync.

My system uses "sleep" -- that is, no hibernation, system never powers off completely.

Note that I have never seen a case where UPnPlay could not find the the DLNA server; only MMA is unable to make the connection, and also unable to wifi sync.

mcow
Posts: 816
Joined: Sun Sep 21, 2008 9:35 pm
Location: Cupertino, California

Re: DLNA-server unavailable after wake from hibernation

Post by mcow » Sat Mar 15, 2014 1:46 pm

Ludek wrote:By hybrid sleep you mean 'sleep' or 'hibernate'? I don't see another option on Win7.
Ludek, Google is your friend. See the first question at:
http://windows.microsoft.com/en-us/wind ... -questions

Ludek
Posts: 2516
Joined: Fri Mar 09, 2007 9:00 am

Re: DLNA-server unavailable after wake from hibernation

Post by Ludek » Sun Mar 16, 2014 7:37 am

Mcow, thanks.

Nevertheless your issue sounds different as Teunis indicated that he is seeing the server "stopped" after the hybernation, actually the fix in #11531 was that the UPnP services are restarted after return from sleep or hibernate, but it problably doesn't work right for Teunis.
@Teunis, could you generate debug log for me? Item 4b here: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341 , does this always happen for you or it is random?

@mcow, you indicated that full reboot (PC and tablet) helps, could you try to reboot only tablet or PC to see which one actually helps? Are you able to see another server running on the same PC? I guess you are solving this issue with bhiefer as http://www.ventismedia.com/mantis/view. ... 774#c39883 ?

Teunis
Posts: 28
Joined: Sat Dec 10, 2005 6:50 am
Location: Amsterdam, NL

Re: DLNA-server unavailable after wake from hibernation

Post by Teunis » Sun Mar 23, 2014 11:23 am

Ludek, sorry for the late reply.
I am talking about Win7-sleep. This means standby initially (when RAM stays active), and full hibernation (commit to HDD and RAM power off) after a couple of hours. I haven't noticed a difference between waking from the two states. The service-stopped status is occurring each and every time after wake from hibernation (no random appearances). I'm submitting a debug log as requested through the helpdesk.
-Teunis

Ludek
Posts: 2516
Joined: Fri Mar 09, 2007 9:00 am

Re: DLNA-server unavailable after wake from hibernation

Post by Ludek » Sun Mar 23, 2014 5:29 pm

Hi, your issue was reproduced and fixed in build 1700.

Please re-test with build 1700 once is available and confirm.

Thanks!

mcow
Posts: 816
Joined: Sun Sep 21, 2008 9:35 pm
Location: Cupertino, California

Re: DLNA-server unavailable after wake from hibernation

Post by mcow » Mon Mar 24, 2014 8:25 pm

Ludek wrote:@mcow, you indicated that full reboot (PC and tablet) helps, could you try to reboot only tablet or PC to see which one actually helps? Are you able to see another server running on the same PC?
So, to be clear: If my PC sleeps while MMW (1692) is running, and it fails to sync after waking, it seems that restarting MMW is sufficient to get it working again.

If my PC sleeps after exiting MMW (which is more usual for me), the failure to sync happens less often (I think). It did just happen this afternoon when I got home. I tried first restarting MMW (no sync), then rebooting the tablet (still no sync). Finally I rebooted the PC, and then I could sync.

If I see this again, I'll try using NET STOP / NET START and see if that works to fix the sync.

I'm not going to install another server on the PC.

Teunis
Posts: 28
Joined: Sat Dec 10, 2005 6:50 am
Location: Amsterdam, NL

Re: DLNA-server unavailable after wake from hibernation

Post by Teunis » Wed Mar 26, 2014 3:42 pm

Ludek, I can confirm that with build 1700, the DLNA-service is again available after waking from hibernation.
I still haven't succeeded in getting the "install as service" to work properly; it says it installs correctly, but exiting MM nonetheless also seems to stop the service. But that's a different issue I suppose.
Thanks, -Teunis

dtsig
Posts: 2846
Joined: Mon Jan 24, 2011 6:34 pm

Re: DLNA-server unavailable after wake from hibernation

Post by dtsig » Wed Mar 26, 2014 6:43 pm

I have noted this installation problem in another thread (don't remember right off) as a reply to someone else having similar problem. This whole service bit seems to be still a little sketchy
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Post Reply