Page 1 of 1

Now-Playing: cannot rate songs in this view

Posted: Mon Jul 26, 2004 3:14 pm
by DC
Error: cannot rate/tag songs from the Now-Playing list (accessible via the first tree node), rating a song has no effect.

Steps to reproduce:
1. add some titles to the Now-Playing playlist
2. change rating of a title via toolbar dropdown menu

Effect: title's rating is not changed, Now-Playing still shows 0 stars, the property dialog shows "unknown" as rating

If the title already had a rating before it was added to Now-Playing the rating is displayed ok but still cannot be changed effectively. Also the current rating is not noticeable from the toolbar dropdown menu (usually the current rating should be highlighted when dropping down the menu). Rating works ok however from other views / treenodes, even for the same song.

Versions: MM build 2.2.0.760 or latest alpha build 2.2.2.772, Winamp 5.03c

Posted: Mon Jul 26, 2004 5:45 pm
by pah68
This has never worked for me when I use Winamp as the player. If I use MM as the player it works fine.

Posted: Mon Jul 26, 2004 5:49 pm
by DC
Ok, but this does not make much sense, does it? I mean MM can tag a song just fine in every view, regardless whether it is playing in Winamp or not. Just not in the Now-Playing view. Winamp compatibility is crucial to me and this should not be a big problem to solve...

Posted: Mon Jul 26, 2004 5:59 pm
by pah68
It would be nice, yes.

My work around, (because it never bugged me that much) was to create an auto playlist that tracks the most recently played songs. So after the song is played, I rate it from there.

Your Not Alone

Posted: Tue Jul 27, 2004 7:22 am
by julzcompufreek
Hi DC,

My name is Julian and I just thoght i'd tel you that you are not alone in using winamp as the player for MM. I use it too and for the smae reason as you. I put it at the top of title bar and have it "Always on Top" so I can see what song I am playing and play/pause/stop the music while doing something else without opening another window and interupting my other stuff.
So I hope that is comforting and if you have any probs to do with using winamp as MMs player, let me know. We might just be having the same problem.

julzcompufreek aka Julian
(I'm contacting you this way because for some reason PM (private messenger is not working for me)

Posted: Tue Jul 27, 2004 9:52 am
by Peke
PM is working but after sending PM it returns error but PM is sent and ignore that error, as it can be found in Sent.

Posted: Tue Jul 27, 2004 1:02 pm
by DC
Maybe a new PHP and/or phpbb Version is required...

Posted: Sat Jul 31, 2004 10:14 am
by DC
Any chance to have this sorted out anytime soon? Of all the Now-Playing related bugs this one is especially annoying and practically stops me from using MM because I cannot rate and classify the title currently playing.

Posted: Wed Aug 04, 2004 7:01 am
by jiri
The issue will be fixed in MM 2.2.2 final.

Jiri