1183 - Access Violation on Shutdown

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

1183 - Access Violation on Shutdown

Post by nynaevelan » Tue Jun 24, 2008 6:30 pm

Help:

I keep getting the following access violation when shutting down MM. It seems to happen if I do not give the program enough time between stopping the playing track and closing MM. It was my understanding that MM would stop the playing track before shutting down. If that is the case, why does this happen if I try to close less than 10 seconds after stopping the playing track. It also happens if I pause the track, then try to close MM. This has been going on for several beta versions but I didn't report it because I thought it was script related. But this also happens on my test MM, and there are no scripts installed in that version.

Image

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

Lowlander
Posts: 46111
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 1183 - Access Violation on Shutdown

Post by Lowlander » Tue Jun 24, 2008 7:29 pm

I can't reproduce it here, I tried to close MediaMonkey while a track was playing and no error message shows.
Lowlander (MediaMonkey user since 2003)

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: 1183 - Access Violation on Shutdown

Post by nynaevelan » Tue Jun 24, 2008 7:42 pm

Well I will try to create a debug log to send in.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

skipgilles
Posts: 18
Joined: Sat Feb 02, 2008 10:01 am

Re: 1183 - Access Violation on Shutdown

Post by skipgilles » Sat Jun 28, 2008 7:43 am

I experienced the same problem (MM3.0), But with the new version (MM3.03), I didn't encouter it yet, so maybe fixed?

(system windows XP)

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: 1183 - Access Violation on Shutdown

Post by nynaevelan » Sat Jun 28, 2008 7:49 am

I am running the latest version and I am still experiencing the errors and I cannot get the Debug program to work. It is not collecting any data. How do I get this to work? I followed the directions on how to save it to a log file, is there something else I should be doing?

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: 1183 - Access Violation on Shutdown

Post by nynaevelan » Sat Jun 28, 2008 2:32 pm

I switched to the debug version and I have sent in a debug log of the error I receive when closing. I wonder if these access violations are what is fudging up my database. :-? It's a good thing I REALLY love this program.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

Post Reply