Date tag.

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

SilentNN
Posts: 2
Joined: Tue Oct 07, 2008 11:46 pm

Date tag.

Post by SilentNN » Tue Oct 07, 2008 11:53 pm

Whenever I edit a single track and save changes, the date (which is only a year) disappears. I've figured that this is because MM only displays the last two digits of the date, even when editing tracks. When the changes are saved, years like 08 just disappear because it expects something more like 2008. This is less of a problem for editing multiple tracks because only the checked fields are saved and everything else is unchanged.

I realize this a minor problem, but I don't really think to edit a year when it should already be correct. And then I save changes and realize I lost the date and have to go find out what the year it was and come back to MM and change the date tag and save. Annoying.

spacefish
Posts: 1427
Joined: Mon Jan 14, 2008 7:21 am
Location: Denmark

Re: Date tag.

Post by spacefish » Wed Oct 08, 2008 3:28 am

The date column in MM is controlled by your computer's Regional Date and Time settings. I had to manually go into Vista's Regional and Language Options > Formats tab > Customize > Date tab and set the short date format to one that would display acceptably for me in MM. I use dd-MM-yyyy.
Image
MM Gold 3.0.3.1183 : Vista HP SP1 (x86) : Zen Stone (2GB)
Zekton: An original MM3 skin by Eyal.
Scripts in Use: Add/Remove PlayStat | Auto Album DJ | AutoRateAccurate | Backup
Case & Leading Zero Fixer | Classification & Genre Changer | Clean Scripts.ini | Clear
Field | Custom Report | Discogs Auto-Tag Web Search | Forget Crossfade | Invert
Selection/Select None | Last 100... | Lyricator | Lyrics to Instrumental | MonkeyRok
MusicBrainz Tagger | My Custom Nodes | Now Playing Art Node | Play History & Stats
Right Click for Reports | Right Click for Scripts | Right Click for Web | Stop After Current
WebNodes

SilentNN
Posts: 2
Joined: Tue Oct 07, 2008 11:46 pm

Re: Date tag.

Post by SilentNN » Wed Oct 08, 2008 3:41 am

Thanks for the help. Problem solved.

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: Date tag.

Post by chrisjj » Wed Oct 08, 2008 4:49 am

spacefish wrote:The date column in MM is controlled by your computer's Regional Date and Time settings. I had to manually go into Vista's Regional and Language Options > Formats tab > Customize > Date tab and set the short date format to one that would display acceptably for me in MM. I use dd-MM-yyyy.
Changing to yyyy-mm-dd doesn't solve the problem here of MM failing to show WMA files' dates e.g. 1941-02-26. Any ideas?
Chris

Post Reply