wininet error #126 : (Unknown WININET error)

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Piksou
Posts: 11
Joined: Fri Oct 17, 2008 2:01 pm

Re: wininet error #126 : (Unknown WININET error)

Post by Piksou » Sun Mar 22, 2009 4:32 pm

Confirmed fixed for me in 1228 :-)

Ludek
Posts: 3036
Joined: Fri Mar 09, 2007 9:00 am

Re: wininet error #126 : (Unknown WININET error)

Post by Ludek » Mon Mar 23, 2009 5:19 am

Note that registering wininet.dll should be performed as "regsvr32 /i /n wininet.dll" - i.e. the /i and /n parameters are needed otherwise error appears: "The module “wininet.dll” was loaded but the entry-point DllRegisterServer was not found."

Nevertheless the error should be resolved by installing build 1228 as confirmed by one of users that experienced this problem.
You can download 1228 from here:
http://www.mediamonkey.com/forum/viewto ... 34522&sd=d

Ludek
Posts: 3036
Joined: Fri Mar 09, 2007 9:00 am

Re: wininet error #126 : (Unknown WININET error)

Post by Ludek » Mon Mar 23, 2009 5:20 am

ooups, now I see it is confirmed by 2 users, nice to hear ;-)

IDisposable
Posts: 13
Joined: Mon Nov 10, 2008 7:04 pm

Re: wininet error #126 : (Unknown WININET error)

Post by IDisposable » Mon Mar 23, 2009 9:53 am

I can also confirm that build 1228 fixed it (where 1227 did not). Perhaps installing 1228 AFTER IE8 might be related.

macmcd
Posts: 96
Joined: Wed Jul 09, 2008 7:22 am

Re: wininet error #126 : (Unknown WININET error)

Post by macmcd » Thu May 21, 2009 3:42 am

How do I get build 1228 to resolve this problem. I gather it is a Beta release as the download page still has 3.0.7.1191.

Thanks.

Ludek
Posts: 3036
Joined: Fri Mar 09, 2007 9:00 am

Re: wininet error #126 : (Unknown WININET error)

Post by Ludek » Thu May 21, 2009 5:12 am


macmcd
Posts: 96
Joined: Wed Jul 09, 2008 7:22 am

Re: wininet error #126 : (Unknown WININET error)

Post by macmcd » Thu May 21, 2009 7:45 am

Lovely. That seems to have done the trick with the added bonus that my phone memory stick has been recognised. Happy Days.

Thanks.

rmegal

Re: wininet error #126 : (Unknown WININET error)

Post by rmegal » Fri May 22, 2009 8:12 am

There is another post that says this is fixed in 3.1. Is there an ETA for 3.1?

rmegal

Re: wininet error #126 : (Unknown WININET error)

Post by rmegal » Fri May 22, 2009 8:18 am

Newbie error; I didn't go to the end of the posts. I installed build 1247 and that fixed it. Looking forward to the GA release.

Mike1980

Re: wininet error #126 : (Unknown WININET error)

Post by Mike1980 » Tue May 26, 2009 4:31 am

I just encountered this error and found this old thread. Seems like the error was never fixed, and I don't like the way IE8 is being blamed for a problem that is affecting Media Monkey exclusively. So, I've fired Media Monkey and replaced it with Winamp. Newest version of Winamp has better podcast support, which was the best selling feature for Media Monkey for me.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: wininet error #126 : (Unknown WININET error)

Post by nohitter151 » Tue May 26, 2009 9:35 am

Mike1980 wrote:I just encountered this error and found this old thread. Seems like the error was never fixed, and I don't like the way IE8 is being blamed for a problem that is affecting Media Monkey exclusively. So, I've fired Media Monkey and replaced it with Winamp. Newest version of Winamp has better podcast support, which was the best selling feature for Media Monkey for me.
The last 5 posts talk about how this was fixed in MM 3.1.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

sbs

Re: wininet error #126 : (Unknown WININET error)

Post by sbs » Mon Aug 03, 2009 10:20 pm

I'm using 3.1.0.1256 and getting this error...

sbs

Re: wininet error #126 : (Unknown WININET error)

Post by sbs » Mon Aug 03, 2009 10:33 pm

ZoneAlarm blocking IE access will result in this error within media monkey.

MrQuan83

Re: wininet error #126 : (Unknown WININET error)

Post by MrQuan83 » Sat Aug 29, 2009 4:10 pm

Still getting this error in version 3.1.1.1261

Tried IE8 on lowest security settings with no luck, and I don't want to uninstall IE8 just for other buggy software. Has this been confirmed as a MM issue??

Btw, iPhone 3G 3.0 is working again in this build which is awesome because MM was my iTunes replacement for that, I don't want to uninstall because of this podcast issue (I have paid for Gold membership, so I'm not just being ungrateful).

MrQuan83

Re: wininet error #126 : (Unknown WININET error)

Post by MrQuan83 » Sun Aug 30, 2009 7:06 am

Ok, so I downgraded Internet Explorer 8 to 7 and I'm still not able to update my podcasts.

Here's some info on my machine:
MediaMonkey 3.1.1.1261
Windows Vista Ultimate 64-bit Service Pack 2
Internet Explorer 7.0.6002.18005
Windows Firewall (no other firewall software)
AVG Anti-Virus Free
Spybot - Search & Destroy

What I've tried:
Downgrading IE8 to IE7
Registering wininet.dll
Checked my Windows 'hosts' file
Adding a program exception for MediaMonkey through Windows Firewall
Disabling Windows Firewall
Restarting heaps etc.

Still no dice. I don't see an error, but when I click to update a podcast I see a progress-bar appear in the status area and instantly disappear (I imagine this is the usual podcast download status). I'm not sure if there is an error log anywhere? Can someone please tell me if an error log exists and how to access it, and I'll post those details here too.

Post Reply