MM 3.1 hangs up on tag update w/album art

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

MM 3.1 hangs up on tag update w/album art

Post by Karolm » Sat Jun 20, 2009 10:58 am

MM 3.1:
I download album art by clicking the icon in track properties "get album art and track properties from Amazon" (much less choice then in previous version, incidentally). Then I re-check the box "apply to all tracks on the album" (though it should do it by itself) on the "Album Art" page of track properties dialog and click "OK". This sometimes works, but most of the time "the program is not responding" (says Microsoft in asking for the report). The process shown after the "3 button panick click" is ccSvcHst. The visible sign is graphic: the line dividing the main screen from the tree appears above (crosses) the dialog window. Needless to say, this is hardly "the improved album art handling" advertised for the newest version: it has never happened to me before.

My system is XP Home Edition, IE8; Sony Vaio desktop.
"I wish you well!" - Rex Stout

Lowlander
Posts: 46408
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MM 3.1 hangs up on tag update w/album art

Post by Lowlander » Sat Jun 20, 2009 12:23 pm

I can't reproduce, it works as expected.

The limited results from Auto-Tag from Web is tracked here: http://www.ventismedia.com/mantis/view.php?id=5802
Lowlander (MediaMonkey user since 2003)

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: MM 3.1 hangs up on tag update w/album art

Post by nohitter151 » Sat Jun 20, 2009 12:49 pm

Try to reproduce the bug with the debug version and produce a log as described in the bug reporting thread.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

Re: MM 3.1 hangs up on tag update w/album art

Post by Karolm » Sat Jun 20, 2009 1:00 pm

As for limited results on artwork search, I never came close to 10 in current version. As for debugging, it sounds a little involved to me; I'll see what I can do. But here's a concrete example: I had 11 songs from the "Best film 100" album (6 disks), most of them from disk 2. I don't know if it's album related, but maybe you'll want to try.
"I wish you well!" - Rex Stout

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: MM 3.1 hangs up on tag update w/album art

Post by nohitter151 » Sat Jun 20, 2009 1:10 pm

Karolm wrote:As for limited results on artwork search, I never came close to 10 in current version. As for debugging, it sounds a little involved to me; I'll see what I can do. But here's a concrete example: I had 11 songs from the "Best film 100" album (6 disks), most of them from disk 2. I don't know if it's album related, but maybe you'll want to try.
Its not difficult at all, the thread is much more long winded than it needs to be. Just download the debug version and install it. Also download the debug viewer. Open the debug viewer, then open the debug version of MM. Reproduce your error and copy the contents of the log into a txt file and send to the devs.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

Re: MM 3.1 hangs up on tag update w/album art

Post by Karolm » Sat Jun 20, 2009 6:37 pm

No, thread's all right, I get that, thank you. What I am wondering about is the aftermath: how do I get rid of the debug version (installed on top) etc.? I tried to ask support, but somehow, very un-typically, can't get the answer.

Anyway, yesterday it (hang-up) was happening all the time, but today it happened twice and no more - so I would be unable "to reproduce the bug" anyway. It is intermittent - the worse kind.

Greetings - K.
"I wish you well!" - Rex Stout

fourteen
Posts: 127
Joined: Tue Mar 03, 2009 9:03 pm

Re: MM 3.1 hangs up on tag update w/album art

Post by fourteen » Sat Jun 20, 2009 7:49 pm

This problem/bug has been reported before, see http://www.mediamonkey.com/forum/viewto ... =6&t=38494 and http://www.ventismedia.com/mantis/view.php?id=5654

I also managed to generate a debug log as is documented in http://www.mediamonkey.com/forum/viewto ... =6&t=38494. Unfortunately the issue was closed without being fixed.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: MM 3.1 hangs up on tag update w/album art

Post by nohitter151 » Sat Jun 20, 2009 8:03 pm

Karolm wrote:No, thread's all right, I get that, thank you. What I am wondering about is the aftermath: how do I get rid of the debug version (installed on top) etc.? I tried to ask support, but somehow, very un-typically, can't get the answer.

Anyway, yesterday it (hang-up) was happening all the time, but today it happened twice and no more - so I would be unable "to reproduce the bug" anyway. It is intermittent - the worse kind.

Greetings - K.
To get rid of the debug version you can just install the regular version right over the old one again. Not that there's anything wrong with the debug version -- its exactly the same as the regular version, just produces logs that the debug viewer can read.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

Re: MM 3.1 hangs up on tag update w/album art

Post by Karolm » Sat Jun 20, 2009 9:08 pm

Thanks, Pavle wrote to me with the same advice. Will do if and when the bug shows up again.
"I wish you well!" - Rex Stout

Peke
Posts: 12595
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: MM 3.1 hangs up on tag update w/album art

Post by Peke » Sun Jun 21, 2009 2:25 pm

@fourteen
The bug was closed as duplicate of http://www.ventismedia.com/mantis/view.php?id=5644 which is also fixed but never closed as Jiri was only one that confirmed fix and we are waiting for users to confirm that there was no regressions and/or issue is fixed.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

Re: MM 3.1 hangs up on tag update w/album art

Post by Karolm » Sun Jun 21, 2009 2:39 pm

Well, I'd suggest considering it as NOT fixed.
"I wish you well!" - Rex Stout

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

Re: MM 3.1 hangs up on tag update w/album art

Post by Karolm » Tue Jun 23, 2009 7:19 pm

An update: the bug showed up again. I found a way to get out of it: close the program (by clicking "End now" in the error message window), then reboot the computer. Since it works afterwards, there would not be a chance to use the debug MM version.

My system: XP SP3 Home Edition, Sony Vaio desktop.
"I wish you well!" - Rex Stout

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: MM 3.1 hangs up on tag update w/album art

Post by jiri » Wed Jun 24, 2009 2:06 am

In case you have the debug build installed, keep it always running and reproduce the issue (when MM freezes), there should be an automatic crash report generated after a while (like 30 seconds or so). Such a report would be very useful for understanding what's going on. This didn't work correctly previously (when you first reported the problem), but is fixed at this moment.

Jiri

Karolm
Posts: 73
Joined: Sun May 13, 2007 12:32 pm
Location: Los Angeles, California

Re: MM 3.1 hangs up on tag update w/album art

Post by Karolm » Wed Jun 24, 2009 1:05 pm

I do not have the debug version installed, for the reasons I mentioned. "It's fixed now" - do you mean I should re-install the regular 3.1 version?
"I wish you well!" - Rex Stout

Post Reply