Convert Audio Format fails on some tracks

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Convert Audio Format fails on some tracks

Postby WilliFixit » Wed Feb 03, 2010 5:30 pm

I have a machine with 8 cores, and it seems that MM uses all possible cores to multithread the conversion of files. Here's what is happening on my Windows 7 -64 machine:

1. Select an album already in MM with say 15 tracks all in APE lossless format.
2. Select all files and choose Tools > Convert Audio Format (I convert to MP3 Extreme preset)
3. MM starts converting, and in Task Manager I can see 8 instances of Decoder.exe working to decode the files.
4. In Windows Explorer I can see the first 8 tracks, without the MP3 extension are created.

At this point several things can happen:
--MM crashes (Message says MediaMonkay - Audio Library has stopped working)
--It looks as if MM finishes, but if you try to play the converted tracks about 20% won't play at all
--It always seems that one or two of the Decoder.exe files remains in Task Manager running (I must kill them in TM to resolve the issue otherwise it seems that it keeps certain desitnation MP3 or MP3.xxxxx files locked)
--Occasionally everything works OK, and MM converts all the files properly.

To fix the bad tracks I have to manually delete the MP3 tracks in their folder using Windows Explorer. In the folder are MP3 files, MP3.XXXXXX files and others. I can always tell in Explorer when the files are bad, as they do not have their track number or the album title showing in the window. See http://emeraldeagle.com/Bad_Convert.png for more detail.

Sometimes I cannot delete the files unless I close MM altogether and kill all the Decoder.exe files in Task Manager.

Then I try again until I get all the tracks converted.


This is a real pain since I have several things to convert at once. What is worse is that I know I have bad tracks since I used this process to convert files when I upgraded my entire collection to loseless, and then converting all the APE files to MP3 for iPods, etc.

What is going wrong, and how do I fix it????

Machine specifics: Windows 7-64 with all updates, Dell Precision T7500, 16GB RAM, internal RAID 10 2TB drives, dual Quad Core Xenon 2.4GHz procs, audio files on external 750 Seagate USB drive, DVD +-RW, Blu Ray RW.

Thanks,
WilliFixit
 
Posts: 7
Joined: Fri May 23, 2008 9:13 pm

Re: Convert Audio Format fails on some tracks

Postby cooperg21 » Wed Mar 17, 2010 2:27 pm

I have a very similar issue. Hopefully someone can put this into a bug report or something and help us out. I too have a quad core and MM just says that it cannot convert some files and they end up being there but with not tag info and won't open.

Everything workeed out just fine until I got my quad core... I stress tested it for 24hr with no errors and I always get ".....was not successfully created" as an error whenever I try to convert a bunch of songs. It works fine for a few, then just gives up and I have to hold enter and scroll through all of the confirmation boxes saying that it didn't convert correctly...
cooperg21
 
Posts: 34
Joined: Thu Jun 11, 2009 12:17 pm

Re: Convert Audio Format fails on some tracks

Postby WilliFixit » Wed Mar 17, 2010 4:01 pm

It is definitely an issue and confirmed it with their team and lots of testing. Seems that there is some issue with the multi-threading and using multiple CPUs, but not multiple cores. My machine has eight cores, but when I limited which cores MM used (in Options > Performance) so that only four (of my eight) cores, and only those on one CPU the conversions seem flawless, and consistent.

I know that they are trying to figure a fix, but don't know the current status. Since this has been affecting so few of us, it wasn't high on their priority list. The last I heard from them was 12FEB, when they asked me to do some more tests. Unfortunately I was on the road, away from my main machine, and I did not really have the time to do more testing so they closed the case. I only hope that they still will make sure that this works on some future revision... I want to use ALL THE POWER of my machine!

Hope that helps!
Will Adams
WilliFixit
 
Posts: 7
Joined: Fri May 23, 2008 9:13 pm

Re: Convert Audio Format fails on some tracks

Postby cooperg21 » Tue Mar 23, 2010 7:00 pm

Is there a way to turn off hyperthreading or something? (I have a q9550.)

Pretty much the only reason that I bought the new processor is so that I can reconvert my entire library without it taking a month...

So yes, I agree, MORE POWER! :)

If I go down to one processor, I am okay, but that totally defeats the purpose of a new processor...
cooperg21
 
Posts: 34
Joined: Thu Jun 11, 2009 12:17 pm

Re: Convert Audio Format fails on some tracks

Postby cooperg21 » Thu Mar 25, 2010 3:35 pm

Sorry for the double post but I was wondering if there was any word from the devs regarding this issue. Using all of my cores is a huge reason to upgrade to gold and it almost feels like a bait and switch when it is broken like it is... If I try to batch convert 7000 songs and it screws up on song 200 (which it usually does) I have to click ok about SEVEN THOUSAND TIMES..... I usually just force close but this erases any changes to my library.....

I love mediamonkey, I really do, but this is pretty unacceptable. Quad cores are fast becoming the future of computing and while I am glad to see that they are utilizing the technology, I am saddened to see that it is so broken.

Any assistance or acknowledgment would be greatly appreciated.

Thanks,

Cooper
cooperg21
 
Posts: 34
Joined: Thu Jun 11, 2009 12:17 pm

Re: Convert Audio Format fails on some tracks

Postby Kov-Ice » Fri Apr 22, 2011 6:01 pm

Any further information on this error? I still have this happen, although it is an occasional error rather than every time I convert. I'm running MM Gold 3.2.4.1304.

Thx,
Kov
Kov-Ice
 
Posts: 27
Joined: Fri Dec 21, 2007 1:13 am

Re: Convert Audio Format fails on some tracks

Postby nohitter151 » Fri Apr 22, 2011 6:26 pm

I can't reproduce any problem. I convert several thousand files for my iPhone and iPod, but I never had a problem. You may need to obtain a debug log and send to the devs to collect some more info about what is actually going wrong.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
nohitter151
 
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA

Re: Convert Audio Format fails on some tracks

Postby Kov-Ice » Fri Apr 22, 2011 6:41 pm

How do I obtain a debug log?
Kov-Ice
 
Posts: 27
Joined: Fri Dec 21, 2007 1:13 am

Re: Convert Audio Format fails on some tracks

Postby Lowlander » Fri Apr 22, 2011 10:32 pm

Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43411
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Convert Audio Format fails on some tracks

Postby wazzer150864 » Thu Sep 21, 2017 11:29 am

Did this issue have a resolution please? I have an on-going issue with MM stopping responding when I am converting MP3 files to 320. Sometimes it is no issue at all and I can do more than 100 tracks at a time, other times it stops after a few tracks. I then have to open task manager and close MM fully. Even then I can not restart the conversion process unless I full reboot the PC.
wazzer150864
 
Posts: 13
Joined: Tue Aug 18, 2009 2:19 am

Re: Convert Audio Format fails on some tracks

Postby Lowlander » Thu Sep 21, 2017 11:46 am

Which version of MediaMonkey?
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43411
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Convert Audio Format fails on some tracks

Postby wazzer150864 » Sun Sep 24, 2017 6:53 am

Hi, I have 4.1.17.1840 version currently

Paul
wazzer150864
 
Posts: 13
Joined: Tue Aug 18, 2009 2:19 am

Re: Convert Audio Format fails on some tracks

Postby Lowlander » Sun Sep 24, 2017 5:44 pm

In that case you could try the latest beta from the Beta forum or also capture a debug log (step 4b) and attach it to a Support Ticket: viewtopic.php?f=7&t=69
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43411
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5


Return to Bug Reports (mmw)

Who is online

Users browsing this forum: No registered users and 12 guests