[bug#8717] Problems with volume analysis and CD Ripping

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

BKKKPewsey
Posts: 361
Joined: Sun Jun 05, 2011 10:45 am
Location: United Kingdom

[bug#8717] Problems with volume analysis and CD Ripping

Post by BKKKPewsey » Thu Nov 17, 2011 7:52 am

If I have the automatically analyze volume of unanalyzed tracks option set I get this rather undesirable behaviour when ripping tracks.
After the 1st tracked is ripped MM goes and analyzes the volume whilst the next track is being ripped.
After that track is ripped MM than goes and analyzes track 1 again and then track 2.
This is repeated on every track as it is being ripped so on a 12 track album track 1 ends up being analyzed 12 times (track 2 ,11 times and so on..)
Shouldn't volume analysis be put "on hold" until all tracks are ripped? :-? (MM will wear my tags out :) )

To get over that I turned off Auto analyze checkbox which lead me to another problem!
(Not reporting as bug because it may be me :cry: )
I added some tracks to the library which already had track volume gain values set in the tags but no Album volume.
I highlighted the tracks and asked MM to analyze volume - which it did.
After it had finished nothing happened eg no saving of tags
I then tried another album which also had track but no album replay gain tags set and the same result :(
So turned back on auto analyze and MM went and analyzed the tracks again but this time updated the tags and added the album volume :)
Any idea why the manual approach didn't work or is this another bug (sorry undocumented feature :D )

All tracks were mp3's and MM running on Vista (32)
Everyone has the right to be stupid Image but some abuse the privilege

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: [bug#8717] Problems with volume analysis and CD Ripping

Post by nohitter151 » Thu Nov 17, 2011 10:29 am

MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Post Reply