[1481] Sorting bug: "Ignore Prefix" ignored in Autoplaylist

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

[1481] Sorting bug: "Ignore Prefix" ignored in Autoplaylist

Post by theta_wave » Sat Mar 24, 2012 2:32 am

I find albums missing under show art with details view when I select an autoplaylist with a bunch alternative/rock genres (alternative/rock/shoegaze/dream pop/grunge/ etc..). I posted a video of what happens below. Per the video, I'm looking for the latest album by The Men, but it is not found under the view "show art with details." However, the artist is listed under the column browser (see video). Switching to details view, I can see the artist and the album which were missing under show art + details (see video). I started over using the details view from the beginning. Selecting the autoplaylist and viewing the results under detail view yields the artist and album that were missing under the view "show art with details." However, I much prefer using the "show art with details" view because I am able to scroll through the album list extremely quickly.

http://youtu.be/_0ruhlX1kV4

EDIT: The problem is that the "ignore prefix" setting for artists is ignored under show art+details. See below
Last edited by theta_wave on Fri Aug 09, 2013 12:12 pm, edited 12 times in total.
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

Lowlander
Posts: 46625
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by Lowlander » Mon Mar 26, 2012 11:00 am

What is the Album Artist for The Men's Album and what column did you sort on?
Lowlander (MediaMonkey user since 2003)

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by theta_wave » Mon Mar 26, 2012 11:50 am

Lowlander wrote:What is the Album Artist for The Men's Album and what column did you sort on?
The value for album artist and artist is the same for that album and sorting for the autoplaylist is set to album artist.
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

Lowlander
Posts: 46625
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by Lowlander » Mon Mar 26, 2012 11:57 am

And you checked the whole list to verify the Artist is missing? What if you select the Artist in the Column Browser, does it display then?
Lowlander (MediaMonkey user since 2003)

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by theta_wave » Mon Mar 26, 2012 9:21 pm

Lowlander wrote:And you checked the whole list to verify the Artist is missing? What if you select the Artist in the Column Browser, does it display then?
Yes, I scrolled down using the sidescroller and noticed the missing album from that artist (same display as in the video I posted). When I scroll down the artist list in the Column Browser and select the artist, the album shows up fine in the view "Show Art with Details." Interestingly, the album goes back missing after selecting "All" under the Column Browser and scrolling down where it should be. Also, under Library > Appearance, I have "Ignore prefixes when sorting by Artist" checked to ignore the prefix "the".
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

Lowlander
Posts: 46625
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by Lowlander » Mon Mar 26, 2012 9:32 pm

theta_wave wrote:Yes, I scrolled down using the sidescroller and noticed the missing album from that artist
So it was in view, but in the wrong place?
Lowlander (MediaMonkey user since 2003)

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by theta_wave » Mon Mar 26, 2012 9:48 pm

Lowlander wrote:
theta_wave wrote:Yes, I scrolled down using the sidescroller and noticed the missing album from that artist
So it was in view, but in the wrong place?
Nope, sorry my bad. I should of proofread. Let me try to be clearer this time. When I brought up the multi-genre autoplaylist to "show art with details" and scrolled down using the sidescroller, the album at issue was not found where it should be (The Men - Open Your Heart). The result is the same as in the video I posted in the first video. Clicking the artist name in the column browser brought the album up. Selecting "All" in the Column Browser under Artist and scrolling down to where the artist results in nothing for it.
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by theta_wave » Mon Mar 26, 2012 9:55 pm

Okay, I think I found the reason for the problem. "Ignore Prefix" does not work when sorting by "Album Artist" under an autoplaylist, which is disappointing because the reason why I sort by "album artist" is due to compilations (album artist = various) within the same genre. The non-compilation albums whose artists begin with "The" are instead sorted at the end of the alphabet of the first character following "The." Here's an example below:

Image

Autoplaylist settings:
Image
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

Lowlander
Posts: 46625
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by Lowlander » Mon Mar 26, 2012 11:02 pm

That's why I asked if it was found elsewhere in the list as the problem is very different now.
Lowlander (MediaMonkey user since 2003)

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by theta_wave » Mon Mar 26, 2012 11:47 pm

Lowlander wrote:That's why I asked if it was found elsewhere in the list as the problem is very different now.
Is there an open ticket dealing with the enabling "Ignore Prefix" for "Album Artist" sorting?
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

Lowlander
Posts: 46625
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1476] Autoplaylist: Albums missing under show art + det

Post by Lowlander » Tue Mar 27, 2012 10:21 am

I think I've seen it reported before, but I'm not sure.
Lowlander (MediaMonkey user since 2003)

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1476] Sorting bug for <Album Artist>, multi. genres

Post by theta_wave » Tue Mar 27, 2012 11:45 am

Actually, it isn't just "Ignore Prefix" that is buggy with autoplaylist, it is sorting under <Album Artist> in general where the autoplaylist queries multiple genres:

ImageImage

The following is from an autoplaylist that only queries the genre "Alternative." As you can see, "ignore prefix" and sorting by <Album Artist> are followed properly:
ImageImage
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1481] Sorting bug: "Ignored Prefix" ignored in Autoplay

Post by theta_wave » Thu Apr 12, 2012 9:26 pm

Bug is still present in 1481, where a autoplaylist queries multiple genres. "Ignore Prefix" is set to ignore "The," which is practically ignored by the autoplaylist when sorted by <Album Artist>.
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1481] Sorting bug: "Ignore Prefix" ignored in Autoplayl

Post by theta_wave » Fri May 04, 2012 5:34 am

Bug still present in 1486
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Re: [1481] Sorting bug: "Ignore Prefix" ignored in Autoplayl

Post by theta_wave » Sat Oct 20, 2012 8:53 pm

Bug still present in 1506. Creating an autoplaylist querying 26 genres that are close to "alternative and rock" yields inconsistent results for artists whose names start with "The," where they are either omitted (2883 artists here) or they are placed at the end of their corresponding letter (3092 artists). For an example of the latter, "The Faints" show up after a band named "Fuzzy" rather than after a band named "Faded," "The Gathering" follows "Guns N' Roses," etc. Pressing F5 to refresh the query leads to an inconsistent number of artists reported under the column browser (2832-3092 artists listed). A similar smartplaylist in iTunes does not exhibit this issue.
MM Gold Lifetime since 2.5.5.998
Computer: Lenovo Y580 System: Win7 Ultimate x64 SP1 / Arch Linux Mediamonkey 4: w/ Monkeyrok 5.6, Minilyrics 1.4b, iMonkey Skin

Post Reply