MM Regenerates All Video Thumbnails in a Folder

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

cydog2001
Posts: 6
Joined: Thu Oct 04, 2012 8:44 pm
Location: In His Head

MM Regenerates All Video Thumbnails in a Folder

Post by cydog2001 » Sat Dec 01, 2012 2:41 pm

Program Details:
  • MediaMonkey (duh) v4.0.7.1511 with Lifetime Gold License
Extensions Installed:
  • Album Art Tagger v5.0 (Current User)
  • BatchArtFinder v4.2 (Current User)
  • Magic Nodes v4.2 (Current User)
  • MM Codec Pack v2.0.1.17 (All Users)
  • RegExp Find and Replace v4.3 (Current User)
Environment Details:
  • Windows 7 x64 Ultimate SP1, fully up to date
Hardware Details:
  • Intel Core i7 3820 @ 3.8GHz
  • 16GB RAM
  • Sound Blaster X-Fi (onboard)
  • 2x 300GB (Raid 0) Boot HDs (C:)
  • 3x 2TB Storage HDs (D:, E:, F:)
Background:
  • MM installed to C:\Program Files (x86)\MediaMonkey
  • Anime stored in D:\Videos\Anime
  • Cartoons stored in E:\Videos\Cartoons
  • TV Shows stored in E:\Videos\TV Shows
  • Movies stored in F:\Videos\Movies
  • MM set to continuously monitor D:\Videos, E:\Videos; F:\Videos
  • Working folder to rename movies and such before they go into F:\Videos\Movies is F:\Working
  • Collections set up in MM for Movies, TV, Anime, and Cartoons using Custom 1 field for differentiation (i.e. I renamed it to 'Video Type' and use the values of 'Movie', 'TV', 'Anime', and 'Cartoon'.)
Problem Description:
After ripping a movie from BluRay or DVD, I store the file temporarily in the Working folder (F:\Working) so I can rename it according to my preferences. Once that is complete, I cut the movie from the Working folder and paste it directly into the Movies folder (F:\Videos\Movies). MM finds the file within a few seconds and proceeds to add it to my library. It will then proceed to generate thumbnails for every video file in that folder rather than just the newly added file. As a secondary bug related to this one, the thumbnail of the video file will automatically be put as the first image in the artwork section of the file properties, so if you already have a cover image set as first, it gets pushed down in the priority so it won't show up as the main image when browsing the library.


I hope this was a thorough enough explanation of my issues, please let me know if I can provide any more details.

--Stryfe
The things that will destroy America are prosperity-at-any-price, peace-at-any-price, safety-first instead of duty-first, the love of soft living, and the get-rich-quick theory of life.

--Theodore Roosevelt

cydog2001
Posts: 6
Joined: Thu Oct 04, 2012 8:44 pm
Location: In His Head

Re: MM Regenerates All Video Thumbnails in a Folder

Post by cydog2001 » Sat Dec 08, 2012 10:32 am

I just uninstalled the MM Codec Pack to see what effect it would have. It had none.

Any ideas about this? It seems to be similar to the already closed issue 7921 in Mantis.

--Stryfe
The things that will destroy America are prosperity-at-any-price, peace-at-any-price, safety-first instead of duty-first, the love of soft living, and the get-rich-quick theory of life.

--Theodore Roosevelt

lordy16

Re: MM Regenerates All Video Thumbnails in a Folder

Post by lordy16 » Fri Mar 08, 2013 3:26 am

I also have this problem - build 1511, windows 8. Reading off a network storage folder - set to continuously scan the video folder.

it regenerates thumbnails every time i open the application

dtsig
Posts: 3148
Joined: Mon Jan 24, 2011 6:34 pm

Re: MM Regenerates All Video Thumbnails in a Folder

Post by dtsig » Fri Mar 08, 2013 10:25 am

I just noticed this in the 1626 beta. I am just starting to use MM for videos and have a 'temp' folder that only has 35-40 videos but it does seem like a pain to have it generate thumbnails each time.

I will hate to add my 2 main video drives (1 3tb and 2 2tb). Wouldn't want to wait hours each start up :D
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Post Reply