[SOLVED] Character inserted at cursor in track properties

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Metahec
Posts: 7
Joined: Tue Nov 06, 2012 11:22 pm

[SOLVED] Character inserted at cursor in track properties

Post by Metahec » Tue May 09, 2017 11:23 am

A character (♠ right now, last night I was getting a diamond) is being created at the cursor whenever I use the keyboard shortcuts (alt-left and alt-right) to move from track to track while editing track properties.
The diamond is inserted after moving to the next track, so I use alt-left to go to the next track, the fields populate with the information on the new track and then the diamond is dropped in wherever the cursor happens to be. This occurs both going forward and back (alt-left and alt-right). It happens in all text editable fields in the basic, details, classification and lyrics tabs -- including the path and filename fields. This does not occur in artwork or virtual CD tabs, or at least, I haven't been able to get it to happen.

Windows 10 Pro 64 bit
MM 4.1.15.1830
I just did a clean install to a new hard drive about six months ago and I don't think I've installed any plugins since then, so I think the only ones I have are the default ones that come with the MM install package.

Peke
Posts: 11338
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Character inserted at cursor in track properties

Post by Peke » Sun May 21, 2017 6:23 pm

I'm unable to replicate.

Can you tell me if same happen in case you delete shortcut.

Additionally for me next/prev track shortcuts are CTRL+ALT+Left/Right
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

Metahec
Posts: 7
Joined: Tue Nov 06, 2012 11:22 pm

Re: Character inserted at cursor in track properties

Post by Metahec » Wed Jun 14, 2017 8:14 pm

Sorry for the delay in replying. I got caught up in other matters.

I looked in Tools/Options/General/Hotkeys and found that "General: Go to next view" was set to "Browser Forward" and "General: Go to previous view" was set to "Browser Back". I set them explicitly to alt-right/alt-left and now it works without weird characters. Thanks for the tip! I had overlooked checking hotkey settings.

For me at least, "Browser Forward" and "Browser Back" are mapped to my mouse buttons (buttons 4 and 5. They sit on the top edge just above the thumb rest.) Interestingly enough, Windows (and most browsers I think) have Forward and Back mapped to alt-right/alt-left by default. So maybe MM was passing the "Browser Forward/Back" command until it resolves to the repective alt-right/alt-left and that added step is creating the odd characters? Is "Browser Forward"/"Browser Back" the default settings in MM upon install or did I somehow manage to change it on my own? I guess I'm not actually expecting answers to those questions... just wondering out loud.

Lastly, CTRL+ALT+LEFT/RIGHT is the keystroke command for my graphics card to rotate the screen to left or right orientation, if I ever want to rotate my display and work in profile instead of landscape. I haven't done so since I left my last job, but that's been the default behavior for that keystokre combination in the last 4 windows machines I've worked on.

Thanks again!
H

Metahec
Posts: 7
Joined: Tue Nov 06, 2012 11:22 pm

Re: Character inserted at cursor in track properties

Post by Metahec » Thu Jun 15, 2017 12:30 am

I spoke too soon... I'm still getting those characters inserted into my text. The reason it looked Ok in my previous message was because I didn't have any focus set. There was no cursor in a text field to insert the character, so the keyboard hotkeys worked as they should moving me from track to track.

I settled down to edit some metadata, and now when I have a cursor in a field, the characters still insert upon hitting alt-left/alt-right. Also, I hover the mouse pointer over the left and right arrows at the bottom left of the Properties window, the tooltip for context help indicates "Update & Nextsong (Alt-Right)". I changed the hotkeys again for "General: Go to Next View" and the tooltip does not change. Am I editing the wrong hotkey entry? I don't see any other that seems to correspond.

I also uninstalled all extensions that affected behavior, so I'm left with only the scripts that come with the MM default installation, and still no change. I still have a bunch of skins installed and I'll probably start deleting most of those over the next few days. Changing to another skin had no effect.

Any other ideas? Anything further I can provide?

Metahec
Posts: 7
Joined: Tue Nov 06, 2012 11:22 pm

Re: Character inserted at cursor in track properties

Post by Metahec » Thu Jul 20, 2017 11:04 pm

Issue remains unresolved. Oh well.

Peke
Posts: 11338
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Character inserted at cursor in track properties

Post by Peke » Thu Jul 27, 2017 11:58 am

I'm still not being able to replicate.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

Ludek
Posts: 2516
Joined: Fri Mar 09, 2007 9:00 am

Re: Character inserted at cursor in track properties

Post by Ludek » Fri Aug 04, 2017 6:46 am

I cannot replicate too.
Does the same character appear at the cursor position when you use Alt+Right in a text editor (e.g. Notepad) ??

Metahec
Posts: 7
Joined: Tue Nov 06, 2012 11:22 pm

Re: Character inserted at cursor in track properties

Post by Metahec » Mon Jan 29, 2018 12:50 am

Hi Peke, Ludek
Apologies for not having checked back in sooner.

No, this behavior occurs only in MM. I decided to try again since I noticed MM was updated, and it still occurs. Is there anything further I can provide? Here's a screenshot with a 'spade' in the "Track #" field:

Image

Oddly, I am now experiencing a new quirk when I edit fields. I suspect this is unrelated, so I'll create a new thread for it.

Metahec
Posts: 7
Joined: Tue Nov 06, 2012 11:22 pm

Re: Character inserted at cursor in track properties

Post by Metahec » Mon Jan 29, 2018 2:26 am

I figured it out. Breevy, a text expansion program, is conflicting with MM.
Geez... it's so obvious. I feel like a dummy.
Thanks for your time.

Peke
Posts: 11338
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Character inserted at cursor in track properties

Post by Peke » Mon Jan 29, 2018 3:42 am

Hi,
These things happen especially with apps that you use for long time and you get used to be around.

It is a relief that problem is not in MMW as it would be very hard to locate such issue.

Thank you for update.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

Post Reply