Page 1 of 1

Skin Elements Query

Posted: Sat Sep 13, 2014 3:23 am
by serendip1959
Hi

I am adapting a skin for my own use and have a couple of queries.

The first is at the top of the artwork window I have a coloured line. I have managed to change the line colour under the tabs, but to the right of the two tabs (Now Playing and Selected) it is the original colour. What element sets the colour of this line (immediately above the artwork)?

Secondly, I have behind the now playing playlist an alternating coloured block, just at the right hand end of the data line. It just appeared, so I must have changed something unwittingly. What controls the background to the Now Playing playlist and how can I remove the alternating colour (or get it to render correctly)?

Thanks for any help.

Re: Skin Elements Query

Posted: Sat Sep 13, 2014 11:07 am
by Corbet199
Can you post a screen shot so we can see what you mean so we can help?

Re: Skin Elements Query

Posted: Sat Sep 13, 2014 11:19 am
by DreadM
Hello serendip1959

1;
Ok ,I'm bit rusty ,but if I remember right ,
the background from A+D are controlled by Theme Editor / Colors / Window

2;
Now playing list can have 2 objects,
Theme Editor / Objects / VirtualTree / NowPlaying Even and Odd,
also in some cases the sdb_background_list.bmp inside the skin file!

I hope i could help you .

Screenshots are very helpful for Skinning questions :wink:

Re: Skin Elements Query

Posted: Sat Sep 13, 2014 4:49 pm
by serendip1959
Apologies, of course it would be helpful...

https://www.dropbox.com/s/shds54b1rznr5 ... e.jpg?dl=0

It appears to be virtual tree odd and even for one of them, but if I try and replace the background bitmap I don't get the expected result - no background renders and I get the same effect as if I tick the override skin backgrounds checkbox in options.

Re: Skin Elements Query

Posted: Sun Sep 14, 2014 4:07 am
by serendip1959
I have solved the now playing list, the element was Virtual Tree - Main Tree Background which in the theme editor was black only, but changing the bitmap resolved it, still black only in the theme editor but when loaded the alternating orange blocks disappeared. I guess the problem was actually in the odd/even now playing backgrounds, but this has solved it anyway.

Re: Skin Elements Query

Posted: Sun Sep 14, 2014 11:54 am
by Corbet199
I think the line under the cover window tabs should be set from within the settings.ini file.
You should have a section headed as [PageControl].
This should contain the folowing lines:

CoverWindowTabsLineUnderTabs=0
CoverWindowTabsLineColor=FFFFFF


Setting the first line to =0 should disable the display of the line. If the line is displayed (=1), the second statement would set the color of the line in a hexadecimal format. In this case, =FFFFFF will make the line white.

Remember, if you change settings.ini, you need to close and restart MM before changes will take effect.

Hope this helps.

Re: Skin Elements Query

Posted: Sun Sep 14, 2014 12:26 pm
by serendip1959
Many thanks, that did the job :D