MM3 Scripting problem - Player.Play leads to a 'black hole'

Beta Testing for Windows Products and plugins

Moderator: Gurus

DiddeLeeDoo
Posts: 1017
Joined: Wed Mar 01, 2006 1:09 am
Location: In a jungle down under
Contact:

MM3 Scripting problem - Player.Play leads to a 'black hole'

Post by DiddeLeeDoo » Sat Jan 12, 2008 11:13 pm

For a period of 600 - 3000 ms after the SDB.Player.Play command is given, other commands get lost in a 'black hole'.

A 'ready to do next command' function seems to be missing

Simple example code

Code: Select all

SDB.Player.Play
SDB.Player.Playbacktime=30000
Some example code.
http://www.mediamonkey.com/forum/viewtopic.php?t=10129
Image

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Post by Bex » Sun Jan 13, 2008 7:37 am

Hi DiddeLeeDoo,

Long time no see. We miss you. Where have you been?

Is this bug also in the latest beta 3.0.2.1129?
(I haven't tested to reproduce it...)
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

DiddeLeeDoo
Posts: 1017
Joined: Wed Mar 01, 2006 1:09 am
Location: In a jungle down under
Contact:

Post by DiddeLeeDoo » Sun Jan 13, 2008 8:30 am

Hi Bex,

Nice to hear from you too. Been a long while. It's Sunday, and I'm sitting here programming an invoice program that has to be ready tomorrow, Monday... my life in a nutshell. Since work keeps me on the computer all day, I tend to do anything but computing in any spare time.

I've been hoping for a more quiet time for awhile, but it only get worse.. :(

Haven't tried with the latest Beta, but from what I read in the list of fixes, it doesn't seem to be addressed. Not like it's a big deal. MM2.5 was rock solid, and I'm sure the 'DreamTeam" want nothing less for MM3.0
Image

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Post by Bex » Sun Jan 13, 2008 9:14 am

I know what you mean. I hope it gets better at work for you. It's not fun when there's too much to do and you need to work weekends to catch up!

Anyway, try the latest beta. Perhaps it fixed there. I've noticed that not all "script" changes are addressed when changed.
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

jiri
Posts: 5394
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Post by jiri » Thu Jan 17, 2008 11:19 am

I agree that this can be quite a problem, so I added a new property http://www.mediamonkey.com/wiki/index.p ... ngPlayback that helps you in waiting for the moment when playback is properly started.

Jiri

Post Reply