Video specific fields and "Auto-Tag from Filename" [#7330]

Beta Testing for Windows Products and plugins

Moderator: Gurus

REIKA
Posts: 107
Joined: Wed Oct 31, 2007 1:32 am
Location: Osaka , Japan

Video specific fields and "Auto-Tag from Filename" [#7330]

Post by REIKA » Sun Jan 09, 2011 6:24 pm

The function "Auto-Tag from Filename" doesn't work well on some video specific fields.
For example , <Series> and <Episode#>.
Win10 64bit , MM4.1 Gold , Japanese Lang files
dsp_vst + iZotope Ozone + out_asio , Magic Nodes , Minilyrics
MM Japanese Wiki : http://mediamonkey.xn--m8jfw.jp/index.php?FrontPage

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Video specific fields and "Auto-Tag from Filename"

Post by Lowlander » Sun Jan 09, 2011 6:31 pm

How doesn't it work?
Lowlander (MediaMonkey user since 2003)

REIKA
Posts: 107
Joined: Wed Oct 31, 2007 1:32 am
Location: Osaka , Japan

Re: Video specific fields and "Auto-Tag from Filename"

Post by REIKA » Sun Jan 09, 2011 7:02 pm

My many video files are named in such a naming convention , <Series>-<Episode#>-<Title>.
So I configured filename format in "Auto-Tag from Filename".

In preview, <Episode#> and <Title> are highlighted, but <Series> are not.
I configured "<Series>-<Episode#>-<Title>" , but folder name is used as <Series>.

And, <Title> only be saved in the tag. <Episode#> is not saved.
Win10 64bit , MM4.1 Gold , Japanese Lang files
dsp_vst + iZotope Ozone + out_asio , Magic Nodes , Minilyrics
MM Japanese Wiki : http://mediamonkey.xn--m8jfw.jp/index.php?FrontPage

rusty
Posts: 7221
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Video specific fields and "Auto-Tag from Filename"

Post by rusty » Tue Feb 08, 2011 12:20 am

Reika,

Thanks. I was able to reproduce the auto-tag from filename bug re. the failed 'Series' mask. It's tracked at:
http://www.ventismedia.com/mantis/view.php?id=7330

Re. failed Episode tag, what format was the file?

Edit: fyi here's a draft list of supported tags in MM4:
https://spreadsheets.google.com/ccc?key ... y=CKCnh7YG

-Rusty

Peke
Posts: 12495
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by Peke » Tue Feb 08, 2011 4:13 pm

REIKA,
Small test. If you open Video Properties and Edit + Save tags (OK) doues file contain tags or?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

REIKA
Posts: 107
Joined: Wed Oct 31, 2007 1:32 am
Location: Osaka , Japan

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by REIKA » Wed Feb 09, 2011 9:06 am

OK.
I tested again in 4.0.0.1346.

I prepared 4 files for this test.

J:\mm4test\folder01\Series01-10-Title01.wmv
J:\mm4test\folder01\Series01-13-Title01.mp4
J:\mm4test\folder01\Series01-14-Title01.mkv
J:\mm4test\folder01\Series01-16-Title01.avi

I added them to my library. -> Fig.1

Auto-Tag from Filename -> Fig.2

However, "Series" and "Episode#" were not saved. -> Fig.3

I edited "Series" and "Episode#" in Propaeties and saved. -> Fig.4
(But "Access violation" error occured.)
Image
Win10 64bit , MM4.1 Gold , Japanese Lang files
dsp_vst + iZotope Ozone + out_asio , Magic Nodes , Minilyrics
MM Japanese Wiki : http://mediamonkey.xn--m8jfw.jp/index.php?FrontPage

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by Lowlander » Wed Feb 16, 2011 4:22 pm

This should be fixed in 1349, can you confirm?
Lowlander (MediaMonkey user since 2003)

REIKA
Posts: 107
Joined: Wed Oct 31, 2007 1:32 am
Location: Osaka , Japan

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by REIKA » Wed Feb 16, 2011 4:47 pm

I confirmed "Series" was fixed in 1349.
But "Episode#" seems not to be fixed.
Win10 64bit , MM4.1 Gold , Japanese Lang files
dsp_vst + iZotope Ozone + out_asio , Magic Nodes , Minilyrics
MM Japanese Wiki : http://mediamonkey.xn--m8jfw.jp/index.php?FrontPage

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by Lowlander » Wed Feb 16, 2011 5:01 pm

Does it still behave the same and end up with folder01?

I'm also wondering about your mask as you show you're using ¥<Series>-<Episode#>-<Title> what is that ¥ like character in English?
Lowlander (MediaMonkey user since 2003)

REIKA
Posts: 107
Joined: Wed Oct 31, 2007 1:32 am
Location: Osaka , Japan

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by REIKA » Wed Feb 16, 2011 6:13 pm

In WinXP(Japanese Version), input "\" key -> display "¥"
Image

"Series" works well in 1349 ("Series" = "Series01").
Win10 64bit , MM4.1 Gold , Japanese Lang files
dsp_vst + iZotope Ozone + out_asio , Magic Nodes , Minilyrics
MM Japanese Wiki : http://mediamonkey.xn--m8jfw.jp/index.php?FrontPage

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by Lowlander » Wed Feb 16, 2011 6:41 pm

I'm sorry, I misread you're earlier post. Yes Series works, but Episode# remains blank.
Lowlander (MediaMonkey user since 2003)

leomeloxp
Posts: 6
Joined: Fri Sep 10, 2010 11:33 pm
Contact:

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by leomeloxp » Mon Feb 28, 2011 7:20 am

Hi, I'm using MM4 1350 and Episode# still doesn't work, do you confirm? Does anyone have the bug track link?

*EDIT:

I was also got an idea, since Auto-Tag is not working well and not all my videos (probably other people's as well) are not in a friendly format to set up Episode numbers, can't we change the Auto Increment Track #'s to Episode #'s as well? I can try to help on it.

Thanks, hope my idea is possible/useful.

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by Lowlander » Mon Feb 28, 2011 10:43 am

It has been noted in the same bug that Episode# doesn't work.
Lowlander (MediaMonkey user since 2003)

leomeloxp
Posts: 6
Joined: Fri Sep 10, 2010 11:33 pm
Contact:

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by leomeloxp » Mon Feb 28, 2011 11:19 am

Okay, Thanks.

What about auto implementing Episode Number as a Script, is it possible to do it?

See ya =]

dNoize
Posts: 8
Joined: Thu Jan 27, 2011 2:32 pm
Location: Germany

Re: Video specific fields and "Auto-Tag from Filename" [#733

Post by dNoize » Wed Mar 02, 2011 9:04 am

Hi,

I think <Season#> isnt working at all either.

Best Regards, dNoize

Post Reply