last.fm doesn't work

Beta Testing for Windows Products and plugins

Moderator: Gurus

Lowlander
Posts: 45855
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: last.fm doesn't work

Post by Lowlander » Fri Mar 11, 2011 3:18 pm

laze wrote:I've found that with the new version of the last.fm plugin, if I pause a song and restart it, it double-scrobbles.
I saw the same:
Lowlander wrote:I also seem to have a lot of double entries when playing tracks through MediaMonkey itself.
Pausing seems to be a plausible cause. I can't test as it no longer scrobbles here.
Lowlander (MediaMonkey user since 2003)

laze
Posts: 23
Joined: Tue Feb 10, 2009 11:23 am

Re: last.fm doesn't work

Post by laze » Sat Mar 12, 2011 9:03 pm

Lowlander wrote:
laze wrote:I've found that with the new version of the last.fm plugin, if I pause a song and restart it, it double-scrobbles.
I saw the same:
Lowlander wrote:I also seem to have a lot of double entries when playing tracks through MediaMonkey itself.
Pausing seems to be a plausible cause. I can't test as it no longer scrobbles here.
Ah, sorry -- somehow I missed your previous note.

If anymore info is needed, let me know.

KJIACC
Posts: 191
Joined: Sun Oct 11, 2009 5:40 am
Location: Магнитогорск. Россия
Contact:

Re: last.fm doesn't work

Post by KJIACC » Sun Mar 13, 2011 4:24 am

Problems are only those who have win7 x64?
Win7 x64 Intel Core i3 CPU 540 @ 3.07GHz 3.07 GHz 8 GB RAM NVIDIA GeForce GTS 450
4HD: (C:/D:/ - 1TB) (F:/ - 2TB) (G:/ - 2TB) (H:/ - 3TB)
Screen Resolution 1920x1080
MM runs as administrator.
I'm Tired to post messages using google-translator. I look forward to a forum for Russian-speaking users.

JOhn-vogel
Posts: 13
Joined: Sun Sep 14, 2008 6:59 pm

Re: last.fm doesn't work

Post by JOhn-vogel » Sun Mar 13, 2011 6:36 am

Also having problems scrobbling under Win7 64bit. It doesnt scrobble without any error message. Newest plugin and MM4 build.

markontour
Posts: 25
Joined: Mon Dec 08, 2008 7:26 pm
Location: Houston, Texas, USA, N America, W Hesmisphere, Earth, Milky Way

Re: last.fm doesn't work

Post by markontour » Sun Mar 13, 2011 3:06 pm

I am also having issues since I upgraded to the 4.xx versions of MM. No scrobbling, I updated everything last night, and still nothing is scrobbling.

I am experiencing the same errors as the above screenshot. If I open my old 3.xx version, scrobbler works perfectly fine.

I am using windows 7x64 Any thoughts would be great.
We're all Fool's for something; I'm a Fool for music, what are you a Fool for?

Machines:
1)OS: Windows 7 Home Premium x64-based | Phys Mem: 8.00 GB | Processor: AMD Phenom 9500 Quad-Core, 2200 Mhz

jmccullo

Re: last.fm doesn't work

Post by jmccullo » Sun Mar 13, 2011 6:06 pm

FYI - My last.fm issues are also under Win 7 x64.

vpsaxman
Posts: 288
Joined: Sun Oct 03, 2010 7:39 pm

Re: last.fm doesn't work

Post by vpsaxman » Sun Mar 13, 2011 10:14 pm

Here as well.
Windows 7 Ultimate 64bit
AMD Phenom II x4 940 (3GHz)
ASRock A780
4GB DDR2 333
ATI Radeon HD 3200
Library on two disks : Western Digital Caviar 1.5TB - WDC 640GB

Peke
Posts: 12105
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: last.fm doesn't work

Post by Peke » Mon Mar 14, 2011 6:15 pm

:( Why it works for me then (as 1.0.2.24 is made on x64 Win 7)?

Do you have IE9?

Errors in Options dialog: Do you have active collections/Filters?

Error in 404 line means that MM do not have enough access right to Open last.fm log in default text editor.

is it possible that Cyrillic username is making problems? (C:\Users\Администратор\AppData\Roaming\MediaMonkey
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

vpsaxman
Posts: 288
Joined: Sun Oct 03, 2010 7:39 pm

Re: last.fm doesn't work

Post by vpsaxman » Mon Mar 14, 2011 7:15 pm

Okay, after installing it again it now works for me. I don't understand why though. I tried several things before but they didn't work and I don't think I did anything different this time... Maybe a combination of several settings?

FWIW, I ran MM as administrator (option set as 'always run as admin' in Windows), unchecked 'install for this user only' after dragging it on the player. That's on Ultimate 64bit.

Edit : excluding tracks under the 'submission rules' breaks it though.
Windows 7 Ultimate 64bit
AMD Phenom II x4 940 (3GHz)
ASRock A780
4GB DDR2 333
ATI Radeon HD 3200
Library on two disks : Western Digital Caviar 1.5TB - WDC 640GB

KJIACC
Posts: 191
Joined: Sun Oct 11, 2009 5:40 am
Location: Магнитогорск. Россия
Contact:

Re: last.fm doesn't work

Post by KJIACC » Tue Mar 15, 2011 5:27 am

Peke wrote::( Why it works for me then (as 1.0.2.24 is made on x64 Win 7)?
To me it is also very interesting
Peke wrote:Do you have IE9?
IE8, but the default is Firefox.
Peke wrote:Errors in Options dialog: Do you have active collections/Filters?
Nothing
Peke wrote:Error in 404 line means that MM do not have enough access right to Open last.fm log in default text editor.
I have a super administrator rights on win7. The default text editor Notepad.
I can not imagine the reasons for this error. It seems that there is no log file is never created.
vpsaxman wrote:is it possible that Cyrillic username is making problems? (C:\Users\Администратор\AppData\Roaming\MediaMonkey
I have tried to create a user name in English. Nothing has changed.
Win7 x64 Intel Core i3 CPU 540 @ 3.07GHz 3.07 GHz 8 GB RAM NVIDIA GeForce GTS 450
4HD: (C:/D:/ - 1TB) (F:/ - 2TB) (G:/ - 2TB) (H:/ - 3TB)
Screen Resolution 1920x1080
MM runs as administrator.
I'm Tired to post messages using google-translator. I look forward to a forum for Russian-speaking users.

Guest

Re: last.fm doesn't work

Post by Guest » Tue Mar 15, 2011 12:42 pm

I'm on Vista and it doesn't work for me either. The log file seems to have crashed or something as it still reports with the start-up from March 3rd. I've repeatedly tried to clear that cache but that was of no help. Also, re-installs as administrator didn't help...

Harlandas

Re: last.fm doesn't work

Post by Harlandas » Tue Mar 15, 2011 9:23 pm

Setting the Media Monkey exe file to run as an adminstrator did the trick for me. I'm running Win 7 32 bit.

CoRsU
Posts: 345
Joined: Tue Dec 19, 2006 6:23 am
Location: DA-City, Germany

Re: last.fm doesn't work

Post by CoRsU » Wed Mar 16, 2011 4:57 am

Harlandas wrote:Setting the Media Monkey exe file to run as an adminstrator did the trick for me. I'm running Win 7 32 bit.
Yes this resolved also my problem, but now I get the next one. Script dont submit the Songs to Last.fm

This is my log:

Code: Select all

16.03.2011 10:31:52.205: MediaMonkey v4.0.0
16.03.2011 10:31:52.213: Loading Last.fm Scrobbler
16.03.2011 10:31:52.222: ----------------------------------------
16.03.2011 10:31:52.230: Last.fm Scrobbler v1.0.2.24
16.03.2011 10:31:52.238: ----------------------------------------
16.03.2011 10:31:52.251: Last.FM: Player got Command wParam (1)
16.03.2011 10:31:52.263: Last.FM: Player got Command wParam (1)
16.03.2011 10:32:20.336: Last.FM: Player got Command wParam (1)
16.03.2011 10:32:20.392: Last.FM: Player got Command wParam (1)
16.03.2011 10:32:20.444: Last.FM: Player got Command wParam (1)
16.03.2011 10:32:20.983: Last.FM: Player got Command wParam (1)
16.03.2011 10:32:21.041: Last.FM: Player got Command wParam (0)
16.03.2011 10:32:21.092: Last.FM: Player got Command wParam (2)
16.03.2011 10:32:21.202: Last.FM: Nowplaying Play Detected at 1300267941
16.03.2011 10:32:21.265: Last.FM: Handshake Session Started
16.03.2011 10:32:22.329: Last.FM: Handshake OK
16.03.2011 10:32:22.540: Last.FM: Handshake Session ID is 7d0e82833c844d82b11e93263e85358d
16.03.2011 10:32:22.682: Last.FM: Handshake NowPlaying URL is http://post.audioscrobbler.com:80/np_1.2
16.03.2011 10:32:22.780: Last.FM: Handshake Submission URL is http://post2.audioscrobbler.com:80/protocol_1.2
16.03.2011 10:32:22.951: Last.FM: NowPlaying Song Athlete - Chances
16.03.2011 10:32:23.043: select Songs.ID from Songs where Songs.id=1486 AND Songs.TrackType in (1,7) 
16.03.2011 10:37:07.513: Last.FM: Player got Command wParam (2)
16.03.2011 10:37:08.388: Last.FM: Player got Command wParam (2)
16.03.2011 10:37:08.430: Last.FM: Player got Command wParam (1001)
16.03.2011 10:37:08.492: Last.FM: Submit Started at 1300268228
16.03.2011 10:37:08.535: Last.FM: Player got Command wParam (1)
16.03.2011 10:37:08.594: Last.FM: Player got Command wParam (1)
16.03.2011 10:37:08.790: Last.FM: Player got Command wParam (1)
16.03.2011 10:37:10.164: Last.FM: Player got Command wParam (1)
16.03.2011 10:37:10.304: Last.FM: Player got Command wParam (0)
16.03.2011 10:37:10.417: Last.FM: Player got Command wParam (2)
16.03.2011 10:39:03.360: Last.FM: Player got Command wParam (2)
16.03.2011 10:39:05.341: Last.FM: Player got Command wParam (1)
16.03.2011 10:39:05.406: Last.FM: Player got Command wParam (1)
16.03.2011 10:39:05.528: Last.FM: Player got Command wParam (1)
16.03.2011 10:39:15.130: Last.FM: Player got Command wParam (1)
16.03.2011 10:39:15.555: Last.FM: Player got Command wParam (0)
16.03.2011 10:39:15.946: Last.FM: Player got Command wParam (2)
16.03.2011 10:44:05.482: Last.FM: Player got Command wParam (2)
16.03.2011 10:44:07.311: Last.FM: Player got Command wParam (1)
16.03.2011 10:44:07.838: Last.FM: Player got Command wParam (1001)
16.03.2011 10:44:07.958: Last.FM: Player got Command wParam (1)
16.03.2011 10:44:08.169: Last.FM: Player got Command wParam (2)
16.03.2011 10:44:08.375: Last.FM: Player got Command wParam (1)
16.03.2011 10:44:11.842: Last.FM: Player got Command wParam (1)
16.03.2011 10:44:11.929: Last.FM: Player got Command wParam (0)
16.03.2011 10:44:12.067: Last.FM: Player got Command wParam (2)
16.03.2011 10:49:10.042: Last.FM: Player got Command wParam (2)
16.03.2011 10:49:12.207: Last.FM: Player got Command wParam (1001)
16.03.2011 10:49:12.260: Last.FM: Player got Command wParam (1)
16.03.2011 10:49:12.362: Last.FM: Player got Command wParam (1)
16.03.2011 10:49:12.416: Last.FM: Player got Command wParam (2)
16.03.2011 10:49:13.174: Last.FM: Player got Command wParam (1)
16.03.2011 10:49:16.411: Last.FM: Player got Command wParam (1)
16.03.2011 10:49:16.581: Last.FM: Player got Command wParam (0)
16.03.2011 10:49:16.755: Last.FM: Player got Command wParam (2)
16.03.2011 10:53:31.273: Last.FM: Player got Command wParam (2)
16.03.2011 10:53:33.341: Last.FM: Player got Command wParam (1001)
16.03.2011 10:53:33.517: Last.FM: Player got Command wParam (1)
16.03.2011 10:53:33.624: Last.FM: Player got Command wParam (1)
16.03.2011 10:53:33.750: Last.FM: Player got Command wParam (2)
16.03.2011 10:53:34.583: Last.FM: Player got Command wParam (1)
16.03.2011 10:53:36.857: Last.FM: Player got Command wParam (1)
16.03.2011 10:53:36.940: Last.FM: Player got Command wParam (0)
16.03.2011 10:53:37.001: Last.FM: Player got Command wParam (2)
What can I do??? Anybody the same problem?
Image

laze
Posts: 23
Joined: Tue Feb 10, 2009 11:23 am

Re: last.fm doesn't work

Post by laze » Wed Mar 16, 2011 9:00 am

In addition to my previous mentioned double-scrobbles-on-pause issue, I'm now seeing a lot of my listens being re-dated to March 3rd. In other words, the song I'm listening to now is getting scrobbled as if it were March 3rd. Checked obvious things like the system clock. Not quite sure what's going on.

Running Win 7/64-bit, IE9 beta installed, MM4 1353, last.fm 1.0.2.24.

scorpus57
Posts: 3
Joined: Thu Feb 10, 2011 12:29 am

Re: last.fm doesn't work

Post by scorpus57 » Thu Mar 17, 2011 6:50 am

laze wrote:In addition to my previous mentioned double-scrobbles-on-pause issue, I'm now seeing a lot of my listens being re-dated to March 3rd. In other words, the song I'm listening to now is getting scrobbled as if it were March 3rd. Checked obvious things like the system clock. Not quite sure what's going on.

Running Win 7/64-bit, IE9 beta installed, MM4 1353, last.fm 1.0.2.24.
Same sort of thing is happening here. I'm getting around 1 in every 20 tracks scrobbled, which are all dated to random dates anywhere from the correct time, to yesterday and even several months ago.

Windows 7 x64, IE9 installed, MM4 1355, last.fm 1.0.2.24
Last edited by scorpus57 on Thu Mar 17, 2011 9:59 pm, edited 1 time in total.

Post Reply