[SOLVED] Sync / Playlist corruption with 1.3.2.0804

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

erlebc
Posts: 34
Joined: Tue Feb 15, 2011 8:46 pm

[SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by erlebc » Fri Apr 13, 2018 8:38 am

From reading other threads in this forum and the regular build forum I nearly want to say that folks talking about playlist corruption or SD card corruption seem to be mentioning similar symptoms of what I am seeing, but not quite the same, so I thought this new thread was warranted. The problem began by seeing the following message being displayed on my LG V20 device - "8350 Tracks couldn't be found in their e..... (I'm not sure what the rest of the message is, but I expect it's about where tracks expect to be found)." There is a MANAGE button as a part of the notification. If you tap it, you are taken to MMA's Library Folders where you are presented with Internal storage and SD card storage both showing Music and Video folders with 'delete' garbage can icons next to them for removal.

At this point, the result of this message is while all of my playlists remain, there are nearly no tracks which are playable / readable by MMA anymore. Weird. Up to this point all had been fine, and I had not performed any sync's of any kind probably in months. I just was listening to the tracks stored on the device. I figured I got an update to the program, and something had gone wrong with that update.

Environment:
MMA - 1.3.2.0804
LG V20 with Android 7.0
120GB SD card

MMW - 4.1.20.1864 on Windows 10

To try and narrow down what was happening, I tried some things.

First time the problem manifests:
I followed the MANAGE button, and deleted the Music folder, knowing that if it really got removed I'd mess up everything, but it was already messed up so.....
From what I can tell it had no appreciable effect on the problem other than it stayed.
I launch Google Play to see what it sees. Regarding the Playlists sorting, it didn't see any playlists anymore although they were still in their original SD card/Playlists location on the device. It had an Autoplaylist, and had some music, and a quick comparison to what MMA could still 'see' made it appear that both MMA and Google Play were seeing the same files available. This tiny subset of the nearly 1700 tracks which should have been available within the synchronized playlists which had been seen and played just fine a few minutes before.
I believe that a week or so prior to me seeing this issue that I did get an Android update from my carrier, but again I detected no issues which I felt linked those two events together.

Remediation (I hoped):
Delete the SD card/Music and SD card/Playlist folders, and then deleted everything else on the SD card. File Manager X-plore shows 119GB free for my SD card which is the max available with this card. I DID NOT format the card. Maybe I should have, but....
I go to MMW to check the sync settings for the SD card for the LG V20 to ensure that something there might not be responsible, although, as I mentioned, I had not performed a manual sync in months. I confirm that I have it set the way I want it by synchronizing a subset of playlists from MMW to MMA. With the situation with the database seemingly out of whack, I did select an option within the SYNC Profile for my device 'Delete other files and playlists from the device --> Unselected Library Files'. Thinking this might help to clean up things maybe and only sync what I have defined.
In total, I have 13 Playlists configured to sync. Those 13 playlists total 1645 tracks.
The sync goes pretty well. I am doing it wirelessly over 802.11ac so it's not too bad, and I'm not converting any files so it's straight copy. The sync does NOT copy over 30 files it says at the end, but I cannot tell which tracks didn't copy. Not life threatening.
I give a quick once-over to see whether all of the Playlists look like they sync'd and they are all there. However, to provide one example, Playlist A has 173 tracks. MMA sees 11 of these tracks. It is a similar story for the rest of the playlists.

Here is another oddity, and contributes to the message about "8350 Tracks could not be found..." If I examine MMA 'Artists' or 'Artists & Album Artists' it looks like the database on MMA contains all of the artists and albums from nearly my entire collection. It's not quite that much as I have a little over 12K tracks in the entire collection, and the sync message mention 8350 tracks. However, the larger point is that the sync db on MMA contains a large quantity of artists and albums not contained in any of the configured Synchronization on MMW for this device. It feels like that is a large part of the disconnect.

Now, I head over to Google Play to see what it is seeing. A similar state of affairs like the first time I saw this issue only it does see the MMA playlists, and while MMA shows all of the proper tracks included in a given playlist, but just can't see/play most of them. Google Play, only shows the tracks it can play within these playlists. On that score - what MMA and Google Play are seeing as playable tracks. That is the same as far as I can tell.

From what I can tell the music is fine as it is stored on the SD card. Using my X-plore file manager I can play any track I select, and I tried selecting tracks I knew were not being seen by MMA / Google Play to make sure it was not data corruption on the media.

A check of my MMW server shows that the playlists from where I sync are intact, and play fine from their source. So, I know that is a lot of information, but I wanted to be thorough as different questions pop into the mind as one tries to ascertain possible causes and develop a theory.

I realize I am running a BETA copy of the program, but it's normally so stable for what I do I don't look at it that way. However, I'm open to assisting development with any logs or traces if they feel this is something worth pursuing. I am willing to perform any actions including synchronizing from scratch again.

Thanks for an overall GREAT product. It's a part of my daily life, and has been for many many years.

erlebc
Posts: 34
Joined: Tue Feb 15, 2011 8:46 pm

Re: Sync / Playlist corruption with 1.3.2.0804

Post by erlebc » Sat Apr 14, 2018 7:41 am

I am glad that I haven't taken up someone's valuable time with determining cause for this one. Even though I could still play music and such from the files stored on the card there must have been some sort of corruption there as 3 different music players all had the same issues in seeing all of the stored files. So, I performed a format of the SD card, and have since re-synchronized the playlists back, and at least for now all is right with the files stored there and MMA's ability to see them and play them. So, a lot of inconsistencies externally and strange things with the MM library, but formatting the card seemed to resolve it all.

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by nonob » Wed Apr 25, 2018 5:34 am

Hi,

I actually have the same issue : notification "tracks couldn't be found in their expected location" but all is playing well, i just can't synchronize anymore : MMA crash every time (i sent logs). I never had this message before.

I have MMA 1.3.2.0807 and MMW 4.1.20.1864.

I tell informed i f i found a less radical fix than delete all my 30 GB music, database, etc.

Bye
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

Lowlander
Posts: 44359
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by Lowlander » Wed Apr 25, 2018 11:29 am

Update MMW to the latest beta as well: http://www.mediamonkey.com/forum/viewto ... 54426&sd=d
Lowlander (MediaMonkey user since 2003)

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by nonob » Thu Apr 26, 2018 2:38 am

Hi,

Oups, i thought i had the last version because i checked from MMW : help : check updates. But so it doesn't check for beta updates, is it ?

So i updated it manually and tried a new sync : i had the same issue : my MMW crashed, i sent a debug log.

Can i try something else ?
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

Lowlander
Posts: 44359
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by Lowlander » Thu Apr 26, 2018 12:05 pm

Check Updates doesn't check for Betas.

Did you attach a debug log (step 4b) a debug log to a Support Ticket: http://www.mediamonkey.com/forum/postin ... f=21&t=341
Lowlander (MediaMonkey user since 2003)

Peke
Posts: 11099
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by Peke » Fri Apr 27, 2018 2:14 pm

If you have problems logging on Support as noted here https://www.mediamonkey.com/forum/viewt ... =3&t=89703

Please let me know in PM if you created LOG file and how We can get it.
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Track couldn't be found in their expected location and others global sync issues

Post by nonob » Tue Jun 05, 2018 2:52 am

Hi,

Since some weeks, i can't sync my android devices anymore. . On each device symptoms are not the same, but all my problems seems arrived at the same time, and i know it doesn't help but "all was working fine before, on all my devices".

-On my main device, a Motorola Moto G4 Plus with Android 7 : i have a notification message saying "5381 tracks couldn't be found in their expected location" (all...) :

Image

I clicked on "manage" but my watched folders was good.

I tried a new sync but every time i had a "crash"; i sent log each time.

After some tests, i decided to delete my main folder on my sd card 128 GB. I also uninstalled MMA then reinstalled it.

I started a new sync of all my about 5500 tracks : it worked but a lot of thumbs are missing and.... notification "5381 tracks couldn't be found in their expected location" is back :(

-On my Motorola Moto G2 with Android 6, when i start a new sync : "Analyzing, Preparing tracks for deletion" : i wait...., it seems not responding, but if i look at notifications i saw that a confirmation dialog is waiting :
Image

If i click on it it do nothing. I have to press on recent task buttons : swipe mediamonkey app to close it then click on "confirm updates & deletions" notification : it ask me for delete all my already presents tracks ! I doesn't check anything and press "yes" : downloading all my tracks are in progress.., i stop manually because i don't undestand why all is syncing.

-On my Samsung A3 2017 with Android 7 : crash while syncing. I sent logs. i don't have the device at this moment.

-On my Samsung S3 mini with Android 7 : crash while syncing, i sent log :
Image

-On my Tablet Lenovo Android 5 : confirm updates : ask me if i want to delete all my tracks ! I cancel.

Because i have symptoms on all my client devices, i think i have maybe a server issue or a general bug on MMA. On my server all seems to be working normally on it except i saw something strange in the "add/scan folders" window : my watched folders where listed on the right panel, but not checked on the left one : i checked them but it didn't resolved my issues.

I have MMW 4.1.21.1867 beta on my windows 7 PC and MMA 1.3.2.0814 beta on all my android devices.

What do you think, could it be a bug on MMW, MMA, or is it a isolated issue for me only ?

What can i fo to try to resolve my issues ? If i have to restart on a fresh install i want to be sure how proceed and make tasks in the good order.

Thanks
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

martin.bohac
Posts: 82
Joined: Thu Nov 14, 2013 5:23 pm

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by martin.bohac » Wed Jun 06, 2018 4:52 am

The issue on Moto G4 Plus is related to
https://www.ventismedia.com/mantis/view.php?id=14139
it's not finished and the notification will be temporarily disabled in a build 816.
Also, one issue with missing Artwork is fixed in build 816.
Can you confirm that all tracks included in the library are playable (not grayed in tracks view)?
if not please send debug log via Options->About MediaMonkey->Send logs
and note LOG ID.
I will fix some crashes to next build 817 (possibly related to crash on your device),
but I am not able to identify which are from your devices.
Please wait for new build 817 and if crash persists send also another log via Options->About MediaMonkey->Send logs
and provide LOG ID to identify your device.

Thanks

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by nonob » Wed Jun 06, 2018 9:49 am

Hi,
martin.bohac wrote:
Wed Jun 06, 2018 4:52 am
The issue on Moto G4 Plus is related to
https://www.ventismedia.com/mantis/view.php?id=14139
it's not finished and the notification will be temporarily disabled in a build 816.
Also, one issue with missing Artwork is fixed in build 816.
Ok :)
martin.bohac wrote:
Wed Jun 06, 2018 4:52 am
Can you confirm that all tracks included in the library are playable (not grayed in tracks view)?
if not please send debug log via Options->About MediaMonkey->Send logs
and note LOG ID.
On MMA, all tracks are white and seems playables; i didn't tried with all my 5k+ tracks ;)
martin.bohac wrote:
Wed Jun 06, 2018 4:52 am
I will fix some crashes to next build 817 (possibly related to crash on your device),
but I am not able to identify which are from your devices.
Please wait for new build 817 and if crash persists send also another log via Options->About MediaMonkey->Send logs
and provide LOG ID to identify your device.
Ok, i will wait the 817. Good luck.
Thanks
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by nonob » Mon Jun 11, 2018 11:01 am

Hi,

I updated MMA on my Moto G4 Plus with version 1.3.2.0807 :

Notification "5381 tracks couldn't be found in their expected location" disappaired as soon as installed :)

My missing thumbs are always missing..., i started a new sync but it didn't helped. Is this issue should be resolved with this build ? If yes, do i have to make a fresh install again or can i do something else ?

I didn't tried yet MMA 1.3.2.0807 on my others devices but i'll do it soon :)

Thanks for your work.
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

martin.bohac
Posts: 82
Joined: Thu Nov 14, 2013 5:23 pm

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by martin.bohac » Mon Jun 11, 2018 4:27 pm

You wrote that
After some tests, i decided to delete my main folder on my sd card 128 GB. I also uninstalled MMA then reinstalled it.
If you want to do absolutely clean MMA installation, also you have to delete MediaMonkey folder after uninstallation on all storages.

I guess that some dead links to deleted album arts persist in MMA.
Did you try to delete some album without AlbumArt and then resync?
If this will not help, please send LOG and note some track title without album art, I will check it in your MMA database.

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by nonob » Tue Jun 12, 2018 2:25 am

Hi :)
martin.bohac wrote:
Mon Jun 11, 2018 4:27 pm
You wrote that
After some tests, i decided to delete my main folder on my sd card 128 GB. I also uninstalled MMA then reinstalled it.
If you want to do absolutely clean MMA installation, also you have to delete MediaMonkey folder after uninstallation on all storages.
I think i had deleted them but i'm not sure.

Is it the good process to try to retreive my thumbs :
1-Uninstall MMA
2-Delete MediaMonkey folders
3-Install MMA
4-Scan folders

Should i delete all my data music folders after step 2 and start a new Wifi sync ?

In general, what is the recommand steps when there is an issue with MMA but not with data, can i just uninstall MMA and delete MediaMonkey folders both internal and external, then rescan data folders ? Or should i delete also all my music data ?
martin.bohac wrote:
Mon Jun 11, 2018 4:27 pm
I guess that some dead links to deleted album arts persist in MMA.
Did you try to delete some album without AlbumArt and then resync?
i just tried to delete one album without AlbumArt then resync : AlbumArt is always missing. To be sure i checked this album on MMW : AlbumArt is present (500x500 in tags).
martin.bohac wrote:
Mon Jun 11, 2018 4:27 pm
If this will not help, please send LOG and note some track title without album art, I will check it in your MMA database.
I sent log ID QIRRH7NY5T; you can check album "1.22.03.Acoustic (Maroon 5)" : none albumart for all tracks, but i have a lot others tracks without albumart.

Thanks
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

martin.bohac
Posts: 82
Joined: Thu Nov 14, 2013 5:23 pm

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by martin.bohac » Tue Jun 12, 2018 5:47 am

Unfortunately, your database is not included in the log. It can happen when your database is bigger than 20MB, can confirm it?
Are you able to send me it directly to email: bohacma@gmail.com ? The database is situated in "Internal Storage/MediaMonkey/files/mmstore.db"

nonob wrote:
Tue Jun 12, 2018 2:25 am
Is it the good process to try to retreive my thumbs :
1-Uninstall MMA
2-Delete MediaMonkey folders
3-Install MMA
4-Scan folders

Should i delete all my data music folders after step 2 and start a new Wifi sync ?

In general, what is the recommand steps when there is an issue with MMA but not with data, can i just uninstall MMA and delete MediaMonkey folders both internal and external, then rescan data folders ? Or should i delete also all my music data ?
This can be the last step and you can lose some metadata such as Rating, Album Artists (which is not supported by Android Media scanner), so wifi sync is preferable.

At first do you have in MMW Options/Portable Device Sync/Your device profile/Options/Tagging enabled "Sync all Artwork to file folders" "albumart"?
Does the albumart.jpg exist in folder where e.g "1.22.03.Acoustic (Maroon 5)" is placed?

nonob
Posts: 234
Joined: Fri Jun 20, 2008 8:18 am

Re: [SOLVED] Sync / Playlist corruption with 1.3.2.0804

Post by nonob » Tue Jun 12, 2018 7:15 am

martin.bohac wrote:
Tue Jun 12, 2018 5:47 am
Unfortunately, your database is not included in the log. It can happen when your database is bigger than 20MB, can confirm it?
Are you able to send me it directly to email: bohacma@gmail.com ? The database is situated in "Internal Storage/MediaMonkey/files/mmstore.db"
Sent :)
martin.bohac wrote:
Tue Jun 12, 2018 5:47 am
This can be the last step and you can lose some metadata such as Rating, Album Artists (which is not supported by Android Media scanner), so wifi sync is preferable.
To be sure to have understood : when i have an issue, i should do all these tasks : uninstall MMA, delete MediaMonkey folders, delete music data folders, reinstall MMA, start a new fresh wifi sync ?
martin.bohac wrote:
Tue Jun 12, 2018 5:47 am
At first do you have in MMW Options/Portable Device Sync/Your device profile/Options/Tagging enabled "Sync all Artwork to file folders" "albumart"?
No it isn't, but i think MMA read albumart in tags, isn't it ?
I think i always unchecked "sync all artwork to file folder" because i believed i don't need them.
martin.bohac wrote:
Tue Jun 12, 2018 5:47 am
Does the albumart.jpg exist in folder where e.g "1.22.03.Acoustic (Maroon 5)" is placed?
I have a folder.jpg file in folder where "1.22.03.Acoustic (Maroon 5)" is placed on my PC, but not on my android device. Do i need it ?

Also, i saw something strange : on MMW, my playlist "last added" doesn't contain the real last songs added, so i think something happened to MMW database...
MMW gold (with extensions : Album Art Tagger, CustomFieldsTagger, Discogs Tagger, French translation, GenreFinder, Last.fm Scrobbler, MusicBrainz Tagger, MusicIPTagger, RegExpFind and Replace, Tagging inconsistencies) on desktop PC with OS Windows 7 64-bit SP1, MB Gigabyte M68M-S2P (Socket M2), CPU AMD Phenom II X6 1035T, RAM 4.00 Go Canal-Double DDR2 @ 401 MHz, SSD 111GB KINGSTON SV300S37A12 (C:), DVDWRITER HL-DT-ST DVD-RAM GH22NP20 ATA Device, VIRTUAL ELBY CLONEDRIVE CdRom Device.
MMA on 4 Android devices.

Post Reply