MediaMonkey v4.1.21.1867 Access Violation [#14897]

Beta Testing for Windows Products and plugins

Moderator: Gurus

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

MediaMonkey v4.1.21.1867 Access Violation [#14897]

Post by Stigg » Wed May 30, 2018 12:07 am

I get the following access violation after installing MediaMonkey v4.1.21.1867 Beta every time it starts.
I went back to MediaMonkey v4.1.20.1864, and all is good again. :)
Access violation at address 00A245C0 in module 'MediaMonkey.exe'. Read of address 00000020.
Image

Peke
Posts: 11129
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Peke » Wed May 30, 2018 5:18 am

Can you please update to Latest MMW Beta and report back?

There was and regression showing some Album Art pictures we already fixed.
Best regards,
Pavle
MediaMonkey lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

AnthonyM1229
Posts: 46
Joined: Fri Oct 14, 2011 2:59 pm

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by AnthonyM1229 » Wed May 30, 2018 7:53 am

What's the latest beta version? As of when I'm writing this, I see nothing newer than 1867 available so far. I too experienced access violation errors at startup in 1867, as I described in my thread at http://mediamonkey.com/forum/viewtopic.php?f=6&t=89857.

Plotino
Posts: 17
Joined: Sun Apr 10, 2011 7:18 am

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Plotino » Wed May 30, 2018 12:41 pm

I have the same problem. In my case, it is caused by MiniLyrics and MiniLyrics Embedder.vbs script

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Stigg » Wed May 30, 2018 7:26 pm

@Peke
I can only see 4.1.21.1867.

Have I missed something?

Ludek
Posts: 2430
Joined: Fri Mar 09, 2007 9:00 am

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Ludek » Thu May 31, 2018 5:59 am

Hi, thanks for reporting, re-opened https://www.ventismedia.com/mantis/view ... 820#c50309 and looking into it...

Ludek
Posts: 2430
Joined: Fri Mar 09, 2007 9:00 am

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Ludek » Fri Jun 01, 2018 1:59 am

Could you please try with build 1868 and report whether the issue is resolved for you?
https://www.mediamonkey.com/forum/viewt ... 0b#p445758

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Stigg » Fri Jun 01, 2018 2:51 am

Ludek wrote:
Fri Jun 01, 2018 1:59 am
Could you please try with build 1868 and report whether the issue is resolved for you?
https://www.mediamonkey.com/forum/viewt ... 0b#p445758
I don't get the Access Violation error now, but it is now very slow to start.
It hangs for quite some time before finally loading.

And the height of my Now Playing momentarily resizes itself at startup.

I'll go back to 4.1.20.1864 for now.

Ludek
Posts: 2430
Joined: Fri Mar 09, 2007 9:00 am

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Ludek » Fri Jun 01, 2018 4:39 am

Stigg wrote:
Fri Jun 01, 2018 2:51 am

I don't get the Access Violation error now, but it is now very slow to start.
It hangs for quite some time before finally loading.

And the height of my Now Playing momentarily resizes itself at startup.
I cannot replicate, are you saying that it is slower to start with comparing to 1867 or comparing to 1864?
The change between 1864 and 1868 is that there is a progress bar when loading the startup scripts/addons indicating which addon is just loading.
Do you see an addon loading during the "slow start"? Which addon it is? Note that the slow start begun rather with the latest Windows 10 update and combination of some scripts (details at https://www.ventismedia.com/mantis/view.php?id=14820 ) -- so 1864 probably also have a slow start for you now?

Could you please generate debug logs (item 4b here http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341 ) for:
1) startup of 1864
2) startup of 1868
so that I could compare the logs and find the difference?

Thanks!

Ludek
Posts: 2430
Joined: Fri Mar 09, 2007 9:00 am

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Ludek » Thu Jun 07, 2018 4:32 pm

Stigg, any update on this? If there is a regression then I would like to fix it before 4.1.21 release.
Thanks!

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

Re: MediaMonkey Logs

Post by Stigg » Fri Jun 22, 2018 11:34 pm

Hi Ludek.

Here are two logs. One for 4.1.20.1864 which works fine, and one for 4.1.21.1871 RC, which is troublesome.
I couldn't find a way to attach the logs, so I uploaded them to here.

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Stigg » Fri Jun 22, 2018 11:53 pm

By the way. I don't have MagicNodes installed which you mentioned in my original thread here.

Here is a screenshot of MM 4.1.21.1871 RC starting. The art browser with details has to be manually re-enabled.

Image

And below is how is MM loading normally with MM 4.1.20.1864.

Image

Ludek
Posts: 2430
Joined: Fri Mar 09, 2007 9:00 am

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Ludek » Sun Jun 24, 2018 3:33 pm

Hi Stigg,
thank you very much for your feedback.

Unfortunatelly the debug logs don't include any MediaMonkey messages, they were proably generated using the release build, could you please download and install debug builds and generate them again?
1864 debug: http://www.mediamonkey.com/beta/MediaMo ... _Debug.exe
1871 debug: http://www.mediamonkey.com/beta/MediaMo ... _Debug.exe
Thanks!

Re the screenshots:
What are names of the addons that you are using for showing the lyrics and details? The panels that are covered by white space in 1871 doesn't seem to be native, which addon(s) it is?
Thanks!


Re:
The art browser with details has to be manually re-enabled.
Thanks, I can replicate this, to be fixed as https://www.ventismedia.com/mantis/view.php?id=14897

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Stigg » Sun Jun 24, 2018 8:58 pm

Ludek wrote:
Sun Jun 24, 2018 3:33 pm
Hi Stigg,
thank you very much for your feedback.

Re the screenshots:
What are names of the addons that you are using for showing the lyrics and details? The panels that are covered by white space in 1871 doesn't seem to be native, which addon(s) it is?
Thanks!
Here are the addons that I have installed.
  • Add-Remove PlayStat 1.3.1.116 by Bex
  • Advanced Report 6.4 by trixmoto
  • Album Art Tagger 5.2 by trixmoto
  • Backup 6.0 by trixmoto
  • Last.fm Scrobbler 1.0.2.29
  • Lyrics and Comment Viewer 2.2 by Gege
  • MonkeyRok 6.2 by trixmoto
The one on the lower left is Lyrics and Comment Viewer
The one on the right is MonkeyRok.

Stigg
Posts: 222
Joined: Wed May 18, 2011 7:56 pm

Re: MediaMonkey v4.1.21.1867 Beta Access Violation

Post by Stigg » Sun Jun 24, 2018 9:01 pm

Ludek wrote:
Sun Jun 24, 2018 3:33 pm
Hi Stigg,
thank you very much for your feedback.

Unfortunately the debug logs don't include any MediaMonkey messages, they were probably generated using the release build, could you please download and install debug builds and generate them again?
1864 debug: http://www.mediamonkey.com/beta/MediaMo ... _Debug.exe
1871 debug: http://www.mediamonkey.com/beta/MediaMo ... _Debug.exe
Thanks!
Thanks, I can replicate this, to be fixed as https://www.ventismedia.com/mantis/view.php?id=14897
Do I still use DebugView with the MediaMonkey Debug versions?

I used DebugView on 4.1.20.1864 and 4.1.21.1871 RC normal versions separately. It produced different logs.
I don't know why it didn't give you what you needed.

Post Reply