Backup 6.0 - Updated 01/07/2014

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

terrypin
Posts: 869
Joined: Mon May 10, 2004 7:48 am

Re: Backup 6.0 - Updated 01/07/2014

Post by terrypin » Fri Aug 14, 2015 7:53 am

Thanks trixmoto. I gave up and re-installed as a single user (the only script for which I've had to do that) and the error no longer occurs.

--
Terry, East Grinstead, UK
Terry, East Grinstead, UK
MM 4.1.20.1864 Gold, 7800 tracks, i7 4.0 GHz running Win 10 Pro

Beckanator
Posts: 8
Joined: Mon Aug 31, 2015 2:26 pm
Location: The OC - So. CA USA

Backup & Restore

Post by Beckanator » Thu Oct 08, 2015 6:34 pm

Well, forgive me being a MM Newbie. I hope this thread would be where to ask my question. After you've backed up with MM 6.0, how do you restore it using the script? What are the steps? I think I understand some of the confusion expressed here. I tried running the restore script from after loading windows and MM and get a VBS error message. Not sure how to proceed. Thanks in advance for any help!

I just cleaned off my old standby Vaio and reinstalled the OS as it was nearly grinding to a halt (Windows 7). My library is 163,377 files, 1024.7 gigs, running on an external drive. Needless to say, MM is handling it much better than iTunes, but I'm still learning something new everyday with MM.
Last edited by Lowlander on Thu Oct 08, 2015 7:14 pm, edited 1 time in total.
Reason: Merged with existing topic

dtsig
Posts: 3062
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by dtsig » Fri Oct 09, 2015 8:08 am

First .. just to set thing somewhat straight it is Backup 6.0 .. not mmw. Most all of the 'addons' are contributed scripts from users and are not part of mmw.
When I have had to restore .. i right-click the file. One of the options should be to use MS Script engine (or similar). Select that option and it should run without fault.
If there is an error you should include the text of the error with the report.

And no worries .. we are all newbies at some point :)
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Beckanator
Posts: 8
Joined: Mon Aug 31, 2015 2:26 pm
Location: The OC - So. CA USA

Re: Backup 6.0 - Updated 01/07/2014

Post by Beckanator » Sat Oct 17, 2015 3:11 pm

dtsig wrote:First .. just to set thing somewhat straight it is Backup 6.0 .. not mmw. Most all of the 'addons' are contributed scripts from users and are not part of mmw.
When I have had to restore .. i right-click the file. One of the options should be to use MS Script engine (or similar). Select that option and it should run without fault.
If there is an error you should include the text of the error with the report.

And no worries .. we are all newbies at some point :)
Gotcha on the 6.0 and the contributed scripts. Very awesome. I was able to get it going with your help. I just wasn't sure how to start the script. Thanks a bunch!

dtsig
Posts: 3062
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by dtsig » Sun Oct 18, 2015 11:08 am

Glad you got it working.
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Beckanator
Posts: 8
Joined: Mon Aug 31, 2015 2:26 pm
Location: The OC - So. CA USA

Re: Backup 6.0 - Updated 01/07/2014

Post by Beckanator » Tue Oct 20, 2015 3:29 pm

:D

lordbear
Posts: 20
Joined: Wed Jan 20, 2010 8:42 pm

Documentation? (Moving playlists)

Post by lordbear » Thu Nov 26, 2015 3:06 pm

I've used MM since 3.0. I've used Trixmoto's Backup (and other scripts) for a long time too. I'm not aware of there being a User Guide, FAQ, Wiki or other documentation. Have I missed something?

Trixmoto has been mostly excellent at providing support for this awesome script. However, he's less responsive these days (probably quite busy) and wouldn't it be great if there was a place that collected the most common information that new (and forgetful) users could go?

My number one wish; break down the Settings options.

For example, despite being a lifelong techie and 17-year IT veteran I still don't grasp what the 3rd from the last Setting's dropdown options will do. Since there's no Doc file installed, and no mouse hover text bubble, I have to guess...

Code: Select all

Include [ExportM3Us | Mod:Nested | Mod:Relative ] export (save all playlists as M3U Files)
So, I'm going to try each setting, do a backup, look at the output and see what I can discover.
All of THIS so that I can figure out why the Backup on PC-A and Restore on PC-B didn't seem to work, but especially not moving the playlists.
*sigh*

orbit111

Re: Backup 6.0 - Updated 01/07/2014

Post by orbit111 » Thu Dec 17, 2015 9:48 am

I just wanted to post some help for those who are having trouble restoring to your new MM install.

If it were not for me being an network engineer I would have never figured out how to make this work!
-In windows 10 or 7 search for Power Shell from the start menu.
-Right click the Power Shell app and select 'Run As Administrator'
-At the command prompt type: cd <Location of MM backup files> Example: (cd C:\users\user1\desktop\media monkey backup\)
-Next type .\Restore

This should get you past the VB script error

terrypin
Posts: 869
Joined: Mon May 10, 2004 7:48 am

How to restore from backup?

Post by terrypin » Thu Dec 17, 2015 11:33 am

Could someone remind me how to restore from my Backup 6 backup please?

I opened MM and noticed that its playlist tree no longer included the most recent playlist I've been working with. (Easy to spot because it's at the top.) So I assume a recent crash or glitch has caused this as a side effect. (I've had two today, probably not MM related). I've no idea what version of my DB and playlists is currently in use. I backup automatically every time I close, and get a message telling me it was successful, and that a restore script has been created. But where is it and how do I run it?
Last edited by Lowlander on Thu Dec 17, 2015 3:37 pm, edited 1 time in total.
Reason: Merged with existing post
Terry, East Grinstead, UK
MM 4.1.20.1864 Gold, 7800 tracks, i7 4.0 GHz running Win 10 Pro

dtsig
Posts: 3062
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by dtsig » Sun Dec 27, 2015 1:01 pm

trixmoto, just wanted to thank you again for this great script. My server died but in the long run (after getting bits started) all i had to do is install mmw then run the restore script. Couple of days old but can't blame that on you <G> ..

Thanks for saving all my work ..
David
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

dtsig
Posts: 3062
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by dtsig » Sun Dec 27, 2015 4:59 pm

Is there a link to the instructions for installing the dotnetzip? New computer .. install dotnetzip using their msi but it looks like backup doesn't see it

Also i think they might have changed the name ...

EDITED: it is found in the notice of 6.0 here

Is not working ..
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by MMFrLife » Sun Jan 03, 2016 4:11 pm

Let me see if I can get through this without having to post an image, as I'm unable to do that right now.

Problem:
I currently have Backup set to auto backup at shutdown and it works brilliantly.
However, I'm trying to get it to only leave a certain number of backups at any given time, 2, but I can't get it to work;
even after setting parameters for it.

Here's how my settings are:
Key: There are 11 long fields at the top of settings dialog (all but one has a label first and then a check box).
There are 13 settings at the bottom (all begin with checkboxes and 5 of them have short fields associated, one with an in-statement checkbox).

I have 1-5 and 8 checked in the top checkboxes
I have 1 and 12 checked in the bottom checkboxes

In addition to these, I've tried checking Delete old backup - keep|2| - output path

But whenever I do this, it doesn't work and I get an error message.
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

dtsig
Posts: 3062
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by dtsig » Wed Jan 06, 2016 9:29 am

Anyone have any thoughts on my post here .. a couple posts up.
Or does anyone have the older install of the dotnet zip dll?
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: Backup 6.0 - Updated 01/07/2014

Post by MMFrLife » Thu Feb 11, 2016 5:51 pm

Does anyone ever use the "Delete old backups - Keep |?| output path" setting?
Does it actually work?
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

Guest

Re: Backup 6.0 - Updated 01/07/2014

Post by Guest » Sun Feb 28, 2016 12:29 pm

Does anyone have a link to this?

Post Reply