Sync / Copy starts process and then hangs

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

Austin WineGuy

Sync / Copy starts process and then hangs

Post by Austin WineGuy » Sun Dec 31, 2017 8:33 pm

I am trying to copy music from my Windows 10 PC (running MM Gold) to my new iPhone X - 256. I set everything up per online instructions, using iTunes (12.7.260) and MediaMonkey. I have a large library, and was trying to Auto Sync a collection of almost 18000 files. Everything started out great, but something went awry after 13000 files were copied. I got an error message at that point, but all was well otherwise and that subset happily resides on the iPhone. I then tried to continue with another Auto Sync. Part way through, I needed to stop the sync to go to work; I tried to initiate a 'Terminate' of the process. I waited and waited, but was never notified of cessation. I took my phone and went to work; when I returned I tried to pick back up.

This time when I tried to Auto Sync, the status line indicated that it built a list and began Copying to my iPhone; however, it 'hung' during the copy of the first song. I waited (an hour) for progress which never happened, I initiated a Terminate of the action in the Status line, but there was no indication of any change. After waiting (almost an hour), I tried to close down MediaMonkey; a message popped up saying "There are background processes running. Terminate them?". Eventually I selected Yes and closed MM. I have since repeated my attempts to complete, both Sync'ing from a collection and trying to Copy single files. The outcome is always the same; the Status shows progress with bar movement and the indication of Copying, but the program then hangs. I can't gracefully Terminate. I am always then forced to Close / override process termination.

At this point, I have exhausted my attempts and would be very grateful for assistance . . .

Posts: 12370
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: Sync / Copy starts process and then hangs

Post by Peke » Sun Dec 31, 2017 11:12 pm

As I replied in Opened ticket a debug log would be teh best way to determine what is going on.

See ... ?f=12&t=69 on how to create Debug log.
Best regards,
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
How to add SCREENSHOTS to forum

Austin WineGuy

Re: Sync / Copy starts process and then hangs

Post by Austin WineGuy » Wed Jan 03, 2018 12:47 am

I found the problem . . .

After many attempts, restarting the PC, reinstalling both MM and iTunes, and every other thing that I could think of trying, I (finally) thought about rebooting the iPhone, I hadn't considered it earlier because it seemed to be working fine (even with the music that I had downloaded) and never had to do it before.

Rebooting (powering off / on) the iPhone did the trick. I suspect that the "dirty" termination somehow left that data transfer mechanism hung. I wanted to let everyone know so that you can use the knowledge if you're ever dealing with similar issues. Also, I'd like to recommend that it would be very useful if MediaMonkey could post some "successful completion" messages (whether natural finish or forced termination) both so that people were certain when to proceed to their next task and so that there are no 'dirty' shut downs.

Just wanted to pass along my learnings . . .

Post Reply