Knowledgebase
Android: MediaMonkey requirements / Google Play Services issues
Updated by Russell Samuels on 10 March 2017 03:43 PM

MMA 1.2.0 and higher from the Google Play store minimally requires Android 4.x and Google Play Services 8.3+ .  This version of MMA is served from the Google Play Store to Android 4.x + devices. If you're receiving an error about out-of-date services, update to the newest version Google Play Services.

MMA 1.1.3 does not have this requirement, and is served from the Google Play Store to devices running Android <= 3.x. You can download this older MediaMonkey apk here.

Versions of MMA served from the Amazon store do not include chromecast functionality and therefore do not require newer versions of Google Play Services.

(4 vote(s))
Helpful
Not helpful

Comments (0)