Knowledgebase: Install and Config
What operating systems is MediaMonkey compatible with?
Updated by Russell Samuels on Jan 15, 2016

MediaMonkey 4.x is supported on 32 and 64-bit versions of Windows 10 (as of MediaMonkey 4.1.9), Windows 8, Windows 7, Windows Vista, and Windows XP, but is also known to work with WINE (Linux) and Wineskin (MAC OS).

MediaMonkey 3.x was supported on 32 and 64-bit versions of Windows 7, Windows Vista, and Windows XP, but is also known to work with Windows 98, Windows ME, Windows 2000, and WINE (Linux).

MediaMonkey 2.5.x was supported on Windows 98, Windows ME, Windows 2000.

No versions of MediaMonkey are currently compatible with the MAC OS or Linux (other than through Wine).

(1590 vote(s))
Helpful
Not helpful

Comments (0)