Coclass: SDBAlbum

Object of album properties.


Interface: ISDBAlbum

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBAlbum

ISDBAlbum members

Properties

Name | Type | HelpString | Category | Frequency of use
AlbumArt | Property Get |  | General | Normal
AlbumLength | Property Get |  | General | Normal
AlbumLengthString | Property Get |  | General | Normal
Artist | Property Get |  | General | Normal
ID | Property Get |  | General | Normal
Name | Property Get/Let |  | General | Normal
Tracks | Property Get |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBAlbum overview


Interface ISDBAlbum

ISDBAlbum members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AlbumArt | Property Get |  | General | Normal
AlbumLength | Property Get |  | General | Normal
AlbumLengthString | Property Get |  | General | Normal
Artist | Property Get |  | General | Normal
ID | Property Get |  | General | Normal
Name | Property Get/Let |  | General | Normal
Tracks | Property Get |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBAlbum overview


Interface ISDBAlbum

ISDBAlbum members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
AlbumArt | Property Get |  | General | Normal
AlbumLength | Property Get |  | General | Normal
AlbumLengthString | Property Get |  | General | Normal
Artist | Property Get |  | General | Normal
ID | Property Get |  | General | Normal
Name | Property Get/Let |  | General | Normal
Tracks | Property Get |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBAlbum overview


ISDBAlbum::AlbumArt

Property Get AlbumArt As SDBAlbumArtList

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBAlbum::AlbumLength

Property Get AlbumLength As Long

No parameters

Property description

Total length of all tracks of this album in milliseconds.


ISDBAlbum::AlbumLengthString

Property Get AlbumLengthString As String

No parameters

Property description

Total length of all tracks of this album formatted as a string.


ISDBAlbum::Artist

Property Get Artist As ISDBArtist

No parameters

Property description

Album artist of the album.


ISDBAlbum::ID

Property Get ID As Long

No parameters

Property description

Internal ID of the album.


ISDBAlbum::Name

Property Get/Let Name As String

No parameters

Property description

Title of the album.


ISDBAlbum::Tracks

Property Get Tracks As SDBSongList

No parameters

Property description

List of all tracks of this album

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBAlbum::UpdateDB

Sub UpdateDB

No parameters

Method description

Not implemented yet.


Coclass: SDBAlbumArtItem

Single album art item.


Interface: ISDBAlbumArtItem

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBAlbumArtItem

ISDBAlbumArtItem members

Properties

Name | Type | HelpString | Category | Frequency of use
Description | Property Get/Let |  | General | Normal
Image | Property Get |  | General | Normal
ItemStorage | Property Get/Let |  | General | Normal
ItemType | Property Get/Let |  | General | Normal
PicturePath | Property Get/Let |  | General | Normal
RelativePicturePath | Property Get/Let |  | General | Normal

ISDBAlbumArtItem overview


Interface ISDBAlbumArtItem

ISDBAlbumArtItem members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Description | Property Get/Let |  | General | Normal
Image | Property Get |  | General | Normal
ItemStorage | Property Get/Let |  | General | Normal
ItemType | Property Get/Let |  | General | Normal
PicturePath | Property Get/Let |  | General | Normal
RelativePicturePath | Property Get/Let |  | General | Normal

ISDBAlbumArtItem overview


Interface ISDBAlbumArtItem

ISDBAlbumArtItem members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Description | Property Get/Let |  | General | Normal
Image | Property Get |  | General | Normal
ItemStorage | Property Get/Let |  | General | Normal
ItemType | Property Get/Let |  | General | Normal
PicturePath | Property Get/Let |  | General | Normal
RelativePicturePath | Property Get/Let |  | General | Normal

ISDBAlbumArtItem overview


ISDBAlbumArtItem::Description

Property Get/Let Description As String

No parameters

Property description

Description of the album art item

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBAlbumArtItem::Image

Property Get Image As ISDBImage

No parameters

Property description

Returns SDBImage object of this Album Art item.


ISDBAlbumArtItem::ItemStorage

Property Get/Let ItemStorage As Long

No parameters

Property description

Where is the item stored (0=tag, 1=external file).


ISDBAlbumArtItem::ItemType

Property Get/Let ItemType As Long

No parameters

Property description

Item type identification according to ID3v2 specification, i.e.: $00 Other $01 32x32 pixels 'file icon' (PNG only) $02 Other file icon $03 Cover (front) $04 Cover (back) $05 Leaflet page $06 Media (e.g. label side of CD) $07 Lead artist/lead performer/soloist $08 Artist/performer $09 Conductor $0A Band/Orchestra $0B Composer $0C Lyricist/text writer $0D Recording Location $0E During recording $0F During performance $10 Movie/video screen capture $11 A bright coloured fish $12 Illustration $13 Band/artist logotype $14 Publisher/Studio logotype


ISDBAlbumArtItem::PicturePath

Property Get/Let PicturePath As String

No parameters

Property description

Full path to image file. If you set this property, the image from the path is loaded.


ISDBAlbumArtItem::RelativePicturePath

Property Get/Let RelativePicturePath As String

No parameters

Property description

Path to the image relatively to path of the track its assigned to. If you set this property, the image from the path is loaded.


Coclass: SDBAlbumArtList

List of album art items.


Interface: ISDBAlbumArtList

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBAlbumArtList

ISDBAlbumArtList members

Properties

Name | Type | HelpString | Category | Frequency of use
AddNew | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBAlbumArtList overview


Interface ISDBAlbumArtList

ISDBAlbumArtList members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AddNew | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBAlbumArtList overview


Interface ISDBAlbumArtList

ISDBAlbumArtList members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
AddNew | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBAlbumArtList overview


ISDBAlbumArtList::AddNew

Property Get AddNew As ISDBAlbumArtItem

No parameters

Property description

Adds new item to the list and returns it to user for further modifications.

Example code

Set SL = SDB.CurrentSongList
  If SL.Count>0 Then
    Set Track = SL.Item(0)
    Set AAList = Track.AlbumArt
    Set AA = AAList.AddNew
    AA.PicturePath = "D:\test.jpg"
    AA.Description = "Test"
    AA.ItemType = 5
    AA.ItemStorage = 0
    AAList.UpdateDB
  End If

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBAlbumArtList::Count

Property Get Count As Long

No parameters

Property description

Number of album art items in the list.


ISDBAlbumArtList::Delete

Sub Delete(Index As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of item to delete.

Method description

Deletes album art item.


ISDBAlbumArtList::Item

Property Get/Let Item(Index As Long) As ISDBAlbumArtItem

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of album art to be returned.

Property description

Returns albums art given by an index.


ISDBAlbumArtList::UpdateDB

Sub UpdateDB

No parameters

Method description

Writes all modifications to DB and to tags.


Coclass: SDBAlbums

A list of albums.


Interface: ISDBAlbums

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBAlbums

ISDBAlbums members

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Sort | Method |  | General | Normal
SortByArtist | Method |  | General | Normal

ISDBAlbums overview


Interface ISDBAlbums

ISDBAlbums members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Sort | Method |  | General | Normal
SortByArtist | Method |  | General | Normal

ISDBAlbums overview


Interface ISDBAlbums

ISDBAlbums members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Sort | Method |  | General | Normal
SortByArtist | Method |  | General | Normal

ISDBAlbums overview


ISDBAlbums::Count

Property Get Count As Long

No parameters

Property description

Returns an album from the list indexed by Index.


ISDBAlbums::Item

Property Get Item(Index As Long) As ISDBAlbum

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the album to return.

Property description

Returns an album from the list indexed by Index.


ISDBAlbums::Sort

Sub Sort

No parameters

Method description

Sort the list of albums by album title.


ISDBAlbums::SortByArtist

Sub SortByArtist

No parameters

Method description

Sort the list of albums by artist name.


Coclass: SDBApplication

This is the main MediaMonkey scripting object that you initially have accessible as 'SDB' variable in your scripts. All your communication with MediaMonkey should start here, you can get references to other objects from properties of this object.


Interface: ISDBApplication

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBApplication

ISDBApplication members

Properties

Name | Type | HelpString | Category | Frequency of use
AllVisibleSongList | Property Get |  | Track | Normal
ApplicationPath | Property Get |  | General | Normal
CommonDialog | Property Get |  | User interface | Normal
CreateTimer | Method |  | General | Normal
CurrentSongList | Property Get |  | Track | Normal
Database | Property Get |  | Library | Normal
Device | Property Get |  | General | Normal
Format | Method |  | General | Normal
IniFile | Property Get |  | General | Normal
IsRunning | Property Get |  | General | Normal
Localize | Method |  | Tools | Normal
LocalizedFormat | Method |  | General | Normal
LocalizeGen | Method |  | General | Normal
MainTracksWindow | Property Get |  | General | Normal
MainTree | Property Get |  | General | Normal
MessageBox | Method |  | User interface | Normal
MyMusicPath | Property Get |  | General | Normal
NewSongData | Property Get |  | General | Normal
NewSongList | Property Get |  | General | Normal
Objects | Property Get/Let |  | General | Normal
Player | Property Get |  | Player | Normal
PlaylistByTitle | Property Get |  | Playlists | Normal
ProcessMessages | Method |  | General | Normal
Progress | Property Get |  | User interface | Normal
RegisterIcon | Method |  | General | Normal
RegisterIconHandle | Method |  | General | Normal
Registry | Property Get |  | General | Normal
SelectedSongList | Property Get |  | Track | Normal
SelectFolder | Method |  | General | Normal
ShutdownAfterDisconnect | Property Get/Let |  | General | Normal
TemporaryFolder | Property Get |  | General | Normal
toASCII | Method |  | Tools | Normal
Tools | Property Get |  | General | Normal
UI | Property Get |  | General | Normal
VersionHi | Property Get |  | Application | Normal
VersionLo | Property Get |  | Application | Normal
VersionRelease | Property Get |  | Application | Normal
VersionString | Property Get |  | Application | Normal
WebControl | Property Get |  | General | Normal

ISDBApplication overview


Interface ISDBApplication

ISDBApplication members by category

Properties

Name | Type | HelpString | Category | Frequency of use
ApplicationPath | Property Get |  | General | Normal
CreateTimer | Method |  | General | Normal
Device | Property Get |  | General | Normal
Format | Method |  | General | Normal
IniFile | Property Get |  | General | Normal
IsRunning | Property Get |  | General | Normal
LocalizedFormat | Method |  | General | Normal
LocalizeGen | Method |  | General | Normal
MainTracksWindow | Property Get |  | General | Normal
MainTree | Property Get |  | General | Normal
MyMusicPath | Property Get |  | General | Normal
NewSongData | Property Get |  | General | Normal
NewSongList | Property Get |  | General | Normal
Objects | Property Get/Let |  | General | Normal
ProcessMessages | Method |  | General | Normal
RegisterIcon | Method |  | General | Normal
RegisterIconHandle | Method |  | General | Normal
Registry | Property Get |  | General | Normal
SelectFolder | Method |  | General | Normal
ShutdownAfterDisconnect | Property Get/Let |  | General | Normal
TemporaryFolder | Property Get |  | General | Normal
Tools | Property Get |  | General | Normal
UI | Property Get |  | General | Normal
WebControl | Property Get |  | General | Normal
VersionHi | Property Get |  | Application | Normal
VersionLo | Property Get |  | Application | Normal
VersionRelease | Property Get |  | Application | Normal
VersionString | Property Get |  | Application | Normal
Database | Property Get |  | Library | Normal
Player | Property Get |  | Player | Normal
PlaylistByTitle | Property Get |  | Playlists | Normal
Localize | Method |  | Tools | Normal
toASCII | Method |  | Tools | Normal
AllVisibleSongList | Property Get |  | Track | Normal
CurrentSongList | Property Get |  | Track | Normal
SelectedSongList | Property Get |  | Track | Normal
CommonDialog | Property Get |  | User interface | Normal
MessageBox | Method |  | User interface | Normal
Progress | Property Get |  | User interface | Normal

ISDBApplication overview


Interface ISDBApplication

ISDBApplication members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
LocalizeGen | Method |  | General | Normal
WebControl | Property Get |  | General | Normal
AllVisibleSongList | Property Get |  | Track | Normal
ApplicationPath | Property Get |  | General | Normal
CommonDialog | Property Get |  | User interface | Normal
CreateTimer | Method |  | General | Normal
CurrentSongList | Property Get |  | Track | Normal
Database | Property Get |  | Library | Normal
Device | Property Get |  | General | Normal
Format | Method |  | General | Normal
IniFile | Property Get |  | General | Normal
IsRunning | Property Get |  | General | Normal
Localize | Method |  | Tools | Normal
LocalizedFormat | Method |  | General | Normal
MainTracksWindow | Property Get |  | General | Normal
MainTree | Property Get |  | General | Normal
MessageBox | Method |  | User interface | Normal
MyMusicPath | Property Get |  | General | Normal
NewSongData | Property Get |  | General | Normal
NewSongList | Property Get |  | General | Normal
Objects | Property Get/Let |  | General | Normal
Player | Property Get |  | Player | Normal
PlaylistByTitle | Property Get |  | Playlists | Normal
ProcessMessages | Method |  | General | Normal
Progress | Property Get |  | User interface | Normal
RegisterIcon | Method |  | General | Normal
RegisterIconHandle | Method |  | General | Normal
Registry | Property Get |  | General | Normal
SelectedSongList | Property Get |  | Track | Normal
SelectFolder | Method |  | General | Normal
ShutdownAfterDisconnect | Property Get/Let |  | General | Normal
TemporaryFolder | Property Get |  | General | Normal
toASCII | Method |  | Tools | Normal
Tools | Property Get |  | General | Normal
UI | Property Get |  | General | Normal
VersionHi | Property Get |  | Application | Normal
VersionLo | Property Get |  | Application | Normal
VersionRelease | Property Get |  | Application | Normal
VersionString | Property Get |  | Application | Normal

ISDBApplication overview


ISDBApplication::AllVisibleSongList

Property Get AllVisibleSongList As ISDBSongList

No parameters

Property description

Returns SDBSongList object of all tracks that are currently in the track list in the main MediaMonkey window.


ISDBApplication::ApplicationPath

Property Get ApplicationPath As String

No parameters

Property description

Returns the path where MediaMonkey.exe is located.


ISDBApplication::CommonDialog

Property Get CommonDialog As ISDBCommonDialog

No parameters

Property description

Returns SDBCommonDialog object that can be used then to show load/save file dialogs.

Example code

' Create common dialog and ask where to save the file
Dim dlg
Set dlg = SDB.CommonDialog
dlg.DefaultExt='mp3'
dlg.Filter=filter
dlg.Flags=cdlOFNOverwritePrompt + cdlOFNHideReadOnly
dlg.InitDir = iniF.StringValue( "Scripts", iniDirValue)
dlg.ShowSave

if Not dlg.Ok Then
  Exit Sub   ' if cancel was pressed, exit
End If

' Get the selected filename
fullfile = dlg.FileName


ISDBApplication::CreateTimer

Function CreateTimer(Interval As Long) As ISDBTimer

Parameters

No | Name | Type | Optional | Default | Description
1 | Interval | Long | No | - | Interval between calls (in milliseconds).

Method description

Creates new timer.

Example code

Set Tmr = SDB.CreateTimer( 10000)   ' Pop up a message in 10 seconds
  Script.RegisterEvent Tmr, "OnTimer", "TestTimer"

Sub TestTimer( Timer)
  SDB.MessageBox "10 seconds elapsed!", mtInformation, Array(mbOk)
  Script.UnregisterEvents Timer  ' Terminate usage of this timer
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBApplication::CurrentSongList

Property Get CurrentSongList As ISDBSongList

No parameters

Property description

Returns SDBSongList object that contains tracks depending on the current context. E.g. if a tree node is in focus then all its tracks are returned, if the main track list is in focus then only its selected tracks are returned.


ISDBApplication::Database

Property Get Database As ISDBDatabase

No parameters

Property description

Returns SDBDatabase object that allows direct execution of SQL statements on MediaMonkey Library (MS Access database).


ISDBApplication::Device

Property Get Device As SDBDevice

No parameters

Property description

Returns SDBDevice object which is useful for portable devices maintenance. This is used by device plug-ins.


ISDBApplication::Format

Function Format(Text As String, Param1, Param2, Param3) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Text | String | No | - | Text with parameters to be replaced
2 | Param1 | Variant | No | - | Parameter 1 (number or string)
3 | Param2 | Variant | No | - | Parameter 2 (number or string)
4 | Param3 | Variant | No | - | Parameter 3 (number or string)

Method description

Works similarly to c printf function, modifies text with specified parameters. It's fixed to three parameters, use some dummy ones if you need less of them.

Example code

SDB.Format( "Number is: %d and string is: %s", 10, "Hello", 0)


ISDBApplication::IniFile

Property Get IniFile As ISDBIniFile

No parameters

Property description

Returns SDBIniFile object. It can be used to persist options between script execution.


ISDBApplication::IsRunning

Property Get IsRunning As Boolean

No parameters

Property description

Returns True if MediaMonkey is properly initialized and running.


ISDBApplication::Localize

Function Localize(Value As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Value | String | No | - | A string to be localized

Method description

This method translates a string to the language that is currectly selected by user in MediaMonkey. The strings to be translated and their translations have to be in default.mo file for each language.


ISDBApplication::LocalizedFormat

Function LocalizedFormat(Text As String, Param1, Param2, Param3) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Text | String | No | - |
2 | Param1 | Variant | No | - |
3 | Param2 | Variant | No | - |
4 | Param3 | Variant | No | - |

Method description

The same as Format method, only Text parameter is localized (Localize method is used) before Format is applied.


ISDBApplication::LocalizeGen

Function LocalizeGen(LangFile As String, Value As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | LangFile | String | No | - | Language file to be used (e.g. 'DB').
2 | Value | String | No | - | A string to be localized.

Method description

This method translates a string to the language that is currectly selected by user in MediaMonkey. The strings to be translated and their translations are taken from specified file for the currently selected language.


ISDBApplication::MainTracksWindow

Property Get MainTracksWindow As ISDBTracksWindow

No parameters

Property description

Returns SDBTrackWindow object for operations on tracklist window.


ISDBApplication::MainTree

Property Get MainTree As ISDBTree

No parameters

Property description

Returns SDBTree object for operations on the main tree.


ISDBApplication::MessageBox

Function MessageBox(MessageText As String, MsgType As EnumMsgBox, Buttons) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | MessageText | String | No | - | Text to be shown in the message box.
2 | MsgType | EnumMsgBox | No | - | Type of the box, can be one of: mtWarning(=0), mtError(=1), mtInformation(=2), mtConfirmation(=3) or mtCustom(=4).
3 | Buttons | Variant | No | - | Array of buttons to be shown, can be any of: mbYes(=0), mbYesToAll(=1), mbNo(=2), mbNoToAll(=3), mbOK(=4), mbOkToAll(=5), mbCancel(=6), mbAbort(=7), mbRetry(=8), mbIgnore(=9), mbIgnoreToAll(=10), mbAll(=11) and mbHelp(=12).

Method description

Shows a customized message box and returns information about button that was pressed, which can be one of the following values: mrNone (=0), mrOk(=1), mrCancel(=2), mrAbort(=3), mrRetry(=4), mrIgnore(=5), mrYes(=6), mrNo(=7), mrAll(=8), mrNoToAll(=9), mrYesToAll(=10), mrOkToAll(=110) or mrIgnoreToAll(=111).

Example code

res = SDB.MessageBox( SDB.Localize("Select tracks to be exported, please."), mtError, Array(mbOk))


ISDBApplication::MyMusicPath

Property Get MyMusicPath As String

No parameters

Property description

Path to 'My Music' folder as used by MediaMonkey.


ISDBApplication::NewSongData

Property Get NewSongData As ISDBSongData

No parameters

Property description

Returns a new SDBSongData object. Can be useful for example for adding new tracks to Library.


ISDBApplication::NewSongList

Property Get NewSongList As ISDBSongList

No parameters

Property description

Returns a newly created SongList object.


ISDBApplication::Objects

Property Get/Let Objects(Name As String) As Object

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | An identifier for object storage.

Property description

A collection for a temporary storage of any type of COM object during MediaMonkey running time. For example if a window is created by script that should remain visible while the script isn't running, the window object can be put to this collection in order to keep a reference to it.

Example code

If SDB.Objects[ 'Store'] Is Nothing Then    ' If the object isn't in collection yet...
  SDB.Objects[ 'Store'] = MyWindow         ' ... add it to the collection...
EndIf

SDB.Objects[ 'Store'] = Nothing               '  ... and now again remove it from the collection.


ISDBApplication::Player

Property Get Player As ISDBPlayer

No parameters

Property description

Returns SDBPlayer object. It allows to start and stop playback, work with Now Playing list and other playback related actions.


ISDBApplication::PlaylistByTitle

Property Get PlaylistByTitle(Title As String) As ISDBPlaylist

Parameters

No | Name | Type | Optional | Default | Description
1 | Title | String | No | - | Name of the playlist to get (use "" to get root of all playlists)

Property description

Retrieves SDBPlaylist object of the given playlist name. Probably most often used parameter is an empty string, the root (virtual) playlist node is returned then, you can use its ChildPlaylists property to get all the first level playlists.

Example code

Set Playlist = SDB.PlaylistByTitle( "")
Set list = Playlist.ChildPlaylists

For i=0 To list.count-1
  Set itm = list.Item(i)
  fout.WriteLine itm.Title & " (" & CStr(itm.ChildPlaylists.Count) & "/" & CStr( itm.Tracks.Count) & ")"
Next

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBApplication::ProcessMessages

Sub ProcessMessages

No parameters

Method description

Processes messages in internal MediaMonkey's message queue.


ISDBApplication::Progress

Property Get Progress As ISDBProgress

No parameters

Property description

Returns SDBProgress object. It is also initialized and shown this way. In order to further modify the progress bar, see SDBProgress properties.

Example code

Dim Progress
Set Progress = SDB.Progress
Progress.Text = SDB.Localize("Exporting...")
Progress.MaxValue = list.count

for i=0 to list.count-1
  '... some code here
  Progress.Value = i+1
next


ISDBApplication::RegisterIcon

Function RegisterIcon(Filename As String, IconType As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | Filename | String | No | - | The .ico file from which the icon is loaded. The path can be relative to MediaMonkey main folder.
2 | IconType | Long | No | - | Either 0 (=Menu icon) or 1(=Tree icon).

Method description

Adds an icon that can be later used either in menu (SDBMenuItem.IconIndex) or in tree (SDBTreeNode.IconIndex).

Example code

Set Node = Tree.CreateNode
Node.Caption = "My Node"
Node.IconIndex = SDB.RegisterIcon( "Scripts\Icons\new_node_icon", 1)


ISDBApplication::RegisterIconHandle

Function RegisterIconHandle(IconHandle As Long, IconType As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | IconHandle | Long | No | - | Handle of the icon to be used.
2 | IconType | Long | No | - | Either 0 (=Menu icon) or 1(=Tree icon).

Method description

Adds an icon that can be later used either in menu (SDBMenuItem.IconIndex) or in tree (SDBTreeNode.IconIndex).


ISDBApplication::Registry

Property Get Registry As ISDBRegistry

No parameters

Property description

Returns SDBRegistry object that can be used to manipulate registry entries.


ISDBApplication::SelectedSongList

Property Get SelectedSongList As ISDBSongList

No parameters

Property description

Returns SDBSongList object of all tracks that are currently selected in the track list in the main MediaMonkey window.


ISDBApplication::SelectFolder

Function SelectFolder(Folder As String, ShowText As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Folder | String | No | - | The initial value for the folder to be selected.
2 | ShowText | String | No | - | Text to be shown to user.

Method description

Shows a dialog for selection of a folder.


ISDBApplication::ShutdownAfterDisconnect

Property Get/Let ShutdownAfterDisconnect As Boolean

No parameters

Property description

Specifies whether to close MediaMonkey after the current object disconnects from it and MediaMonkey wasn't running before the object started it. For example a .vbs file is started from command line, it starts using SDBApplication object which causes MediaMonkey start-up (it wasn't running yet). Then if the script sets this property to True and terminates, MediaMonkey stays running.


ISDBApplication::TemporaryFolder

Property Get TemporaryFolder As String

No parameters

Property description

Temporary folder as set in Windows.


ISDBApplication::toASCII

Function toASCII(Value As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Value | String | No | - | Unicode string to be converted to ASCII.

Method description

Converts 'Value' to plain ASCII. Useful when string to be written is in Unicode but should be represented only by plain ascii (e.g. in export to .csv format).


ISDBApplication::Tools

Property Get Tools As ISDBTools

No parameters

Property description

Returns Tools object.


ISDBApplication::UI

Property Get UI As ISDBUI

No parameters

Property description

Returns SDBUI object that can be used to create and manipulate User Interface elements (windows, buttons, ...).


ISDBApplication::VersionHi

Property Get VersionHi As Long

No parameters

Property description

MediaMonkey's high version number.


ISDBApplication::VersionLo

Property Get VersionLo As Long

No parameters

Property description

MediaMonkey's low version number.


ISDBApplication::VersionRelease

Property Get VersionRelease As Long

No parameters

Property description

MediaMonkey's release number.


ISDBApplication::VersionString

Property Get VersionString As String

No parameters

Property description

The full version string of MediaMonkey

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBApplication::WebControl

Property Get WebControl As Object

No parameters

Property description

This property returns web browser window as is shown on the main MediaMonkey panel. In order to show the browser on tree node focus change, use SDBTreeNode.OnNodeFocused event.

Example code

SDB.WebControl.Navigate "http://www.mediamonkey.com"


Interface: ISDBApplicationEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBApplicationEvents

ISDBApplicationEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnBeforeTracksMove | Event |  | General | Normal
OnChangedSelection | Event |  | General | Normal
OnPause | Event |  | General | Normal
OnPlay | Event |  | General | Normal
OnShutdown | Event |  | General | Normal
OnStop | Event |  | General | Normal
OnTrackConverted | Event |  | General | Normal
OnTrackProperties | Event |  | General | Normal

ISDBApplicationEvents overview


Interface ISDBApplicationEvents

ISDBApplicationEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnBeforeTracksMove | Event |  | General | Normal
OnChangedSelection | Event |  | General | Normal
OnPause | Event |  | General | Normal
OnPlay | Event |  | General | Normal
OnShutdown | Event |  | General | Normal
OnStop | Event |  | General | Normal
OnTrackConverted | Event |  | General | Normal
OnTrackProperties | Event |  | General | Normal

ISDBApplicationEvents overview


Interface ISDBApplicationEvents

ISDBApplicationEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnBeforeTracksMove | Event |  | General | Normal
OnChangedSelection | Event |  | General | Normal
OnPause | Event |  | General | Normal
OnPlay | Event |  | General | Normal
OnStop | Event |  | General | Normal
OnTrackConverted | Event |  | General | Normal
OnShutdown | Event |  | General | Normal
OnTrackProperties | Event |  | General | Normal

ISDBApplicationEvents overview


ISDBApplicationEvents::OnBeforeTracksMove

Sub OnBeforeTracksMove(Tracks As ISDBSongList, NewPaths As ISDBStringList, IsMove As Boolean)

Parameters

No | Name | Type | Optional | Default | Description
1 | Tracks | ISDBSongList | No | - | A list of tracks that will be moved.
2 | NewPaths | ISDBStringList | No | - | A list of new full paths of individual tracks. (Number of items of NewPaths is the same as of Tracks)
3 | IsMove | Boolean | No | - | When true, it is a move operation, otherwise it is copy operation.

Event description

This event is called when a set of tracks is going to be copied/moved.


ISDBApplicationEvents::OnChangedSelection

Sub OnChangedSelection

No parameters

Event description

This event is called whenever the list of currently selected tracks changes (user selects another track(s), node, etc.).


ISDBApplicationEvents::OnPause

Sub OnPause

No parameters

Event description

This event is called whenever playback is paused.


ISDBApplicationEvents::OnPlay

Sub OnPlay

No parameters

Event description

This event is called on start of playback.


ISDBApplicationEvents::OnShutdown

Sub OnShutdown

No parameters

Event description

Called when application is going to shutdown.


ISDBApplicationEvents::OnStop

Sub OnStop

No parameters

Event description

This event is called when playback is stopped.


ISDBApplicationEvents::OnTrackConverted

Sub OnTrackConverted(SourceTrack As ISDBSongData, TargetTrack As ISDBSongData)

Parameters

No | Name | Type | Optional | Default | Description
1 | SourceTrack | ISDBSongData | No | - | SDBSongData object of source track of the conversion.
2 | TargetTrack | ISDBSongData | No | - | Description of the target of the conversion.

Event description

This event is called when a track is successfully converted to another audio format.


ISDBApplicationEvents::OnTrackProperties

Sub OnTrackProperties(TrackList As ISDBSongList)

Parameters

No | Name | Type | Optional | Default | Description
1 | TrackList | ISDBSongList | No | - | A list of tracks that were modified.

Event description

Is called whenever track(s) metadata were modified.


Coclass: SDBArtist

Object of artist properties.


Interface: ISDBArtist

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBArtist

ISDBArtist members

Properties

Name | Type | HelpString | Category | Frequency of use
Comment | Property Get/Let |  | General | Normal
ID | Property Get |  | General | Normal
Name | Property Get/Let |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBArtist overview


Interface ISDBArtist

ISDBArtist members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Comment | Property Get/Let |  | General | Normal
ID | Property Get |  | General | Normal
Name | Property Get/Let |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBArtist overview


Interface ISDBArtist

ISDBArtist members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Comment | Property Get/Let |  | General | Normal
ID | Property Get |  | General | Normal
Name | Property Get/Let |  | General | Normal
UpdateDB | Method |  | General | Normal

ISDBArtist overview


ISDBArtist::Comment

Property Get/Let Comment As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBArtist::ID

Property Get ID As Long

No parameters

Property description

Internal ID of the artist.


ISDBArtist::Name

Property Get/Let Name As String

No parameters

Property description

Name of artist.


ISDBArtist::UpdateDB

Sub UpdateDB

No parameters

Method description

Not implemented yet.


Coclass: SDBArtists

List of artists.


Interface: ISDBArtists

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBArtists

ISDBArtists members

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Sort | Method |  | General | Normal

ISDBArtists overview


Interface ISDBArtists

ISDBArtists members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Sort | Method |  | General | Normal

ISDBArtists overview


Interface ISDBArtists

ISDBArtists members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Sort | Method |  | General | Normal

ISDBArtists overview


ISDBArtists::Count

Property Get Count As Long

No parameters

Property description

Number of artists in the list.


ISDBArtists::Item

Property Get Item(Index As Long) As ISDBArtist

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the artist to return.

Property description

Returns an artist from the list indexed by Index.


ISDBArtists::Sort

Sub Sort

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


Coclass: SDBCommonDialog

Object for Open/Save dialogs handling.


Interface: ISDBCommonDialog

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBCommonDialog

ISDBCommonDialog members

Properties

Name | Type | HelpString | Category | Frequency of use
DefaultExt | Property Get/Let |  | General | Normal
Filename | Property Get |  | General | Normal
Filter | Property Get/Let |  | General | Normal
FilterIndex | Property Get/Let |  | General | Normal
Flags | Property Get/Let |  | General | Normal
InitDir | Property Get/Let |  | General | Normal
Ok | Property Get |  | General | Normal
ShowOpen | Method |  | General | Normal
ShowSave | Method |  | General | Normal
Title | Property Get/Let |  | General | Normal

ISDBCommonDialog overview


Interface ISDBCommonDialog

ISDBCommonDialog members by category

Properties

Name | Type | HelpString | Category | Frequency of use
DefaultExt | Property Get/Let |  | General | Normal
Filename | Property Get |  | General | Normal
Filter | Property Get/Let |  | General | Normal
FilterIndex | Property Get/Let |  | General | Normal
Flags | Property Get/Let |  | General | Normal
InitDir | Property Get/Let |  | General | Normal
Ok | Property Get |  | General | Normal
ShowOpen | Method |  | General | Normal
ShowSave | Method |  | General | Normal
Title | Property Get/Let |  | General | Normal

ISDBCommonDialog overview


Interface ISDBCommonDialog

ISDBCommonDialog members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
DefaultExt | Property Get/Let |  | General | Normal
Filename | Property Get |  | General | Normal
Filter | Property Get/Let |  | General | Normal
FilterIndex | Property Get/Let |  | General | Normal
Flags | Property Get/Let |  | General | Normal
InitDir | Property Get/Let |  | General | Normal
Ok | Property Get |  | General | Normal
ShowOpen | Method |  | General | Normal
ShowSave | Method |  | General | Normal
Title | Property Get/Let |  | General | Normal

ISDBCommonDialog overview


ISDBCommonDialog::DefaultExt

Property Get/Let DefaultExt As String

No parameters

Property description

Default extension of filenames to be saved.


ISDBCommonDialog::Filename

Property Get Filename As String

No parameters

Property description

Filename selected by user can be retrieved here.


ISDBCommonDialog::Filter

Property Get/Let Filter As String

No parameters

Property description

A filter for filenames, for example 'CSV (*.csv)|*.csv|All files (*.*)|*.*'.


ISDBCommonDialog::FilterIndex

Property Get/Let FilterIndex As Long

No parameters

Property description

Active part of filter.


ISDBCommonDialog::Flags

Property Get/Let Flags As Long

No parameters

Property description

Some combination of values as described in MSDN (OPENFILENAME.Flags). The values can be: OFN_READONLY 0x00000001 OFN_OVERWRITEPROMPT 0x00000002 OFN_HIDEREADONLY 0x00000004 OFN_NOCHANGEDIR 0x00000008 OFN_SHOWHELP 0x00000010 OFN_ENABLEHOOK 0x00000020 OFN_ENABLETEMPLATE 0x00000040 OFN_ENABLETEMPLATEHANDLE 0x00000080 OFN_NOVALIDATE 0x00000100 OFN_ALLOWMULTISELECT 0x00000200 OFN_EXTENSIONDIFFERENT 0x00000400 OFN_PATHMUSTEXIST 0x00000800 OFN_FILEMUSTEXIST 0x00001000 OFN_CREATEPROMPT 0x00002000 OFN_SHAREAWARE 0x00004000 OFN_NOREADONLYRETURN 0x00008000 OFN_NOTESTFILECREATE 0x00010000 OFN_NONETWORKBUTTON 0x00020000 OFN_NOLONGNAMES 0x00040000 // force no long names for 4.x modules OFN_EXPLORER 0x00080000 // new look commdlg OFN_NODEREFERENCELINKS 0x00100000 OFN_LONGNAMES 0x00200000 // force long names for 3.x modules OFN_ENABLEINCLUDENOTIFY 0x00400000 // send include message to callback OFN_ENABLESIZING 0x00800000


ISDBCommonDialog::InitDir

Property Get/Let InitDir As String

No parameters

Property description

Folder to open when showing the dialog.


ISDBCommonDialog::Ok

Property Get Ok As Boolean

No parameters

Property description

Returns True if the dialog was successfully closed.


ISDBCommonDialog::ShowOpen

Sub ShowOpen

No parameters

Method description

Shows 'Open file' dialog.


ISDBCommonDialog::ShowSave

Sub ShowSave

No parameters

Method description

Shows 'Save file' dialog.


ISDBCommonDialog::Title

Property Get/Let Title As String

No parameters

Property description

Caption of the dialog.


Coclass: SDBDatabase

Object for interaction with Database.


Interface: ISDBDatabase

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBDatabase

ISDBDatabase members

Properties

Name | Type | HelpString | Category | Frequency of use
DatabaseID | Property Get |  | General | Normal
ExecSQL | Method |  | General | Normal
OpenSQL | Method |  | General | Normal
Path | Property Get |  | General | Normal
QuerySongs | Method |  | General | Normal

ISDBDatabase overview


Interface ISDBDatabase

ISDBDatabase members by category

Properties

Name | Type | HelpString | Category | Frequency of use
DatabaseID | Property Get |  | General | Normal
ExecSQL | Method |  | General | Normal
OpenSQL | Method |  | General | Normal
Path | Property Get |  | General | Normal
QuerySongs | Method |  | General | Normal

ISDBDatabase overview


Interface ISDBDatabase

ISDBDatabase members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Path | Property Get |  | General | Normal
DatabaseID | Property Get |  | General | Normal
ExecSQL | Method |  | General | Normal
OpenSQL | Method |  | General | Normal
QuerySongs | Method |  | General | Normal

ISDBDatabase overview


ISDBDatabase::DatabaseID

Property Get DatabaseID As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBDatabase::ExecSQL

Sub ExecSQL(SQL As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | SQL | String | No | - | Full SQL to be executed

Method description

Executes SQL in the MS Access database that is used for Library storage. In order to understand how to construct such SQL commands you have to know SQL language and the structure of MM database.

Example code

SDB.Database.ExecSQL( "UPDATE Songs SET PlayCounter=0")   ' Clears # played of all tracks in the library


ISDBDatabase::OpenSQL

Function OpenSQL(SQL As String) As Object

Parameters

No | Name | Type | Optional | Default | Description
1 | SQL | String | No | - | SQL string specifying the query.

Method description

Returns SDBDBIterator object with records specified by SQL parameter.

Example code

Set Iter = SDB.Database.OpenSQL( "SELECT DISTINCT TextData FROM AddSongInfo WHERE DataType=200 Order BY TextData")

While Not Iter.EOF
   ' do something here....
  Iter.Next
WEnd

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBDatabase::Path

Property Get Path As String

No parameters

Property description

This property returns the full path of database file.


ISDBDatabase::QuerySongs

Function QuerySongs(AddSQL As String) As Object

Parameters

No | Name | Type | Optional | Default | Description
1 | AddSQL | String | No | - | Only condition part of SQL statement. It should start with AND operator.

Method description

Returns a SDBSongIterator object with a list of tracks fulfiling criteria specified by AddSQL parameter.

Example code

Set Iter = SDB.Database.QuerySongs( 'AND SongLength>60*1000')


Coclass: SDBDBIterator

Iterator through a result of DB query.


Interface: ISDBDBIterator

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBDBIterator

ISDBDBIterator members

Properties

Name | Type | HelpString | Category | Frequency of use
EOF | Property Get |  | General | Normal
Next | Method |  | General | Normal
StringByIndex | Property Get |  | General | Normal
StringByName | Property Get |  | General | Normal
ValueByIndex | Property Get |  | General | Normal
ValueByName | Property Get |  | General | Normal

ISDBDBIterator overview


Interface ISDBDBIterator

ISDBDBIterator members by category

Properties

Name | Type | HelpString | Category | Frequency of use
EOF | Property Get |  | General | Normal
Next | Method |  | General | Normal
StringByIndex | Property Get |  | General | Normal
StringByName | Property Get |  | General | Normal
ValueByIndex | Property Get |  | General | Normal
ValueByName | Property Get |  | General | Normal

ISDBDBIterator overview


Interface ISDBDBIterator

ISDBDBIterator members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
EOF | Property Get |  | General | Normal
Next | Method |  | General | Normal
StringByIndex | Property Get |  | General | Normal
StringByName | Property Get |  | General | Normal
ValueByIndex | Property Get |  | General | Normal
ValueByName | Property Get |  | General | Normal

ISDBDBIterator overview


ISDBDBIterator::EOF

Property Get EOF As Boolean

No parameters

Property description

Returns True if there isn't any new record.


ISDBDBIterator::Next

Sub Next

No parameters

Method description

Advances to the next record.


ISDBDBIterator::StringByIndex

Property Get StringByIndex(Index As Long) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the field to return.

Property description

Returns a field of the current record specified by Index. The returned value is a string.


ISDBDBIterator::StringByName

Property Get StringByName(Name As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of the field to return.

Property description

Returns a field of the current record specified by Name. The returned value is a string.


ISDBDBIterator::ValueByIndex

Property Get ValueByIndex(Index As Long) As Variant

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the field to return.

Property description

Returns a field of the current record specified by Index. The returned value is of the same type as in database.


ISDBDBIterator::ValueByName

Property Get ValueByName(Name As String) As Variant

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of the field to return.

Property description

Returns a field of the current record specified by Name. The returned value is of the same type as in database.


Coclass: SDBDevice

Mainly for usage in device plug-ins for controling several aspects of portable device functionality.


Interface: ISDBDevice

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBDevice

ISDBDevice members

Properties

Name | Type | HelpString | Category | Frequency of use
ActiveDeviceList | Property Get |  | General | Normal
canEjectDevice | Property Get |  | General | Normal
CreateDeviceNode | Method |  | General | Normal
DeviceEject | Method |  | General | Normal
DeviceIcon | Property Get/Let |  | General | Normal
DeviceMenuIcon | Property Get/Let |  | General | Normal
DeviceStart | Method |  | General | Normal
DeviceStartEx | Method |  | General | Normal
DeviceStop | Method |  | General | Normal
DeviceThreadedEject | Method |  | General | Normal
DriveLetterFree | Property Get |  | General | Normal
FreeSpace | Property Get |  | General | Normal
GetTrackIDSynchStatus | Method |  | General | Normal
GetTrackSynchStatus | Method |  | General | Normal
ChangeDeviceCaption | Method |  | General | Normal
ChangeDeviceID | Method |  | General | Normal
isPlaylistForSynch | Property Get/Let |  | General | Normal
IsVisible | Property Get |  | General | Normal
LockPlugin | Method |  | General | Normal
RegisterTreeNode | Method |  | General | Normal
ShowDeviceConfig | Method |  | General | Normal
StartSynch | Method |  | General | Normal
TotalSpace | Property Get |  | General | Normal
UnlockPlugin | Method |  | General | Normal

ISDBDevice overview


Interface ISDBDevice

ISDBDevice members by category

Properties

Name | Type | HelpString | Category | Frequency of use
ActiveDeviceList | Property Get |  | General | Normal
canEjectDevice | Property Get |  | General | Normal
CreateDeviceNode | Method |  | General | Normal
DeviceEject | Method |  | General | Normal
DeviceIcon | Property Get/Let |  | General | Normal
DeviceMenuIcon | Property Get/Let |  | General | Normal
DeviceStart | Method |  | General | Normal
DeviceStartEx | Method |  | General | Normal
DeviceStop | Method |  | General | Normal
DeviceThreadedEject | Method |  | General | Normal
DriveLetterFree | Property Get |  | General | Normal
FreeSpace | Property Get |  | General | Normal
GetTrackIDSynchStatus | Method |  | General | Normal
GetTrackSynchStatus | Method |  | General | Normal
ChangeDeviceCaption | Method |  | General | Normal
ChangeDeviceID | Method |  | General | Normal
isPlaylistForSynch | Property Get/Let |  | General | Normal
IsVisible | Property Get |  | General | Normal
LockPlugin | Method |  | General | Normal
RegisterTreeNode | Method |  | General | Normal
ShowDeviceConfig | Method |  | General | Normal
StartSynch | Method |  | General | Normal
TotalSpace | Property Get |  | General | Normal
UnlockPlugin | Method |  | General | Normal

ISDBDevice overview


Interface ISDBDevice

ISDBDevice members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
ActiveDeviceList | Property Get |  | General | Normal
canEjectDevice | Property Get |  | General | Normal
CreateDeviceNode | Method |  | General | Normal
DeviceEject | Method |  | General | Normal
DeviceIcon | Property Get/Let |  | General | Normal
DeviceMenuIcon | Property Get/Let |  | General | Normal
DeviceStart | Method |  | General | Normal
DeviceStartEx | Method |  | General | Normal
DeviceStop | Method |  | General | Normal
DeviceThreadedEject | Method |  | General | Normal
DriveLetterFree | Property Get |  | General | Normal
FreeSpace | Property Get |  | General | Normal
GetTrackIDSynchStatus | Method |  | General | Normal
GetTrackSynchStatus | Method |  | General | Normal
ChangeDeviceCaption | Method |  | General | Normal
ChangeDeviceID | Method |  | General | Normal
isPlaylistForSynch | Property Get/Let |  | General | Normal
IsVisible | Property Get |  | General | Normal
LockPlugin | Method |  | General | Normal
RegisterTreeNode | Method |  | General | Normal
ShowDeviceConfig | Method |  | General | Normal
StartSynch | Method |  | General | Normal
TotalSpace | Property Get |  | General | Normal
UnlockPlugin | Method |  | General | Normal

ISDBDevice overview


ISDBDevice::ActiveDeviceList

Property Get ActiveDeviceList(containID As String) As ISDBDeviceList

Parameters

No | Name | Type | Optional | Default | Description
1 | containID | String | No | - | Specifies the string that must be in each device ID in the list of devices

Property description

Returns the list of devices connected to the computer.


ISDBDevice::canEjectDevice

Property Get canEjectDevice As Boolean

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBDevice::CreateDeviceNode

Function CreateDeviceNode(DeviceHandle As Long) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::DeviceEject

Function DeviceEject(DevInstHandle As Long, DeviceName As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | DevInstHandle | Long | No | - |
2 | DeviceName | String | No | - |


ISDBDevice::DeviceIcon

Property Get/Let DeviceIcon(DeviceHandle As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::DeviceMenuIcon

Property Get/Let DeviceMenuIcon(DeviceHandle As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::DeviceStart

Function DeviceStart(LibraryHandle As Long, DeviceCaption As String, DeviceDriveLetter As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | LibraryHandle | Long | No | - | DLL handle of the library.
2 | DeviceCaption | String | No | - | Title of the device to show in MM UI.
3 | DeviceDriveLetter | Long | No | - | Drive letter of the device (can be 0 if the device doesn't have one).

Method description

Adds new device for handling by MM. Its icon is shown in the tree then.

Example code

See some device plug-in source code for examples.


ISDBDevice::DeviceStartEx

Function DeviceStartEx(LibraryHandle As Long, DeviceID As String, DeviceCaption As String, DeviceDriveLetter As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | LibraryHandle | Long | No | - |
2 | DeviceID | String | No | - |
3 | DeviceCaption | String | No | - |
4 | DeviceDriveLetter | Long | No | - |


ISDBDevice::DeviceStop

Sub DeviceStop(DeviceHandle As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - | Handle of the device to stop.

Method description

Stops given device handling and removes it from MM tree.


ISDBDevice::DeviceThreadedEject

Sub DeviceThreadedEject(DeviceHandle As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::DriveLetterFree

Property Get DriveLetterFree(LetterIndex As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | LetterIndex | Long | No | - |


ISDBDevice::FreeSpace

Property Get FreeSpace(DeviceHandle As Long) As Empty

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::GetTrackIDSynchStatus

Function GetTrackIDSynchStatus(DeviceHandle As Long, TrackID As Long) As ISDBTrackSynchStatus

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |
2 | TrackID | Long | No | - |


ISDBDevice::GetTrackSynchStatus

Function GetTrackSynchStatus(DeviceHandle As Long, TrackPath As String) As ISDBTrackSynchStatus

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |
2 | TrackPath | String | No | - |


ISDBDevice::ChangeDeviceCaption

Sub ChangeDeviceCaption(DeviceHandle As Long, NewCaption As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |
2 | NewCaption | String | No | - |


ISDBDevice::ChangeDeviceID

Function ChangeDeviceID(PluginName As String, OldID As String, NewID As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | PluginName | String | No | - |
2 | OldID | String | No | - |
3 | NewID | String | No | - |


ISDBDevice::isPlaylistForSynch

Property Get/Let isPlaylistForSynch(DeviceHandle As Long, IdPlaylist As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |
2 | IdPlaylist | Long | No | - |


ISDBDevice::IsVisible

Property Get IsVisible(DeviceHandle As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::LockPlugin

Sub LockPlugin(HLibrary As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | HLibrary | Long | No | - |


ISDBDevice::RegisterTreeNode

Sub RegisterTreeNode(DeviceHandle As Long, TreeNode As ISDBTreeNode)

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |
2 | TreeNode | ISDBTreeNode | No | - |


ISDBDevice::ShowDeviceConfig

Sub ShowDeviceConfig(DeviceHandle As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::StartSynch

Sub StartSynch(DeviceHandle As Long, TrackList As SDBSongList)

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |
2 | TrackList | SDBSongList | No | - |


ISDBDevice::TotalSpace

Property Get TotalSpace(DeviceHandle As Long) As Empty

Parameters

No | Name | Type | Optional | Default | Description
1 | DeviceHandle | Long | No | - |


ISDBDevice::UnlockPlugin

Sub UnlockPlugin(HLibrary As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | HLibrary | Long | No | - |


Coclass: SDBDeviceList

List of device parameters


Interface: ISDBDeviceList

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBDeviceList

ISDBDeviceList members

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
DeviceID | Property Get |  | General | Normal
DeviceInst | Property Get |  | General | Normal
DriveLetterIndex | Property Get |  | General | Normal
FriendlyName | Property Get |  | General | Normal

ISDBDeviceList overview


Interface ISDBDeviceList

ISDBDeviceList members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
DeviceID | Property Get |  | General | Normal
DeviceInst | Property Get |  | General | Normal
DriveLetterIndex | Property Get |  | General | Normal
FriendlyName | Property Get |  | General | Normal

ISDBDeviceList overview


Interface ISDBDeviceList

ISDBDeviceList members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
FriendlyName | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
DeviceID | Property Get |  | General | Normal
DeviceInst | Property Get |  | General | Normal
DriveLetterIndex | Property Get |  | General | Normal

ISDBDeviceList overview


ISDBDeviceList::Count

Property Get Count As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBDeviceList::DeviceID

Property Get DeviceID(Index As Long) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - |


ISDBDeviceList::DeviceInst

Property Get DeviceInst(Index As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - |


ISDBDeviceList::DriveLetterIndex

Property Get DriveLetterIndex(Index As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - |


ISDBDeviceList::FriendlyName

Property Get FriendlyName(Index As Long) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - |


Coclass: SDBDropTarget

For internal usage only.


Interface: ISDBDropTarget

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBDropTarget

ISDBDropTarget members

ISDBDropTarget overview


Interface ISDBDropTarget

ISDBDropTarget members by category

ISDBDropTarget overview


Interface ISDBDropTarget

ISDBDropTarget members by frequency of use

ISDBDropTarget overview


Coclass: SDBDropTargetLast

For internal usage only.


Coclass: SDBDropTargetNext

For internal usage only.


Coclass: SDBDropTargetRip

For internal usage only.


Coclass: SDBFileSystem

Replacement of the default scripting FileSystemObject (very simple, but isn't blocked by antiviruses).


Interface: ISDBFileSystem

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBFileSystem

ISDBFileSystem members

Properties

Name | Type | HelpString | Category | Frequency of use
CorrectFilename | Method |  | General | Normal
CreateFolder | Method |  | General | Normal
CreateTextFile | Method |  | General | Normal
DeleteFile | Method |  | General | Normal
FileExists | Method |  | General | Normal

ISDBFileSystem overview


Interface ISDBFileSystem

ISDBFileSystem members by category

Properties

Name | Type | HelpString | Category | Frequency of use
CorrectFilename | Method |  | General | Normal
CreateFolder | Method |  | General | Normal
CreateTextFile | Method |  | General | Normal
DeleteFile | Method |  | General | Normal
FileExists | Method |  | General | Normal

ISDBFileSystem overview


Interface ISDBFileSystem

ISDBFileSystem members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
CorrectFilename | Method |  | General | Normal
CreateFolder | Method |  | General | Normal
CreateTextFile | Method |  | General | Normal
DeleteFile | Method |  | General | Normal
FileExists | Method |  | General | Normal

ISDBFileSystem overview


ISDBFileSystem::CorrectFilename

Function CorrectFilename(Filename As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Filename | String | No | - | Filename to be modified.

Method description

Changes characters of filename as defined by character mapping in MM (e.g. removes incorrect character).


ISDBFileSystem::CreateFolder

Function CreateFolder(Folder As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Folder | String | No | - | Folder to be created.

Method description

Makes sure given folder exists and creates it if it doesn't.


ISDBFileSystem::CreateTextFile

Function CreateTextFile(Filename As String, [Overwrite As Boolean = False]) As ISDBTextFile

Parameters

No | Name | Type | Optional | Default | Description
1 | Filename | String | No | - | Full path of file to be openned.
2 | Overwrite | Boolean | Yes | False | Overwrite data if the file already has some.

Method description

Creates and opens a file for writing.


ISDBFileSystem::DeleteFile

Sub DeleteFile(Filename As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | Filename | String | No | - | File to be deleted.

Method description

Deletes given file.


ISDBFileSystem::FileExists

Function FileExists(Filename As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Filename | String | No | - | Filename to be checked.

Method description

Returns TRUE if the file exists.


Coclass: SDBHWEvents

For internal usage only.


Interface: ISDBHWEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBHWEvents

ISDBHWEvents members

ISDBHWEvents overview


Interface ISDBHWEvents

ISDBHWEvents members by category

ISDBHWEvents overview


Interface ISDBHWEvents

ISDBHWEvents members by frequency of use

ISDBHWEvents overview


Coclass: SDBImage

Object with image data.


Interface: ISDBImage

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBImage

ISDBImage members

Properties

Name | Type | HelpString | Category | Frequency of use
ConvertFormat | Method |  | General | Normal
Height | Property Get |  | General | Normal
ImageData | Property Get |  | General | Normal
ImageDataLen | Property Get |  | General | Normal
ImageFormat | Property Get |  | General | Normal
Width | Property Get |  | General | Normal

ISDBImage overview


Interface ISDBImage

ISDBImage members by category

Properties

Name | Type | HelpString | Category | Frequency of use
ConvertFormat | Method |  | General | Normal
Height | Property Get |  | General | Normal
ImageData | Property Get |  | General | Normal
ImageDataLen | Property Get |  | General | Normal
ImageFormat | Property Get |  | General | Normal
Width | Property Get |  | General | Normal

ISDBImage overview


Interface ISDBImage

ISDBImage members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
ConvertFormat | Method |  | General | Normal
Height | Property Get |  | General | Normal
ImageData | Property Get |  | General | Normal
ImageDataLen | Property Get |  | General | Normal
ImageFormat | Property Get |  | General | Normal
Width | Property Get |  | General | Normal

ISDBImage overview


ISDBImage::ConvertFormat

Function ConvertFormat(NewWidth As Long, NewHeight As Long, NewFormat As String, Compression As Long, BackgroundColor As Long) As ISDBImage

Parameters

No | Name | Type | Optional | Default | Description
1 | NewWidth | Long | No | - | Width of the new image (in pixels).
2 | NewHeight | Long | No | - | Height of the new image (in pixels).
3 | NewFormat | String | No | - | Specification of the target format, can be: 'image/jpeg', 'image/png' or 'RGB565'.
4 | Compression | Long | No | - | JPEG compression value (0-100), higher value means better image/less compression.
5 | BackgroundColor | Long | No | - | -1..Convert to given dimensions, 0...Keep aspect ratio and fill by black color pixels to get requested dimensions

Method description

Converts this image to another format and/or dimensions.


ISDBImage::Height

Property Get Height As Long

No parameters

Property description

Height of image in pixels.


ISDBImage::ImageData

Property Get ImageData As Long

No parameters

Property description

Pointer to binary image data.


ISDBImage::ImageDataLen

Property Get ImageDataLen As Long

No parameters

Property description

Byte of binary image data.


ISDBImage::ImageFormat

Property Get ImageFormat As String

No parameters

Property description

Image format specification, can be: 'image/jpeg' 'image/png' 'image/x-bmp' 'image/gif'


ISDBImage::Width

Property Get Width As Long

No parameters

Property description

Width of image in pixels.


Coclass: SDBIniFile

Object for working with inifiles.


Interface: ISDBIniFile

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBIniFile

ISDBIniFile members

Properties

Name | Type | HelpString | Category | Frequency of use
BoolValue | Property Get/Let |  | General | Normal
DeleteKey | Method |  | General | Normal
DeleteSection | Method |  | General | Normal
IntValue | Property Get/Let |  | General | Normal
Keys | Property Get |  | General | Normal
Sections | Property Get |  | General | Normal
StringValue | Property Get/Let |  | General | Normal

ISDBIniFile overview


Interface ISDBIniFile

ISDBIniFile members by category

Properties

Name | Type | HelpString | Category | Frequency of use
BoolValue | Property Get/Let |  | General | Normal
DeleteKey | Method |  | General | Normal
DeleteSection | Method |  | General | Normal
IntValue | Property Get/Let |  | General | Normal
Keys | Property Get |  | General | Normal
Sections | Property Get |  | General | Normal
StringValue | Property Get/Let |  | General | Normal

ISDBIniFile overview


Interface ISDBIniFile

ISDBIniFile members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
BoolValue | Property Get/Let |  | General | Normal
DeleteKey | Method |  | General | Normal
DeleteSection | Method |  | General | Normal
IntValue | Property Get/Let |  | General | Normal
Keys | Property Get |  | General | Normal
Sections | Property Get |  | General | Normal
StringValue | Property Get/Let |  | General | Normal

ISDBIniFile overview


ISDBIniFile::BoolValue

Property Get/Let BoolValue(Section As String, Ident As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Section | String | No | - | Section of ini file.
2 | Ident | String | No | - | Identifier in the given section.

Property description

Reads/writes a boolean value.

Example code

value = inif.BoolValue["MySection","MyValue"


ISDBIniFile::DeleteKey

Sub DeleteKey(Section As String, Key As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | Section | String | No | - | A section where to find the key to delete.
2 | Key | String | No | - | A key to delete.

Method description

Deletes the given key in a given section.


ISDBIniFile::DeleteSection

Sub DeleteSection(Section As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | Section | String | No | - | A section to delete.

Method description

Deletes an entire section in ini file.


ISDBIniFile::IntValue

Property Get/Let IntValue(Section As String, Ident As String) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | Section | String | No | - | Section in ini file.
2 | Ident | String | No | - | Identifier in the given section.

Property description

Reads/writes an integer value.


ISDBIniFile::Keys

Property Get Keys(Section As String) As SDBStringList

Parameters

No | Name | Type | Optional | Default | Description
1 | Section | String | No | - | A section where to find all the keys.

Property description

Returns a list of all keys in a given section.


ISDBIniFile::Sections

Property Get Sections As SDBStringList

No parameters

Property description

Returns a list of all sections in ini file.


ISDBIniFile::StringValue

Property Get/Let StringValue(Section As String, Ident As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Section | String | No | - | Section to be accessed.
2 | Ident | String | No | - | Value to be read/written.

Property description

Reads or writes a string value in an ini file.


Coclass: SDBMedia

Object with media properties.


Interface: ISDBMedia

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBMedia

ISDBMedia members

Properties

Name | Type | HelpString | Category | Frequency of use
DriveLetter | Property Get |  | General | Normal
DriveType | Property Get/Let |  | General | Normal
ID | Property Get |  | General | Normal
MediaLabel | Property Get/Let |  | General | Normal
SerialNumber | Property Get/Let |  | General | Normal

ISDBMedia overview


Interface ISDBMedia

ISDBMedia members by category

Properties

Name | Type | HelpString | Category | Frequency of use
DriveLetter | Property Get |  | General | Normal
DriveType | Property Get/Let |  | General | Normal
ID | Property Get |  | General | Normal
MediaLabel | Property Get/Let |  | General | Normal
SerialNumber | Property Get/Let |  | General | Normal

ISDBMedia overview


Interface ISDBMedia

ISDBMedia members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
DriveLetter | Property Get |  | General | Normal
DriveType | Property Get/Let |  | General | Normal
ID | Property Get |  | General | Normal
MediaLabel | Property Get/Let |  | General | Normal
SerialNumber | Property Get/Let |  | General | Normal

ISDBMedia overview


ISDBMedia::DriveLetter

Property Get DriveLetter As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBMedia::DriveType

Property Get/Let DriveType As Long

No parameters

Property description

Type of the media: 2 - Removable 3 - Fixed 4 - Remote 5 - CDROM 12345 - Network


ISDBMedia::ID

Property Get ID As Long

No parameters

Property description

MM internal identification of media.


ISDBMedia::MediaLabel

Property Get/Let MediaLabel As String

No parameters

Property description

Label assigment to the media.


ISDBMedia::SerialNumber

Property Get/Let SerialNumber As Long

No parameters

Property description

Serial number of the media.


Coclass: SDBMenuItem

Object representing a single menu or toolbar item.


Interface: ISDBMenuItem

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBMenuItem

ISDBMenuItem members

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Enabled | Property Get/Let |  | General | Normal
Hint | Property Get/Let |  | General | Normal
Checked | Property Get/Let |  | General | Normal
IconIndex | Property Get/Let |  | General | Normal
OnClickFunc | Property Get/Let |  | General | Normal
ShortCut | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal
Visible | Property Get/Let |  | General | Normal

ISDBMenuItem overview


Interface ISDBMenuItem

ISDBMenuItem members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Enabled | Property Get/Let |  | General | Normal
Hint | Property Get/Let |  | General | Normal
Checked | Property Get/Let |  | General | Normal
IconIndex | Property Get/Let |  | General | Normal
OnClickFunc | Property Get/Let |  | General | Normal
ShortCut | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal
Visible | Property Get/Let |  | General | Normal

ISDBMenuItem overview


Interface ISDBMenuItem

ISDBMenuItem members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Enabled | Property Get/Let |  | General | Normal
Hint | Property Get/Let |  | General | Normal
Checked | Property Get/Let |  | General | Normal
IconIndex | Property Get/Let |  | General | Normal
OnClickFunc | Property Get/Let |  | General | Normal
ShortCut | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal
Visible | Property Get/Let |  | General | Normal

ISDBMenuItem overview


ISDBMenuItem::Caption

Property Get/Let Caption As String

No parameters

Property description

A string that is shown in the button.


ISDBMenuItem::Enabled

Property Get/Let Enabled As Boolean

No parameters

Property description

Controls enabled status of the item.


ISDBMenuItem::Hint

Property Get/Let Hint As String

No parameters

Property description

A tooltip to be shown when mouse is over the item.


ISDBMenuItem::Checked

Property Get/Let Checked As Boolean

No parameters

Property description

Controls whether the item is checked.


ISDBMenuItem::IconIndex

Property Get/Let IconIndex As Long

No parameters

Property description

Specifies which icon is used for this node (see Icons documentation for their list). You can use SDBApplication.RegisterIcon to add you own icons.


ISDBMenuItem::OnClickFunc

Property Get/Let OnClickFunc As String

No parameters

Property description

Name of the function that is called when the item is clicked. The function is expected to be in 'UseScript' file. There is one parameter passed to the function - this menu item (SDBMenuItem object).

Example code

'The function to be called can look like:

Sub OnMenuItemClick( Item)
  ' Some code here
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBMenuItem::ShortCut

Property Get/Let ShortCut As String

No parameters

Property description

String that specifies a shortcut assigned to the item, for example 'Ctrl+Alt+2'. Any standard character can be used, additional keys include: BkSp, Tab, Esc, Enter, Space, PgUp, PgDn, End, Home, Left, Up, Right, Down, Ins, Del and F1-F12. Any key could contain Ctrl+, Alt+ or Shift+ in front of it (and any combination of them).


ISDBMenuItem::UseScript

Property Get/Let UseScript As String

No parameters

Property description

Filename of a script where event functions are located.


ISDBMenuItem::Visible

Property Get/Let Visible As Boolean

No parameters

Property description

Sets or gets whether the item is currently visible.


Interface: ISDBMenuItemEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBMenuItemEvents

ISDBMenuItemEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal

ISDBMenuItemEvents overview


Interface ISDBMenuItemEvents

ISDBMenuItemEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal

ISDBMenuItemEvents overview


Interface ISDBMenuItemEvents

ISDBMenuItemEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal

ISDBMenuItemEvents overview


ISDBMenuItemEvents::OnClick

Sub OnClick(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |


Coclass: SDBPlayer

Object for controlling of player and Now Playing list.


Interface: ISDBPlayer

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBPlayer

ISDBPlayer members

Properties

Name | Type | HelpString | Category | Frequency of use
CurrentPlaylist | Property Get |  | General | Normal
CurrentSong | Property Get |  | General | Normal
CurrentSongIndex | Property Get/Let |  | General | Normal
CurrentSongLength | Property Get |  | General | Normal
CurrentSongList | Property Get |  | General | Normal
isAutoDJ | Property Get/Let |  | General | Normal
isPaused | Property Get |  | General | Normal
isPlaying | Property Get |  | General | Normal
isRepeat | Property Get/Let |  | General | Normal
isShuffle | Property Get/Let |  | General | Normal
Next | Method |  | General | Normal
Panning | Property Get/Let |  | General | Normal
Pause | Method |  | General | Normal
Play | Method |  | General | Normal
PlaybackTime | Property Get/Let |  | General | Normal
PlaylistAddTrack | Method |  | General | Normal
PlaylistAddTracks | Method |  | General | Normal
PlaylistClear | Method |  | General | Normal
PlaylistCount | Property Get |  | General | Normal
PlaylistDelete | Method |  | General | Normal
PlaylistItems | Property Get |  | General | Normal
PlaylistMoveTrack | Method |  | General | Normal
Previous | Method |  | General | Normal
Stop | Method |  | General | Normal
Volume | Property Get/Let |  | General | Normal

ISDBPlayer overview


Interface ISDBPlayer

ISDBPlayer members by category

Properties

Name | Type | HelpString | Category | Frequency of use
CurrentPlaylist | Property Get |  | General | Normal
CurrentSong | Property Get |  | General | Normal
CurrentSongIndex | Property Get/Let |  | General | Normal
CurrentSongLength | Property Get |  | General | Normal
CurrentSongList | Property Get |  | General | Normal
isAutoDJ | Property Get/Let |  | General | Normal
isPaused | Property Get |  | General | Normal
isPlaying | Property Get |  | General | Normal
isRepeat | Property Get/Let |  | General | Normal
isShuffle | Property Get/Let |  | General | Normal
Next | Method |  | General | Normal
Panning | Property Get/Let |  | General | Normal
Pause | Method |  | General | Normal
Play | Method |  | General | Normal
PlaybackTime | Property Get/Let |  | General | Normal
PlaylistAddTrack | Method |  | General | Normal
PlaylistAddTracks | Method |  | General | Normal
PlaylistClear | Method |  | General | Normal
PlaylistCount | Property Get |  | General | Normal
PlaylistDelete | Method |  | General | Normal
PlaylistItems | Property Get |  | General | Normal
PlaylistMoveTrack | Method |  | General | Normal
Previous | Method |  | General | Normal
Stop | Method |  | General | Normal
Volume | Property Get/Let |  | General | Normal

ISDBPlayer overview


Interface ISDBPlayer

ISDBPlayer members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
isAutoDJ | Property Get/Let |  | General | Normal
isRepeat | Property Get/Let |  | General | Normal
isShuffle | Property Get/Let |  | General | Normal
CurrentPlaylist | Property Get |  | General | Normal
CurrentSong | Property Get |  | General | Normal
CurrentSongIndex | Property Get/Let |  | General | Normal
CurrentSongLength | Property Get |  | General | Normal
CurrentSongList | Property Get |  | General | Normal
isPaused | Property Get |  | General | Normal
isPlaying | Property Get |  | General | Normal
Next | Method |  | General | Normal
Panning | Property Get/Let |  | General | Normal
Pause | Method |  | General | Normal
Play | Method |  | General | Normal
PlaybackTime | Property Get/Let |  | General | Normal
PlaylistAddTrack | Method |  | General | Normal
PlaylistAddTracks | Method |  | General | Normal
PlaylistClear | Method |  | General | Normal
PlaylistCount | Property Get |  | General | Normal
PlaylistDelete | Method |  | General | Normal
PlaylistItems | Property Get |  | General | Normal
PlaylistMoveTrack | Method |  | General | Normal
Previous | Method |  | General | Normal
Stop | Method |  | General | Normal
Volume | Property Get/Let |  | General | Normal

ISDBPlayer overview


ISDBPlayer::CurrentPlaylist

Property Get CurrentPlaylist As ISDBSongList

No parameters

Property description

Does the same as CurrentSongList.


ISDBPlayer::CurrentSong

Property Get CurrentSong As ISDBSongData

No parameters

Property description

The currently playing track.


ISDBPlayer::CurrentSongIndex

Property Get/Let CurrentSongIndex As Long

No parameters

Property description

Returns index of the currently playing track from Now Playing list.


ISDBPlayer::CurrentSongLength

Property Get CurrentSongLength As Long

No parameters

Property description

Length of the current track (in milliseconds).


ISDBPlayer::CurrentSongList

Property Get CurrentSongList As ISDBSongList

No parameters

Property description

Returns the list of tracks in Now Playing window.


ISDBPlayer::isAutoDJ

Property Get/Let isAutoDJ As Boolean

No parameters

Property description

You can get/set whether AutoDJ function of player is enabled.


ISDBPlayer::isPaused

Property Get isPaused As Boolean

No parameters

Property description

Is True if the playback is paused.


ISDBPlayer::isPlaying

Property Get isPlaying As Boolean

No parameters

Property description

Is True if there is a track playing.


ISDBPlayer::isRepeat

Property Get/Let isRepeat As Boolean

No parameters

Property description

You can get/set whether Repeat function of player is enabled.


ISDBPlayer::isShuffle

Property Get/Let isShuffle As Boolean

No parameters

Property description

You can get/set whether Shuffle function of player is enabled.


ISDBPlayer::Next

Sub Next

No parameters

Method description

Plays the next track

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBPlayer::Panning

Property Get/Let Panning As Double

No parameters

Property description

Gets/Sets player balance (-1..1).


ISDBPlayer::Pause

Sub Pause

No parameters

Method description

Pauses playback.


ISDBPlayer::Play

Sub Play

No parameters

Method description

Starts playback

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBPlayer::PlaybackTime

Property Get/Let PlaybackTime As Long

No parameters

Property description

How many milliseconds of the current track were already played.


ISDBPlayer::PlaylistAddTrack

Sub PlaylistAddTrack(Song As ISDBSongData)

Parameters

No | Name | Type | Optional | Default | Description
1 | Song | ISDBSongData | No | - | Track to be added.

Method description

Adds new track to Now Playing list.


ISDBPlayer::PlaylistAddTracks

Sub PlaylistAddTracks(Songs As ISDBSongList)

Parameters

No | Name | Type | Optional | Default | Description
1 | Songs | ISDBSongList | No | - | List of tracks to be added.

Method description

Adds a list of tracks to Now Playing list.


ISDBPlayer::PlaylistClear

Sub PlaylistClear

No parameters

Method description

Clears Now Playing list.


ISDBPlayer::PlaylistCount

Property Get PlaylistCount As Long

No parameters

Property description

Number of tracks in Now Playing list.


ISDBPlayer::PlaylistDelete

Sub PlaylistDelete(Index As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the track to be removed.

Method description

Removes a track from Now Playing.


ISDBPlayer::PlaylistItems

Property Get PlaylistItems(Index As Long) As ISDBSongData

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the track to be returned.

Property description

Returns a track (SDBSongData object) from Now Playing indexed by Index.


ISDBPlayer::PlaylistMoveTrack

Sub PlaylistMoveTrack(Index As Long, NewIndex As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of track to be moved.
2 | NewIndex | Long | No | - | Where to move the track.

Method description

Moves track to a new position in Now Playing.


ISDBPlayer::Previous

Sub Previous

No parameters

Method description

Goes to the previous track.


ISDBPlayer::Stop

Sub Stop

No parameters

Method description

Stops playback.


ISDBPlayer::Volume

Property Get/Let Volume As Double

No parameters

Property description

Gets/Sets player volume (0..1)


Coclass: SDBPlaylist

Object for playlist manipulation.


Interface: ISDBPlaylist

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBPlaylist

ISDBPlaylist members

Properties

Name | Type | HelpString | Category | Frequency of use
AddTrack | Method |  | General | Normal
AddTrackById | Method |  | General | Normal
AddTracks | Method |  | General | Normal
Clear | Method |  | General | Normal
CreateChildPlaylist | Method |  | General | Normal
Delete | Method |  | General | Normal
ChildPlaylists | Property Get |  | General | Normal
ID | Property Get |  | General | Normal
isAutoplaylist | Property Get |  | General | Normal
MoveTrack | Method |  | General | Normal
RemoveTrack | Method |  | General | Normal
Title | Property Get/Let |  | General | Normal
Tracks | Property Get |  | General | Normal

ISDBPlaylist overview


Interface ISDBPlaylist

ISDBPlaylist members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AddTrack | Method |  | General | Normal
AddTrackById | Method |  | General | Normal
AddTracks | Method |  | General | Normal
Clear | Method |  | General | Normal
CreateChildPlaylist | Method |  | General | Normal
Delete | Method |  | General | Normal
ChildPlaylists | Property Get |  | General | Normal
ID | Property Get |  | General | Normal
isAutoplaylist | Property Get |  | General | Normal
MoveTrack | Method |  | General | Normal
RemoveTrack | Method |  | General | Normal
Title | Property Get/Let |  | General | Normal
Tracks | Property Get |  | General | Normal

ISDBPlaylist overview


Interface ISDBPlaylist

ISDBPlaylist members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
AddTrackById | Method |  | General | Normal
AddTracks | Method |  | General | Normal
Clear | Method |  | General | Normal
CreateChildPlaylist | Method |  | General | Normal
Delete | Method |  | General | Normal
ChildPlaylists | Property Get |  | General | Normal
ID | Property Get |  | General | Normal
isAutoplaylist | Property Get |  | General | Normal
MoveTrack | Method |  | General | Normal
RemoveTrack | Method |  | General | Normal
Title | Property Get/Let |  | General | Normal
Tracks | Property Get |  | General | Normal
AddTrack | Method |  | General | Normal

ISDBPlaylist overview


ISDBPlaylist::AddTrack

Sub AddTrack(Track As ISDBSongData)

Parameters

No | Name | Type | Optional | Default | Description
1 | Track | ISDBSongData | No | - | Track to be added (SDBSongData object)

Method description

Adds track to the playlist.


ISDBPlaylist::AddTrackById

Sub AddTrackById(Track As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Track | Long | No | - |

Method description

Add a track specified by its ID to the playlsit.


ISDBPlaylist::AddTracks

Sub AddTracks(Tracks As ISDBSongList)

Parameters

No | Name | Type | Optional | Default | Description
1 | Tracks | ISDBSongList | No | - | Tracks to be added (SDBSongList object)

Method description

Adds tracks to the playlist.


ISDBPlaylist::Clear

Sub Clear

No parameters

Method description

Removes all tracks from this playlist.


ISDBPlaylist::CreateChildPlaylist

Function CreateChildPlaylist(Title As String) As Object

Parameters

No | Name | Type | Optional | Default | Description
1 | Title | String | No | - | Title of the playlist to be created.

Method description

Creates a new sub-playlists of this playlist with the given Title. Reference to the newly created playlist is returned.


ISDBPlaylist::Delete

Sub Delete

No parameters

Method description

Completely removes this playlist and its subplaylists from the Library. Be careful with this operation, there's no further confirmation and all is deleted!


ISDBPlaylist::ChildPlaylists

Property Get ChildPlaylists As ISDBPlaylists

No parameters

Property description

Returns a list of all sub-playlists of this playlist.


ISDBPlaylist::ID

Property Get ID As Long

No parameters

Property description

ID of this playlist

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBPlaylist::isAutoplaylist

Property Get isAutoplaylist As Boolean

No parameters

Property description

Is TRUE when this playlist is an auto-playlist.


ISDBPlaylist::MoveTrack

Sub MoveTrack(Track As ISDBSongData, BeforeTrack As ISDBSongData)

Parameters

No | Name | Type | Optional | Default | Description
1 | Track | ISDBSongData | No | - | Track to move (SDBSongData object)
2 | BeforeTrack | ISDBSongData | No | - | Move in front of this track (use NULL to move to the last position) (SDBSongData object)

Method description

Changes track position in a playlist.


ISDBPlaylist::RemoveTrack

Sub RemoveTrack(Track As ISDBSongData)

Parameters

No | Name | Type | Optional | Default | Description
1 | Track | ISDBSongData | No | - | Track to be removed

Method description

Removes a track from this playlist.


ISDBPlaylist::Title

Property Get/Let Title As String

No parameters

Property description

Name of this playlist.


ISDBPlaylist::Tracks

Property Get Tracks As ISDBSongList

No parameters

Property description

Returns list of tracks in this playlist.


Coclass: SDBPlaylists

List of plyalists.


Interface: ISDBPlaylists

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBPlaylists

ISDBPlaylists members

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal

ISDBPlaylists overview


Interface ISDBPlaylists

ISDBPlaylists members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal

ISDBPlaylists overview


Interface ISDBPlaylists

ISDBPlaylists members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Count | Property Get |  | General | Normal
Item | Property Get |  | General | Normal

ISDBPlaylists overview


ISDBPlaylists::Count

Property Get Count As Long

No parameters

Property description

Number of playlists in this list.


ISDBPlaylists::Item

Property Get Item(Index As Long) As ISDBPlaylist

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the playlist

Property description

Returns a specific playlist (SDBPlaylist object) indexed by Index parameter.


Coclass: SDBProgress

Progress bar handling methods.


Interface: ISDBProgress

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBProgress

ISDBProgress members

Properties

Name | Type | HelpString | Category | Frequency of use
Increase | Method |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
Terminate | Property Get |  | General | Normal
Text | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBProgress overview


Interface ISDBProgress

ISDBProgress members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Increase | Method |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
Terminate | Property Get |  | General | Normal
Text | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBProgress overview


Interface ISDBProgress

ISDBProgress members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Increase | Method |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
Terminate | Property Get |  | General | Normal
Text | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBProgress overview


ISDBProgress::Increase

Sub Increase

No parameters

Method description

Increases Value of the progress bar by one. It is equivalent to Value=Value+1.


ISDBProgress::MaxValue

Property Get/Let MaxValue As Long

No parameters

Property description

Sets the maximum value of the progress (minimum is always zero).


ISDBProgress::Terminate

Property Get Terminate As Boolean

No parameters

Property description

Returns TRUE when script processing should terminate (e.g. the thread of this script was terminated by user). The script code should periodacally check this property (mainly in loops) and terminate its processing as soon as possible in case the property value is TRUE.

Example code

for i=0 to list.count-1
  ' ... some code here

  if Progress.Terminate then
    Exit For
  end if
next


ISDBProgress::Text

Property Get/Let Text As String

No parameters

Property description

Gets or sets the text that is shown on the progress bar.


ISDBProgress::Value

Property Get/Let Value As Long

No parameters

Property description

Gets or sets the current value (that should be between 0 and MaxValue).


Coclass: SDBRegistry

Object for manipulation of registry.


Interface: ISDBRegistry

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBRegistry

ISDBRegistry members

Properties

Name | Type | HelpString | Category | Frequency of use
BoolValue | Property Get/Let |  | General | Normal
CloseKey | Method |  | General | Normal
IntValue | Property Get/Let |  | General | Normal
KeyExists | Property Get |  | General | Normal
OpenKey | Method |  | General | Normal
StringValue | Property Get/Let |  | General | Normal
ValueExists | Property Get |  | General | Normal

ISDBRegistry overview


Interface ISDBRegistry

ISDBRegistry members by category

Properties

Name | Type | HelpString | Category | Frequency of use
BoolValue | Property Get/Let |  | General | Normal
CloseKey | Method |  | General | Normal
IntValue | Property Get/Let |  | General | Normal
KeyExists | Property Get |  | General | Normal
OpenKey | Method |  | General | Normal
StringValue | Property Get/Let |  | General | Normal
ValueExists | Property Get |  | General | Normal

ISDBRegistry overview


Interface ISDBRegistry

ISDBRegistry members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
BoolValue | Property Get/Let |  | General | Normal
CloseKey | Method |  | General | Normal
IntValue | Property Get/Let |  | General | Normal
KeyExists | Property Get |  | General | Normal
OpenKey | Method |  | General | Normal
StringValue | Property Get/Let |  | General | Normal
ValueExists | Property Get |  | General | Normal

ISDBRegistry overview


ISDBRegistry::BoolValue

Property Get/Let BoolValue(Name As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of Value to be returned.

Property description

Returns a value specified by 'Name' as a boolean.


ISDBRegistry::CloseKey

Sub CloseKey

No parameters

Method description

Closes previously openned key.


ISDBRegistry::IntValue

Property Get/Let IntValue(Name As String) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of Value to be returned.

Property description

Returns a value specified by 'Name' as an integer.


ISDBRegistry::KeyExists

Property Get KeyExists(Name As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of key to be tested.

Property description

Checks if given key exists.


ISDBRegistry::OpenKey

Function OpenKey(Key As String, CanCreate As Boolean) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Key | String | No | - | Key to be openned.
2 | CanCreate | Boolean | No | - | Whether the key can be created in case it doesn't exist.

Method description

Opens a key so that it can be subsequently used to get/set its values. Key can either contain a full path starting with '\' (e.g. \Software\Microsoft\Windows\) or only part of path (e.g. 'My Value'). In the second case \Software\Songs-DB\Scripts\ is used as a base key.

Example code

Set Regs = SDB.Registry
If Regs.OpenKey( "Some key", False) Then
  MyValue = Regs.StringValue("Some value")
  Regs.CloseKey
End If

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBRegistry::StringValue

Property Get/Let StringValue(Name As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of Value to be returned.

Property description

Returns a value specified by 'Name' as a string.


ISDBRegistry::ValueExists

Property Get ValueExists(Name As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Name | String | No | - | Name of Value to be tested.

Property description

Returns 'True' if value specified by 'Name' exists in the current key.


Coclass: SDBScriptControl

Object for controlling of script related functionality.


Interface: ISDBScriptControl

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBScriptControl

ISDBScriptControl members

Properties

Name | Type | HelpString | Category | Frequency of use
Include | Method |  | General | Normal
RegisterEvent | Method |  | General | Normal
ScriptPath | Property Get |  | General | Normal
Terminate | Property Get |  | General | Normal
UnRegisterAllEvents | Method |  | General | Normal
UnRegisterEvents | Method |  | General | Normal

ISDBScriptControl overview


Interface ISDBScriptControl

ISDBScriptControl members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Include | Method |  | General | Normal
RegisterEvent | Method |  | General | Normal
ScriptPath | Property Get |  | General | Normal
Terminate | Property Get |  | General | Normal
UnRegisterAllEvents | Method |  | General | Normal
UnRegisterEvents | Method |  | General | Normal

ISDBScriptControl overview


Interface ISDBScriptControl

ISDBScriptControl members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Include | Method |  | General | Normal
RegisterEvent | Method |  | General | Normal
ScriptPath | Property Get |  | General | Normal
Terminate | Property Get |  | General | Normal
UnRegisterAllEvents | Method |  | General | Normal
UnRegisterEvents | Method |  | General | Normal

ISDBScriptControl overview


ISDBScriptControl::Include

Sub Include(ScriptPath As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | ScriptPath | String | No | - | Script file to be included (path can be relative to the Scripts folder).

Method description

Include given script in execution of the current script.


ISDBScriptControl::RegisterEvent

Sub RegisterEvent(ObjectVar As Object, EventName As String, HandlerName As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | ObjectVar | Object | No | - | Object of the event
2 | EventName | String | No | - | Event name (string)
3 | HandlerName | String | No | - | Procedure name of the handler (string)

Method description

Registers COM object event to be handled by a script.

Example code

Script.RegisterEvent SDB, "OnShutdown", "ShutdownHandler"

Sub ShutdownHandler
  ' Event code goes here....
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBScriptControl::ScriptPath

Property Get ScriptPath As String

No parameters

Property description

Returns the full path of the script that is just running.


ISDBScriptControl::Terminate

Property Get Terminate As Boolean

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBScriptControl::UnRegisterAllEvents

Sub UnRegisterAllEvents

No parameters

Method description

Unregisters all event handlers created by this script.


ISDBScriptControl::UnRegisterEvents

Sub UnRegisterEvents(ObjectVar As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | ObjectVar | Object | No | - | Object whose events should be disconnected.

Method description

Unregisters all event handlers of the fiven object created by this script.


Coclass: SDBSongData

Object with all properties of a track.


Interface: ISDBSongData

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBSongData

ISDBSongData members

Properties

Name | Type | HelpString | Category | Frequency of use
Album | Property Get |  | General | Normal
AlbumArt | Property Get |  | General | Normal
AlbumArtistName | Property Get/Let |  | General | Normal
AlbumName | Property Get/Let |  | General | Normal
Artist | Property Get |  | General | Normal
ArtistName | Property Get/Let |  | General | Normal
Author | Property Get/Let |  | General | Normal
Band | Property Get/Let |  | General | Normal
Bitrate | Property Get/Let |  | General | Normal
BPM | Property Get/Let |  | General | Normal
Cached | Property Get/Let |  | General | Normal
CachedPath | Property Get |  | General | Normal
Comment | Property Get/Let |  | General | Normal
Conductor | Property Get/Let |  | General | Normal
Copyright | Property Get/Let |  | General | Normal
Custom1 | Property Get/Let |  | General | Normal
Custom2 | Property Get/Let |  | General | Normal
Custom3 | Property Get/Let |  | General | Normal
DateAdded | Property Get/Let |  | General | Normal
Encoder | Property Get/Let |  | General | Normal
FileLength | Property Get/Let |  | General | Normal
FileModified | Property Get/Let |  | General | Normal
Genre | Property Get/Let |  | General | Normal
GetCopy | Method |  | General | Normal
Channels | Property Get/Let |  | General | Normal
ID | Property Get/Let |  | General | Normal
InvolvedPeople | Property Get/Let |  | General | Normal
IsntInDB | Property Get/Let |  | General | Normal
ISRC | Property Get/Let |  | General | Normal
LastPlayed | Property Get/Let |  | General | Normal
Leveling | Property Get/Let |  | General | Normal
Lyricist | Property Get/Let |  | General | Normal
Lyrics | Property Get/Let |  | General | Normal
Media | Property Get |  | General | Normal
MediaLabel | Property Get |  | General | Normal
MetadataFromFilename | Method |  | General | Normal
Mood | Property Get/Let |  | General | Normal
MusicComposer | Property Get/Let |  | General | Normal
Occasion | Property Get/Let |  | General | Normal
OriginalArtist | Property Get/Let |  | General | Normal
OriginalLyricist | Property Get/Let |  | General | Normal
OriginalTitle | Property Get/Let |  | General | Normal
OriginalYear | Property Get/Let |  | General | Normal
ParseText | Method |  | General | Normal
Path | Property Get/Let |  | General | Normal
PeakValue | Property Get/Let |  | General | Normal
PlayCounter | Property Get/Let |  | General | Normal
PlaylistOrder | Property Get/Let |  | General | Normal
Preview | Property Get |  | General | Normal
PreviewPath | Property Get |  | General | Normal
Publisher | Property Get/Let |  | General | Normal
Quality | Property Get/Let |  | General | Normal
Rating | Property Get/Let |  | General | Normal
RatingString | Property Get/Let |  | General | Normal
ReadTags | Method |  | General | Normal
RenameByMask | Method |  | General | Normal
SampleRate | Property Get/Let |  | General | Normal
SongID | Property Get |  | General | Normal
SongLength | Property Get/Let |  | General | Normal
SongLengthString | Property Get |  | General | Normal
Tempo | Property Get/Let |  | General | Normal
Title | Property Get/Let |  | General | Normal
TrackOrder | Property Get/Let |  | General | Normal
UpdateAlbum | Method |  | General | Normal
UpdateArtist | Method |  | General | Normal
UpdateDB | Method |  | General | Normal
VBR | Property Get/Let |  | General | Normal
WriteTags | Method |  | General | Normal
Year | Property Get/Let |  | General | Normal

ISDBSongData overview


Interface ISDBSongData

ISDBSongData members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Album | Property Get |  | General | Normal
AlbumArt | Property Get |  | General | Normal
AlbumArtistName | Property Get/Let |  | General | Normal
AlbumName | Property Get/Let |  | General | Normal
Artist | Property Get |  | General | Normal
ArtistName | Property Get/Let |  | General | Normal
Author | Property Get/Let |  | General | Normal
Band | Property Get/Let |  | General | Normal
Bitrate | Property Get/Let |  | General | Normal
BPM | Property Get/Let |  | General | Normal
Cached | Property Get/Let |  | General | Normal
CachedPath | Property Get |  | General | Normal
Comment | Property Get/Let |  | General | Normal
Conductor | Property Get/Let |  | General | Normal
Copyright | Property Get/Let |  | General | Normal
Custom1 | Property Get/Let |  | General | Normal
Custom2 | Property Get/Let |  | General | Normal
Custom3 | Property Get/Let |  | General | Normal
DateAdded | Property Get/Let |  | General | Normal
Encoder | Property Get/Let |  | General | Normal
FileLength | Property Get/Let |  | General | Normal
FileModified | Property Get/Let |  | General | Normal
Genre | Property Get/Let |  | General | Normal
GetCopy | Method |  | General | Normal
Channels | Property Get/Let |  | General | Normal
ID | Property Get/Let |  | General | Normal
InvolvedPeople | Property Get/Let |  | General | Normal
IsntInDB | Property Get/Let |  | General | Normal
ISRC | Property Get/Let |  | General | Normal
LastPlayed | Property Get/Let |  | General | Normal
Leveling | Property Get/Let |  | General | Normal
Lyricist | Property Get/Let |  | General | Normal
Lyrics | Property Get/Let |  | General | Normal
Media | Property Get |  | General | Normal
MediaLabel | Property Get |  | General | Normal
MetadataFromFilename | Method |  | General | Normal
Mood | Property Get/Let |  | General | Normal
MusicComposer | Property Get/Let |  | General | Normal
Occasion | Property Get/Let |  | General | Normal
OriginalArtist | Property Get/Let |  | General | Normal
OriginalLyricist | Property Get/Let |  | General | Normal
OriginalTitle | Property Get/Let |  | General | Normal
OriginalYear | Property Get/Let |  | General | Normal
ParseText | Method |  | General | Normal
Path | Property Get/Let |  | General | Normal
PeakValue | Property Get/Let |  | General | Normal
PlayCounter | Property Get/Let |  | General | Normal
PlaylistOrder | Property Get/Let |  | General | Normal
Preview | Property Get |  | General | Normal
PreviewPath | Property Get |  | General | Normal
Publisher | Property Get/Let |  | General | Normal
Quality | Property Get/Let |  | General | Normal
Rating | Property Get/Let |  | General | Normal
RatingString | Property Get/Let |  | General | Normal
ReadTags | Method |  | General | Normal
RenameByMask | Method |  | General | Normal
SampleRate | Property Get/Let |  | General | Normal
SongID | Property Get |  | General | Normal
SongLength | Property Get/Let |  | General | Normal
SongLengthString | Property Get |  | General | Normal
Tempo | Property Get/Let |  | General | Normal
Title | Property Get/Let |  | General | Normal
TrackOrder | Property Get/Let |  | General | Normal
UpdateAlbum | Method |  | General | Normal
UpdateArtist | Method |  | General | Normal
UpdateDB | Method |  | General | Normal
VBR | Property Get/Let |  | General | Normal
WriteTags | Method |  | General | Normal
Year | Property Get/Let |  | General | Normal

ISDBSongData overview


Interface ISDBSongData

ISDBSongData members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
IsntInDB | Property Get/Let |  | General | Normal
Occasion | Property Get/Let |  | General | Normal
OriginalArtist | Property Get/Let |  | General | Normal
ParseText | Method |  | General | Normal
PlaylistOrder | Property Get/Let |  | General | Normal
PreviewPath | Property Get |  | General | Normal
Publisher | Property Get/Let |  | General | Normal
Quality | Property Get/Let |  | General | Normal
SampleRate | Property Get/Let |  | General | Normal
Album | Property Get |  | General | Normal
AlbumArt | Property Get |  | General | Normal
AlbumArtistName | Property Get/Let |  | General | Normal
AlbumName | Property Get/Let |  | General | Normal
Artist | Property Get |  | General | Normal
ArtistName | Property Get/Let |  | General | Normal
Author | Property Get/Let |  | General | Normal
Band | Property Get/Let |  | General | Normal
Bitrate | Property Get/Let |  | General | Normal
BPM | Property Get/Let |  | General | Normal
Cached | Property Get/Let |  | General | Normal
CachedPath | Property Get |  | General | Normal
Comment | Property Get/Let |  | General | Normal
Conductor | Property Get/Let |  | General | Normal
Copyright | Property Get/Let |  | General | Normal
Custom1 | Property Get/Let |  | General | Normal
Custom2 | Property Get/Let |  | General | Normal
Custom3 | Property Get/Let |  | General | Normal
DateAdded | Property Get/Let |  | General | Normal
Encoder | Property Get/Let |  | General | Normal
FileLength | Property Get/Let |  | General | Normal
FileModified | Property Get/Let |  | General | Normal
Genre | Property Get/Let |  | General | Normal
GetCopy | Method |  | General | Normal
Channels | Property Get/Let |  | General | Normal
ID | Property Get/Let |  | General | Normal
InvolvedPeople | Property Get/Let |  | General | Normal
ISRC | Property Get/Let |  | General | Normal
LastPlayed | Property Get/Let |  | General | Normal
Leveling | Property Get/Let |  | General | Normal
Lyricist | Property Get/Let |  | General | Normal
Lyrics | Property Get/Let |  | General | Normal
Media | Property Get |  | General | Normal
MediaLabel | Property Get |  | General | Normal
MetadataFromFilename | Method |  | General | Normal
Mood | Property Get/Let |  | General | Normal
MusicComposer | Property Get/Let |  | General | Normal
OriginalLyricist | Property Get/Let |  | General | Normal
OriginalTitle | Property Get/Let |  | General | Normal
OriginalYear | Property Get/Let |  | General | Normal
Path | Property Get/Let |  | General | Normal
PeakValue | Property Get/Let |  | General | Normal
PlayCounter | Property Get/Let |  | General | Normal
Preview | Property Get |  | General | Normal
Rating | Property Get/Let |  | General | Normal
RatingString | Property Get/Let |  | General | Normal
ReadTags | Method |  | General | Normal
RenameByMask | Method |  | General | Normal
SongID | Property Get |  | General | Normal
SongLength | Property Get/Let |  | General | Normal
SongLengthString | Property Get |  | General | Normal
Tempo | Property Get/Let |  | General | Normal
Title | Property Get/Let |  | General | Normal
TrackOrder | Property Get/Let |  | General | Normal
UpdateAlbum | Method |  | General | Normal
UpdateArtist | Method |  | General | Normal
UpdateDB | Method |  | General | Normal
VBR | Property Get/Let |  | General | Normal
WriteTags | Method |  | General | Normal
Year | Property Get/Let |  | General | Normal

ISDBSongData overview


ISDBSongData::Album

Property Get Album As ISDBAlbum

No parameters

Property description

Returns SDBAlbum object of this track.


ISDBSongData::AlbumArt

Property Get AlbumArt As SDBAlbumArtList

No parameters

Property description

Returns list of album art items associated with this track.


ISDBSongData::AlbumArtistName

Property Get/Let AlbumArtistName As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::AlbumName

Property Get/Let AlbumName As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Artist

Property Get Artist As ISDBArtist

No parameters

Property description

Returns SDBArtist object of this track.


ISDBSongData::ArtistName

Property Get/Let ArtistName As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Author

Property Get/Let Author As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Band

Property Get/Let Band As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Bitrate

Property Get/Let Bitrate As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::BPM

Property Get/Let BPM As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Cached

Property Get/Let Cached As EnumCacheStatus

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::CachedPath

Property Get CachedPath As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Comment

Property Get/Let Comment As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Conductor

Property Get/Let Conductor As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Copyright

Property Get/Let Copyright As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Custom1

Property Get/Let Custom1 As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Custom2

Property Get/Let Custom2 As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Custom3

Property Get/Let Custom3 As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::DateAdded

Property Get/Let DateAdded As Date

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Encoder

Property Get/Let Encoder As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::FileLength

Property Get/Let FileLength As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::FileModified

Property Get/Let FileModified As Date

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Genre

Property Get/Let Genre As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::GetCopy

Function GetCopy As Object

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Channels

Property Get/Let Channels As EnumChannels

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::ID

Property Get/Let ID As Long

No parameters

Property description

Internal identification number of the track in the Library.


ISDBSongData::InvolvedPeople

Property Get/Let InvolvedPeople As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::IsntInDB

Property Get/Let IsntInDB As Boolean

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::ISRC

Property Get/Let ISRC As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::LastPlayed

Property Get/Let LastPlayed As Date

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Leveling

Property Get/Let Leveling As Double

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Lyricist

Property Get/Let Lyricist As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Lyrics

Property Get/Let Lyrics As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Media

Property Get Media As ISDBMedia

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::MediaLabel

Property Get MediaLabel As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::MetadataFromFilename

Sub MetadataFromFilename

No parameters

Method description

Tries to parse filename to track properties.


ISDBSongData::Mood

Property Get/Let Mood As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::MusicComposer

Property Get/Let MusicComposer As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Occasion

Property Get/Let Occasion As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::OriginalArtist

Property Get/Let OriginalArtist As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::OriginalLyricist

Property Get/Let OriginalLyricist As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::OriginalTitle

Property Get/Let OriginalTitle As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::OriginalYear

Property Get/Let OriginalYear As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::ParseText

Function ParseText(TextData As String, Mask As String) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | TextData | String | No | - | Text to be parsed.
2 | Mask | String | No | - | Mask that specifies how to parse the text. It must be in a compiled form, use Mask2UFText and UFText2Mask functions in order to convert between the internal and user friendly forms of masks.

Method description

A string is parsed into fields of SDBSongData according to the given mask.

Example code

SD.ParseText( "Abba - Waterloo", "%A - %S")


ISDBSongData::Path

Property Get/Let Path As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::PeakValue

Property Get/Let PeakValue As Double

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::PlayCounter

Property Get/Let PlayCounter As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::PlaylistOrder

Property Get/Let PlaylistOrder As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Preview

Property Get Preview As EnumPreview

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::PreviewPath

Property Get PreviewPath As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Publisher

Property Get/Let Publisher As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Quality

Property Get/Let Quality As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Rating

Property Get/Let Rating As Long

No parameters

Property description

Rating of the track (-1=Unknown, 0..100).


ISDBSongData::RatingString

Property Get/Let RatingString As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::ReadTags

Function ReadTags As Boolean

No parameters

Method description

Reads tags from file.


ISDBSongData::RenameByMask

Function RenameByMask(Mask As String) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Mask | String | No | - | Mask that specifies how to rename the track's filename.

Method description

Renames track using Mask.


ISDBSongData::SampleRate

Property Get/Let SampleRate As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::SongID

Property Get SongID As Long

No parameters

Property description

For internal use only.


ISDBSongData::SongLength

Property Get/Let SongLength As Long

No parameters

Property description

Length of track in milliseconds.


ISDBSongData::SongLengthString

Property Get SongLengthString As String

No parameters

Property description

Length of track as a formatted string.


ISDBSongData::Tempo

Property Get/Let Tempo As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::Title

Property Get/Let Title As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::TrackOrder

Property Get/Let TrackOrder As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBSongData::UpdateAlbum

Sub UpdateAlbum

No parameters

Method description

Normally it isn't necessary to call this method because album is updated in Library after UpdateDB. However, you need to call this method in case you changed only the capitalization of the album name or album artist.


ISDBSongData::UpdateArtist

Sub UpdateArtist

No parameters

Method description

Normally it isn't necessary to call this method because artist is updated in Library after UpdateDB. However, you need to call this method in case you changed only the capitalization of the artist name.


ISDBSongData::UpdateDB

Sub UpdateDB

No parameters

Method description

Writes changes that were made to track's properties back to the Library.


ISDBSongData::VBR

Property Get/Let VBR As Boolean

No parameters

Property description

Whether track is encoded with Variable Bitrate.


ISDBSongData::WriteTags

Sub WriteTags

No parameters

Method description

Updates tags of file according to properties of the track.


ISDBSongData::Year

Property Get/Let Year As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


Coclass: SDBSongIterator

Object for iteration through a set of tracks.


Interface: ISDBSongIterator

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBSongIterator

ISDBSongIterator members

Properties

Name | Type | HelpString | Category | Frequency of use
EOF | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Next | Method |  | General | Normal

ISDBSongIterator overview


Interface ISDBSongIterator

ISDBSongIterator members by category

Properties

Name | Type | HelpString | Category | Frequency of use
EOF | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Next | Method |  | General | Normal

ISDBSongIterator overview


Interface ISDBSongIterator

ISDBSongIterator members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
EOF | Property Get |  | General | Normal
Item | Property Get |  | General | Normal
Next | Method |  | General | Normal

ISDBSongIterator overview


ISDBSongIterator::EOF

Property Get EOF As Boolean

No parameters

Property description

Is TRUE when there are no more records.


ISDBSongIterator::Item

Property Get Item As ISDBSongData

No parameters

Property description

Returns a track of the list. The result is SDBSongData object.


ISDBSongIterator::Next

Sub Next

No parameters

Method description

Plays the next track

(C) 2000-2005 Ventis Media Inc. All rights reserved


Coclass: SDBSongList

List of tracks.


Interface: ISDBSongList

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBSongList

ISDBSongList members

Properties

Name | Type | HelpString | Category | Frequency of use
Add | Method |  | General | Normal
Albums | Property Get |  | General | Normal
Artists | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
UpdateAll | Method |  | General | Normal

ISDBSongList overview


Interface ISDBSongList

ISDBSongList members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Add | Method |  | General | Normal
Albums | Property Get |  | General | Normal
Artists | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
UpdateAll | Method |  | General | Normal

ISDBSongList overview


Interface ISDBSongList

ISDBSongList members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Add | Method |  | General | Normal
Albums | Property Get |  | General | Normal
Artists | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
UpdateAll | Method |  | General | Normal

ISDBSongList overview


ISDBSongList::Add

Sub Add(Song As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Song | Object | No | - | A track to be added to the list.

Method description

Adds a track to this list.


ISDBSongList::Albums

Property Get Albums As ISDBAlbums

No parameters

Property description

Returns a list of albums that are present in the list.


ISDBSongList::Artists

Property Get Artists As ISDBArtists

No parameters

Property description

Returns a list of artists that are present in the list.


ISDBSongList::Count

Property Get Count As Long

No parameters

Property description

Number of tracks in the list.


ISDBSongList::Delete

Sub Delete(Index As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of track to remove from the list

Method description

Removes specified track from the list.


ISDBSongList::Item

Property Get/Let Item(Index As Long) As ISDBSongData

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the track to be returned (0..Count-1).

Property description

Returns/sets a track of the list. The result is SDBSongData object.


ISDBSongList::UpdateAll

Sub UpdateAll

No parameters

Method description

For all tracks in the list updates DB entries, i.e. writes any modifications back to DB. Also all tags are updated accordingly, but only if the option is turned on if Options dialog (by default it is).


Coclass: SDBStringList

Object handling of list of strings.


Interface: ISDBStringList

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBStringList

ISDBStringList members

Properties

Name | Type | HelpString | Category | Frequency of use
Add | Method |  | General | Normal
Copy | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
Sort | Method |  | General | Normal

ISDBStringList overview


Interface ISDBStringList

ISDBStringList members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Add | Method |  | General | Normal
Copy | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
Sort | Method |  | General | Normal

ISDBStringList overview


Interface ISDBStringList

ISDBStringList members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Add | Method |  | General | Normal
Copy | Property Get |  | General | Normal
Count | Property Get |  | General | Normal
Delete | Method |  | General | Normal
Item | Property Get/Let |  | General | Normal
Sort | Method |  | General | Normal

ISDBStringList overview


ISDBStringList::Add

Sub Add(Value As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | Value | String | No | - | String to add

Method description

Adds a string to the list.


ISDBStringList::Copy

Property Get Copy As SDBStringList

No parameters

Property description

Returns a copy of this list.


ISDBStringList::Count

Property Get Count As Long

No parameters

Property description

Returns the number of items in this list.


ISDBStringList::Delete

Sub Delete(Index As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the string to remove

Method description

Removes string given by an index.


ISDBStringList::Item

Property Get/Let Item(Index As Long) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of the string

Property description

Gets or sets string given by index.


ISDBStringList::Sort

Sub Sort

No parameters

Method description

Sorts the list alphabetically.


Coclass: SDBTextFile

Object representings an open file.


Interface: ISDBTextFile

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTextFile

ISDBTextFile members

Properties

Name | Type | HelpString | Category | Frequency of use
Close | Method |  | General | Normal
Write | Method |  | General | Normal
WriteData | Method |  | General | Normal
WriteLine | Method |  | General | Normal

ISDBTextFile overview


Interface ISDBTextFile

ISDBTextFile members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Close | Method |  | General | Normal
Write | Method |  | General | Normal
WriteData | Method |  | General | Normal
WriteLine | Method |  | General | Normal

ISDBTextFile overview


Interface ISDBTextFile

ISDBTextFile members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Close | Method |  | General | Normal
Write | Method |  | General | Normal
WriteData | Method |  | General | Normal
WriteLine | Method |  | General | Normal

ISDBTextFile overview


ISDBTextFile::Close

Sub Close

No parameters

Method description

Closes openned file.


ISDBTextFile::Write

Sub Write(aText As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | aText | String | No | - | String to be written to the file.

Method description

Writes string to a file.


ISDBTextFile::WriteData

Sub WriteData(DataPointer As Long, DataLength As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | DataPointer | Long | No | - | Pointer to data to be written.
2 | DataLength | Long | No | - | Number of bytes to be written.

Method description

Writes binary data to the file.


ISDBTextFile::WriteLine

Sub WriteLine([aText As String])

Parameters

No | Name | Type | Optional | Default | Description
1 | aText | String | Yes | - | String to be written to the file.

Method description

Writes strings to a file and add new line.


Coclass: SDBTimer

This object is used for periodically repeating actions (specified in milliseconds).


Interface: ISDBTimer

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTimer

ISDBTimer members

Properties

Name | Type | HelpString | Category | Frequency of use
Enabled | Property Get/Let |  | General | Normal
Interval | Property Get/Let |  | General | Normal

ISDBTimer overview


Interface ISDBTimer

ISDBTimer members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Enabled | Property Get/Let |  | General | Normal
Interval | Property Get/Let |  | General | Normal

ISDBTimer overview


Interface ISDBTimer

ISDBTimer members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Enabled | Property Get/Let |  | General | Normal
Interval | Property Get/Let |  | General | Normal

ISDBTimer overview


ISDBTimer::Enabled

Property Get/Let Enabled As Boolean

No parameters

Property description

Whether this timer is enabled.


ISDBTimer::Interval

Property Get/Let Interval As Long

No parameters

Property description

Interval between firing the OnTimer event (in milliseconds).


Interface: ISDBTimerEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTimerEvents

ISDBTimerEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnTimer | Event |  | General | Normal

ISDBTimerEvents overview


Interface ISDBTimerEvents

ISDBTimerEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnTimer | Event |  | General | Normal

ISDBTimerEvents overview


Interface ISDBTimerEvents

ISDBTimerEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnTimer | Event |  | General | Normal

ISDBTimerEvents overview


ISDBTimerEvents::OnTimer

Sub OnTimer(Timer As ISDBTimer)

Parameters

No | Name | Type | Optional | Default | Description
1 | Timer | ISDBTimer | No | - |

Event description

This event is called when timer expires.


Coclass: SDBTools

Object for miscellaneous helper methods.


Interface: ISDBTools

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTools

ISDBTools members

Properties

Name | Type | HelpString | Category | Frequency of use
AlbumByName | Property Get |  | General | Normal
ArtistByName | Property Get |  | General | Normal
ArtistCompFunc | Property Get |  | General | Normal
DeleteTracks | Method |  | General | Normal
FileSystem | Property Get |  | General | Normal
IniFileByPath | Property Get |  | General | Normal
MainThreadCallFunc | Property Get |  | General | Normal
Mask2UFText | Method |  | General | Normal
UFText2Mask | Method |  | General | Normal

ISDBTools overview


Interface ISDBTools

ISDBTools members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AlbumByName | Property Get |  | General | Normal
ArtistByName | Property Get |  | General | Normal
ArtistCompFunc | Property Get |  | General | Normal
DeleteTracks | Method |  | General | Normal
FileSystem | Property Get |  | General | Normal
IniFileByPath | Property Get |  | General | Normal
MainThreadCallFunc | Property Get |  | General | Normal
Mask2UFText | Method |  | General | Normal
UFText2Mask | Method |  | General | Normal

ISDBTools overview


Interface ISDBTools

ISDBTools members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
IniFileByPath | Property Get |  | General | Normal
Mask2UFText | Method |  | General | Normal
UFText2Mask | Method |  | General | Normal
AlbumByName | Property Get |  | General | Normal
ArtistByName | Property Get |  | General | Normal
ArtistCompFunc | Property Get |  | General | Normal
FileSystem | Property Get |  | General | Normal
MainThreadCallFunc | Property Get |  | General | Normal
DeleteTracks | Method |  | General | Normal

ISDBTools overview


ISDBTools::AlbumByName

Property Get AlbumByName(ArtistName As String, AlbumName As String) As SDBAlbum

Parameters

No | Name | Type | Optional | Default | Description
1 | ArtistName | String | No | - | Album artist name
2 | AlbumName | String | No | - | Album name

Property description

Returns SDBAlbum object for given album and album artist name.


ISDBTools::ArtistByName

Property Get ArtistByName(ArtistName As String) As SDBArtist

Parameters

No | Name | Type | Optional | Default | Description
1 | ArtistName | String | No | - | Artist name.

Property description

Returns SDBArtist object for given artist name.


ISDBTools::ArtistCompFunc

Property Get ArtistCompFunc As Long

No parameters

Property description

For usage in plug-ins only.


ISDBTools::DeleteTracks

Function DeleteTracks(TrackList As ISDBSongList, Confirmation As Boolean, ToRecycleBin As EnumYesNo) As EnumYesNo

Parameters

No | Name | Type | Optional | Default | Description
1 | TrackList | ISDBSongList | No | - | List of tracks to be deleted.
2 | Confirmation | Boolean | No | - | Show confirmation dialog?
3 | ToRecycleBin | EnumYesNo | No | - | Delete to recycle bin? If YesNo_Default value is used, the result depends on Shift key being pressed.

Method description

Deletes selected tracks from computer and library.


ISDBTools::FileSystem

Property Get FileSystem As ISDBFileSystem

No parameters

Property description

Returns SDBFileSystem object that can be used instead of MS Scripting FileSystemObject (that's often disabled by antiviruses). Only some features are implemented yet.


ISDBTools::IniFileByPath

Property Get IniFileByPath(Path As String) As SDBIniFile

Parameters

No | Name | Type | Optional | Default | Description
1 | Path | String | No | - | Full path to the ini file.

Property description

Retuns SDBIniFile object for ini file stored at given path.


ISDBTools::MainThreadCallFunc

Property Get MainThreadCallFunc As Long

No parameters

Property description

For usage in plug-ins only.


ISDBTools::Mask2UFText

Function Mask2UFText(Mask As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Mask | String | No | - | Mask string to be converted.

Method description

Converts mask string in the internal format into user friendly format. E.g., if user uses English language, '%A' is converted to '<Artist>'.


ISDBTools::UFText2Mask

Function UFText2Mask(InText As String) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | InText | String | No | - | Mask string to be converted.

Method description

Converts mask string in the user friendly format into internal format. E.g., if user uses English language, '<Artist>' is converted to '%A'.


Coclass: SDBTracksWindow

Object for track list window manipulation.


Interface: ISDBTracksWindow

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTracksWindow

ISDBTracksWindow members

Properties

Name | Type | HelpString | Category | Frequency of use
AddTrack | Method |  | General | Normal
AddTrackEx | Method |  | General | Normal
AddTracksFromQuery | Method |  | General | Normal
CurrentAddingID | Property Get |  | General | Normal
FinishAdding | Method |  | General | Normal
FinishAddingEx | Method |  | General | Normal
Refresh | Method |  | General | Normal
RemoveSelectedTracks | Method |  | General | Normal

ISDBTracksWindow overview


Interface ISDBTracksWindow

ISDBTracksWindow members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AddTrack | Method |  | General | Normal
AddTrackEx | Method |  | General | Normal
AddTracksFromQuery | Method |  | General | Normal
CurrentAddingID | Property Get |  | General | Normal
FinishAdding | Method |  | General | Normal
FinishAddingEx | Method |  | General | Normal
Refresh | Method |  | General | Normal
RemoveSelectedTracks | Method |  | General | Normal

ISDBTracksWindow overview


Interface ISDBTracksWindow

ISDBTracksWindow members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
AddTrack | Method |  | General | Normal
AddTrackEx | Method |  | General | Normal
AddTracksFromQuery | Method |  | General | Normal
CurrentAddingID | Property Get |  | General | Normal
FinishAdding | Method |  | General | Normal
FinishAddingEx | Method |  | General | Normal
Refresh | Method |  | General | Normal
RemoveSelectedTracks | Method |  | General | Normal

ISDBTracksWindow overview


ISDBTracksWindow::AddTrack

Sub AddTrack(AddedTrack As ISDBSongData)

Parameters

No | Name | Type | Optional | Default | Description
1 | AddedTrack | ISDBSongData | No | - | Track to be added.

Method description

Adds a single track to the tracklist window.


ISDBTracksWindow::AddTrackEx

Function AddTrackEx(AddedTrack As ISDBSongData, AddingID As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | AddedTrack | ISDBSongData | No | - |
2 | AddingID | Long | No | - |

Method description

Adds a track to tracklist window, but only if AddingID is equal to the current ID of adding tracks to tracklist window. If it isn't, nothing is added and FALSE is returned.


ISDBTracksWindow::AddTracksFromQuery

Sub AddTracksFromQuery(AddSQL As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | AddSQL | String | No | - |

Method description

Adds a set of tracks to the tracklist window. The tracks added are those selected by the supplied SQL. It is not a full SQL statement but only a condition (WHERE part).


ISDBTracksWindow::CurrentAddingID

Property Get CurrentAddingID As Long

No parameters

Property description

Returns ID of the current process of adding tracks to tracklist window.


ISDBTracksWindow::FinishAdding

Sub FinishAdding

No parameters

Method description

This method must be called when script finishes filling of tracklist window after a new tree node was selected.


ISDBTracksWindow::FinishAddingEx

Sub FinishAddingEx(AddingID As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | AddingID | Long | No | - |

Method description

Finishes adding of tracks to tracklist window, but only of given AddingID.


ISDBTracksWindow::Refresh

Sub Refresh

No parameters

Method description

Re-reads the track list for the currently selected tree node (like pressing F5 in the main window).


ISDBTracksWindow::RemoveSelectedTracks

Sub RemoveSelectedTracks

No parameters

Method description

Removes items that are curently selected in the track list window (visually only).


Coclass: SDBTrackSynchStatus

Used by device plug-ins.


Interface: ISDBTrackSynchStatus

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTrackSynchStatus

ISDBTrackSynchStatus members

Properties

Name | Type | HelpString | Category | Frequency of use
DeviceTrackPath | Property Get |  | General | Normal
PlayCount | Property Get/Let |  | General | Normal
Rating | Property Get/Let |  | General | Normal
Track | Property Get |  | General | Normal

ISDBTrackSynchStatus overview


Interface ISDBTrackSynchStatus

ISDBTrackSynchStatus members by category

Properties

Name | Type | HelpString | Category | Frequency of use
DeviceTrackPath | Property Get |  | General | Normal
PlayCount | Property Get/Let |  | General | Normal
Rating | Property Get/Let |  | General | Normal
Track | Property Get |  | General | Normal

ISDBTrackSynchStatus overview


Interface ISDBTrackSynchStatus

ISDBTrackSynchStatus members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
DeviceTrackPath | Property Get |  | General | Normal
PlayCount | Property Get/Let |  | General | Normal
Rating | Property Get/Let |  | General | Normal
Track | Property Get |  | General | Normal

ISDBTrackSynchStatus overview


ISDBTrackSynchStatus::DeviceTrackPath

Property Get DeviceTrackPath As String

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTrackSynchStatus::PlayCount

Property Get/Let PlayCount As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTrackSynchStatus::Rating

Property Get/Let Rating As Long

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTrackSynchStatus::Track

Property Get Track As ISDBSongData

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


Coclass: SDBTree

Object for tree manipulation.


Interface: ISDBTree

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTree

ISDBTree members

Properties

Name | Type | HelpString | Category | Frequency of use
AddNode | Method |  | General | Normal
CreateNode | Property Get |  | General | Normal
CurrentNode | Property Get/Let |  | General | Normal
FirstChildNode | Property Get |  | General | Normal
LastChildNode | Property Get |  | General | Normal
NextNode | Property Get |  | General | Normal
NextSiblingNode | Property Get |  | General | Normal
Node_Album | Property Get |  | General | Normal
Node_Artist | Property Get |  | General | Normal
Node_Classification | Property Get |  | General | Normal
Node_FilesToEdit | Property Get |  | General | Normal
Node_Genre | Property Get |  | General | Normal
Node_Library | Property Get |  | General | Normal
Node_Location | Property Get |  | General | Normal
Node_MyComputer | Property Get |  | General | Normal
Node_NowPlaying | Property Get |  | General | Normal
Node_Playlists | Property Get |  | General | Normal
Node_Previews | Property Get |  | General | Normal
Node_Radio | Property Get |  | General | Normal
Node_Rating | Property Get |  | General | Normal
Node_VirtualCD | Property Get |  | General | Normal
Node_Web | Property Get |  | General | Normal
Node_Year | Property Get |  | General | Normal
ParentNode | Property Get |  | General | Normal
PreviousNode | Property Get |  | General | Normal
PreviousSiblingNode | Property Get |  | General | Normal
RemoveNode | Method |  | General | Normal
SortChildren | Method |  | General | Normal

ISDBTree overview


Interface ISDBTree

ISDBTree members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AddNode | Method |  | General | Normal
CreateNode | Property Get |  | General | Normal
CurrentNode | Property Get/Let |  | General | Normal
FirstChildNode | Property Get |  | General | Normal
LastChildNode | Property Get |  | General | Normal
NextNode | Property Get |  | General | Normal
NextSiblingNode | Property Get |  | General | Normal
Node_Album | Property Get |  | General | Normal
Node_Artist | Property Get |  | General | Normal
Node_Classification | Property Get |  | General | Normal
Node_FilesToEdit | Property Get |  | General | Normal
Node_Genre | Property Get |  | General | Normal
Node_Library | Property Get |  | General | Normal
Node_Location | Property Get |  | General | Normal
Node_MyComputer | Property Get |  | General | Normal
Node_NowPlaying | Property Get |  | General | Normal
Node_Playlists | Property Get |  | General | Normal
Node_Previews | Property Get |  | General | Normal
Node_Radio | Property Get |  | General | Normal
Node_Rating | Property Get |  | General | Normal
Node_VirtualCD | Property Get |  | General | Normal
Node_Web | Property Get |  | General | Normal
Node_Year | Property Get |  | General | Normal
ParentNode | Property Get |  | General | Normal
PreviousNode | Property Get |  | General | Normal
PreviousSiblingNode | Property Get |  | General | Normal
RemoveNode | Method |  | General | Normal
SortChildren | Method |  | General | Normal

ISDBTree overview


Interface ISDBTree

ISDBTree members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Node_Radio | Property Get |  | General | Normal
ParentNode | Property Get |  | General | Normal
AddNode | Method |  | General | Normal
CreateNode | Property Get |  | General | Normal
CurrentNode | Property Get/Let |  | General | Normal
FirstChildNode | Property Get |  | General | Normal
LastChildNode | Property Get |  | General | Normal
NextNode | Property Get |  | General | Normal
NextSiblingNode | Property Get |  | General | Normal
Node_Album | Property Get |  | General | Normal
Node_Artist | Property Get |  | General | Normal
Node_Classification | Property Get |  | General | Normal
Node_FilesToEdit | Property Get |  | General | Normal
Node_Genre | Property Get |  | General | Normal
Node_Library | Property Get |  | General | Normal
Node_Location | Property Get |  | General | Normal
Node_MyComputer | Property Get |  | General | Normal
Node_NowPlaying | Property Get |  | General | Normal
Node_Playlists | Property Get |  | General | Normal
Node_Previews | Property Get |  | General | Normal
Node_Rating | Property Get |  | General | Normal
Node_VirtualCD | Property Get |  | General | Normal
Node_Web | Property Get |  | General | Normal
Node_Year | Property Get |  | General | Normal
PreviousNode | Property Get |  | General | Normal
PreviousSiblingNode | Property Get |  | General | Normal
RemoveNode | Method |  | General | Normal
SortChildren | Method |  | General | Normal

ISDBTree overview


ISDBTree::AddNode

Sub AddNode(ParentNode As ISDBTreeNode, AddNode As ISDBTreeNode, NodePosition As EnumTreeNodePos)

Parameters

No | Name | Type | Optional | Default | Description
1 | ParentNode | ISDBTreeNode | No | - | The node where the new node as is added. Can be one of Node_xxx properties or some previously created node.
2 | AddNode | ISDBTreeNode | No | - | The node to be added
3 | NodePosition | EnumTreeNodePos | No | - | Relative location of AddNode to ParentNode: 0..before, 1..after, 2.. the first child or 3..the last child.

Method description

Adds AddNode as a child of ParentNode.

Example code

Set Node = Tree.CreateNode
Node.Caption = "Reversed Now Playing"
Node.IconIndex = 40
Node.UseScript = Script.ScriptPath
Node.OnFillTracksFunct = "FillNPTracks"

Tree.AddNode Tree.Node_NowPlaying, Node, 3    ' Add as the last child


ISDBTree::CreateNode

Property Get CreateNode As ISDBTreeNode

No parameters

Property description

Returns a new SDBTreeNode object. You can set its properties then and finally add it to some position at the main tree using AddNode method.


ISDBTree::CurrentNode

Property Get/Let CurrentNode As ISDBTreeNode

No parameters

Property description

Gets or sets the current tree node.


ISDBTree::FirstChildNode

Property Get FirstChildNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Property description

Returns the first child node of given node.


ISDBTree::LastChildNode

Property Get LastChildNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Property description

Returns the last child node of given node.


ISDBTree::NextNode

Property Get NextNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Property description

Returns next node (regardless of hierarchy) after the given node.


ISDBTree::NextSiblingNode

Property Get NextSiblingNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Property description

Returns the next node on the same tree level.


ISDBTree::Node_Album

Property Get Node_Album As ISDBTreeNode

No parameters

Property description

As well as any Node_xxx property returns an existings node in the tree.


ISDBTree::Node_Artist

Property Get Node_Artist As ISDBTreeNode

No parameters

Property description

Artist node.


ISDBTree::Node_Classification

Property Get Node_Classification As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_FilesToEdit

Property Get Node_FilesToEdit As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_Genre

Property Get Node_Genre As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_Library

Property Get Node_Library As ISDBTreeNode

No parameters

Property description

Library node.


ISDBTree::Node_Location

Property Get Node_Location As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_MyComputer

Property Get Node_MyComputer As ISDBTreeNode

No parameters

Property description

My Computer node.


ISDBTree::Node_NowPlaying

Property Get Node_NowPlaying As ISDBTreeNode

No parameters

Property description

Now Playing node.


ISDBTree::Node_Playlists

Property Get Node_Playlists As ISDBTreeNode

No parameters

Property description

Playlists node.


ISDBTree::Node_Previews

Property Get Node_Previews As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_Radio

Property Get Node_Radio As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_Rating

Property Get Node_Rating As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_VirtualCD

Property Get Node_VirtualCD As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::Node_Web

Property Get Node_Web As ISDBTreeNode

No parameters

Property description

Web node.


ISDBTree::Node_Year

Property Get Node_Year As ISDBTreeNode

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTree::ParentNode

Property Get ParentNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Node whose parent we need.

Property description

Returns parent node of the given node.


ISDBTree::PreviousNode

Property Get PreviousNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Property description

Returns the previous node (regardless of tree hierarchy).


ISDBTree::PreviousSiblingNode

Property Get PreviousSiblingNode(Node As ISDBTreeNode) As ISDBTreeNode

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Property description

Returns previous tree node on the same level.


ISDBTree::RemoveNode

Sub RemoveNode(Node As ISDBTreeNode)

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - |

Method description

Removes given node from the tree.


ISDBTree::SortChildren

Sub SortChildren(Node As ISDBTreeNode)

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Parent node of nodes to be sorted.

Method description

Sorts children of given node according to the order they should appear (not always alphabetically).


Coclass: SDBTreeNode

Object representing a single tree node.


Interface: ISDBTreeNode

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTreeNode

ISDBTreeNode members

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
CustomData | Property Get/Let |  | General | Normal
CustomDataId | Property Get/Let |  | General | Normal
CustomNodeId | Property Get/Let |  | General | Normal
CustomObject | Property Get/Let |  | General | Normal
Expanded | Property Get/Let |  | General | Normal
HasChildren | Property Get/Let |  | General | Normal
IconIndex | Property Get/Let |  | General | Normal
NodeType | Property Get/Let |  | General | Normal
OnDragDrop | Property Get/Let |  | General | Normal
OnEdited | Property Get/Let |  | General | Normal
OnFillChildren | Property Get/Let |  | General | Normal
OnFillTracksFunct | Property Get/Let |  | General | Normal
Path | Property Get/Let |  | General | Normal
SortCriteria | Property Get/Let |  | General | Normal
SortGroup | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal
Visible | Property Get/Let |  | General | Normal

ISDBTreeNode overview


Interface ISDBTreeNode

ISDBTreeNode members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
CustomData | Property Get/Let |  | General | Normal
CustomDataId | Property Get/Let |  | General | Normal
CustomNodeId | Property Get/Let |  | General | Normal
CustomObject | Property Get/Let |  | General | Normal
Expanded | Property Get/Let |  | General | Normal
HasChildren | Property Get/Let |  | General | Normal
IconIndex | Property Get/Let |  | General | Normal
NodeType | Property Get/Let |  | General | Normal
OnDragDrop | Property Get/Let |  | General | Normal
OnEdited | Property Get/Let |  | General | Normal
OnFillChildren | Property Get/Let |  | General | Normal
OnFillTracksFunct | Property Get/Let |  | General | Normal
Path | Property Get/Let |  | General | Normal
SortCriteria | Property Get/Let |  | General | Normal
SortGroup | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal
Visible | Property Get/Let |  | General | Normal

ISDBTreeNode overview


Interface ISDBTreeNode

ISDBTreeNode members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
CustomData | Property Get/Let |  | General | Normal
CustomDataId | Property Get/Let |  | General | Normal
CustomNodeId | Property Get/Let |  | General | Normal
CustomObject | Property Get/Let |  | General | Normal
Expanded | Property Get/Let |  | General | Normal
HasChildren | Property Get/Let |  | General | Normal
IconIndex | Property Get/Let |  | General | Normal
NodeType | Property Get/Let |  | General | Normal
OnDragDrop | Property Get/Let |  | General | Normal
OnEdited | Property Get/Let |  | General | Normal
OnFillChildren | Property Get/Let |  | General | Normal
OnFillTracksFunct | Property Get/Let |  | General | Normal
Path | Property Get/Let |  | General | Normal
SortCriteria | Property Get/Let |  | General | Normal
SortGroup | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal
Visible | Property Get/Let |  | General | Normal

ISDBTreeNode overview


ISDBTreeNode::Caption

Property Get/Let Caption As String

No parameters

Property description

A string that is shown beside the radio button.


ISDBTreeNode::CustomData

Property Get/Let CustomData As String

No parameters

Property description

This is for arbitrary use.


ISDBTreeNode::CustomDataId

Property Get/Let CustomDataId As Long

No parameters

Property description

This is for arbitrary use.


ISDBTreeNode::CustomNodeId

Property Get/Let CustomNodeId As Long

No parameters

Property description

This is for arbitrary use.


ISDBTreeNode::CustomObject

Property Get/Let CustomObject As Unknown

No parameters

Property description

This is for arbitrary use.


ISDBTreeNode::Expanded

Property Get/Let Expanded As Boolean

No parameters

Property description

Can get or set whether the node is expanded in the tree.


ISDBTreeNode::HasChildren

Property Get/Let HasChildren As Boolean

No parameters

Property description

Specifies whether there are any child nodes of this node.


ISDBTreeNode::IconIndex

Property Get/Let IconIndex As Long

No parameters

Property description

Specifies which icon is used for this node (see Icons documentation for their list). You can use SDBApplication.RegisterIcon to add you own icons.


ISDBTreeNode::NodeType

Property Get/Let NodeType As Long

No parameters

Property description

Returns the type of node. Mainly for internal usage.


ISDBTreeNode::OnDragDrop

Property Get/Let OnDragDrop As String

No parameters

Property description

Name of an event function in UseScript file that is called to handle drag and drop. The function is called with the following parameters: destNode - Target tree node. srcNode - The node from which the list of tracks to be dragged originates. songList - List of tracks that are dragged. dropType - is either 1 - Copy - Tracks are expected to be copied. 2 - Move - Tracks are expected to be moved. test - if true, the drop operation should not occur, the method is only expected to return a value that indicates what kind of operation is by default expected. It can be any of values used in 'dropType' parameter and in addition the following can be used 0 - No drop - tracks cannot be dropped here. 3 - Just Move - Tracks can only be moved here (no copied). User cannot change the shape of cursor to copy. 4 - Just Copy - Tracks can only be copied here (no moved). User cannot change the shape of cursor to move.

Example code

' The function can look like:

Function LyricistDragDrop( destNode, srcNode, SongList, DropType, Test)
  If Test Then
    LyricistDragDrop = 2         ' Move operation
  Else
    Dim i, itm
    For i=0 To SongList.Count-1
      Set itm = SongList.Item(i)
      itm.Lyricist = destNode.CustomData
      itm.UpdateDB
    Next
  End If
End Function

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTreeNode::OnEdited

Property Get/Let OnEdited As String

No parameters

Property description

Name of an event function in UseScript file that is called when a tree node is edited (user modified its text). This function takes two parameters: Node - The node where edit operation occured NewText - Text entered by user

Example code

' The function can look like:

Sub LyricistEdited( Node, NewText)
  SDB.Database.ExecSQL( "UPDATE AddSongInfo SET TextData='" & NewText & "' WHERE DataType=200 and TextData='" & Node.CustomData & "'")
  Node.CustomData = NewText
  Node.Caption = NewText
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTreeNode::OnFillChildren

Property Get/Let OnFillChildren As String

No parameters

Property description

Name of an event function in UseScript file that is called when user expands a node (clicks the plus sign). The function is called with one parameter - the node that is about to be expanded.

Example code

Sub FillLyricists( Node)
  Node.HasChildren = false   ' To delete all old children
  ' Add new children
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTreeNode::OnFillTracksFunct

Property Get/Let OnFillTracksFunct As String

No parameters

Property description

Name of an event function in UseScript file that is called when user selects a node and its tracks should be shown in track list. The only parameter of this function is the node that was just selected.

Example code

Sub FillLyricist( Node)
  Set Trcks = SDB.MainTracksWindow

  Trcks.AddTracksFromQuery( "and Songs.ID in (SELECT IDSong FROM AddSongInfo WHERE DataType=200 AND TextData='" & Node.CustomData & "')")
  Trcks.FinishAdding
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTreeNode::Path

Property Get/Let Path As String

No parameters

Property description

Path stored in this node (e.g. full path in My Computer nodes).


ISDBTreeNode::SortCriteria

Property Get/Let SortCriteria As Long

No parameters

Property description

Defines to which group of nodes is this node similar in the sense that it uses the same ordering. Possible values include: 0 - None 1 - Artist (works as any Artist node) 2 - Album 3 - Location 4 - Title 5 - Genre 6 - Year 7 - Rating 8 - Classification 9 - My Computer 10 - Audio CD - Location node


ISDBTreeNode::SortGroup

Property Get/Let SortGroup As Long

No parameters

Property description

Specifies to which group of nodes this node belong - the tracks of this node are sorted the same way as tracks in other nodes of the same group. Possible values: 0 - None 1 - Artist 2 - Album 3 - Location 4 - Title 5 - Genre 6 - Year 7 - Rating 8 - Classification 9 - My Computer 10 - Location - Audio CD


ISDBTreeNode::UseScript

Property Get/Let UseScript As String

No parameters

Property description

Filename of a script where event functions are located.


ISDBTreeNode::Visible

Property Get/Let Visible As Boolean

No parameters

Property description

Modifies visibility of a tree node.


Interface: ISDBTreeNodeEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBTreeNodeEvents

ISDBTreeNodeEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnCanEditNode | Event |  | General | Normal
OnExecMenuItem | Event |  | General | Normal
OnExecTrackMenuItem | Event |  | General | Normal
OnFillChildren | Event |  | General | Normal
OnFillTracks | Event |  | General | Normal
OnGetFreeSpace | Event |  | General | Normal
OnNodeDragDrop | Event |  | General | Normal
OnNodeEdited | Event |  | General | Normal
OnNodeEditText | Event |  | General | Normal
OnNodeFocused | Event |  | General | Normal
OnShowMenuItem | Event |  | General | Normal
OnShowTrackMenuItem | Event |  | General | Normal

ISDBTreeNodeEvents overview


Interface ISDBTreeNodeEvents

ISDBTreeNodeEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnCanEditNode | Event |  | General | Normal
OnExecMenuItem | Event |  | General | Normal
OnExecTrackMenuItem | Event |  | General | Normal
OnFillChildren | Event |  | General | Normal
OnFillTracks | Event |  | General | Normal
OnGetFreeSpace | Event |  | General | Normal
OnNodeDragDrop | Event |  | General | Normal
OnNodeEdited | Event |  | General | Normal
OnNodeEditText | Event |  | General | Normal
OnNodeFocused | Event |  | General | Normal
OnShowMenuItem | Event |  | General | Normal
OnShowTrackMenuItem | Event |  | General | Normal

ISDBTreeNodeEvents overview


Interface ISDBTreeNodeEvents

ISDBTreeNodeEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnNodeFocused | Event |  | General | Normal
OnCanEditNode | Event |  | General | Normal
OnExecMenuItem | Event |  | General | Normal
OnExecTrackMenuItem | Event |  | General | Normal
OnFillChildren | Event |  | General | Normal
OnFillTracks | Event |  | General | Normal
OnGetFreeSpace | Event |  | General | Normal
OnNodeDragDrop | Event |  | General | Normal
OnNodeEdited | Event |  | General | Normal
OnNodeEditText | Event |  | General | Normal
OnShowMenuItem | Event |  | General | Normal
OnShowTrackMenuItem | Event |  | General | Normal

ISDBTreeNodeEvents overview


ISDBTreeNodeEvents::OnCanEditNode

Function OnCanEditNode(Node As ISDBTreeNode) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Node parameter

Event description

This event is fired when MM asks whether given node can be edited (using F2 or mouse click).


ISDBTreeNodeEvents::OnExecMenuItem

Function OnExecMenuItem(ItemIndex As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | ItemIndex | Long | No | - |


ISDBTreeNodeEvents::OnExecTrackMenuItem

Function OnExecTrackMenuItem(ItemIndex As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | ItemIndex | Long | No | - |


ISDBTreeNodeEvents::OnFillChildren

Sub OnFillChildren(Node As ISDBTreeNode)

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Node parameter

Event description

This event is called when user expands given node (using '+') and called code here can add children nodes.


ISDBTreeNodeEvents::OnFillTracks

Sub OnFillTracks(Node As ISDBTreeNode)

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Node parameter

Event description

This event is called when node content (tracks) should be shown.


ISDBTreeNodeEvents::OnGetFreeSpace

Function OnGetFreeSpace As Empty

No parameters

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBTreeNodeEvents::OnNodeDragDrop

Function OnNodeDragDrop(DestinationNode As ISDBTreeNode, SourceNode As ISDBTreeNode, TrackList As ISDBSongList, CopyType As Long, JustTest As Boolean) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | DestinationNode | ISDBTreeNode | No | - | Node where user is about to drop tracks
2 | SourceNode | ISDBTreeNode | No | - | Node where the drag&drop operation started
3 | TrackList | ISDBSongList | No | - | List of tracks that are being dragged
4 | CopyType | Long | No | - | The same list of values as the return value of this function
5 | JustTest | Boolean | No | - | If true, this is just a test and return value of this event specifies whether tracks can be dropped here or not.

Event description

This event is called when: 1. User drags tracks over the given node 2. User drops tracks on the given node This event is supposed to either let MM know whether drag&drop can proceed here, or should directly process the operation (depending on justTest parameter)


ISDBTreeNodeEvents::OnNodeEdited

Sub OnNodeEdited(Node As ISDBTreeNode, NewText As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Node parameter
2 | NewText | String | No | - | Newly entered node caption

Event description

This event is called when user presses Enter and confirms node caption change.


ISDBTreeNodeEvents::OnNodeEditText

Function OnNodeEditText(Node As ISDBTreeNode) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | ISDBTreeNode | No | - | Node parameter

Event description

Using this event plug-in/script can modify what text user edits after node editing is started. For example node caption shows 'Black Album (Metallica)', but this event modifies the text so that user edits only text 'Black Album'.


ISDBTreeNodeEvents::OnNodeFocused

Function OnNodeFocused(Node As SDBTreeNode) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | Node | SDBTreeNode | No | - | A node that just received focus.

Event description

This event is called when a new tree node gets focus.


ISDBTreeNodeEvents::OnShowMenuItem

Function OnShowMenuItem(ItemIndex As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | ItemIndex | Long | No | - |


ISDBTreeNodeEvents::OnShowTrackMenuItem

Function OnShowTrackMenuItem(ItemIndex As Long) As Boolean

Parameters

No | Name | Type | Optional | Default | Description
1 | ItemIndex | Long | No | - |


Coclass: SDBUI

Object for manipulation of User Interface elements.


Interface: ISDBUI

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUI

ISDBUI members

Properties

Name | Type | HelpString | Category | Frequency of use
AddMenuItem | Method |  | General | Normal
AddMenuItemSep | Method |  | General | Normal
AddMenuItemSub | Method |  | General | Normal
AddOptionSheet | Method |  | General | Normal
Menu_Edit | Property Get |  | General | Normal
Menu_Export | Property Get |  | General | Normal
Menu_File | Property Get |  | General | Normal
Menu_Help | Property Get |  | General | Normal
Menu_Play | Property Get |  | General | Normal
Menu_Pop_NP | Property Get |  | General | Normal
Menu_Pop_NP_MoreFrom | Property Get |  | General | Normal
Menu_Pop_NP_SendTo | Property Get |  | General | Normal
Menu_Pop_TrackList | Property Get |  | General | Normal
Menu_Pop_TrackList_MoreFrom | Property Get |  | General | Normal
Menu_Pop_TrackList_SendTo | Property Get |  | General | Normal
Menu_Pop_Tree | Property Get |  | General | Normal
Menu_Pop_Tree_SendTo | Property Get |  | General | Normal
Menu_Scripts | Property Get |  | General | Normal
Menu_TbAdvanced | Property Get |  | General | Normal
Menu_TbCategorize | Property Get |  | General | Normal
Menu_TbEdit | Property Get |  | General | Normal
Menu_TbNavigation | Property Get |  | General | Normal
Menu_TbNPEdit | Property Get |  | General | Normal
Menu_TbNPList | Property Get |  | General | Normal
Menu_TbNPMain | Property Get |  | General | Normal
Menu_TbSearch | Property Get |  | General | Normal
Menu_TbStandard | Property Get |  | General | Normal
Menu_Tools | Property Get |  | General | Normal
Menu_TrayIcon | Property Get |  | General | Normal
Menu_View | Property Get |  | General | Normal
NewActiveX | Property Get |  | General | Normal
NewButton | Property Get |  | General | Normal
NewDockablePanel | Property Get |  | General | Normal
NewDockablePersistentPanel | Property Get |  | General | Normal
NewDropDown | Property Get |  | General | Normal
NewEdit | Property Get |  | General | Normal
NewForm | Property Get |  | General | Normal
NewCheckBox | Property Get |  | General | Normal
NewLabel | Property Get |  | General | Normal
NewPanel | Property Get |  | General | Normal
NewRadioButton | Property Get |  | General | Normal
NewSpinEdit | Property Get |  | General | Normal
NewTrackBar | Property Get |  | General | Normal
NewTranspPanel | Property Get |  | General | Normal

ISDBUI overview


Interface ISDBUI

ISDBUI members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AddMenuItem | Method |  | General | Normal
AddMenuItemSep | Method |  | General | Normal
AddMenuItemSub | Method |  | General | Normal
AddOptionSheet | Method |  | General | Normal
Menu_Edit | Property Get |  | General | Normal
Menu_Export | Property Get |  | General | Normal
Menu_File | Property Get |  | General | Normal
Menu_Help | Property Get |  | General | Normal
Menu_Play | Property Get |  | General | Normal
Menu_Pop_NP | Property Get |  | General | Normal
Menu_Pop_NP_MoreFrom | Property Get |  | General | Normal
Menu_Pop_NP_SendTo | Property Get |  | General | Normal
Menu_Pop_TrackList | Property Get |  | General | Normal
Menu_Pop_TrackList_MoreFrom | Property Get |  | General | Normal
Menu_Pop_TrackList_SendTo | Property Get |  | General | Normal
Menu_Pop_Tree | Property Get |  | General | Normal
Menu_Pop_Tree_SendTo | Property Get |  | General | Normal
Menu_Scripts | Property Get |  | General | Normal
Menu_TbAdvanced | Property Get |  | General | Normal
Menu_TbCategorize | Property Get |  | General | Normal
Menu_TbEdit | Property Get |  | General | Normal
Menu_TbNavigation | Property Get |  | General | Normal
Menu_TbNPEdit | Property Get |  | General | Normal
Menu_TbNPList | Property Get |  | General | Normal
Menu_TbNPMain | Property Get |  | General | Normal
Menu_TbSearch | Property Get |  | General | Normal
Menu_TbStandard | Property Get |  | General | Normal
Menu_Tools | Property Get |  | General | Normal
Menu_TrayIcon | Property Get |  | General | Normal
Menu_View | Property Get |  | General | Normal
NewActiveX | Property Get |  | General | Normal
NewButton | Property Get |  | General | Normal
NewDockablePanel | Property Get |  | General | Normal
NewDockablePersistentPanel | Property Get |  | General | Normal
NewDropDown | Property Get |  | General | Normal
NewEdit | Property Get |  | General | Normal
NewForm | Property Get |  | General | Normal
NewCheckBox | Property Get |  | General | Normal
NewLabel | Property Get |  | General | Normal
NewPanel | Property Get |  | General | Normal
NewRadioButton | Property Get |  | General | Normal
NewSpinEdit | Property Get |  | General | Normal
NewTrackBar | Property Get |  | General | Normal
NewTranspPanel | Property Get |  | General | Normal

ISDBUI overview


Interface ISDBUI

ISDBUI members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
AddMenuItem | Method |  | General | Normal
AddMenuItemSep | Method |  | General | Normal
AddMenuItemSub | Method |  | General | Normal
AddOptionSheet | Method |  | General | Normal
Menu_Edit | Property Get |  | General | Normal
Menu_Export | Property Get |  | General | Normal
Menu_File | Property Get |  | General | Normal
Menu_Help | Property Get |  | General | Normal
Menu_Play | Property Get |  | General | Normal
Menu_Pop_NP | Property Get |  | General | Normal
Menu_Pop_NP_MoreFrom | Property Get |  | General | Normal
Menu_Pop_NP_SendTo | Property Get |  | General | Normal
Menu_Pop_TrackList | Property Get |  | General | Normal
Menu_Pop_TrackList_MoreFrom | Property Get |  | General | Normal
Menu_Pop_TrackList_SendTo | Property Get |  | General | Normal
Menu_Pop_Tree | Property Get |  | General | Normal
Menu_Pop_Tree_SendTo | Property Get |  | General | Normal
Menu_Scripts | Property Get |  | General | Normal
Menu_TbAdvanced | Property Get |  | General | Normal
Menu_TbCategorize | Property Get |  | General | Normal
Menu_TbEdit | Property Get |  | General | Normal
Menu_TbNavigation | Property Get |  | General | Normal
Menu_TbNPEdit | Property Get |  | General | Normal
Menu_TbNPList | Property Get |  | General | Normal
Menu_TbNPMain | Property Get |  | General | Normal
Menu_TbSearch | Property Get |  | General | Normal
Menu_TbStandard | Property Get |  | General | Normal
Menu_Tools | Property Get |  | General | Normal
Menu_TrayIcon | Property Get |  | General | Normal
Menu_View | Property Get |  | General | Normal
NewActiveX | Property Get |  | General | Normal
NewButton | Property Get |  | General | Normal
NewDockablePanel | Property Get |  | General | Normal
NewDockablePersistentPanel | Property Get |  | General | Normal
NewDropDown | Property Get |  | General | Normal
NewEdit | Property Get |  | General | Normal
NewForm | Property Get |  | General | Normal
NewCheckBox | Property Get |  | General | Normal
NewLabel | Property Get |  | General | Normal
NewPanel | Property Get |  | General | Normal
NewRadioButton | Property Get |  | General | Normal
NewSpinEdit | Property Get |  | General | Normal
NewTrackBar | Property Get |  | General | Normal
NewTranspPanel | Property Get |  | General | Normal

ISDBUI overview


ISDBUI::AddMenuItem

Function AddMenuItem(ParentItem As ISDBMenuItem, InSection As Long, ItemOrder As Long) As ISDBMenuItem

Parameters

No | Name | Type | Optional | Default | Description
1 | ParentItem | ISDBMenuItem | No | - | Specifies where to add the new item, it can either be any of Menu_xxx properties or a value returned from a previous call to AddMenuItemSub
2 | InSection | Long | No | - | To which section of the ParentItem to add the new item (section is a part separated by two separator items). 0=Last section, 1=The first, 2=The second, ..., -1=The first from bottom (=the last), -2=The second from bottom, ...
3 | ItemOrder | Long | No | - | Where will the item appear within the section: 0=The last, 1=The first, 2=The second, ..., -1=The first from bottom (=the last), -2=The second from bottom, ...

Method description

AddMenuItem creates a new menu item or a toolbar item (these two are internally handled as the same).

Example code

' Add a submenu to the View menu...
Set Mnu = UI.AddMenuItemSub( UI.Menu_View, -1, 1)      ' The first item in the last section of View menu
Mnu.Caption = "Custom items"

' ... and add Statistics item there
Set SubMnu = UI.AddMenuItem( Mnu, 0, 0)    ' Add an item to the previously created menu
SubMnu.Caption = "&Statistics"

  Mnu.OnClickFunc = "ShowIt"
  Mnu.Shortcut = "Ctrl+1"
  Mnu.IconIndex = 35

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBUI::AddMenuItemSep

Function AddMenuItemSep(ParentItem As ISDBMenuItem, InSection As Long, ItemOrder As Long) As ISDBMenuItem

Parameters

No | Name | Type | Optional | Default | Description
1 | ParentItem | ISDBMenuItem | No | - | Specifies where to add the new item, it can either be any of Menu_xxx properties or a value returned from a previous call to AddMenuItemSub
2 | InSection | Long | No | - | To which section of the ParentItem to add the new item (section is a part separated by two separator items). 0=Last section, 1=The first, 2=The second, ..., -1=The first from bottom (=the last), -2=The second from bottom, ...
3 | ItemOrder | Long | No | - | Where will the item appear within the section: 0=The last, 1=The first, 2=The second, ..., -1=The first from bottom (=the last), -2=The second from bottom, ...

Method description

Works as AddMenuItem, only the created item is a separator (=a horizontal line).


ISDBUI::AddMenuItemSub

Function AddMenuItemSub(ParentItem As ISDBMenuItem, InSection As Long, ItemOrder As Long) As ISDBMenuItem

Parameters

No | Name | Type | Optional | Default | Description
1 | ParentItem | ISDBMenuItem | No | - | Specifies where to add the new item, it can either be any of Menu_xxx properties or a value returned from a previous call to AddMenuItemSub
2 | InSection | Long | No | - | To which section of the ParentItem to add the new item (section is a part separated by two separator items). 0=Last section, 1=The first, 2=The second, ..., -1=The first from bottom (=the last), -2=The second from bottom, ...
3 | ItemOrder | Long | No | - | Where will the item appear within the section: 0=The last, 1=The first, 2=The second, ..., -1=The first from bottom (=the last), -2=The second from bottom, ...

Method description

Works as AddMenuItem, only the created item contains sub-menu.


ISDBUI::AddOptionSheet

Function AddOptionSheet(SheetLabel As String, ScriptFile As String, InitProcedure As String, SaveProcedure As String, ParentId As Long) As Long

Parameters

No | Name | Type | Optional | Default | Description
1 | SheetLabel | String | No | - | A label that appears in the tree of option sheet.
2 | ScriptFile | String | No | - | A script file that contains event functions (InitProcedure and SaveProcedure).
3 | InitProcedure | String | No | - | A function from ScriptFile that is called when Options dialog is created. There is one parameter present - a reference to the sheet (SDBUITranspPanel)
4 | SaveProcedure | String | No | - | A function from ScriptFile that is called when Options is closed by Ok button. There is one parameter present - a reference to the sheet (SDBUITranspPanel)
5 | ParentId | Long | No | - | Either an ID returned from a previous call to AddOptionSheet or 0 for a last sheet, -1 for General sheet, -2 for Player sheet, -3 for Library sheet, -4 for Portable sheet, -5 for Appearance sheet.

Method description

Creates a new sheet that appears in Options dialog.

Example code

Sub OnStartup
  ' Create our own option sheet
  ind = SDB.UI.AddOptionSheet( "Test", Script.ScriptPath, "InitSheet", "SaveSheet", 0)
  ' Create another sheet as a child of the previous one
  SDB.UI.AddOptionSheet "Test2", Script.ScriptPath, "InitSheet2", "", ind
  ' Create one more sheet that is a child of Player sheet
  SDB.UI.AddOptionSheet "Player test", Script.ScriptPath, "InitSheet2", "", -2
End Sub

Sub InitSheet( Sheet)
 ' Prepare the sheet here...
End Sub

Sub SaveSheet( Sheet)
 ' Save entered values
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBUI::Menu_Edit

Property Get Menu_Edit As SDBMenuItem

No parameters

Property description

Menu item of the main 'Edit' menu.


ISDBUI::Menu_Export

Property Get Menu_Export As SDBMenuItem

No parameters

Property description

Menu item of 'File|Export' menu.


ISDBUI::Menu_File

Property Get Menu_File As ISDBMenuItem

No parameters

Property description

Menu item of the main 'File' menu.


ISDBUI::Menu_Help

Property Get Menu_Help As SDBMenuItem

No parameters

Property description

Menu item of the main 'Help' menu.


ISDBUI::Menu_Play

Property Get Menu_Play As SDBMenuItem

No parameters

Property description

Menu item of the main 'Play' menu.


ISDBUI::Menu_Pop_NP

Property Get Menu_Pop_NP As SDBMenuItem

No parameters

Property description

The pop-up menu in Now Playing window.


ISDBUI::Menu_Pop_NP_MoreFrom

Property Get Menu_Pop_NP_MoreFrom As SDBMenuItem

No parameters

Property description

'More from....' item of the pop-up menu in Now Playing window.


ISDBUI::Menu_Pop_NP_SendTo

Property Get Menu_Pop_NP_SendTo As SDBMenuItem

No parameters

Property description

'Send to....' item of the pop-up menu in Now Playing window.


ISDBUI::Menu_Pop_TrackList

Property Get Menu_Pop_TrackList As SDBMenuItem

No parameters

Property description

Pop-up menu of the track list window.


ISDBUI::Menu_Pop_TrackList_MoreFrom

Property Get Menu_Pop_TrackList_MoreFrom As SDBMenuItem

No parameters

Property description

'More from....' item of the pop-up menu in track list window.


ISDBUI::Menu_Pop_TrackList_SendTo

Property Get Menu_Pop_TrackList_SendTo As SDBMenuItem

No parameters

Property description

'Send to....' item of the pop-up menu in track list window.


ISDBUI::Menu_Pop_Tree

Property Get Menu_Pop_Tree As SDBMenuItem

No parameters

Property description

Pop-up menu of the main tree.


ISDBUI::Menu_Pop_Tree_SendTo

Property Get Menu_Pop_Tree_SendTo As SDBMenuItem

No parameters

Property description

'Send to....' item of the pop-up menu of the main tree..


ISDBUI::Menu_Scripts

Property Get Menu_Scripts As SDBMenuItem

No parameters

Property description

Menu item of 'Tools|Scripts' menu.


ISDBUI::Menu_TbAdvanced

Property Get Menu_TbAdvanced As SDBMenuItem

No parameters

Property description

Advanced toolbar.


ISDBUI::Menu_TbCategorize

Property Get Menu_TbCategorize As SDBMenuItem

No parameters

Property description

Categorize toolbar.


ISDBUI::Menu_TbEdit

Property Get Menu_TbEdit As SDBMenuItem

No parameters

Property description

Edit toolbar.


ISDBUI::Menu_TbNavigation

Property Get Menu_TbNavigation As SDBMenuItem

No parameters

Property description

Navigation toolbar.


ISDBUI::Menu_TbNPEdit

Property Get Menu_TbNPEdit As SDBMenuItem

No parameters

Property description

Edit item of the menu in Now Playing window.


ISDBUI::Menu_TbNPList

Property Get Menu_TbNPList As SDBMenuItem

No parameters

Property description

List item of the menu in Now Playing window.


ISDBUI::Menu_TbNPMain

Property Get Menu_TbNPMain As SDBMenuItem

No parameters

Property description

The menu of Now Playing window.


ISDBUI::Menu_TbSearch

Property Get Menu_TbSearch As SDBMenuItem

No parameters

Property description

Search toolbar.


ISDBUI::Menu_TbStandard

Property Get Menu_TbStandard As SDBMenuItem

No parameters

Property description

Standard toolbar (the main one).


ISDBUI::Menu_Tools

Property Get Menu_Tools As SDBMenuItem

No parameters

Property description

Menu item of the main 'Tools' menu.


ISDBUI::Menu_TrayIcon

Property Get Menu_TrayIcon As SDBMenuItem

No parameters

Property description

Menu item of the tray icon menu. It can be used to place menu items to tray icon menu.


ISDBUI::Menu_View

Property Get Menu_View As SDBMenuItem

No parameters

Property description

Menu item of the main 'View' menu.


ISDBUI::NewActiveX

Property Get NewActiveX(Owner As Object, ProgID As String) As ISDBUIActiveX

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.
2 | ProgID | String | No | - | ProgID of the control to be created, e.g. 'Shell.Explorer' for a web browser from IE.

Property description

Creates a new ActiveX control.

Example code

' An example of how to create a web browser control (that can display any HTML page).

Set WB = UI.NewActiveX( Form, "Shell.Explorer")
WB.Common.Align = 5      ' Fill all client rectangle
WB.Interf.Navigate "about:"          ' A trick to make sure document exists
Set Doc = WB.Interf.Document

Doc.Write "Hello world!"
Doc.Close

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBUI::NewButton

Property Get NewButton(Owner As Object) As ISDBUIButton

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new button.


ISDBUI::NewDockablePanel

Property Get NewDockablePanel As SDBUIDockablePanel

No parameters

Property description

Creates a new dockable panel on the main window.


ISDBUI::NewDockablePersistentPanel

Property Get NewDockablePersistentPanel(PanelName As String) As SDBUIDockablePanel

Parameters

No | Name | Type | Optional | Default | Description
1 | PanelName | String | No | - | An indentifier for the panel (used for persistance).

Property description

Creates a new dockable panel on the main window and persists its position for next MediaMonkey sessions.


ISDBUI::NewDropDown

Property Get NewDropDown(Owner As Object) As ISDBUIDropDown

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new drop-down list.


ISDBUI::NewEdit

Property Get NewEdit(Owner As Object) As ISDBUIEdit

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new edit box.


ISDBUI::NewForm

Property Get NewForm As ISDBUIForm

No parameters

Property description

Creates a new Form object. You can place additional controls on it then.

Example code

Set Form = SDB.UI.NewForm
Form.Common.SetRect 100, 100, 500, 400
Form.Caption = "Statistics"

Set Btn = SDB.UI.NewButton( Form)
Btn.Caption = "Close"
Btn.Common.SetRect 10, 10, 100, 20

Form.ShowModal

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBUI::NewCheckBox

Property Get NewCheckBox(Owner As Object) As ISDBUICheckBox

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new checkbox.


ISDBUI::NewLabel

Property Get NewLabel(Owner As Object) As ISDBUILabel

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new label (a static text).


ISDBUI::NewPanel

Property Get NewPanel(Owner As Object) As ISDBUIPanel

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new panel.


ISDBUI::NewRadioButton

Property Get NewRadioButton(Owner As Object) As ISDBUIRadioButton

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - |

Property description

Creates a new radio button.


ISDBUI::NewSpinEdit

Property Get NewSpinEdit(Owner As Object) As SDBUISpinEdit

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - |

Property description

Creates a new edit line for integers with up and down arrows.


ISDBUI::NewTrackBar

Property Get NewTrackBar(Owner As Object) As SDBUITrackBar

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new trackbar.


ISDBUI::NewTranspPanel

Property Get NewTranspPanel(Owner As Object) As ISDBUITranspPanel

Parameters

No | Name | Type | Optional | Default | Description
1 | Owner | Object | No | - | Parent control of the newly created control.

Property description

Creates a new transparent panel.


Coclass: SDBUIActiveX

ActiveX object (UI element).


Interface: ISDBUIActiveX

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIActiveX

ISDBUIActiveX members

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Interf | Property Get |  | General | Normal

ISDBUIActiveX overview


Interface ISDBUIActiveX

ISDBUIActiveX members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Interf | Property Get |  | General | Normal

ISDBUIActiveX overview


Interface ISDBUIActiveX

ISDBUIActiveX members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Interf | Property Get |  | General | Normal

ISDBUIActiveX overview


ISDBUIActiveX::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIActiveX::Interf

Property Get Interf As Object

No parameters

Property description

This property allows to access all methods and properties of the underlying ActiveX object.


Interface: ISDBUIActiveXEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIActiveXEvents

ISDBUIActiveXEvents members

ISDBUIActiveXEvents overview


Interface ISDBUIActiveXEvents

ISDBUIActiveXEvents members by category

ISDBUIActiveXEvents overview


Interface ISDBUIActiveXEvents

ISDBUIActiveXEvents members by frequency of use

ISDBUIActiveXEvents overview


Coclass: SDBUIButton

Button (UI element).


Interface: ISDBUIButton

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIButton

ISDBUIButton members

Properties

Name | Type | HelpString | Category | Frequency of use
Cancel | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Default | Property Get/Let |  | General | Normal
ModalResult | Property Get/Let |  | General | Normal
OnClickFunc | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal

ISDBUIButton overview


Interface ISDBUIButton

ISDBUIButton members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Cancel | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Default | Property Get/Let |  | General | Normal
ModalResult | Property Get/Let |  | General | Normal
OnClickFunc | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal

ISDBUIButton overview


Interface ISDBUIButton

ISDBUIButton members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Cancel | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Default | Property Get/Let |  | General | Normal
ModalResult | Property Get/Let |  | General | Normal
OnClickFunc | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal

ISDBUIButton overview


ISDBUIButton::Cancel

Property Get/Let Cancel As Boolean

No parameters

Property description

This property specifies whether this button is a Cancel button, i.e. if it's called when user presses Esc key.


ISDBUIButton::Caption

Property Get/Let Caption As String

No parameters

Property description

A string that is shown in the button.


ISDBUIButton::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIButton::Default

Property Get/Let Default As Boolean

No parameters

Property description

Specifies whether the button is the default button, i.e. if called when Enter key is pressed.


ISDBUIButton::ModalResult

Property Get/Let ModalResult As Long

No parameters

Property description

An integer value that is returned by ShowModal when the button is clicked.


ISDBUIButton::OnClickFunc

Property Get/Let OnClickFunc As String

No parameters

Property description

Name of the function that is called when the button is clicked. The function is expected to be in 'UseScript' file. There is one parameter passed to the function - this button (SDBUIButton object).

Example code

'The function to be called can look like:

Sub OnbuttonClick( Btn)
  ' Some code here
End Sub

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBUIButton::UseScript

Property Get/Let UseScript As String

No parameters

Property description

Filename of a script where event functions are located.


Interface: ISDBUIButtonEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIButtonEvents

ISDBUIButtonEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal

ISDBUIButtonEvents overview


Interface ISDBUIButtonEvents

ISDBUIButtonEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal

ISDBUIButtonEvents overview


Interface ISDBUIButtonEvents

ISDBUIButtonEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal

ISDBUIButtonEvents overview


ISDBUIButtonEvents::OnClick

Sub OnClick

No parameters

Event description

This event is called when button is clicked.


Coclass: SDBUICommon

Object with properties common to all user interface elements used in MediaMonkey.


Interface: ISDBUICommon

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUICommon

ISDBUICommon members

Properties

Name | Type | HelpString | Category | Frequency of use
Align | Property Get/Let |  | General | Normal
Anchors | Property Get/Let |  | General | Normal
ClientHeight | Property Get/Let |  | General | Normal
ClientWidth | Property Get/Let |  | General | Normal
ControlName | Property Get/Let |  | General | Normal
Enabled | Property Get/Let |  | General | Normal
Height | Property Get/Let |  | General | Normal
Hint | Property Get/Let |  | General | Normal
ChildControl | Property Get |  | General | Normal
Left | Property Get/Let |  | General | Normal
MaxHeight | Property Get/Let |  | General | Normal
MaxWidth | Property Get/Let |  | General | Normal
MinHeight | Property Get/Let |  | General | Normal
MinWidth | Property Get/Let |  | General | Normal
Parent | Property Get |  | General | Normal
SetRect | Method |  | General | Normal
Top | Property Get/Let |  | General | Normal
TopParent | Property Get |  | General | Normal
Visible | Property Get/Let |  | General | Normal
Width | Property Get/Let |  | General | Normal

ISDBUICommon overview


Interface ISDBUICommon

ISDBUICommon members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Align | Property Get/Let |  | General | Normal
Anchors | Property Get/Let |  | General | Normal
ClientHeight | Property Get/Let |  | General | Normal
ClientWidth | Property Get/Let |  | General | Normal
ControlName | Property Get/Let |  | General | Normal
Enabled | Property Get/Let |  | General | Normal
Height | Property Get/Let |  | General | Normal
Hint | Property Get/Let |  | General | Normal
ChildControl | Property Get |  | General | Normal
Left | Property Get/Let |  | General | Normal
MaxHeight | Property Get/Let |  | General | Normal
MaxWidth | Property Get/Let |  | General | Normal
MinHeight | Property Get/Let |  | General | Normal
MinWidth | Property Get/Let |  | General | Normal
Parent | Property Get |  | General | Normal
SetRect | Method |  | General | Normal
Top | Property Get/Let |  | General | Normal
TopParent | Property Get |  | General | Normal
Visible | Property Get/Let |  | General | Normal
Width | Property Get/Let |  | General | Normal

ISDBUICommon overview


Interface ISDBUICommon

ISDBUICommon members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Align | Property Get/Let |  | General | Normal
Anchors | Property Get/Let |  | General | Normal
ClientHeight | Property Get/Let |  | General | Normal
ClientWidth | Property Get/Let |  | General | Normal
ControlName | Property Get/Let |  | General | Normal
Enabled | Property Get/Let |  | General | Normal
Height | Property Get/Let |  | General | Normal
Hint | Property Get/Let |  | General | Normal
ChildControl | Property Get |  | General | Normal
Left | Property Get/Let |  | General | Normal
MaxHeight | Property Get/Let |  | General | Normal
MaxWidth | Property Get/Let |  | General | Normal
MinHeight | Property Get/Let |  | General | Normal
MinWidth | Property Get/Let |  | General | Normal
Parent | Property Get |  | General | Normal
SetRect | Method |  | General | Normal
Top | Property Get/Let |  | General | Normal
TopParent | Property Get |  | General | Normal
Visible | Property Get/Let |  | General | Normal
Width | Property Get/Let |  | General | Normal

ISDBUICommon overview


ISDBUICommon::Align

Property Get/Let Align As Long

No parameters

Property description

Value of this property controls alignment of the control in its parent control. It is mostly used for panels. It can be: 0 (alNone) - No alignment is applied. 1 (alTop) - Control is aligned to the top. 2 (alBottom) - Control is aligned to the bottom. 3 (alLeft) - Control is aligned to the left. 4 (alRight) - Control is aligned to the right. 5 (alClient) - Control completely covers its parent.

Example code

Set Head = UI.NewPanel( Form)
Head.Common.Align = 1   ' Align panel to the top of form


ISDBUICommon::Anchors

Property Get/Let Anchors As Long

No parameters

Property description

Anchors control to which borders of the parent control is this control sticked. It is useful for resizable forms in order to maintain proper positions of controls. It can be any combination of the following: 1 (akLeft) - Distance from the left border of the parent is constant. 2 (akTop) - Distance from the top border of the parent is constant. 4 (akRight) - Distance from the right border of the parent is constant. 8 (akBottom) - Distance from the bottom border of the parent is constant.

Example code

Btn.Common.Anchors = 4+8   ' The button is always in a constant distance from Bottom Right corner.


ISDBUICommon::ClientHeight

Property Get/Let ClientHeight As Long

No parameters

Property description

Height of the inner part of the control. It is mainly useful for forms where this value means height of the form without the caption bar and borders.


ISDBUICommon::ClientWidth

Property Get/Let ClientWidth As Long

No parameters

Property description

Width of the inner part of the control. It is mainly useful for forms where this value means width of the form without borders.


ISDBUICommon::ControlName

Property Get/Let ControlName As String

No parameters

Property description

Name that is internally assigned to the control. You can for example use ChildControl method to locate such control then.


ISDBUICommon::Enabled

Property Get/Let Enabled As Boolean

No parameters

Property description

Specifies whether user can work with the control or it is disabled.


ISDBUICommon::Height

Property Get/Let Height As Long

No parameters

Property description

Height of the control.


ISDBUICommon::Hint

Property Get/Let Hint As String

No parameters

Property description

A string that is shown if mouse cursor stays on the control.


ISDBUICommon::ChildControl

Property Get ChildControl(ControlName As String) As Object

Parameters

No | Name | Type | Optional | Default | Description
1 | ControlName | String | No | - | Name of the control to be found

Property description

This property can easily localize a control by its name.

Example code

Set Btn = Form.Common.ChildControl( "Button1")   ' Finds a button named 'Button1'


ISDBUICommon::Left

Property Get/Let Left As Long

No parameters

Property description

Left side of the control.


ISDBUICommon::MaxHeight

Property Get/Let MaxHeight As Long

No parameters

Property description

Maximum height of the control. User cannot resize it outside of specified region.


ISDBUICommon::MaxWidth

Property Get/Let MaxWidth As Long

No parameters

Property description

Maximum width of the control. User cannot resize it outside of specified region.


ISDBUICommon::MinHeight

Property Get/Let MinHeight As Long

No parameters

Property description

Minimum height of the control. User cannot resize it outside of specified region.


ISDBUICommon::MinWidth

Property Get/Let MinWidth As Long

No parameters

Property description

Minimum width of the control. User cannot resize it outside of specified region.


ISDBUICommon::Parent

Property Get Parent As Object

No parameters

Property description

Parent control of this control.


ISDBUICommon::SetRect

Sub SetRect(Left As Long, Top As Long, Width As Long, Height As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Left | Long | No | - | Left side of the control
2 | Top | Long | No | - | Top side of the control
3 | Width | Long | No | - | Width of the control
4 | Height | Long | No | - | Height of the control

Method description

A faster way how to set position and size of a control.


ISDBUICommon::Top

Property Get/Let Top As Long

No parameters

Property description

Top side of the control.


ISDBUICommon::TopParent

Property Get TopParent As Object

No parameters

Property description

Iterates through Parent properties to find the top-most parent of this control (usually a form).


ISDBUICommon::Visible

Property Get/Let Visible As Boolean

No parameters

Property description

Controls whether the control is visible.


ISDBUICommon::Width

Property Get/Let Width As Long

No parameters

Property description

Width of the control.


Interface: ISDBUICommonEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUICommonEvents

ISDBUICommonEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal
OnResize | Event |  | General | Normal

ISDBUICommonEvents overview


Interface ISDBUICommonEvents

ISDBUICommonEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal
OnResize | Event |  | General | Normal

ISDBUICommonEvents overview


Interface ISDBUICommonEvents

ISDBUICommonEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnClick | Event |  | General | Normal
OnResize | Event |  | General | Normal

ISDBUICommonEvents overview


ISDBUICommonEvents::OnClick

Sub OnClick(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |

Event description

This event is called when the associated control is clicked.


ISDBUICommonEvents::OnResize

Sub OnResize(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |

Event description

This event is called when the associated control is resized.


Coclass: SDBUIDockablePanel

Panel that can be docked to the main window (UI element).


Interface: ISDBUIDockablePanel

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIDockablePanel

ISDBUIDockablePanel members

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
DockedTo | Property Get/Let |  | General | Normal
IsNew | Property Get |  | General | Normal
Persistent | Property Get/Let |  | General | Normal

ISDBUIDockablePanel overview


Interface ISDBUIDockablePanel

ISDBUIDockablePanel members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
DockedTo | Property Get/Let |  | General | Normal
IsNew | Property Get |  | General | Normal
Persistent | Property Get/Let |  | General | Normal

ISDBUIDockablePanel overview


Interface ISDBUIDockablePanel

ISDBUIDockablePanel members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
DockedTo | Property Get/Let |  | General | Normal
IsNew | Property Get |  | General | Normal
Persistent | Property Get/Let |  | General | Normal

ISDBUIDockablePanel overview


ISDBUIDockablePanel::Caption

Property Get/Let Caption As String

No parameters

Property description

Title of the panel to be shown.


ISDBUIDockablePanel::Common

Property Get Common As SDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIDockablePanel::DockedTo

Property Get/Let DockedTo As Long

No parameters

Property description

Specifies to which dock position this panel is docked: 0..Undocked 1..Left 2..Right 3..Top 4..Bottom -1..Unknown


ISDBUIDockablePanel::IsNew

Property Get IsNew As Boolean

No parameters

Property description

Whether this panel was created for the first time. (the other case is that the panel already existed in the previous session and its size/position was saved).

Example code

Set Pnl = UI.NewDockablePersistentPanel("TestingPanel")
If Pnl.IsNew Then
  Pnl.DockedTo = 2
  Pnl.Common.Width = 250
End If

(C) 2000-2005 Ventis Media Inc. All rights reserved


ISDBUIDockablePanel::Persistent

Property Get/Let Persistent As Boolean

No parameters

Property description

Whether position of this panel persists.


Interface: ISDBUIDockablePanelEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIDockablePanelEvents

ISDBUIDockablePanelEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnClose | Event |  | General | Normal
OnDockChanged | Event |  | General | Normal

ISDBUIDockablePanelEvents overview


Interface ISDBUIDockablePanelEvents

ISDBUIDockablePanelEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnClose | Event |  | General | Normal
OnDockChanged | Event |  | General | Normal

ISDBUIDockablePanelEvents overview


Interface ISDBUIDockablePanelEvents

ISDBUIDockablePanelEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnDockChanged | Event |  | General | Normal
OnClose | Event |  | General | Normal

ISDBUIDockablePanelEvents overview


ISDBUIDockablePanelEvents::OnClose

Sub OnClose(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |

Event description

This event is called when user closes the panel.


ISDBUIDockablePanelEvents::OnDockChanged

Sub OnDockChanged(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |

Event description

This event is called whenever user docks the panel to another part of MediaMonkey's UI.


Coclass: SDBUIDropDown

Drop-down box (UI element).


Interface: ISDBUIDropDown

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIDropDown

ISDBUIDropDown members

Properties

Name | Type | HelpString | Category | Frequency of use
AddItem | Method |  | General | Normal
Common | Property Get |  | General | Normal
DeleteItem | Method |  | General | Normal
ItemCount | Property Get |  | General | Normal
ItemIndex | Property Get/Let |  | General | Normal
ItemText | Property Get/Let |  | General | Normal
OnSelectFunc | Property Get/Let |  | General | Normal
Style | Property Get/Let |  | General | Normal
Text | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal

ISDBUIDropDown overview


Interface ISDBUIDropDown

ISDBUIDropDown members by category

Properties

Name | Type | HelpString | Category | Frequency of use
AddItem | Method |  | General | Normal
Common | Property Get |  | General | Normal
DeleteItem | Method |  | General | Normal
ItemCount | Property Get |  | General | Normal
ItemIndex | Property Get/Let |  | General | Normal
ItemText | Property Get/Let |  | General | Normal
OnSelectFunc | Property Get/Let |  | General | Normal
Style | Property Get/Let |  | General | Normal
Text | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal

ISDBUIDropDown overview


Interface ISDBUIDropDown

ISDBUIDropDown members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
AddItem | Method |  | General | Normal
Common | Property Get |  | General | Normal
DeleteItem | Method |  | General | Normal
ItemCount | Property Get |  | General | Normal
ItemIndex | Property Get/Let |  | General | Normal
ItemText | Property Get/Let |  | General | Normal
OnSelectFunc | Property Get/Let |  | General | Normal
Style | Property Get/Let |  | General | Normal
Text | Property Get/Let |  | General | Normal
UseScript | Property Get/Let |  | General | Normal

ISDBUIDropDown overview


ISDBUIDropDown::AddItem

Sub AddItem(Text As String)

Parameters

No | Name | Type | Optional | Default | Description
1 | Text | String | No | - | Text of item to be added.

Method description

Add new item to the list.


ISDBUIDropDown::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIDropDown::DeleteItem

Sub DeleteItem(Index As Long)

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of item to be deleted.

Method description

Removes item specified by index.


ISDBUIDropDown::ItemCount

Property Get ItemCount As Long

No parameters

Property description

The total number of items in the list.


ISDBUIDropDown::ItemIndex

Property Get/Let ItemIndex As Long

No parameters

Property description

Index of the currently selected item.


ISDBUIDropDown::ItemText

Property Get/Let ItemText(Index As Long) As String

Parameters

No | Name | Type | Optional | Default | Description
1 | Index | Long | No | - | Index of item to be get/set.

Property description

Text of item specified by 'index'.


ISDBUIDropDown::OnSelectFunc

Property Get/Let OnSelectFunc As String

No parameters

Property description

Name of the function that is called when a dropped item is selected. The function is expected to be in 'UseScript' file. There is one parameter passed to the function - this dropdown control (SDBDropDown object).


ISDBUIDropDown::Style

Property Get/Let Style As Long

No parameters

Property description

Specifies style of the drop down control. It can be: 0 (csDropDown) - Drop down control that can be edited. 2 (csDropDownList) - Drop down control that cannot be edited (user can only select from a list of values).


ISDBUIDropDown::Text

Property Get/Let Text As String

No parameters

Property description

The current value that is entered in the control.


ISDBUIDropDown::UseScript

Property Get/Let UseScript As String

No parameters

Property description

Filename of a script where event functions are located.


Interface: ISDBUIDropDownEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIDropDownEvents

ISDBUIDropDownEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnSelect | Event |  | General | Normal

ISDBUIDropDownEvents overview


Interface ISDBUIDropDownEvents

ISDBUIDropDownEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnSelect | Event |  | General | Normal

ISDBUIDropDownEvents overview


Interface ISDBUIDropDownEvents

ISDBUIDropDownEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnSelect | Event |  | General | Normal

ISDBUIDropDownEvents overview


ISDBUIDropDownEvents::OnSelect

Sub OnSelect(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |


Coclass: SDBUIEdit

Edit Box (UI element).


Interface: ISDBUIEdit

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIEdit

ISDBUIEdit members

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Text | Property Get/Let |  | General | Normal

ISDBUIEdit overview


Interface ISDBUIEdit

ISDBUIEdit members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Text | Property Get/Let |  | General | Normal

ISDBUIEdit overview


Interface ISDBUIEdit

ISDBUIEdit members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Text | Property Get/Let |  | General | Normal

ISDBUIEdit overview


ISDBUIEdit::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIEdit::Text

Property Get/Let Text As String

No parameters

Property description

Text that is entered in the edit box.


Interface: ISDBUIEditEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIEditEvents

ISDBUIEditEvents members

ISDBUIEditEvents overview


Interface ISDBUIEditEvents

ISDBUIEditEvents members by category

ISDBUIEditEvents overview


Interface ISDBUIEditEvents

ISDBUIEditEvents members by frequency of use

ISDBUIEditEvents overview


Coclass: SDBUIForm

Representation of a single window.


Interface: ISDBUIForm

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIForm

ISDBUIForm members

Properties

Name | Type | HelpString | Category | Frequency of use
BorderStyle | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
FormPosition | Property Get/Let |  | General | Normal
SavePositionName | Property Get/Let |  | General | Normal
ShowModal | Method |  | General | Normal
StayOnTop | Property Get/Let |  | General | Normal

ISDBUIForm overview


Interface ISDBUIForm

ISDBUIForm members by category

Properties

Name | Type | HelpString | Category | Frequency of use
BorderStyle | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
FormPosition | Property Get/Let |  | General | Normal
SavePositionName | Property Get/Let |  | General | Normal
ShowModal | Method |  | General | Normal
StayOnTop | Property Get/Let |  | General | Normal

ISDBUIForm overview


Interface ISDBUIForm

ISDBUIForm members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
BorderStyle | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
FormPosition | Property Get/Let |  | General | Normal
SavePositionName | Property Get/Let |  | General | Normal
ShowModal | Method |  | General | Normal
StayOnTop | Property Get/Let |  | General | Normal

ISDBUIForm overview


ISDBUIForm::BorderStyle

Property Get/Let BorderStyle As Long

No parameters

Property description

Specifies how the form looks like: 0 (bsNone) - there isn't any border 2 (bsSizeable) - a standard resizable window 3 (bsDialog) - a dialog that isn't resizable 4 (bsToolWindow) - a tool window 5 (bsSizeToolWin) - a resizable toolwindow


ISDBUIForm::Caption

Property Get/Let Caption As String

No parameters

Property description

Caption of the form.


ISDBUIForm::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIForm::FormPosition

Property Get/Let FormPosition As Long

No parameters

Property description

The initial position of the form, can be one of: 0 (poDesigned) - The position and size specified by Left, Top, Width and Height. 1 (poDefault) - The position and size determined by the operating system. 4 (poScreenCenter) - The form appears centered on the screen.


ISDBUIForm::SavePositionName

Property Get/Let SavePositionName As String

No parameters

Property description

If specified dimensions of the form are saved to registry and next time the same string is used for SavePositionName the form is restored to the same position.


ISDBUIForm::ShowModal

Function ShowModal As Long

No parameters

Method description

This method shows the form and waits until user closes it.


ISDBUIForm::StayOnTop

Property Get/Let StayOnTop As Boolean

No parameters

Property description

Specifies whether this form stays on top over other MM forms.


Interface: ISDBUIFormEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIFormEvents

ISDBUIFormEvents members

Properties

Name | Type | HelpString | Category | Frequency of use
OnClose | Event |  | General | Normal

ISDBUIFormEvents overview


Interface ISDBUIFormEvents

ISDBUIFormEvents members by category

Properties

Name | Type | HelpString | Category | Frequency of use
OnClose | Event |  | General | Normal

ISDBUIFormEvents overview


Interface ISDBUIFormEvents

ISDBUIFormEvents members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
OnClose | Event |  | General | Normal

ISDBUIFormEvents overview


ISDBUIFormEvents::OnClose

Sub OnClose(Control As Object)

Parameters

No | Name | Type | Optional | Default | Description
1 | Control | Object | No | - |

Event description

This event is called when its form is closed.


Coclass: SDBUICheckBox

Checkbox (UI element).


Interface: ISDBUICheckBox

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUICheckBox

ISDBUICheckBox members

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Checked | Property Get/Let |  | General | Normal

ISDBUICheckBox overview


Interface ISDBUICheckBox

ISDBUICheckBox members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Checked | Property Get/Let |  | General | Normal

ISDBUICheckBox overview


Interface ISDBUICheckBox

ISDBUICheckBox members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Checked | Property Get/Let |  | General | Normal

ISDBUICheckBox overview


ISDBUICheckBox::Caption

Property Get/Let Caption As String

No parameters

Property description

Get/set a caption of the checkbox.


ISDBUICheckBox::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUICheckBox::Checked

Property Get/Let Checked As Boolean

No parameters

Property description

Get/set whether the checkbox is checked.


Interface: ISDBUICheckBoxEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUICheckBoxEvents

ISDBUICheckBoxEvents members

ISDBUICheckBoxEvents overview


Interface ISDBUICheckBoxEvents

ISDBUICheckBoxEvents members by category

ISDBUICheckBoxEvents overview


Interface ISDBUICheckBoxEvents

ISDBUICheckBoxEvents members by frequency of use

ISDBUICheckBoxEvents overview


Coclass: SDBUILabel

Label - a static text (UI element).


Interface: ISDBUILabel

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUILabel

ISDBUILabel members

Properties

Name | Type | HelpString | Category | Frequency of use
Alignment | Property Get/Let |  | General | Normal
Autosize | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Multiline | Property Get/Let |  | General | Normal

ISDBUILabel overview


Interface ISDBUILabel

ISDBUILabel members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Alignment | Property Get/Let |  | General | Normal
Autosize | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Multiline | Property Get/Let |  | General | Normal

ISDBUILabel overview


Interface ISDBUILabel

ISDBUILabel members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Alignment | Property Get/Let |  | General | Normal
Autosize | Property Get/Let |  | General | Normal
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Multiline | Property Get/Let |  | General | Normal

ISDBUILabel overview


ISDBUILabel::Alignment

Property Get/Let Alignment As Long

No parameters

Property description

Specifies how the Caption is aligned: 0..Left 1..Right 2..Center


ISDBUILabel::Autosize

Property Get/Let Autosize As Boolean

No parameters

Property description

Whether label size is automatically adjusted according to the entered text.


ISDBUILabel::Caption

Property Get/Let Caption As String

No parameters

Property description

Get/set a caption of the checkbox.


ISDBUILabel::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUILabel::Multiline

Property Get/Let Multiline As Boolean

No parameters

Property description

Whether text can be wrapped over several lines.


Interface: ISDBUILabelEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUILabelEvents

ISDBUILabelEvents members

ISDBUILabelEvents overview


Interface ISDBUILabelEvents

ISDBUILabelEvents members by category

ISDBUILabelEvents overview


Interface ISDBUILabelEvents

ISDBUILabelEvents members by frequency of use

ISDBUILabelEvents overview


Coclass: SDBUIPanel

Panel (UI element).


Interface: ISDBUIPanel

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIPanel

ISDBUIPanel members

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal

ISDBUIPanel overview


Interface ISDBUIPanel

ISDBUIPanel members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal

ISDBUIPanel overview


Interface ISDBUIPanel

ISDBUIPanel members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal

ISDBUIPanel overview


ISDBUIPanel::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


Interface: ISDBUIPanelEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIPanelEvents

ISDBUIPanelEvents members

ISDBUIPanelEvents overview


Interface ISDBUIPanelEvents

ISDBUIPanelEvents members by category

ISDBUIPanelEvents overview


Interface ISDBUIPanelEvents

ISDBUIPanelEvents members by frequency of use

ISDBUIPanelEvents overview


Coclass: SDBUIRadioButton

Radio button (UI element).


Interface: ISDBUIRadioButton

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIRadioButton

ISDBUIRadioButton members

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Checked | Property Get/Let |  | General | Normal

ISDBUIRadioButton overview


Interface ISDBUIRadioButton

ISDBUIRadioButton members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Checked | Property Get/Let |  | General | Normal

ISDBUIRadioButton overview


Interface ISDBUIRadioButton

ISDBUIRadioButton members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Caption | Property Get/Let |  | General | Normal
Common | Property Get |  | General | Normal
Checked | Property Get/Let |  | General | Normal

ISDBUIRadioButton overview


ISDBUIRadioButton::Caption

Property Get/Let Caption As String

No parameters

Property description

A string that is shown beside the radio button.


ISDBUIRadioButton::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUIRadioButton::Checked

Property Get/Let Checked As Boolean

No parameters

Property description

State of the radio button.


Interface: ISDBUIRadioButtonEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUIRadioButtonEvents

ISDBUIRadioButtonEvents members

ISDBUIRadioButtonEvents overview


Interface ISDBUIRadioButtonEvents

ISDBUIRadioButtonEvents members by category

ISDBUIRadioButtonEvents overview


Interface ISDBUIRadioButtonEvents

ISDBUIRadioButtonEvents members by frequency of use

ISDBUIRadioButtonEvents overview


Coclass: SDBUISpinEdit

Edit line with up/down arrows (UI element).


Interface: ISDBUISpinEdit

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUISpinEdit

ISDBUISpinEdit members

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
MinValue | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBUISpinEdit overview


Interface ISDBUISpinEdit

ISDBUISpinEdit members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
MinValue | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBUISpinEdit overview


Interface ISDBUISpinEdit

ISDBUISpinEdit members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
MinValue | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBUISpinEdit overview


ISDBUISpinEdit::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUISpinEdit::MaxValue

Property Get/Let MaxValue As Long

No parameters

Property description

Maximum value of the edit box allowed.


ISDBUISpinEdit::MinValue

Property Get/Let MinValue As Long

No parameters

Property description

Minimum value of the edit box allowed.


ISDBUISpinEdit::Value

Property Get/Let Value As Long

No parameters

Property description

Current value of the edit box (integer).


Interface: ISDBUISpinEditEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUISpinEditEvents

ISDBUISpinEditEvents members

ISDBUISpinEditEvents overview


Interface ISDBUISpinEditEvents

ISDBUISpinEditEvents members by category

ISDBUISpinEditEvents overview


Interface ISDBUISpinEditEvents

ISDBUISpinEditEvents members by frequency of use

ISDBUISpinEditEvents overview


Coclass: SDBUITrackBar

Track bar (UI element).


Interface: ISDBUITrackBar

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUITrackBar

ISDBUITrackBar members

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Horizontal | Property Get/Let |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
MinValue | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBUITrackBar overview


Interface ISDBUITrackBar

ISDBUITrackBar members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Horizontal | Property Get/Let |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
MinValue | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBUITrackBar overview


Interface ISDBUITrackBar

ISDBUITrackBar members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal
Horizontal | Property Get/Let |  | General | Normal
MaxValue | Property Get/Let |  | General | Normal
MinValue | Property Get/Let |  | General | Normal
Value | Property Get/Let |  | General | Normal

ISDBUITrackBar overview


ISDBUITrackBar::Common

Property Get Common As SDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


ISDBUITrackBar::Horizontal

Property Get/Let Horizontal As Boolean

No parameters

Property description

Whether the trackbar has horizontal (or vertical) orientation.


ISDBUITrackBar::MaxValue

Property Get/Let MaxValue As Long

No parameters

Property description

Maximal value of the trackbar.


ISDBUITrackBar::MinValue

Property Get/Let MinValue As Long

No parameters

Property description

Minimal value of the trackbar.


ISDBUITrackBar::Value

Property Get/Let Value As Long

No parameters

Property description

Selected value of the trackbar.


Interface: ISDBUITrackBarEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUITrackBarEvents

ISDBUITrackBarEvents members

ISDBUITrackBarEvents overview


Interface ISDBUITrackBarEvents

ISDBUITrackBarEvents members by category

ISDBUITrackBarEvents overview


Interface ISDBUITrackBarEvents

ISDBUITrackBarEvents members by frequency of use

ISDBUITrackBarEvents overview


Coclass: SDBUITranspPanel

Transparent panel (UI element).


Interface: ISDBUITranspPanel

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUITranspPanel

ISDBUITranspPanel members

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal

ISDBUITranspPanel overview


Interface ISDBUITranspPanel

ISDBUITranspPanel members by category

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal

ISDBUITranspPanel overview


Interface ISDBUITranspPanel

ISDBUITranspPanel members by frequency of use

Properties

Name | Type | HelpString | Category | Frequency of use
Common | Property Get |  | General | Normal

ISDBUITranspPanel overview


ISDBUITranspPanel::Common

Property Get Common As ISDBUICommon

No parameters

Property description

Returns SDBUICommon object that can be used to modify basic properties of this object, e.g. position, size, etc.


Interface: ISDBUITranspPanelEvents

Browse members alphabetically

Browse members by category

Browse members by use


Interface ISDBUITranspPanelEvents

ISDBUITranspPanelEvents members

ISDBUITranspPanelEvents overview


Interface ISDBUITranspPanelEvents

ISDBUITranspPanelEvents members by category

ISDBUITranspPanelEvents overview


Interface ISDBUITranspPanelEvents

ISDBUITranspPanelEvents members by frequency of use

ISDBUITranspPanelEvents overview


Enumerations

Enumeration EnumMsgBox

Enumeration EnumCacheStatus

Enumeration EnumChannels

Enumeration EnumPreview

Enumeration EnumTreeNodePos

Enumeration EnumYesNo


Enumeration EnumMsgBox

Member name | Member value
MsgBox_Warning | 0
MsgBox_Error | 1
MsgBox_Information | 2
MsgBox_Confirmation | 3


Enumeration EnumCacheStatus

Member name | Member value
Cache_None | 0
Cache_Queued | 1
Cache_Cached | 2


Enumeration EnumChannels

Member name | Member value
ChannelsMono | 0
ChannelsStereo | 1


Enumeration EnumPreview

Member name | Member value
Preview_None | 0
Preview_Exists | 1


Enumeration EnumTreeNodePos

Member name | Member value
NodePos_InsertBefore | 0
NodePos_InsertAfter | 1
NodePos_AddChildFirst | 2
NodePos_AddChildLast | 3


Enumeration EnumYesNo

Member name | Member value
YesNo_Default | -1
YesNo_Yes | 1
YesNo_No | 0


ISDBAlbumArtList::Add

Sub Add(Item As ISDBAlbumArtItem)

Parameters

No | Name | Type | Optional | Default | Description
1 | Item | ISDBAlbumArtItem | No | - |