Access violation at address 00AFADFC

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Access violation at address 00AFADFC

Re: Access violation at address 00AFADFC

by Jlexa » Mon Aug 14, 2017 10:05 am

Windows updates can be the reason of this error, especially if you use a pirated version of OS. Try to gradually remove the latest updates until the error notifications stop appearing.

Re: Access violation at address errors RESOLUTION

by MMFrLife » Thu Jun 18, 2015 8:58 pm

Carolyn wrote:I work in I.T. and it was killing me trying to figure out the resolution and finally did. The skin you have selected is corrupt. Change it! :D
Which post/poster/AV issue are you referring to?
Can you give us a bit more context for your reply?

Access violation at address errors RESOLUTION

by Carolyn » Thu Jun 18, 2015 8:39 pm

I work in I.T. and it was killing me trying to figure out the resolution and finally did. The skin you have selected is corrupt. Change it! :D

Re: Access violation at address 00AFADFC

by Lowlander » Sat May 16, 2015 11:13 am

Access Violations should be captured with a debug log (step 4b) and the log send to support: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=69

Re: Access violation at address 00AFADFC

by MMFrLife » Sat May 16, 2015 6:05 am

I just discovered something interesting this morning when attempting to listen to an album of tracks.
I brought up the album using search. I attempted to click on a track and got an Access Violation.... error.

I tried all the tracks, and the same thing. I looked at their paths and they were all correct from what I could tell.
So, thinking this wouldn't do anything - but what the hey, I did a locate moved/missing tracks on the folder and
the results came back as "0" in all categories, as expected. Yet, now when I click on any of the tracks, they all played perfectly fine (no error).

Re: Access violation at address 00AFADFC

by MMFrLife » Thu May 07, 2015 2:47 pm

Also, are we even talking about the same thing?

It's my understanding that "access" error messages that generally say something to the effect of "access denied"
or "can't access that location or file" are different than error messages that also use the term "access"
but also use the terms "violation, address, and some number and or letter combination.
They both use the term access, but the latter is some sort of problem with the
process "itself" of reading a memory address", not the on/off-enable/disable code switching of a
software feature (OS permissions).

Not sure though. :-?

Re: Access violation at address 00AFADFC

by MMFrLife » Thu May 07, 2015 11:38 am

nohitter151 wrote:If you're getting them every time you try to edit a track's metadata, 99% of the time that is the cause (based on my anecdotal experience in the forum)
In the specific case of editing maybe, but I've had those too and I never did anything to the rights to solve it. I think I updated one time and another
time I did something else (don't remember). So, I guess errolbest and I are in the 1% or 10 % ....... or, whatever it really is.

Re: Access violation at address 00AFADFC

by nohitter151 » Thu May 07, 2015 9:49 am

MMFrLife wrote:Glad things are working.
Note, all the access violation errors I've ever had were not rights permission issues.
If you're getting them every time you try to edit a track's metadata, 99% of the time that is the cause (based on my anecdotal experience in the forum)

Re: Access violation at address 00AFADFC

by MMFrLife » Thu May 07, 2015 8:13 am

Glad things are working.
Note, all the access violation errors I've ever had were not rights permission issues.

Re: Access violation at address 00AFADFC

by errolbest » Thu May 07, 2015 4:12 am

Thanks nohitter151. I tried all you said but the problem still occurred. I have reinstalled MediaMonkey and, at this stage, problem gone. There must have been a corrupted file somewhere in the system. Thanks for your help.
Errol

Re: Access violation at address 00AFADFC

by nohitter151 » Wed May 06, 2015 11:31 am

errolbest wrote:The tracks are on an external hard drive. I have tried to upgrade my version of MediaMonkey but when I click on 'check for updates' it says checking but then nothing happens. Still scratching my head.

Errol
Ok so the problem is that your Windows user does not have ownership of the files and so MediaMonkey cannot modify them.

See https://technet.microsoft.com/en-us/lib ... 53659.aspx

Re: Access violation at address 00AFADFC

by Lowlander » Wed May 06, 2015 9:00 am

Just download and install the update: http://www.mediamonkey.com/forum/viewto ... 52#p406952

(it seems the servers were having issues yesterday)

Re: Access violation at address 00AFADFC

by errolbest » Wed May 06, 2015 6:45 am

The tracks are on an external hard drive. I have tried to upgrade my version of MediaMonkey but when I click on 'check for updates' it says checking but then nothing happens. Still scratching my head.

Errol

Re: Access violation at address 00AFADFC

by nohitter151 » Tue May 05, 2015 10:10 am

errolbest1 wrote:I, too, am having problems with this error message. I have removed the 'read only' setting from the folders concerned but am still having problems. It is a PITA (pain in the a***). Every time I play a tune the error message appears. If I change anything using 'Properties ' I get the message twice. If I do a bulk change e.g 20 files, I get the message 60 times !!!!!! I have version 4.1.5.1719 on the computer giving problems. On my other computer, I have version 4.0.7.1511 with no problems. Can anyone give me an actual solution not could be's.

Errol
It is most likely a permissions issue, are the tracks in question on an external drive or have been copied from another PC? Also your version of MediaMonkey is out of date.

Re: Access violation at address 00AFADFC

by errolbest1 » Tue May 05, 2015 8:35 am

I, too, am having problems with this error message. I have removed the 'read only' setting from the folders concerned but am still having problems. It is a PITA. Every time I play a tune the error message appears. If I change anything using 'Properties ' I get the message twice. If I do a bulk change e.g 20 files, I get the message 60 times !!!!!! I have version 4.1.5.1719 on the computer giving problems. On my other computer, I have version 4.0.7.1511 with no problems. Can anyone give me an actual solution.

Errol

Top