Volume leveling does not work [#13592]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Volume leveling does not work [#13592]

Re: Volume leveling does not work [#13592]

by rusty » Thu Jun 29, 2017 12:48 pm

Hi Jason,

The issue boils down to the fact that reduction in volume levels works the same as MMW, but increasing volume levels is limited by the Android player engine (the issue is summarized at http://www.ventismedia.com/mantis/view. ... 957#c45907 ). The solution for eliminating this limitation is to adopt a custom player engine--something that's planned for a future version of MMA.

-Rusty

Re: Volume leveling does not work [#13592]

by JasonMowry » Sat Jun 24, 2017 11:38 am

My apologies, it's now clear that some volume leveling is occurring in MMA. However, what is notable in the previous example is that it appears that MMA and MMW take different approaches to how much into the boost territory they are willing to go (i.e. positive volume coefficients). Within MMW, the two tracks I referenced seem remarkably balanced, most likely because MMW is fearless about boosting levels for tracks that were unfortunately mastered way too low. However, in MMA one track is still noticeably quieter than the other, though there is also a much more pronounced difference when volume leveling is turned off. Can MMA be updated to adopt the MMW approach?

Re: Volume leveling does not work [#13592]

by JasonMowry » Wed Jun 21, 2017 8:19 pm

I just downloaded the Android app version 1.3.0.0694 and this issue is still a problem. My noticeable example is play U2's Vertigo (-10.8) back to back with King Crimson's Peace--A Beginning (+20.5) and it is obvious whether volume leveling is working. I've followed all the advice previously presented here: using MediaMonkey for both ends of the auto sync, replay gain settings are correctly configured in MMW and working, volume leveling is on in MMA, ratings changes sync correctly. How is this regressing?

Re: Volume leveling does not work [#13592]

by bakker_be » Wed Mar 08, 2017 4:25 pm

Hi there,
this had me stumped until now ... I always thought my tagging was somehow to blame :-)
Looking at the related issues in the bug tracker and especially at the initial implementation (0008911) I'd like to propose an enhancement however: apply "smart gain". It's a notion that's present in Logitech Media Server and seems to me as a more logical way to approach volume levelling. Below the description from the settings page of my LMS

Code: Select all

Some audio tracks contain volume adjustment, or "Replay Gain", information that can be used during playback to make sure that tracks and albums sound equally loud. The player can use this information if it is present. "Track gain" can be used to make sure that all tracks sound equally loud. "Album gain" can be used to make sure that all albums sound equally loud, but that volume differences between tracks within an album are preserved. "Smart" gain selection uses album gain if successive songs are from the same album or track gain for a mixed playlist.

Re: Volume leveling does not work

by Aff » Tue Oct 18, 2016 3:52 pm

Fixed in latest beta! :)
Bug tracker: 0013592: Volume Leveling doesn't work (Regression)

Re: Volume leveling does not work

by Aff » Sun Oct 02, 2016 12:05 pm

Ticket submitted 2 weeks ago, but no feedback yet to my log files. :(
Who else is experiencing the problem, that volume leveling doesn't work?

Re: Volume leveling does not work

by Lowlander » Sat Sep 10, 2016 12:50 pm

Correct, only an MMW to MMA sync will have MMA be able to do this as MMW directly updates the MMA database with this information.

At this point MMA still relies on Google Media Scanner which is limited in its capabilities.

Re: Volume leveling does not work

by cncb » Sat Sep 10, 2016 12:27 pm

rusty wrote:To clarify: volume leveling should work in MMA if:
- The tracks were synced to the device with MMW (if they're just copied to the device, metadata from the database such as ratings/volume leveling will not be in MMA)
MMA relies on MMW for volume leveling information and can't read it from the track file itself?? So, if I just copy a track with volume leveling metadata onto my device from Windows Explorer (outside of MMW) it will not be able to read the volume leveling information?

Re: Volume leveling does not work

by Aff » Sat Sep 10, 2016 10:06 am

Log file sent (before playback: 8QFSXR98C, after: NVNHH28ESW).

The volume_leveling field in mmstore.db has -12.52.
I've created a copy with a lower volume (volume_leveling 0.29), but it plays the same volume.

That's on a Samsung S5, Android 6.0.1.

See Volume leveling for MMA not working while it works on MMW as well.

Re: Volume leveling does not work

by Aff » Sun Sep 04, 2016 5:47 pm

Same here with MMA 1.2.0.0614. Volume leveling has no effect, it doesn't turn the volume down on loud tracks.

Volume leveling for MMA not working while it works on MMW

by bob123 » Fri Apr 08, 2016 11:54 pm

I have the latest versions of both MMW and MMA and Android 6.0 on my phone. I have set my volume leveling set to 89 db and set the "level/sync volume value" to per track in MMW. I did the analyze volume command for all my songs in MMW and it works fine (also have volume leveling option checked in MMA), however when I sync my songs to my phone the leveling does not work and the volume is all over the place on my phone as it would be if I had not done anything with it at all. Is there another setting I need to tweak to get it to work? I also checked the properties of a number of songs and all of them show the leveling coefficient so I know the info is in there.

As a test to see if the metadata is transferring over I changed the rating on a song an re-synced and it did transfer to my phone so I know that's working but the volume leveling still isn't working for some reason.

Re: Volume leveling does not work

by rusty » Mon Mar 07, 2016 10:16 am

Nightroan,

When I'd last responded, one of the questions I'd asked was whether Ratings appear on the device (1-5 star ratings). The reason i asked is because if they don't then it means that track metadata isn't being correctly synced to the device (i.e. the device is only getting whatever metadata is included within the track's tags, but not any other metadata that is stored solely in the db). So if track ratings don't appear on the device, then it means that volume leveling data won't have been synced either.

-Rusty

Re: Volume leveling does not work

by Peke » Sat Feb 27, 2016 4:09 am

Hi,
Tested on Moto G LTE (2013) LP 5.1, Verizon LG KK 4.4.2, Nexus 7 (2012 LP 5.1.1, 2013 MM 6.0.2) , ZTE Blade Q JB 4.2.2 and had no issues.

Can you send Log before you start playback of file and one after and send us both log IDs here? We should see what is read and why it is not used.

Only difference I can see is that there is Track gain but no Album gain or album gain is badly calculated. Can you copy track directly off device and send us a sample to see what exactly is going on and we can analyze audio data.

Re: Volume leveling does not work

by nightroan » Thu Feb 25, 2016 12:17 am

Thanks for taking a look. Let me know if you want me to create more debug logs.

Re: Volume leveling does not work

by Peke » Mon Feb 22, 2016 9:56 pm

Ok Thank you. I'll tested on my devices today and see if I can find one that can replicate the problem.

Top