Disable Auto-Play on Bluetooth Connection?

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Disable Auto-Play on Bluetooth Connection?

Re: Disable Auto-Play on Bluetooth Connection?

by Dngrsone » Sat Oct 03, 2020 3:23 am

I had a persistent problem with mediamonkey autoplaying upon Bluetooth connection with my car, even when I had another player queued up on my Galaxy S7 Edge

I finally found that if I go to Settings>Device Maintenance>Battery>Power Saving, I can force mediamonkey to "go to sleep" and the problem goes away (until the next time Iuse the app again)

Re: Disable Auto-Play on Bluetooth Connection?

by Lowlander » Mon May 27, 2019 10:06 am

Have you disabled Resume Play on Connection from the Options in MMA?

Re: Disable Auto-Play on Bluetooth Connection?

by Jozef Mercier » Sun May 26, 2019 6:29 am

It's NOT the car that sends commands. It is MM (on all my android devices) that starts up whenever one of these devices connect to any bluetooth device. It makes no difference if it's my brand new car, my soundbar, or a new bluetooth speaker.
This is driving me mad. Please find a solution for this annoying behavior.

Re: Disable Auto-Play on Bluetooth Connection?

by Lowlander » Thu Oct 27, 2016 11:04 am

If MMA was the last used media App it does start here if the Play command is send from the Bluetooth device. This all seems to work as expected.

Re: Disable Auto-Play on Bluetooth Connection?

by gpzbc » Thu Oct 27, 2016 10:06 am

Ok, I can understand that the car is sending the play command, but your statement that "probably no other apps listening for it when they are not in the foreground" makes no sense. MMA is not in the foreground and it still starts playing. Often times, MMA tries to play over the other music app that is in the foreground. And when MMA is uninstalled, and a different music app is in the foreground, nothing starts playing automatically. In other words, if the car is indeed sending the play command, every other music app that I use has the option to ignore it.

By the way, I disabled "Always respond to remote buttons" in the MMA Options and MMA still starts playing automatically upon connection.

Re: Disable Auto-Play on Bluetooth Connection?

by rivorson » Wed Oct 26, 2016 5:54 pm

gpzbc wrote:If I uninstall MMA, my car doesn't send a play command to any other music app on my phone.
The car will still send the command, but there are probably no other apps listening for it when they are not in the foreground. Lowlander makes a good suggestion. With that option disabled then perhaps MMA will not receive the command.

My car does the same but I have several other bluetooth audio devices that do not. The assumption with a car is that you want to get in and drive, not get in then spend a few minutes picking your music before you drive. It avoids encouraging people to use their phone while driving.

Re: Disable Auto-Play on Bluetooth Connection?

by Lowlander » Wed Oct 26, 2016 5:45 pm

Try disabling Always respond to remote buttons in the MMA Options. Maybe that stops this behavior.

I do assume it's the car though as no Bluetooth device I've ever used starts playback in MMA on connection.

Re: Disable Auto-Play on Bluetooth Connection?

by gpzbc » Wed Oct 26, 2016 4:43 pm

That's weird. Why doesn't it do it for my other music player apps? I have a couple installed on my phone that I use for different things and MMA is the only one that does this. If I uninstall MMA, my car doesn't send a play command to any other music app on my phone.

Re: Disable Auto-Play on Bluetooth Connection?

by rivorson » Wed Oct 26, 2016 3:48 pm

This isn't controlled by MMA or anything on your phone. Your car sends the play command when it connects.

Disable Auto-Play on Bluetooth Connection?

by gpzbc » Wed Oct 26, 2016 3:29 pm

I love using MMA, but I HATE the fact that MMA starts playing a song automatically every time my phone connects to my car bluetooth, which is every time I start up my car. I've looked around and can't find an option to disable this. Am I missing something? I'm sure some people might appreciate this feature, but I certainly don't.
Thanks

Top