Had a very bad start with MM5

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Had a very bad start with MM5

Re: Had a very bad start with MM5

by Snofru » Mon Mar 04, 2019 5:28 pm

Thank you again, looks fine now!
I am glad that we could work it out!

Re: Had a very bad start with MM5

by PetrCBR » Mon Mar 04, 2019 1:33 pm

Backup your database from VirtualStore folder (the actual one), move it to Roaming/MediaMonkey and delete from all other places (from Program Files/MediaMonkey). Then MM4 will use automatically database in it's default folder (Roaming/MediaMonkey).

Re: Had a very bad start with MM5

by Snofru » Mon Mar 04, 2019 1:05 pm

Thanks, that did help, I can now use MM5 normally.

Is there a chance to get MM4 back to using MM.db with the correct path? I feel pretty uneasy that something is wrong there, especially considering the hundreds of hours I spend with creating this database.

BTW, I deleted the box.com files, a little bit too much personal information to have it available for a long time for everyone.

Re: Had a very bad start with MM5

by PetrCBR » Mon Mar 04, 2019 12:36 pm

I see the problem. As i wrote before, default data location is in Roaming/MediaMonkey folder. MM5 can import data from different folder when it's defined in MediaMonkey.ini file, but it's not your case. For some reason you have your DB in MM install folder and use VirtualStore (so database is not saved even in MM folder, but in VirtualStore). As a workaround you can copy your MM.DB into MM5/Portable folder manually.

Re: Had a very bad start with MM5

by Snofru » Mon Mar 04, 2019 12:20 pm

Re: Had a very bad start with MM5

by PetrCBR » Mon Mar 04, 2019 12:12 pm

Default data path for non portable install is 'C:\Users\.....\AppData\Roaming\MediaMonkey' so MM5 will copy your DB from that folder. Can you also send me MediaMonkey.ini from that folder ?

Re: Had a very bad start with MM5

by Snofru » Mon Mar 04, 2019 11:59 am

I have checked for MM.db on my HDDs and found these paths:

C:\Users\.....\AppData\Local\VirtualStore\Program Files (x86)\MediaMonkey (this is from today)

C:\Program Files (x86)\MediaMonkey (from November 2018)

C:\Users\.....\AppData\Roaming\MediaMonkey (from August 2018)

And a number of locations on drive D: where I automatically save with the Backup addon.

Re: Had a very bad start with MM5

by Snofru » Mon Mar 04, 2019 11:46 am

Thanks for your quick reply!

I have uploaded the Log file which can be found there:

https://app.box.com/s/96m56gr9glvh8g4xhb85wnxz1dq1ca48

Added later: I have only one installation of MM4 and it is not portable.

Re: Had a very bad start with MM5

by PetrCBR » Mon Mar 04, 2019 11:32 am

MM4 you have installed as portable or non portable ? Do you have more than one MM4 installation ?

Re: Had a very bad start with MM5

by Ludek » Mon Mar 04, 2019 11:26 am

Hi,
it really sounds like an incorrect database is imported in your case.

Could you please catch this in the debug log (item 4b here: https://www.mediamonkey.com/forum/viewt ... 30&t=86643 )
1) Start DbgView
2) Start MM5 (clean install) and accept the prompt to import the database from MM4
3) Save the log from the DbgView app, upload it to a free file hosting service (DropBox, Box, FileDropper, ...) and share the link to the debug file so that we can see what it going on on your side

This should explain from where is your MM.DB imported and what is the reason for this.

Thanks!

Had a very bad start with MM5

by Snofru » Mon Mar 04, 2019 9:06 am

For the 1st time I tried out MM5, version 5.0.0.2164. I installed the portable version in a seperate folder and followed the suggestion to import from MM4. There the 1st problem started. What was imported was not my current MM4 database! It is one from at least some weeks ago, with some Music missing and playlists missing all the changes I have done recently. Maybe an old saved database was used? That leads me to my 1st question:

How can I direct MM5 to import the correct MM4 database?

Then I tried to play a song. Nothing happened. Tried other songs but they simply didn´t start playing. I then saw that the paths for all my songs start with a question mark (they should all start with "D:"). Maybe that is the reason? My music somehow wasn´t found? Maybe because the wrong database was imported?
My issue: I get absolutely no information why the music isn´t played. I haven´t installed the codec pack. Should I?
I tried "locate moved/missing files". After selecting the correct path and waiting for a few seconds the program crashed.

I completely deleted MM5 and reinstalled it again (portable). Again the wrong database was imported. I deleted again and installed once more without import. I tried to find a way to import the correct MM4 database by hand but gave up after a while after finding nothing.

I know this is still in beta state but I really am desperate now. How can everything go so terribly wrong? I have absolutely no issues with MM4...

Top