Library -> Layout feature not working for me [#15869]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Library -> Layout feature not working for me [#15869]

Re: Library -> Layout feature not working for me [#15869]

by pbryanw » Sun Aug 25, 2019 12:58 pm

@MiPi - Thanks once again for your help.

Re: Library -> Layout feature not working for me [#15869]

by MiPi » Sun Aug 25, 2019 5:12 am

We will look at it, thanks.

Re: Library -> Layout feature not working for me [#15869]

by pbryanw » Sat Aug 24, 2019 1:52 pm

@MiPi - Hi, I've just been trying out MM 5.0.0.2192, and layouts are now working largely as expected (with the Active layout showing the currently selected one) - thanks.

However, I've found a bug when switching between new profiles and old ones. Here are my steps to reproduce:
  1. Go into Options -> Layout. Select "Add new layout" from the Active Layout dropdown.
  2. Create a new layout called "Test", and deselect every ticked panel element for this layout. Just deselect each element, and leave all the panels as ticked.
  3. Press OK to confirm.
  4. Go back into Options -> Layout. Set the Active Layout back to the "Default" one, and press OK to confirm.
  5. The layout reverts to the new "Test" one, instead of the selected "Default" one. If I now go back into Options, the "Default" layout gets activated.
I've also noticed that if you make a new "Test" layout and deselect Panels, if you then select the "Default" layout again, these unticked panels stay deselected. Even if they were previously ticked in the "Default" layout. I hope this makes sense.

Thanks again for your help, and I hope you can reproduce these bugs.

Re: 2191 - Library -> Layout feature not working for me

by pbryanw » Mon Aug 12, 2019 11:52 am

@MiPi - Thank you for your help with this, and for adding this issue to your tracker. Much appreciated!

Re: 2191 - Library -> Layout feature not working for me

by MiPi » Mon Aug 12, 2019 1:57 am

Options/Layout is only for editing layouts, you switch which layout you are editing there, not which is then used. They could be switched in menu View - Mode. But you are right, there should be also possibility to switch to new layout also directly in Options dialog, we will look at it, it really could be confusing now.
Tracked as https://www.ventismedia.com/mantis/view.php?id=15869

Library -> Layout feature not working for me [#15869]

by pbryanw » Sun Aug 11, 2019 2:29 pm

Hi,

I'm trying to use the Library -> Layout option in MM preferences (in MM 5.0.0.2191 on Windows 10 1903). However, unfortunately, it doesn't appear to be working for me.

For example, I created a "Test" layout and arranged it to my liking. However, when I clicked OK to set this as the active layout, it instead reverted back to the "Default" layout. And back in MM preferences, the active layout was also set to "Default".

I'm just wondering if you can reproduce this on your end?

Thanks, Paul

Top