cpu loop when MM5 playing from web, forcing destructive PC reboot [#14499]

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: cpu loop when MM5 playing from web, forcing destructive PC reboot [#14499]

Re: 2219 - cpu loop when MM5 playing from web, forcing destructive PC reboot

by Ludek » Thu Jan 02, 2020 10:41 am

MiPi wrote: Thu Jan 02, 2020 6:37 am
Barry4679 wrote: Mon Dec 23, 2019 4:08 am I have authorised MM5 access to my GPM library ... there is a good chance that the tracks are there (ie. streamed by GPM, although maybe not in my library), and I have paid to have access, and the quality is good (320mps I think) ... in a situation like this, could you try there 1st, before going to YouTube?
Currently not possible. Hopefully Ludek will know more, whether it could be possible in the future, I do not know this part of MM.
Hi, this request is tracked as https://www.ventismedia.com/mantis/view.php?id=14499

Re: 2219 - cpu loop when MM5 playing from web, forcing destructive PC reboot

by MiPi » Thu Jan 02, 2020 6:37 am

Barry4679 wrote: Mon Dec 23, 2019 4:08 am Could the tool tips for the play controls say something like "Play From YouTube" instead of just Play? So that I can predict what is going to happen.
But Play button runs playback for any track, not only for YT, it would be confusing. But we consider this, maybe displaying source icon in standard NP list could be handier.

Barry4679 wrote: Mon Dec 23, 2019 4:08 am I don't have any experience with YouTube. Sorry about the naive question. ... What is the original source of what I would be playing? Is it from YouTube Muisc... ie. uploaded by the Rights holder ... or is it a dodgy illegal upload from the public, which may have some unwanted payloads?
We use Youtube API provided by Google for searching and playing. We comply with their rules, so it is legal. We e.g. cannot automatically hide ads or that clickable Youtube logo, cannot display e.g. player control above YT video, or cannot hide video and play only audio.

Barry4679 wrote: Mon Dec 23, 2019 4:08 am I have authorised MM5 access to my GPM library ... there is a good chance that the tracks are there (ie. streamed by GPM, although maybe not in my library), and I have paid to have access, and the quality is good (320mps I think) ... in a situation like this, could you try there 1st, before going to YouTube?
Currently not possible. Hopefully Ludek will know more, whether it could be possible in the future, I do not know this part of MM.

Re: 2219 - cpu loop when MM5 playing from web, forcing destructive PC reboot

by Barry4679 » Mon Dec 23, 2019 4:08 am

MiPi wrote: Mon Dec 23, 2019 1:48 am This was regression in YT playback in the last build, please wait for the next, thanks.
Thanks. ... the experience was so unpleasant, I will probably wait a little longer than that. :(

If this is an area that you work in, I have some comments and questions.

Could the tool tips for the play controls say something like "Play From YouTube" instead of just Play? So that I can predict what is going to happen.

I don't have any experience with YouTube. Sorry about the naive question. ... What is the original source of what I would be playing? Is it from YouTube Muisc... ie. uploaded by the Rights holder ... or is it a dodgy illegal upload from the public, which may have some unwanted payloads?

I have authorised MM5 access to my GPM library ... there is a good chance that the tracks are there (ie. streamed by GPM, although maybe not in my library), and I have paid to have access, and the quality is good (320mps I think) ... in a situation like this, could you try there 1st, before going to YouTube?

Re: 2219 - cpu loop when MM5 playing from web, forcing destructive PC reboot

by MiPi » Mon Dec 23, 2019 1:48 am

This was regression in YT playback in the last build, please wait for the next, thanks.

cpu loop when MM5 playing from web, forcing destructive PC reboot [#14499]

by Barry4679 » Fri Dec 20, 2019 9:12 pm

I tried to play something from the Web using MM5

I was in Music>Artists>xxxx ... and I have the main panel toggled to Online.

I tried playing an album that i don't own. I was hoping to see some integration with my Google Play Music account, which I have authorised MM5 to access.

But no ... it went to YouTube, or somewhere like that

The experience was horrible .. I could hear some music ... I could see some artist pics ... but I lost control of my PC

No way to close the window ... Very high CPU usage ... Task bar very very slow to respond to clicks ... unable to close any program, or save any work in progress in other apps.

I managed to kill the MM5 app off, but the cpu looping persisted .... I tried to get a debug log, but although MM services where monopolising my CPU, nothing was being logged.

Rebooting the PC is not much fun either ... any sites that you sync to (eg. Google Drive, Dropbox etc) go nuts, and light up the cpu for a long time ... and the Google Music Manager re-synced each of the 45,000 tracks that I have uploaded there.

So not happy ... that was yesterday ... I was going to report this, but not at all interested in testing this again.

But .. today, after powering up my PC after overnight, I opened MM5 to check something that dtsig had reported in another thread ... I had trouble replicating ... I saw that he was playing something when the issue happened to him ... so I pressed the MM5 play button to make something play, forgetting what was the last item that I have playing.

So the same thing happened again ... MM5 turned my PC into a zombie, and ruined my morning ... this time no forced GPM resync, presumably because I had not opened D&S>GPM today.

So it has happened twice ... and it happens the instance that I press the MM5 play button.

Top