1213 - Allows multiple version of MM to run [

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: 1213 - Allows multiple version of MM to run [

Re: 1213 - Allows multiple version of MM to run

by chrisjj » Fri Apr 17, 2009 5:11 am

> Cannot drag and drop mmip files into mediamonkey

Drag'n'drop into MM is unfortuantely undefined behaviour. It works for some objects, some targets, some combinations - not for others.

Could the Devs please document what is supposed to work? Then I we will at least know which of the non-working cases to report as bugs.

Re: 1213 - Allows multiple version of MM to run

by Taomyn » Fri Apr 17, 2009 1:56 am

Bex wrote:You need to drop onto the playbutton!

Re. explorer/desktop, some other user said it worked...
Sorry, it doesn't :-(

Re: 1213 - Allows multiple version of MM to run [

by Dan415 » Thu Apr 16, 2009 1:15 pm

(My first post--hopefully I did it correctly)

3/14/09-First installed Media Monkey V. 3.07.1191 on Vista 32bit.
--- In the days following, successfully installed numerous down-loaded scripts; started MM "as administrator" to install each script.
4/12/09-Installed MM V. 3.1.0.1234.
4/13/09-Started MM "as Administrator". Attempted to install script, SqlViewer.2.3.; SECOND COPY of MM started--"Installation Failed".
4/15/09-Started MM "as Administrator". Attempted to install script, ExportM3UsForSubNodes; SECOND COPY of MM started--"Installation Failed".
4/16/09-Installed MM V. 3.1.0.1235. (Succeeded after deleting a number of .dlls in MM main folder and Plug-in sub-folder.)
4/16/09-Started MM "as Administrator". Attempted to install ExportM3UsForSubNodes; SECOND COPY of MM started--"Installation Failed".

"Drop(ping) the MMIP onto the playbutton!" did not work.

While running V. 3.07.1191, the 'Second Copy of MM' never started and all attempted script installations were successful.

I believe that as new, Vista Users attempt to install scripts, they will encounter this V. 3.1 issue.

Dan

Re: 1213 - Allows multiple version of MM to run

by Bex » Thu Mar 26, 2009 5:38 pm

You need to drop onto the playbutton!

Re. explorer/desktop, some other user said it worked...

Re: 1213 - Allows multiple version of MM to run

by fenrir » Thu Mar 26, 2009 4:26 pm

Cannot drag and drop mmip files into mediamonkey

and the desktop or explorer thing doesnt work either.. (can you explain how this solution would work actually?)

Re: 1213 - Allows multiple version of MM to run

by Bex » Thu Mar 26, 2009 3:26 pm

To circumvent this problem, until it gets fixed, try to run the .mmip file from within explorer (or your desktop). You can also try to drag and drop the .mmip file onto MM's playbutton. Either method will hopefully work.

Re: 1213 - Allows multiple version of MM to run

by fenrir » Thu Mar 26, 2009 3:04 pm

bump.

Please help!

Re: 1213 - Allows multiple version of MM to run

by Taomyn » Sat Mar 21, 2009 12:44 pm

I'm having similar issues with Vista, but this is why it's happening at least for my installation.

Logged in as a standard user i.e. does not have admin rights. Try to install a plug-in and fails as we all know. Run MM as administrator with right-click runas, try to install plug-in again by double-clicking it, a second copy of MM appears and fails yet again. Why? Because running as Adminstrator when logged in as a standard user doesn't elevate thay user, but runs the new process as the administrator user you choose (you may have one), and loads a new profile. Same would happen even if you could run the plugin direct the same would happen.

My only course of action is to temporarily make my user an administrator, add the plugin, demote the user back again and then continue. Not very friendly.

What MM needs is either a menu option to allow you to say "Tools, Install plug-in" so it uses the correct session (but this won't help my case), or more sensibly, as Firefox/Thunderbird and many other applications do, stores plug-ins in a user accessible area without the need for admin rights.

Re: 1213 - Allows multiple version of MM to run

by fenrir » Mon Mar 09, 2009 6:37 pm

rinvelt wrote:Under Vista (at least) I can run multiple version of MM even with the "Allow just one instance of MM" option checked.

This seems to only happen when installing extensions. I have UAC on, so I run MM as Admin and then double click the extension. This used to install the extension in the MM running as admin. Now it open another version of MM.
Same issue here too.. Using 3.1.0.1224

Re: 1213 - Allows multiple version of MM to run

by nynaevelan » Wed Jan 14, 2009 11:57 am

I cannot reproduce in Vista Ultimate but I have UAC turned off.

Nyn

Re: 1213 - Allows multiple version of MM to run

by Lowlander » Wed Jan 14, 2009 11:13 am

I can't reproduce this with 1213 on Windows XP.

Try to restart MediaMonkey after disabling the multiple instances and then install a plugin. Does that still result in a new instance created?

1213 - Allows multiple version of MM to run [

by rinvelt » Wed Jan 14, 2009 10:53 am

Under Vista (at least) I can run multiple version of MM even with the "Allow just one instance of MM" option checked.

This seems to only happen when installing extensions. I have UAC on, so I run MM as Admin and then double click the extension. This used to install the extension in the MM running as admin. Now it open another version of MM.

[Moderator edit: related to the following bug: http://www.ventismedia.com/mantis/view.php?id=3702]

Top