Wrong track order when using MM server

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Wrong track order when using MM server

Re: Wrong track order when using MM server

by Lowlander » Thu May 22, 2014 1:20 pm

Playlists should be served in Playlist order. Are you on MediaMonkey 4.1.1.1703 or newer? It does so for me on 4.1.2.1704. Are you sure the client isn't sorting?

Re: Wrong track order when using MM server

by natakk » Thu May 22, 2014 1:15 pm

because i have some troubles since some weeks. even if i choose a playlist
it do not play the sequence saved in MM. it takes even the track number.

this is ok for albums but for playlists its not so funny. could this come from
MM? i do not seen this in 2013 i guess.

Re: Wrong track order when using MM server

by Lowlander » Wed May 21, 2014 11:08 am

Nowhere, they're now hard coded for DLNA serving.

Re: Wrong track order when using MM server

by natakk » Wed May 21, 2014 10:33 am

Lowlander wrote:Try MediaMonkey 4.1 beta from the Beta Testing forum which features sorting improvements over DLNA.
where in MM can i set this sorting options?

Re: Wrong track order when using MM server

by heynow » Sat May 17, 2014 7:30 pm

Lowlander wrote:Try MediaMonkey 4.1 beta from the Beta Testing forum which features sorting improvements over DLNA.
I was having the same problem. I updated to the latest version and problem solved. Thanks.

Re: Wrong track order when using MM server

by Ludek » Tue Nov 26, 2013 10:47 am

I am almost certain that .NET framework version doesn't have an impact on this.

Maybe you tested slightly another way or previously you tested the old MM version (4.0.7)?

e.g. previously you could test navigating Music->Album->.. amd this time you tested Music->Artist->Album... or something like such a difference?
Anyhow if you will be able to reproduce it again then it would be best to catch this in debug log as we cannot reproduce it (might be device specific)

Re: Wrong track order when using MM server

by napoca » Tue Nov 26, 2013 12:41 am

Thanks everybody for your contributions, the issue has been solved in a quite strange mode.

I installed today JRiver Media Center (demo mode) with the idea in mind to try other server and see if it's MM's problem or not. At some moment the software downloaded and installed Microsoft Net Framework (I didn't pay attention to what version, but I think some 3.x version). After the installation was done, JRiver started to scan for music, and as it was taking too long, I tried once again to stream music (pull) from MM server. Magically, it played flawless: correct order and gapless.

I mentioned this because that's the only difference between yesterday and today on my system, an installation of some old version of Net Framework. I have no idea what that program does, or even if that really was the solution, if Windows 8.1 (my current OS) had already have it or not, but now it's working.

Cheers.

Re: Wrong track order when using MM server

by Lowlander » Mon Nov 25, 2013 3:22 pm

nohitter151 wrote:I believe the sort order over the network mimics the sort order you've set in MM.
That should no longer the case in 4.1. Sorting should be hard coded (independent of what you've sorted on in MMW) and for me it works.

Re: Wrong track order when using MM server

by nohitter151 » Mon Nov 25, 2013 1:11 pm

Are the tracks in order in MM? I believe the sort order over the network mimics the sort order you've set in MM.

Re: Wrong track order when using MM server

by napoca » Sun Nov 24, 2013 3:39 pm

OK, thanks for the heads up.

No, I don't have magic nodes yet. What is happening is I go into my receiver's input and select network. Receiver sees both servers as I said in the first post: WMP12 and MM. If I choose the WMP12 and select and play one album everything works fine except gapless playback (which I had expected to not work). If I choose MMW, gapless playback is fine (as Pioneer Elite SC-71 implemented this year for network playback and desktop version of MMW can do - but not MM8 yet).

So, what confuses me is why WMP can sort the tracks correctly and MMW cannot. I mention the players use different libraries, but WMP library is just the same library MM use but converted using MM into wma, which WMP can read.

Re: Wrong track order when using MM server

by Lowlander » Sun Nov 24, 2013 3:28 pm

MMW is MediaMonkey for Windows and MMA is MediaMonkey for Android (MM8 is MediaMonkey for Metro).

I checked on a Samsung TV and it also shows the tracks in the correct order. Are you maybe viewing a Magic Nodes?

Re: Wrong track order when using MM server

by napoca » Sun Nov 24, 2013 3:19 pm

Lowlander wrote:Trying on MMW (client) and MMA it shows files in expected Track# order. Do your files have Track#, Album Artist and Disc# assigned correctly (eg. sorting in MMW (library) it sorts tracks as expected)?
I don't understand what MMW and MMA stand for, but I guess you are asking if my files show in player in the correct order?

If this is the question, than the answer is yes, everything is properly tagged, and in MM player, in the main window and in the playlist everything works fine. When streaming, MM sort the tracks alphabetically according to the "Title" file property, I guess, ignoring Track# tag. These are just my guesses, as I don't have a deep understanding of how the software works.

Re: Wrong track order when using MM server

by Lowlander » Sun Nov 24, 2013 2:47 pm

Trying on MMW (client) and MMA it shows files in expected Track# order. Do your files have Track#, Album Artist and Disc# assigned correctly (eg. sorting in MMW (library) it sorts tracks as expected)?

Re: Wrong track order when using MM server

by napoca » Sun Nov 24, 2013 2:11 pm

Lowlander wrote:Which build?
4.1.0.1672

Re: Wrong track order when using MM server

by Lowlander » Sun Nov 24, 2013 2:02 pm

Which build?

Top