GAPLESS! ARRGH :P [#16940]

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: GAPLESS! ARRGH :P [#16940]

Re: GAPLESS! ARRGH :P [#16940]

by Peke » Fri Jun 17, 2022 5:57 pm

Hi,
No, Playback rules are further improved in 5.0.3 and current design can't be ported to MM4.

Re: GAPLESS! ARRGH :P [#16940]

by xor » Wed Jan 06, 2021 7:54 am

Is there still hope for a backport of the fixed gapless MP3 playback to MM4?

If it is not to big of a hassle, that would be a very nice feature.

Re: GAPLESS! ARRGH :P [#16940]

by xor » Thu Oct 08, 2020 1:59 pm

I just checked with MediaMonkey 5 build 2268 and gapless playback is perfect now, great job, thanks guys! :D

If you could even port this back to MM4, that would be super cool!

Re: GAPLESS! ARRGH :P [#16940]

by hazelscha1981 » Fri Sep 25, 2020 12:55 am

My old computer was capable of doing something close to gapless (although it was cutting the ends of the songs), and that one was from 2003! My new one runs circles around the old one.

Re: GAPLESS! ARRGH :P

by xor » Tue Sep 22, 2020 5:28 am

Very cool, thanks a lot for listening!

Re: GAPLESS! ARRGH :P

by MiPi » Tue Sep 22, 2020 4:59 am

xor: good catch, support for these pregap/postgap values is missing and solves your problem with given files, tracked for MM5 here: https://www.ventismedia.com/mantis/view.php?id=16940
We will consider adding this to possible future MM4 version too.

Re: GAPLESS! ARRGH :P

by Peke » Tue Sep 22, 2020 4:15 am

Hi,
Files sent to Michal for analyze.

Re: GAPLESS! ARRGH :P

by xor » Mon Sep 21, 2020 7:02 pm

PS: I see that there is already the option to "Remove silence at the beginning/end of track" which seems to do a good job. Maybe it already uses the ENC_DELAY/ENC_PADDING information to do its job?

Re: GAPLESS! ARRGH :P

by xor » Mon Sep 21, 2020 6:57 pm

Thanks a lot Pavle,

that is very interesting!

I found that it is unavoidable to have these bogus samples at the end (and beginning) of compressed audio files, but there is some additional information in the MP3 tags that tells you how many samples should be dropped from the beginning ("ENC_DELAY") and end ("ENC_PADDING") of the MP3 for correct gapless playback:

http://wiki.hydrogenaud.io/index.php?title=Gapless

Foobar2000 allows to show these tags (right click on track -> properties):

Image

It seems both Winamp an Foobar2000 honor these tags for perfect gapless playback.

It would be very cool if Mediamonkey would also support this!

Re: GAPLESS! ARRGH :P

by Peke » Mon Sep 21, 2020 4:52 pm

Hi,
I have been able to set things to play them gapless using crossfade 0.1 (WASAPI in MM5) and 0.5 (WASAPI in MM4), but the files are not gapless and have artifact at start of track "04. Symphony No. 3 in D minor- Part 2. Ganz plotzlich gemachlich. Tempo di Menuetto"
See the image from Sound editor app, marker is set at the end of track "03. Symphony No. 3 in D minor- Part 2. A tempo (Wie im Anfang)"
Image

And in PM I sent you how that look and sound

Re: GAPLESS! ARRGH :P

by xor » Mon Sep 21, 2020 1:31 am

Thanks Pavle, I sent you a link with the tracks and examples!

Re: GAPLESS! ARRGH :P

by Peke » Sun Sep 20, 2020 10:17 pm

Hi,
This is something that bothered us for quite some time. Not just MM. To test this I have pulled my old CDs that are my night mix sets (eg. Mixed as a whole CD [RAW BURN MODE] with no gaps, but cut at transition beat at start of next song/loop that results 50+ tracks on CD) and MM could not play it correctly (heard TICK sound).

OK for a test I used Winamp, AIMP, WMP and few others. Same Result. Hmm ok Windows/Software is wrong, so inserted it into BD-Player -> Same result, Inserted in Car head Unit -> Same result, finally I inserted it in a very very old $10 USD Low Quality CD player in kitchen (it do not have any time display except Track Playing number) -> It played it flawlessly ?!?!?!?

In my case I have found the reason, Simply an old old player used RAW DA (Digital to Analog) convert of read data from CD and send it to AMP and all other uses DD (Digital to Digital Stream) conversion.

Can you please send me PM with DL links of two files so that I can try to get settings tweaked?

Re: GAPLESS! ARRGH :P

by xor » Sun Sep 20, 2020 10:58 am

Thanks Peke,

the tracks in question are really one continuous piece of classical music split into tracks. Therefore, crossfade would also disturb the audio due to the crossfade overlap.

However, even with 0.5s crossfade there is still a noticeable jump (I should have said "jump", not gap, to begin with: there is no pause between the tracks in MM, but the 2nd track starts to far in it seems, although silence removal if off).

Using the WASAPI output plugin makes no noticeable difference to the DirectSound plugin.

Using the Wave output plugin gives the worst experience (big jump).

I wonder how Winamp manages to play these tracks so perfectly without any hickup.

Re: GAPLESS! ARRGH :P

by Peke » Sun Sep 20, 2020 8:16 am

Hi,
If you disable all, MM tries to load file only after last file is done so there is no pre-loading like in case of Crossfade 0.5s.

Using WiFi to fetch track from NAS can create very noticeable delay. Even Loading larger FLAC file from USB can create that.

Re: GAPLESS! ARRGH :P

by xor » Sat Sep 19, 2020 12:01 pm

PS: I get exactly the same issue in MM 5.0.0.2267 Beta

Top