Any way to disable auto-fill in the Properties window?

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Posts: 23
Joined: Tue Jun 27, 2006 1:00 am

Any way to disable auto-fill in the Properties window?

Post by VALIS666 »

Hey everyone, long time user here. I don't remember exactly when it started, I'd say roughly about 6 months ago (I always update to the latest beta), but when I try to edit a track or group of tracks in the Properties window, after about 5 seconds the window hangs and I can't enter anything, then it's free for a second, then it hangs for another 5 seconds, then it's all clear. I can only assume the first pause is MM loading the auto-fill artists for the drop down, then perhaps the next pause is for the auto-fill album drop down to get populated. I have a very large library of over 400,000 tracks, so I'm sure filling those drop down lists causes quite a spike in terms of memory and processing. However, my computer is plenty powerful (quad core, 4gb ram).

As I'm sure you can assume, this is a bit annoying. Every time I want to edit a track I either have to open the properties window and hope I can get everything done in the 5 seconds before the first pause, or just wait about 15 seconds until everything is loaded in, then do my editing. Is there a way to disable the artist and album auto-fill lists? Of course, assuming that is what the problem is, but I can't imagine what else it might be. Thanks! Don't forget your large library users. :wink: Media Monkey is brilliant with large libraries while almost every other program chokes on them.
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA

Re: Any way to disable auto-fill in the Properties window?

Post by nohitter151 »

1) No, you can't disable auto-fill
2) That may or may not be the issue, it would probably be best to produce a debug log for the developers so that they can see what really is the problem. See
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Post Reply