Stumped with auto-organize masks

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

kazadharri
Posts: 109
Joined: Fri Jul 28, 2006 1:07 am
Contact:

Stumped with auto-organize masks

Post by kazadharri »

Ok,
I have been trying to get an mask to work, but have not been able to get it to work. So can any one help me?

Right now I use a simple mask of:

\\Kazadzen\share\ZEN Music\Done Music\<Album Artist@1>\<Album Artist>\<Album>\<Track#:2>_<Artist>_<Album>_<Title>

This works and gives me a nice simple directory structure, but it places the multi-artist albums in the alphabet tree. I have Soundtracks, Compiliations, and various tracks tagged as Soundtracks, Compiliation, or Various under <Album Artist>.

But I would like to get to this:
Normal Albums
\\Kazadzen\share\ZEN Music\Done Music\J\Jerry Harrison\Casual Gods\05_Jerry Harrison_Casual Gods_Cherokee Chief.mp3
Soundtracks
\\Kazadzen\share\ZEN Music\Done Music\Soundtrack\Easy Rider\02_Steppenwolf_Easy Rider_Born to Be Wild.mp3
Compiliations
\\Kazadzen\share\ZEN Music\Done Music\Compiliation\Now That's What I Call Music! 11\08_No Doubt_Now That's What I Call Music! 11_Underneath It All.mp3
Various Misc Albums (party CDs etc- I have imported)
\\Kazadzen\share\ZEN Music\Done Music\Various\Rockin Beats\13_Various_Rockin Beats_Track 13.mp3

I tried this mask but it hasn't worked.
\\Kazadzen\share\ZEN Music\Done Music\$if(<Album Artist>,$if(<Album Artist>=<Artist>,<Artist@1>)$if(<Album Artist>=Various,<Album>)$if(<Album Artist>=Soundtrack,<Album>)$if(<Album Artist>=Compiliation,<Album>)\<Track#:2>_<Artist>_<Album>_<Title>

It is based one from the Wiki, but can't seem to get it to work in all situations.
Help would be apprecitated.
Thnaks, Jeff
Mizery_Made
Posts: 2283
Joined: Tue Aug 29, 2006 1:09 pm
Location: Kansas City, Missouri, United States
Contact:

Re: Stumped with auto-organize masks

Post by Mizery_Made »

Code: Select all

\\Kazadzen\share\ZEN Music\Done Music\$if(<Album Artist>=Various,<Album Artist>,$if(<Album Artist>=Compilation,<Album Artist>,$if(<Album Artist>=Soundtrack,<Album Artist>,<Album Artist@1>\<Album Artist>)))\<Album>\<Track#:2>_<Artist>_<Album>_<Title>
Maybe? Can't really say for sure without knowing how you tag, but this would be a simpler mask if it would work with the way you tag:

Code: Select all

\\Kazadzen\share\ZEN Music\Done Music\$if(<Album Artist>=<Artist>,<Album Artist@1>\<Album Artist>,<Album Artist>)\<Album>\<Track#:2>_<Artist>_<Album>_<Title>
However, with this one, if you have "Artist 1; Artist 2" in the Artist field and "Artist 1" in the Album Artist field and this should be a normal album, it's going to throw off this mask.
kazadharri
Posts: 109
Joined: Fri Jul 28, 2006 1:07 am
Contact:

Re: Stumped with auto-organize masks

Post by kazadharri »

Thanks,
But neither of those worked. :-(

I have my tags this way.

Artist = Artist on track

Album Artist = Artist if a normal Album, = Compilation for compilation albums, = Soundtrack for Sound Track Albums


Does this help.

/Jeff
Mizery_Made
Posts: 2283
Joined: Tue Aug 29, 2006 1:09 pm
Location: Kansas City, Missouri, United States
Contact:

Re: Stumped with auto-organize masks

Post by Mizery_Made »

Looking over the mask I wrote up, I can't see why it might fail. I adjusted it slightly to account for a "Various Artist" Album Artist as opposed to "Various" and I was seeing results that fell in line with what you're wanting. Could you maybe write up the path this mask will give you for each type, then point out exactly how it fails to work what you're trying to do?

Maybe you could clarify whether you're using the "Auto-Organize files... (CTRL+R)" feature, or the Auto-Organize that is set up under options that has the ability to automatically move the files. I've had a little trouble with masks in the latter one in the past and took a little time to debug why they were going wrong.

EDIT: One more question, do all your files have Album Artists set? If you have some files that have Artists, but not Album Artists, then the mask should probably account for that too.
Post Reply