**DEFINITIVE ANSWER NEEDED: Why isn't album art showing?**

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Batalanto!
Posts: 72
Joined: Sun Nov 05, 2006 4:24 am
Contact:

**DEFINITIVE ANSWER NEEDED: Why isn't album art showing?**

Post by Batalanto! »

This question is being repeatedly asked and the moderators have yet to provide a definitive answer...

If I play an album, the thumbnail shows up in the "Now Playing" area with no problem. But when I go to Album View, the artwork doesn't show up. I have already downloaded and attached all artwork: saved it as a tag AND as a jpeg in the folder.

First time I noticed this? When I downloaded additional skins and switched them. However, going back to the original MM skin hasn't helped. And other users have reported album art not showing under under a variety of contexts.

Plenty of folks have asked about this. Again, we're asking the developers: what's going on?

As I have written before, I am a Music Monkey loyalist. But I have run into lots quirks and bugs over the past several years which I have had to spend an unreasonable amount of time in trying to troubleshoot. And I have just about reached my frustration maximum. I love supporting the underdog but at this point, I'm seriously thinking about downloading iTunes just so that I'm not constantly having to troubleshoot.
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by nohitter151 »

What shows if you right-click the art in the album view?
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Batalanto!
Posts: 72
Joined: Sun Nov 05, 2006 4:24 am
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Batalanto! »

It doesn't show up.
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by nohitter151 »

nightrocket wrote:It doesn't show up.
There's no "Image 1: ", "Image 2: ", etc.?
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Batalanto!
Posts: 72
Joined: Sun Nov 05, 2006 4:24 am
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Batalanto! »

Hi Nohitter,

First, thanks for taking the time to interface with me on this.

Here's the background...When I switched to album view or album w/details view, nothing was showing up. I would right click to pull up the "image 1, etc" dropdown that you mentioned. Regardless of what I clicked, no artwork popped up.

Now, although this doesn't solve my problem, let me tell you what I did as an interim workaround. I deleted MM, downloaded it again, and stuck with the default skin. Sometimes the artwork doesn't show up here either, unless I click the "Image 1, etc) dropdown individually. And that's a major hassle. Why they don't show up all the time - or why it takes so long to pull them up when it does so automatically - is a point of frustration.

As I've said, I'm sick of all the larger companies monopolizing the market when it comes to music player/organizer software. But it seems like it is one quirk after another with our beloved MM program. To make matters worse, I wind up the having to take the time out to jump on this board, ask for help, and/or troubleshoot individually. Is it a matter of the company not having enough resources to hire more developers to fix this stuff?

It would be VERY HELPFUL if there were an OFFICIAL TO-DO LIST in which users could add these bugs so that management had it squarely on their radar.

SUGGESTION: I think we would all be much happier with an MM that functioned more reliably and smoothly, rather than the next version having NEW bells and whistles. I'd love for what it CURRENTLY has to work, rather than investing in new features on a shaky foundation.

Thanks again.

Peace,
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by nohitter151 »

nightrocket wrote:
It would be VERY HELPFUL if there were an OFFICIAL TO-DO LIST in which users could add these bugs so that management had it squarely on their radar.
There is: http://www.ventismedia.com/mantis/my_view_page.php

However, as you can imagine, it would lead to WAY too much clutter if any user off the street could add items here. Instead a team of moderators patrols the forum and adds bugs as necessary to the list. The problem here is that I'm unclear as to what the problem is, so I can't add it. Not to mention, I can't reproduce the problem. Without a clear set of steps to reproduce the problem, it can't be reported.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Lowlander
Posts: 47913
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Lowlander »

Have you checked the Temp folder that's configured under Tools > Options > General. Go to the folder in Windows Explorer and check if it contains a folder like MMCache762336682_1 and does it have album art images inside? Also can you confirm that on tracks/albums you have no Album Art showing that when you go into the Track Properties Album Art tab that the first image is a working image (ie it shows)?
Lowlander (MediaMonkey user since 2003)
Batalanto!
Posts: 72
Joined: Sun Nov 05, 2006 4:24 am
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Batalanto! »

Lowlander,

Thanks for asking.

Yes. I went to the folder containing the album art. I had several folders like this with slightly different names containing album artwork. I combined all of them, moved the folder to an easier location on the computer to access/monitor, and reconfigured MM so that it knew the new location. This didn't help.

Yes again. Good question. When checking artwork under properties, the first image is indeed visible. In fact, I have all my tunes tagged with the album artwork and also have a jpeg in the album folder.

Peace.
Lowlander
Posts: 47913
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Lowlander »

I doubt you can move these temp album art folders around, you could change the temp folder itself, but that would be it. Anyways the reason I asked was to make sure it wasn't a rights issue that prevented MediaMonkey from creating these temp thumbnails.

The following would be to remove all these temporary album arts in the temp folder and see if this improves things for you. Also make sure there is sufficient free space on the drive where the temp folder is located.

If that fails I suggest that you create a debug log for this issue. Although you're not the only one having issues it is an uncommon issue and a debug log might give the developers an insight as to why this isn't working for you: http://mediamonkey.com/forum/viewtopic.php?f=7&t=69
Lowlander (MediaMonkey user since 2003)
Belgrath
Posts: 71
Joined: Sat Oct 27, 2007 6:14 pm
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Belgrath »

Lowlander wrote:I doubt you can move these temp album art folders around, you could change the temp folder itself, but that would be it. Anyways the reason I asked was to make sure it wasn't a rights issue that prevented MediaMonkey from creating these temp thumbnails.

The following would be to remove all these temporary album arts in the temp folder and see if this improves things for you. Also make sure there is sufficient free space on the drive where the temp folder is located.

If that fails I suggest that you create a debug log for this issue. Although you're not the only one having issues it is an uncommon issue and a debug log might give the developers an insight as to why this isn't working for you: http://mediamonkey.com/forum/viewtopic.php?f=7&t=69
========================
Lowlander is there any way to force the rebuilding of the MMCache directory? If I do the following I see the cache directory being built up.

- Close down MM
- go into the temp directory as listed above
- Nuke the temp files
- relaunch MM
- Go into the album view (no art will be seen)
- now if I select and play various albums, then I toggle between 'show album art' and 'show album art with details' then I see the cache files being populated

Is there anyway to populate this cache file without having to play a single song from the various albums? (yeah forcing MM to do this manually would take quite a bit of time on larger collections)


Belg
Last edited by Belgrath on Mon Sep 06, 2010 11:20 pm, edited 1 time in total.
Lowlander
Posts: 47913
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Lowlander »

Removing the cache folders from the temp directory set under Tools > Options > General would force rebuilding I assume.
Lowlander (MediaMonkey user since 2003)
Belgrath
Posts: 71
Joined: Sat Oct 27, 2007 6:14 pm
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Belgrath »

Lowlander wrote:Removing the cache folders from the temp directory set under Tools > Options > General would force rebuilding I assume.
Doesn't seem to... but a force a rebuild on an album basis by my steps above.... Sorry I edited my post before checking to see if you responded...
Lowlander
Posts: 47913
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Lowlander »

It should rebuild when viewing files in your library, it doesn't do it automatically for the whole collection.
Lowlander (MediaMonkey user since 2003)
Barry4679
Posts: 1164
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: **DEFINITIVE ANSWER NEEDED: Why isn't album art showing?

Post by Barry4679 »

Belgrath wrote: Is there anyway to populate this cache file without having to play a single song from the various albums? (yeah forcing MM to do this manually would take quite a bit of time on larger collections)
I deleted all the cache files, then put MM into Show Album Art mode (View|ShowAlbumArt). I then rolled through my whole collection. I have 1300 albums; it took less than a minute). This rebuilt the cache. The disappearing album art problem seems to have gone away for me.
Batalanto!
Posts: 72
Joined: Sun Nov 05, 2006 4:24 am
Contact:

Nohitter: Here's the problem...

Post by Batalanto! »

When I look at my inventory of tunes under the "Show album art with details", most - but not all - of the album art shows up. I can usually get it to show if - album by album - I right click while hovering over where the image should be and choose "Image 1" or "Image 2" or whatever. But that makes for a plodding and irritating process.

On the question of needing to provide steps to "recreate the problem", this is an easy way for MM to recuse itself from having to take ownership and resolve its own program's problems. As a consumer, it's not my responsibility to do MM's troubleshooting footwork. And this is the only company I've dealt with in which the import of my issue is based solely on whether I can provide "recreating" information or not. There is much about this product I love and contribution feels good, so I'm willing to forward or share whatever information that might aid programmers. But if I myself knew how to recreate certain features that are more endemic to the program itself (rather than how the consumer is using it) I might be able to solve the issue myself.

Seriously, nohitter, there is nothing more for me to say than "I buy MM. I install it. I have the program scan in all my music with image art attached to the tag AND included as a jpeg in the file. I switch to "Album view with details" and the artwork doesn't show." In a situation like this, providing "additional" information as a requirement for MM to resolve the issue for myself (and others, whether that amount is big or small) is a cop out.

I welcome your thoughts and feedback.
Post Reply