Odd podcast behavior: can play, can't download [#8876]

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Kimpire

Odd podcast behavior: can play, can't download [#8876]

Post by Kimpire » Sun Dec 18, 2011 9:33 am

Ever since I upgraded to MediaMonkey 4.0.0.1459, one of my podcasts has stopped working. I haven't been able to download any episodes, getting the error "HTTP/1.1 404 Not Found" for each one, but what's weird is that I'm still able to double-click on episodes to start playing them and they work perfectly. All of my other podcasts save for this one (http://www.dafyomiyicc.org/sec-audio.rss for those who want to see if they can reproduce the error) work perfectly as well.

Now, it could well be a coincidence - maybe the podcast changed its RSS format around the same time I upgraded MediaMonkey (there was a span of about a week or two during which I downloaded no episodes, at the end of which I ran the upgrade, so it doesn't have to be too insane of a coincidence for this to be the case) but I know that in my previous version (3.something) it worked perfectly fine.

Help!
Last edited by Lowlander on Sun Dec 18, 2011 4:27 pm, edited 1 time in total.
Reason: Moved to Bug Report forum

Lowlander
Posts: 47582
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Odd podcast behavior: can play, can't download

Post by Lowlander » Sun Dec 18, 2011 3:50 pm

Did the Podcast work in MediaMonkey 3? Does it work in other Podcast catchers? I do see the same here on 4.0.1.
Lowlander (MediaMonkey user since 2003)

Yerushalmi
Posts: 23
Joined: Sun Apr 11, 2010 5:12 am

Re: Odd podcast behavior: can play, can't download

Post by Yerushalmi » Sun Dec 18, 2011 4:23 pm

(Note: I am the original poster; this is my actual account. I typed in the wrong name under username, not noticing it wasn't expecting me to log in, and it let me use it temporarily.)

The podcast did indeed work perfectly in MM3. And I've just tried downloading the most recent episode through gPodder, an Ubuntu podcast program, and it works perfectly fine.

Lowlander
Posts: 47582
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Odd podcast behavior: can play, can't download

Post by Lowlander » Sun Dec 18, 2011 4:26 pm

I've added it here to the bug tracker: http://www.ventismedia.com/mantis/view.php?id=8876
Lowlander (MediaMonkey user since 2003)

larry1024
Posts: 1
Joined: Mon Jan 02, 2012 10:02 am

Re: Odd podcast behavior: can play, can't download [#8876]

Post by larry1024 » Mon Jan 02, 2012 10:07 am

I have exactly the same problem; worked great in version 3 but not at ALL in version 4.

Yerushalmi
Posts: 23
Joined: Sun Apr 11, 2010 5:12 am

Re: Odd podcast behavior: can play, can't download [#8876]

Post by Yerushalmi » Mon Jan 02, 2012 10:18 am

Well, according to the bug tracker, it's been fixed in 4.0.3. When it gets released, I hope to post here with effusive thanks :)

Lowlander
Posts: 47582
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Odd podcast behavior: can play, can't download [#8876]

Post by Lowlander » Mon Jan 02, 2012 4:33 pm

The fix is for a specific Podcast.

For those that upgrade from MM3 to MM4 and have Podcasts not updating just open each Podcasts settings and copy & paste the URL (some indicated merely Oking the window is enough) should fix this.
Lowlander (MediaMonkey user since 2003)

Lowlander
Posts: 47582
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Odd podcast behavior: can play, can't download [#8876]

Post by Lowlander » Tue Jan 03, 2012 3:46 pm

Lowlander (MediaMonkey user since 2003)

Post Reply