error during player initialization

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Digiti
Posts: 3
Joined: Sat Apr 14, 2012 2:52 pm
Contact:

Re: error during player initialization

Post by Digiti »

I found a fix for this issue:"error during player initialization". I did a complete uninstall of MM with the free Revo Uninstaller using its moderate setting then rebooted. After the reboot I reinstalled MM lastest version.. I selected the skin override of Windows skinning. I now have a working skinnable MM.
tHe-BiNk

Re: error during player initialization

Post by tHe-BiNk »

On a new machine (new windows install without any prior installation of MM), if you install the portable version you get this error. Installing first the non-portable version, followed by the portable version, solved my problem. I used the most recent beta MM 4.0.5 something.
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

I would like to confirm this. The problem seems to be the last.fm dll file from the native scrobbler in combination with Windows 7 and a portable installation.

If you install MM portable on a windows 7 machine (or just attach a drive that has it pre-installed) you will get the player initialization error. If you remove the .dll file it works fine, except you can't scrobble.

If you install a non-portable version first and then install a portable version it works fine and you can scrobble.
Image
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

Has anyone been able to pinpoint the exact nature of this problem? The offending file is clearly gen_LastFMScrobbler.dll

If that file is present in a portable installation on a system that runs win 7 that does not also have a non-portable installation of MM then we get the error described above.

Has anyone been able to run this exact setup without the problem? I now know of 4 direct instances of this problem in my private circle, all 4 of these instances have used different win 7 installs, meaning they do not come from the same win 7 disk or .iso. I have seen no example where it actually did work.

It seems to me that the .dll file needs to be registered in Win 7 for it to work properly. Maybe 'registered' is not the correct word. Anyway what happens with the .dll file when one installs non-portable which does not happen when one installs portable?
Image
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: error during player initialization

Post by nohitter151 »

Onweerwolf wrote:Has anyone been able to pinpoint the exact nature of this problem? The offending file is clearly gen_LastFMScrobbler.dll

If that file is present in a portable installation on a system that runs win 7 that does not also have a non-portable installation of MM then we get the error described above.

Has anyone been able to run this exact setup without the problem? I now know of 4 direct instances of this problem in my private circle, all 4 of these instances have used different win 7 installs, meaning they do not come from the same win 7 disk or .iso. I have seen no example where it actually did work.

It seems to me that the .dll file needs to be registered in Win 7 for it to work properly. Maybe 'registered' is not the correct word. Anyway what happens with the .dll file when one installs non-portable which does not happen when one installs portable?
Maybe there's a problem with the scrobbler toolbar button settings as they are usually saved in the registry?
HKEY_CURRENT_USER\Software\MediaMonkey\Interface\V4\Toolbars\LastFMScrobbler
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

Oh, you might be on to something here.
Image
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

nohitter151 wrote:Maybe there's a problem with the scrobbler toolbar button settings as they are usually saved in the registry?
HKEY_CURRENT_USER\Software\MediaMonkey\Interface\V4\Toolbars\LastFMScrobbler
Well, I don't have that folder in my registry.
Image
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: error during player initialization

Post by nohitter151 »

Onweerwolf wrote:
nohitter151 wrote:Maybe there's a problem with the scrobbler toolbar button settings as they are usually saved in the registry?
HKEY_CURRENT_USER\Software\MediaMonkey\Interface\V4\Toolbars\LastFMScrobbler
Well, I don't have that folder in my registry.
I wouldn't expect you to, since you are using the portable version. The portable version shouldn't save anything to the computer, including in the registry.

My point is that maybe the addon gives an error message when it cannot access the regular registry.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

But I installed the non portable version as well to make sure I could scrobble.

I did however uninstall the non-portable version after that.
Image
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: error during player initialization

Post by nohitter151 »

Onweerwolf wrote:But I installed the non portable version as well to make sure I could scrobble.

I did however uninstall the non-portable version after that.
The registry entry still wouldn't appear unless you installed non-portable, and then installed the scrobbler addon for the non-portable.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

But the scrobbler add-on comes with MM itself these days, right?
Image
Lowlander
Posts: 47910
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: error during player initialization

Post by Lowlander »

No, it doesn't.
Lowlander (MediaMonkey user since 2003)
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

I see, I thought it did.

Anyway, it could indeed be something with the add-on not being able to access the registry then or something similar.
Image
spacekris
Posts: 159
Joined: Sun Mar 05, 2006 8:09 pm
Contact:

Re: error during player initialization

Post by spacekris »

pretty annoying, i also installed the portable version and ran it on server 2003.
then i started it on win7 (dualboot,same mm location).
both worked fine until next restart with server2003, then i got the failed initialization error.
when i try to change skin, the image error appears.
i deleted temp & registry from the portable dir, but still no light..

my version is 1501.. how can i fix this error??

ps. i dont have scrobble dll and error appears with skinned and non-skinned.
Lowlander
Posts: 47910
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: error during player initialization

Post by Lowlander »

Send a debug log (step 4b) to support: http://www.mediamonkey.com/forum/viewtopic.php?t=69
Lowlander (MediaMonkey user since 2003)
Post Reply