error during player initialization

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

Meh78 wrote:This still happens : (

MM Gold 4.1.5.1719 (Portable Mode)

Installing the last.fm plugin (tried 1.0.2.29 and also 1.0.2.26), you start getting this error after a restart. I'm on "Metro M" skin and the player (with the start button etc.) disappears completely, I cannot even find it or drag it around.

It's definitely the last.fm plugin causing this error.
Yes it is. Installing MM in non-portable mode in addition to portable mode fixes this.

You can de-install the non-portable version afterwards. It's probably some kind of registry thing.
Image
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

Got a chance to test this on Windows 10 last week, bug is still persistent there.
Image
Onweerwolf
Posts: 665
Joined: Tue Dec 12, 2006 5:32 pm
Location: The Netherlands
Contact:

Re: error during player initialization

Post by Onweerwolf »

Onweerwolf wrote:Has anyone been able to pinpoint the exact nature of this problem? The offending file is clearly gen_LastFMScrobbler.dll

If that file is present in a portable installation on a system that runs win 7 that does not also have a non-portable installation of MM then we get the error described above.

Has anyone been able to run this exact setup without the problem? I now know of 4 direct instances of this problem in my private circle, all 4 of these instances have used different win 7 installs, meaning they do not come from the same win 7 disk or .iso. I have seen no example where it actually did work.

It seems to me that the .dll file needs to be registered in Win 7 for it to work properly. Maybe 'registered' is not the correct word. Anyway what happens with the .dll file when one installs non-portable which does not happen when one installs portable?
After many years the above problem still exists for me. Has anyone managed to find a solution for this?
Image
MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm
Contact:

Re: error during player initialization

Post by MMFrLife »

4 pages and no comments on this from Peke (add-on author)?
Maybe this should be in the Scrobbler thread.
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]
Post Reply