Statistics report is wrong

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

leafinator
Posts: 86
Joined: Thu Nov 09, 2006 10:23 am

Statistics report is wrong

Post by leafinator »

I ran the statistics today and noticed that the total number of files it shows and actually number of files is off by a wide margin. Is this a bug? I've done everything I can think to do to try to correct this so far:

1.) Ran the locate removed/missing files (removed all files that were missing etc...)
2.) Ran the maintain script with everything checked other than "create multi-artist albums

Is there something else that I can try?
User since 2006, Lifetime licence owner since 2007
Lowlander
Posts: 48769
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Statistics report is wrong

Post by Lowlander »

How is it off? Did you verify with the Entire Library Collection how many files are shown? Also try File > Maintain Library with complete optimization.
Lowlander (MediaMonkey user since 2003)
leafinator
Posts: 86
Joined: Thu Nov 09, 2006 10:23 am

Re: Statistics report is wrong

Post by leafinator »

The total number of tracks it shows is what's way off (by about 20,000). I ran the File > Maintain Library with complete optimization but the report shows the same number. How would I go about verifying the entire library? Thanks for the response!
User since 2006, Lifetime licence owner since 2007
Lowlander
Posts: 48769
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Statistics report is wrong

Post by Lowlander »

20,000 too many or too little? Enable Entire Library under Tools > Options > Media Tree.
Lowlander (MediaMonkey user since 2003)
leafinator
Posts: 86
Joined: Thu Nov 09, 2006 10:23 am

Re: Statistics report is wrong

Post by leafinator »

20,000 too many. I only use MM for sound files - not video files if that helps. I enabled the entire library as you suggested and then ran a statistic report and it gave me the same problem, do I need to restart or do something else after enabling the entire library before running another report? As always, thanks a ton for taking the time to help me!!
User since 2006, Lifetime licence owner since 2007
Lowlander
Posts: 48769
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Statistics report is wrong

Post by Lowlander »

Did you verify with the Entire Library Collection (you can select Location node if Collection nodes aren't set to show all files) how many files are in your Library? Any of the other Collections show a filtered amount of files.

Testing here shows a discrepancy of only 1 file between Entire Library > Location and Statistics, but the same amount between Entire Library and Statistics.
Lowlander (MediaMonkey user since 2003)
Lowlander
Posts: 48769
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Statistics report is wrong

Post by Lowlander »

And Maintain Library fixed that discrepancy for me.
Lowlander (MediaMonkey user since 2003)
leafinator
Posts: 86
Joined: Thu Nov 09, 2006 10:23 am

Re: Statistics report is wrong

Post by leafinator »

Problem is now fixed. When I deselected all but entire library and then selected "Artist and Album Artist" it showed the same number of files as in the statistics report. Thanks a ton Lowlander for your help.
User since 2006, Lifetime licence owner since 2007
Post Reply