Auto-Organize not deleting empty folders.

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

SpunkyTheMunky

Auto-Organize not deleting empty folders.

Post by SpunkyTheMunky » Sun Jan 27, 2013 11:39 pm

I freakin' LOVE MM. In fact, it's one of the only reasons I am not willing to switch to OSX. I would also love to upgrade to Gold, but there is a problem I have always had: auto-organize doesn't delete empty folders even though I choose to do so with the check box. It simply doesn't work. If I could figure this out I will probably be upgrading to Gold.

Thanks!

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: Auto-Organize not deleting empty folders.

Post by nohitter151 » Mon Jan 28, 2013 12:14 am

Probably the folders aren't actually empty but still have files in them (artwork or windows index files)
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

rovingcowboy
Posts: 14162
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Auto-Organize not deleting empty folders.

Post by rovingcowboy » Mon Jan 28, 2013 2:45 am

Yeah check for hidden windows desktop ini files in them if you customize windows explorer with different images for a few folders it likes to add the desktop ini to every folder then, and thats a hidden file. Also if you used any other player to play songs from those folder or burn cds from those songs it would have stuck a file in for it to remember what the songs were and or where they are, :)
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

hajoni
Posts: 6
Joined: Sun Jan 13, 2013 6:33 am

Re: Auto-Organize not deleting empty folders.

Post by hajoni » Mon Jan 28, 2013 4:55 am

Got the same Problem, after lot of tagging / reorganizing. Often *.jpg (album art) or *.txt *.lrc, *.thm files still remaining, so a folder is in fact not real "empty".
For this case I'm using "Remove Empty Directories - a freeware tool to batch delete empty folders" http://sourceforge.net/projects/rem-empty-dir/
It's quick & easy, of course it would be nicer, if something like that would become a built-in feature of MM.

SpunkyTheMunky

Re: Auto-Organize not deleting empty folders.

Post by SpunkyTheMunky » Mon Jan 28, 2013 12:35 pm

rovingcowboy wrote:Yeah check for hidden windows desktop ini files in them if you customize windows explorer with different images for a few folders it likes to add the desktop ini to every folder then, and thats a hidden file. Also if you used any other player to play songs from those folder or burn cds from those songs it would have stuck a file in for it to remember what the songs were and or where they are, :)
I actuallyha checked for hidden files as well before posting this as another thread with the same problem mentioned. There were no hidden files.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: Auto-Organize not deleting empty folders.

Post by nohitter151 » Mon Jan 28, 2013 3:08 pm

SpunkyTheMunky wrote:
rovingcowboy wrote:Yeah check for hidden windows desktop ini files in them if you customize windows explorer with different images for a few folders it likes to add the desktop ini to every folder then, and thats a hidden file. Also if you used any other player to play songs from those folder or burn cds from those songs it would have stuck a file in for it to remember what the songs were and or where they are, :)
I actuallyha checked for hidden files as well before posting this as another thread with the same problem mentioned. There were no hidden files.
Don't forget to also check for "Protected operating system files"
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

MyCsPiTTa
Posts: 128
Joined: Fri Dec 21, 2007 4:56 pm

Re: Auto-Organize not deleting empty folders.

Post by MyCsPiTTa » Sat May 03, 2014 11:35 pm

I know there are many posts about this, but I'd just like to revisit something I've noticed. l

I've recent done a fresh Windows install, along with MM, etc. The thin I notice is that I don't recall this "not deleting folders" thing happening in my old install.
I'm quite certain that the reason folders are not emptying is that they have artwork in them - though why MM can't just delete a "mostly empty folder" when the command is given to delete that album is beyond me.

But as I didn't used to have this problem, it seems to lie with the fact that MM Auto Organize copied the artwork over in the first place.
For example, in my old install Auto Org used to continuously monitor My Music root folder. So, after I've finished cleaning up tags etc, I would simply move folder to My Music, and MM would auto move those mp3s to their respective Genre/Artist/Album etc folders - but would NOT copy over any artwork, .nfo, .txt etc files - only the mp3.
Of course, that would sometime mean I had to manually then delete that "mostly empty" folder from the My Music root folder.

In my new install, it seems MM Auto Org copies over ALL files, which means non-mp3 files end up getting carried over.

I dunno, I haven't tested this extensively, so it may not 100% be what is going on. And the end-result of having to delete folders either when adding to my library or deleting from my library is the same. Except that it's much easier to remember to do when adding an album to my library.

Lowlander
Posts: 47576
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Auto-Organize not deleting empty folders.

Post by Lowlander » Sat May 03, 2014 11:41 pm

Auto-Organize (Files) should copy over accompanying files if they're not hidden (WMP creates hidden Artwork files) and all the music files in the folder belong to the same Album (if there are files from different Albums MM doesn't know which Album the accompanying files belong to).

Empty folders (actually empty, no hidden files either) should be deleted when using Auto-Organize (Files) and the option to do so is enabled.

For me both parts are working with Auto-Organize Files.
Lowlander (MediaMonkey user since 2003)

MyCsPiTTa
Posts: 128
Joined: Fri Dec 21, 2007 4:56 pm

Re: Auto-Organize not deleting empty folders.

Post by MyCsPiTTa » Sat May 03, 2014 11:53 pm

Same here; MM is working exactly as you describe. It just seems my recollection of my old install was that MM didn't copy over accompanying files, so auto-organised folders were purely mp3s (and hence deleted when album was deleted).

I think the thing most people are asking is that would be great if MM applied that same intuition of copying over accompanying files when adding, to when it is deleting an album. Maybe this couldn't be done if tracks are selected in the library window, but maybe a "rigth-click-->delete" on the album name Column Browser window.

Lowlander
Posts: 47576
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Auto-Organize not deleting empty folders.

Post by Lowlander » Sun May 04, 2014 12:08 pm

MyCsPiTTa wrote:but maybe a "rigth-click-->delete" on the album name Column Browser window.
I use right click on Folder in Location node to do this. You can quickly navigate there by using right click on file > Find More from Same > Folder (Library).
Lowlander (MediaMonkey user since 2003)

Post Reply