multiple Errors Querying Database; MMW Beta unusable

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

PDoyle
Posts: 74
Joined: Tue Mar 03, 2009 2:13 pm
Contact:

multiple Errors Querying Database; MMW Beta unusable

Post by PDoyle »

Good morning,
Hope you can help with Errors which have grown in frequency over the past month or so. After several hours yesterday organizing my 7,000 tracks, correct their tags, and move them into new folders; I noticed the script RegExp Find and Replace stopped removing leading digits on track titles. Now, MM cannot open without error that it cannot find the database, I have to create a new one. All my changes from yesterday do not appear. Plus I cannot even change the view without several errors; cannot query the database, plus autorate accurate script error. I cannot scroll the library; now Backup 6.0 cannot access the backup folders. Another error is connected to a track; which only appears as grayed out and isn't in the library anymore. I installed 1754 MMW Beta today; it's only gotten worse.
My pc is less than a year old; i've had to replace the failed hard drive, I've installed Portable several different places to try to help sync with MMA. I've gone back to regular installation after uninstalling all versions of MMW; Portable, standard. As of July 17th I think it was operating fine, and Pavle spent an hour working on it remotely helping me delete 80GB of duplicate files from windows.old, C:, etc.
When MMW works I love it...It seems to have a major problem more often than not. e.g. even when I'm ripping a CD to the library; I cannot seem to do it without errors turning up somehow. I rip Rolling Stones 40 Licks CD; and MMW sometimes reverses the Title and the Artist.
Any ideas?
Thanks!
MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm
Contact:

Re: multiple Errors Querying Database; MMW Beta unusable

Post by MMFrLife »

Did you try just uninstalling some of the problematic scripts and try querying without uninstalling the whole thing?
Pavle helped you just to remove dups or did he also make any suggestions as to what he thought might be happening?
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]
PDoyle
Posts: 74
Joined: Tue Mar 03, 2009 2:13 pm
Contact:

Re: multiple Errors Querying Database; MMW Beta unusable

Post by PDoyle »

thanks!
- Pavle did not say anything about problems, because the MMW Beta he was helping eliminate duplicates from the standard MMW Beta that had just been installed, after I had uninstalled all the problematic versions of standard and portable including updates. Upon that new installation, I had to create a new library, and did so by searching all music locations on my hdd; which resulted in 4,5 duplicate copies of most tracks. The tracks came from different directories; so I believe he had started moving groups of duplicates to the same directory, organizing the files; so then elimination would be easier.

I did remove a couple of scripts I was using yesterday; now I'm trying to locate 30GB of dead link tracks, out of a total library of 41GB. Some had successfully been organized yesterday; most had not, or were not saved. So many of the tracks had digits at the start of the track title; I was trying to remove them. Maybe that's not necessary, I just want every Rolling Stones track in the Rolling Stones upper folder; maybe they'll still end up there, even though the track title might read 00 Satisfaction

I'll keep eliminating scripts cuz I'm still getting errors now. I'm doing one at a time.
PDoyle
Posts: 74
Joined: Tue Mar 03, 2009 2:13 pm
Contact:

Re: multiple Errors Querying Database; MMW Beta unusable

Post by PDoyle »

I've deleted many scripts, restarted...now 32 GB of the 41 GB library tracks are dead links. MMW can find the tracks; but gives error Cannot Query Database and does not add the new locations, therefore doesn't eliminate the dead links. I'll try deleting more scripts...
Lowlander
Posts: 47897
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: multiple Errors Querying Database; MMW Beta unusable

Post by Lowlander »

What exactly does the database error message state?

Perhaps your drive is nearing its end of life causing trouble with file access.
Lowlander (MediaMonkey user since 2003)
PDoyle
Posts: 74
Joined: Tue Mar 03, 2009 2:13 pm
Contact:

Re: multiple Errors Querying Database; MMW Beta unusable

Post by PDoyle »

There are several different error notices that pop-up; cannot query database is the common element. If I clicked Album to sort in library view; rather than sort, I'd get three error messages. It wouldn't play a track; I'd get an error message.
I tried removing the MM.DB file; and replacing it with one from an earlier time this month, when I wasn't having problems. Even that did not work.
One of the consistent error messages looked like it was related to SongBird DB; another one mentioned AutoAccuRate, another script I had downloaded.
Some of the error messages would allow me to use MM if I clicked onto Cancel.
Ultimately I deleted most of the scripts I had installed; then used Revo uninstaller to completely remove MM. then I re=installed the newest Beta version of MMW. I created a new database by scanning the new directory file locations I had organized most of the tracks into; still on the C drive, my music. That worked, and MMW seems to be working properly now. It has 1 GB more files than yesterday; but many are duplicates, I can remove them.
So I learned that the autoorganizing was successful; yet it seemed to burn out and crash MM, to where it needed to be reinstalled.

I just hope it doesn't happen again.
The UPNP/DLNA is back working again...
I'm tempted to use Backup 6.0, but that was one of the scripts I was using every day; could that have caused a problem?
thanks!
Post Reply