Error on Startup After folder scan

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Downink
Posts: 4
Joined: Fri Feb 16, 2018 10:37 am

Error on Startup After folder scan

Post by Downink » Fri Feb 16, 2018 10:44 am

Hi-

Longtime MM Gold user here, first time caller. I have not had any issues until the most recent update. When I start MM now, it scans my actively monitored folder but as soon as it is finished, the app crashes with the following error:

MediaMonkey has encountered a problem - A call to an OS function failed.

I can close MM after the error but it does not actually close or kill the running process. I have to manually kill it in Task Manager.

I have done extensive browsing of the forums, reverted back to an earlier version, installed the debug version and submitted multiple bug reports via the MM error reporting window that pops up. Since I'm not seeing this error reported other places, I assume it's something specific to my machine? Any troubleshooting advice would be appreciated and I'm happy to provide log files or bug reports.

Thank you!

Lowlander
Posts: 46093
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Error on Startup After folder scan

Post by Lowlander » Fri Feb 16, 2018 12:19 pm

Which version of MediaMonkey?
Lowlander (MediaMonkey user since 2003)

Downink
Posts: 4
Joined: Fri Feb 16, 2018 10:37 am

Re: Error on Startup After folder scan

Post by Downink » Fri Feb 16, 2018 1:28 pm

Currently running 4.1.19.1859. It also happened in an identical manner with 4.1.20.1864.

Lowlander
Posts: 46093
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Error on Startup After folder scan

Post by Lowlander » Fri Feb 16, 2018 2:04 pm

Then capture it in a debug log (step 4b) and attach it to a Support Ticket: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=69
Lowlander (MediaMonkey user since 2003)

Downink
Posts: 4
Joined: Fri Feb 16, 2018 10:37 am

Re: Error on Startup After folder scan

Post by Downink » Fri Feb 16, 2018 2:56 pm

Thanks for the response. I attempted to submit the ticket with an attached DebugView log and received the following response:

We encountered a problem (cross-site request forgery detected); please try again
Sorry, we encountered a problem (invalid department). Please start over.

As I stated earlier, I have submitted multiple debug reports via the MM interface each time this happens. Is that not providing the same information? I included my email address, which is the same as my user account here, so it should be trackable in some manner.

Lowlander
Posts: 46093
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Error on Startup After folder scan

Post by Lowlander » Fri Feb 16, 2018 4:50 pm

See: http://www.mediamonkey.com/support/inde ... t-web-site

Auto submitted logs go on the big pile and can be easily missed, so you receive no feedback. This means that it may take much longer or not even get resolved. Opening a Support Ticket with the log file works much better (if you're able to submit in the first place).

Make sure you ZIP/RAR the log file.
Lowlander (MediaMonkey user since 2003)

Downink
Posts: 4
Joined: Fri Feb 16, 2018 10:37 am

Re: Error on Startup After folder scan

Post by Downink » Mon Apr 09, 2018 10:27 am

Just wanted to post a follow-up for anyone that comes across my thread looking for a similar issue. Putting MM in compatibility mode has eliminated the error and MM now functions and closes properly.

ceinj
Posts: 65
Joined: Sun Mar 22, 2009 4:36 pm

Re: Error on Startup After folder scan

Post by ceinj » Mon Sep 09, 2019 11:57 pm

I ran across a similar issue. The portable version of MM (1885) worked fine but the regular version encountered this error. Your suggestion worked fine! But I wonder what is the real root cause.

Post Reply