Sony NW-A55 not all songs appear on playlist

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

CosmicKnowledge
Posts: 127
Joined: Sun Mar 15, 2020 11:24 am

Re: From Bad to Worse

Post by CosmicKnowledge »

Peke wrote: Tue Oct 27, 2020 3:04 pm Hi,
Are you referring to Sony NW-A55 from https://www.mediamonkey.com/forum/viewt ... 70#p472470 ?

Duplicates are worked on thru https://www.ventismedia.com/mantis/view.php?id=16901 and main issue is that A55 is not Android player where you can install MMA.

During summer I had few hours with A100 at my friends shop https://www.sony.com/electronics/walkma ... s#features and installed nightly build of MMA 2.0 it was amazing experience not a single issue with syncing to https://www.lexar.com/portfolio_page/hi ... s-i-cards/ and https://www.amazon.com/Lexar-Profession ... B088K39RBN Write speeds were around 60MB/s Direct to SDCard and around 25MB/s over Wi-Fi 802.11ac (450mbit connection). No duplicates playlist there at its place, clean folder structure, Sony native player registered all track and playlist (few tweaks needed, eg. relative path and playlists directly to music. But that is native player limitation Power player alongside MMA worked perfectly).
I'm not talking about MMA or Android. Let's not get sidetracked.

The Sony NW-A55 does nothing more than act as an SD card reader. MM simply copies files to the mounted filesystem. When are you guys going to fix this? A month ago, I gave you guys remote desktop access to my system, let you collect debug logs, gave you the MM database, etc.

I still have a paperweight.
Lowlander
Posts: 49792
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Sony NW-A55 not all songs appear on playlist

Post by Lowlander »

1) What do you have selected for sync? Is it parts of Collections or do AutoPlaylists you created?

2) What settings do you have set for Playlist sync in the Device Profile?

3) Do the Playlist files not get created on the card (check with File Explorer) or can the device not read the Playlist files on the card?

4) How exactly do you initiate sync?

Be as detailed as possible as sync is generally working.
Lowlander (MediaMonkey user since 2003)
CosmicKnowledge
Posts: 127
Joined: Sun Mar 15, 2020 11:24 am

Re: From Bad to Worse

Post by CosmicKnowledge »

Lowlander wrote: Tue Oct 27, 2020 2:28 pm Provide more details on your exact setup or capture this in a debug log (step 4b) and attach it to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... p?f=7&t=69.

Are you syncing directly to the SD card or the SD card in a device?
What happened with all the logs and database you guys got from me for the first issue? Is that problem fixed?
CosmicKnowledge
Posts: 127
Joined: Sun Mar 15, 2020 11:24 am

Re: Sony NW-A55 not all songs appear on playlist

Post by CosmicKnowledge »

Lowlander wrote: Tue Oct 27, 2020 4:13 pm 1) What do you have selected for sync? Is it parts of Collections or do AutoPlaylists you created?
I don't know what you mean by parts of collections.... isn't any playlist or autoplaylist contained in a collection, even if it's just the default one? But I am syncing only autoplaylists.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 2) What settings do you have set for Playlist sync in the Device Profile?
I'm 1500 miles from home so I can't take screenshots right now but basically the same sync settings I had prior to the latest MM release. The prior settings worked. (although MM has an indexing problem that results in not all songs mentioned in the playlist being replicated to the device).
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 3) Do the Playlist files not get created on the card (check with File Explorer) or can the device not read the Playlist files on the card?
Glad you asked because there's much misunderstanding.
a) If you browse the filesystem using any file explorer (e.g. explorer.exe, cmd.exe), you will find no M3U playlist text files anywhere on the SD card.

b) Since (a) is true, naturally the device will show no playlists.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm 4) How exactly do you initiate sync?
I disabled/unchecked sync on initial connect. I press the sync button on the bottom right of the interface when the proper SD card is selected on the directory tree. The same way I've always done it.
Lowlander wrote: Tue Oct 27, 2020 4:13 pm Be as detailed as possible as sync is generally working.
It *was* (generally) working. It just didn't sync half the playlist contents.

This recent release definitely broke everything.
Murdie
Posts: 8
Joined: Thu Sep 03, 2020 2:37 am

Re: Sony NW-A55 not all songs appear on playlist

Post by Murdie »

Hi i run A40 the unit hasn't changed much since then. and I pretty sure software wise it hasn't except for addition of MQA.flac maybe.
Please read my post on sync on A40-45. If you have recently bought/ recieved a55 (merry christmas) and are trying a large song library transfer to your sd card and re-reading this thread with problems then check below.I know this player is making it higher in the recommended dap playlists these days.

viewtopic.php?p=472323#p472323.

I too synced only autoplaylists for a while, please note point 2 and 3 on the above post.
Also the free add-on plug-in for the a A40-45 and 50 hasn't been updated for wav and flac.

Reading your post, I am going to highlight just 4 lines from your post(s) and share my thoughts and observations i remember to my memory.
CosmicKnowledge wrote: Tue Oct 27, 2020 4:25 pm It *was* (generally) working. It just didn't sync half the playlist contents.

1) "The prior settings worked. (although MM has an indexing problem that results in not all songs mentioned in the playlist being replicated to the device)."

2) "a) If you browse the filesystem using any file explorer (e.g. explorer.exe, cmd.exe), you will find no M3U playlist text files anywhere on the SD card. b) Since (a) is true, naturally the device will show no playlists."

3) "It *was* (generally) working. It just didn't sync half the playlist contents."

4) the lines dont match the playlists in MM

So there are 2 thoughts on what's happening here.
I am going to assume you are doing some of these actions based on my post link in this post above, a) you are going to write the autoplaylists to the sd card along with the files due to sony kinda crazy playlists dont see each others contents via 2 separate storage areas (internal and sd). you have installed plugin 1.2 of the free add on from https://www.mediamonkey.com/addons/brow ... 40-series/ and have read the limitations from my above post. and your now at this step

1) you are attempting to do a large transfer of files on to a sd card (new or freshly formatted)

If all 1-3 points above are true then its very likley windows power saving settings (screen saver screen lock) or some other usb shut off has occurred or something has interrupted MM over the hour(s) of the transfer. I have seen this on android phone sync via cable and Sony a40. Since playlists are created last a lack of playlists M3U8 files (that's what I am using) suggests it didn't write them. I have now bought a usb3.0 hub which I connect my old (7 year) desktop pc via a rear usb3.0 port, if you are using a usb 2.0 port Its going to take along time to transfer over 120gb of music to the device thus time out is a risk at least on my system thats what i have found so use a usb 3.x port.

TIP: - in the left hand pane of MM4 where you select the card for sync, if you double click on that you will see the contents of the card. in my card which I assume is the plugin setting (I cant remember) {sd card name}/Music/Artist/Album if you scroll down that artist list and it stops at say R then also indicator that it didnt sync all the tracks. Also playlist files are stored in the root music folder in my player. so under the artist folders right at the bottom you shouild see your playlist files.

FIX just resync, MM should look at what's on the card and go find everything that's missing and add it. If you do want too and want a fresh format the card from start (remember to apply plugin if its a deep format with rename or at the very least see the linux option at bottom of this post). disable windows sleep under power settings in windows then sync, to hopefully stop this from happening. I dont know for sure what time outs but i think this I turn off sleep as a mater of large transfers to cards as standard now in MM. once done turn it back on.

2) If you only have a problem with point 3
and read my above post then its v.likley you haven't enabled Wav or flac from the plug in. V1.2 it has your sony player as not being able to play these this can be seen in {select card}/options/auto conversion/ (supported formats on device - bottom of page) also note that incompatible audio is unticked so it wont convert the tracks thus playlist will be light (ps you don't want to convert to mp3 cause they are trash). {{this references earlier post comments about playlist lines not matching contents of device}}.

CROSS CHECK"- create a autoplaylist/advanced/{add search criteria}/property{Extention} select wav flac. Then name playlist "wav flac", and sort by album.
This provides a 2 fold test,
1) without resyncing look at the playlist in MM select few albums different format and bitrate and see if they are on the sony device, are these your missing files?
2) now resync and the sony after selecting the "wav flac" playlist to sync to device, if its empty then you need to add these formats.

FIX that can via {select card}/options/auto conversion/ (supported formats on device - bottom of page) above or if you want to see a full list of compatible files types see the link at the start of this post.

QUESTION FOR PEKE and awareness for lowlander. I haven't done this for MQA files as I dont have any. I don't know if that's a selectable file type for MM4 as I think they are mqa.flac extensions is this captured under the flac tag? Also be awear that MQA is supported for A55 I think A45 but I am not sure for the A40.

Also the 999 files playlist size is for using the sony software for transfer as referenced in the A45 thread above. I have a autoplaylist on the sd card of 3077 files which the sony walkman handles fine.

FOR EVERYONE ELSE NOT USING THE PLUG IN. good luck in configuring BUT you will need to {select card or device for playlist tracks} device/options/playlists/ tick the box saying "Use linux folder separator (/ instead of \)" This is also where it states the directory the playlist are getting written to.
Last edited by Murdie on Mon Jan 04, 2021 10:45 am, edited 13 times in total.
CosmicKnowledge
Posts: 127
Joined: Sun Mar 15, 2020 11:24 am

Re: Sony NW-A55 not all songs appear on playlist

Post by CosmicKnowledge »

Murdie wrote: Mon Jan 04, 2021 4:35 am Hi i run A40 the unit hasn't changed much since then. and I pretty sure software wise it hasn't except for addition of MQA.flac maybe.
Please read my post on sync on A40-45. If you have recently bought/ recieved a55 (merry christmas) and are trying a large song library transfer to your sd card and re-reading this thread with problems then check below.I know this player is making it higher in the recommended dap playlists these days.

viewtopic.php?p=472323#p472323.

I too synced only autoplaylists for a while, please note point 2 and 3 on the above post.
Also the free add-on plug-in for the a A40-45 and 50 hasn't been updated for wav and flac.

Reading your post, I am going to highlight just 4 lines from your post(s) and share my thoughts and observations i remember to my memory.
CosmicKnowledge wrote: Tue Oct 27, 2020 4:25 pm It *was* (generally) working. It just didn't sync half the playlist contents.

1) "The prior settings worked. (although MM has an indexing problem that results in not all songs mentioned in the playlist being replicated to the device)."

2) "a) If you browse the filesystem using any file explorer (e.g. explorer.exe, cmd.exe), you will find no M3U playlist text files anywhere on the SD card. b) Since (a) is true, naturally the device will show no playlists."

3) "It *was* (generally) working. It just didn't sync half the playlist contents."

4) the lines dont match the playlists in MM

So there are 2 thoughts on what's happening here.
I am going to assume you are doing some of these actions based on my post link in this post above, a) you are going to write the autoplaylists to the sd card along with the files due to sony kinda crazy playlists dont see each others contents via 2 separate storage areas (internal and sd). you have installed plugin 1.2 of the free add on from https://www.mediamonkey.com/addons/brow ... 40-series/ and have read the limitations from my above post. and your now at this step

1) you are attempting to do a large transfer of files on to a sd card (new or freshly formatted)

If all 1-3 points above are true then its very likley windows power saving settings (screen saver screen lock) or some other usb shut off has occurred or something has interrupted MM over the hour(s) of the transfer. I have seen this on android phone sync via cable and Sony a40. Since playlists are created last a lack of playlists M3U8 files (that's what I am using) suggests it didn't write them. I have now bought a usb3.0 hub which I connect my old (7 year) desktop pc via a rear usb3.0 port, if you are using a usb 2.0 port Its going to take along time to transfer over 120gb of music to the device thus time out is a risk at least on my system thats what i have found so use a usb 3.x port.

TIP: - in the left hand pane of MM4 where you select the card for sync, if you double click on that you will see the contents of the card. in my card which I assume is the plugin setting (I cant remember) {sd card name}/Music/Artist/Album if you scroll down that artist list and it stops at say R then also indicator that it didnt sync all the tracks. Also playlist files are stored in the root music folder in my player. so under the artist folders right at the bottom you shouild see your playlist files.

FIX just resync, MM should look at what's on the card and go find everything that's missing and add it. If you do want too and want a fresh format the card from start (remember to apply plugin if its a deep format with rename or at the very least see the linux option at bottom of this post). disable windows sleep under power settings in windows then sync, to hopefully stop this from happening. I dont know for sure what time outs but i think this I turn off sleep as a mater of large transfers to cards as standard now in MM. once done turn it back on.

2) If you only have a problem with point 3
and read my above post then its v.likley you haven't enabled Wav or flac from the plug in. V1.2 it has your sony player as not being able to play these this can be seen in {select card}/options/auto conversion/ (supported formats on device - bottom of page) also note that incompatible audio is unticked so it wont convert the tracks thus playlist will be light (ps you don't want to convert to mp3 cause they are trash). {{this references earlier post comments about playlist lines not matching contents of device}}.

CROSS CHECK"- create a autoplaylist/advanced/{add search criteria}/property{Extention} select wav flac. Then name playlist "wav flac", and sort by album.
This provides a 2 fold test,
1) without resyncing look at the playlist in MM select few albums different format and bitrate and see if they are on the sony device, are these your missing files?
2) now resync and the sony after selecting the "wav flac" playlist to sync to device, if its empty then you need to add these formats.

FIX that can via {select card}/options/auto conversion/ (supported formats on device - bottom of page) above or if you want to see a full list of compatible files types see the link at the start of this post.

QUESTION FOR PEKE and awareness for lowlander. I haven't done this for MQA files as I dont have any. I don't know if that's a selectable file type for MM4 as I think they are mqa.flac extensions is this captured under the flac tag? Also be awear that MQA is supported for A55 I think A45 but I am not sure for the A40.

Also the 999 files playlist size is for using the sony software for transfer as referenced in the A45 thread above. I have a autoplaylist on the sd card of 3077 files which the sony walkman handles fine.

FOR EVERYONE ELSE NOT USING THE PLUG IN. good luck in configuring BUT you will need to {select card or device for playlist tracks} device/options/playlists/ tick the box saying "Use linux folder separator (/ instead of \)" This is also where it states the directory the playlist are getting written to.
Unfortunately none of this helps my case. I'm using MM Android and the failure is squarely in the MMA client.
jackpetj

Re: Sony NW-A55 not all songs appear on playlist

Post by jackpetj »

I have an NW-A45 and inserted a 512Gb SD microcard, formatted and mounted it via the settings menu. After transferring music files to the SD using my laptop I could see they were present on the SD card, but they were not listed on the Walkman music listing.
It took some searching, but I found them !
On the main menu screen that appears when the Walkman starts up (Artist, Songs, etc...) there is a second menu screen (swipe left) there are two small dots at the bottom of the screen to show which menu screen you are looking at.
On the second screen there is a FOLDER icon. Click on this and select the SD card to see all the files on the SD card !!
I'm sure Sony could improve navigation or access to the SD card.
Good luck.
Post Reply