Device Deleted Files Won't Re-Sync

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

Sucia
Posts: 3
Joined: Mon Jul 19, 2010 4:56 pm

Device Deleted Files Won't Re-Sync

Post by Sucia » Tue Nov 09, 2010 2:28 pm

I've been working through trying to get my Android 2.2 based Epic phone to sync with MM. I think I've figured it out, however during the process of troubleshooting, I deleted a number of Podcasts and a few music files from the device outside of MM using Windows Explorer.

Now that I have the sync settings correct (USB plugin, instead of WMDM), I'm finding that the previously deleted files are just not transferring during the auto-sync process or even during a push (right click, send to the device).

It's as if MM has some sort of cache file to remember files loaded to device that have been deleted from the device so it won't try to load them again.

If this is true, is there a way to delete this history/cache file?

Thanks.

J.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: Device Deleted Files Won't Re-Sync

Post by nohitter151 » Tue Nov 09, 2010 6:41 pm

No, this isn't true. There's no cache or anything like that, for USBmass plugin MM checks the timestamp of the files on the filesystem.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Sucia
Posts: 3
Joined: Mon Jul 19, 2010 4:56 pm

Re: Device Deleted Files Won't Re-Sync

Post by Sucia » Wed Nov 10, 2010 2:47 pm

Yep. False alarm.

Figured out late yesterday that I made a fatal error - I selected, drug and dropped the files into the folder on my Epic - which moved the files rather than copying them, so when I deleted them - I had deleted the source files. Would have been unfortunate if I didn't have a back up of them on an iPod.

It's now working great - though I can say that it's working better syncing as a Mass Storage USB than as a WM device.

Thanks for the help. Sorry for the trouble.

drapper
Posts: 16
Joined: Fri Nov 19, 2010 9:25 am
Location: France

Re: Device Deleted Files Won't Re-Sync

Post by drapper » Mon Nov 22, 2010 12:43 pm

nohitter151 wrote:No, this isn't true. There's no cache or anything like that, for USBmass plugin MM checks the timestamp of the files on the filesystem.
Hi, Are you sure about this?
i'm having the same symptoms:
1- I've started a sync but I've stopped it half way.
2- Deleted all files on my mass storage HDD
3- tried to do a full sync .. but
It starts .. I see a
a)message like "preparing the tracks" or something close
b) then another one "removing previous..." but it's going so quickly I can't read it.

But it won't sync my library.

What am I doing wrong?
Is there a log I can read ?

Thanks

Post Reply